Microsoft®

Excel 2016

Expert Certification Guide

Exam 77-728
March 2017
© CCI Learning Solutions
Preface

Microsoft® Excel 2016 Expert Certification Guide

This courseware is one in a series prepared by CCI Learning Solutions Inc. for use by students and instructors in courses on computer software applications. CCI designed these materials to assist students and instructors in making the learning process both effective and enjoyable.

This courseware is copyrighted and all rights are reserved by CCI Learning Solutions Inc. No part of this publication may be reproduced, transmitted, stored in a retrieval system, modified, or translated into any language or computer language, in any form or by any means, electronic, mechanical, magnetic, optical, chemical, manual or otherwise without written permission of CCI Learning Solutions, Canada: 1-800-668-1669.

The information in this courseware is distributed on an “as is” basis, without warranty. While every precaution has been taken in the preparation of this courseware, neither the author nor CCI Learning Solutions Inc. shall have any liability to any person or entity with respect to any liability, loss, or damage caused or alleged to be caused directly or indirectly by the instructions contained in this courseware or by the computer software and hardware products described therein.

Working with the Data Files

The exercises in this courseware are designed to utilize a specific set of data files, which are available for download. Follow these instructions to download the data files for this courseware.

1. Launch your browser and navigate to the CCI Web site location http://www.ccilearning.com/data.
2. Enter: 3264 in the Courseware # box and click Find Data.
3. Click Run in the File Download – Security Warning window. (Alternatively, you can choose to Save the file to a location on your computer.)
4. In the WinZip window click Extract.
5. In the Extract window, from the Folders/drives list box, scroll and then click the Desktop folder and click Extract.

The 3264 Student Files folder containing the required student work files has now been downloaded to your desktop. It is recommended that you rename the folder using your own name before starting the exercises in this courseware. You can reinstall and use the work files as many times as you like.
What is the Microsoft Office Specialist Certification?

Microsoft Office Specialist (MOS) certification is the leading IT certification in the world. More than 1 million MOS exams are taken every year in over 140 countries.

The Microsoft Office Specialist Program enables you to demonstrate the knowledge, skills, and abilities to productively use Microsoft Office. MOS enables you to tap into the full features and functionality of the Microsoft Office system, resulting in heightened levels of individual performance, confidence, and differentiation.

Microsoft Office Specialist

The Microsoft Office Specialist (MOS) certification exams validate skills within the applicable Microsoft Office programs. The 2016 exams are more powerful for assessing student skills and preparing students for real-world application. Skill assessments include performance-based formats, revised instructions, multiple projects, and questions integrated with objective domains.

The available Microsoft Office Specialist Program 2016 exams include:

- Microsoft Office Specialist: Word 2016
- Microsoft Office Specialist: Excel 2016
- Microsoft Office Specialist: PowerPoint 2016
- Microsoft Office Specialist: Outlook 2016
- Microsoft Office Specialist: Access 2016

For more information:


To learn about other Microsoft approved courseware from CCI Learning Solutions, visit [mos.ccilearning.com](http://mos.ccilearning.com)


Microsoft, Access, Excel, the Office Logo, Outlook, PowerPoint, SharePoint, and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. The Microsoft Office Specialist logo is used under license from Microsoft Corporation.
# Table of Contents

Courseware Description........................................................................................................................................................................................ viii
Lesson Objectives............................................................................................................................................................................................ 1
Conditional Formatting..................................................................................................................................................................................... 2
- Basic Conditional Formatting .................................................................................................................................................................... 2
- Manage Conditional Formatting Rules .................................................................................................................................................... 5
- Custom Conditional Formatting Using a Formula ....................................................................................................................................... 8
Using Custom Cell Formats........................................................................................................................................................................... 11
- Using Custom Number Formats ................................................................................................................................................................. 12
- Using Custom Accounting Formats ........................................................................................................................................................ 15
- Using Custom Date and Time Formats .................................................................................................................................................. 17
Internationalization ...................................................................................................................................................................................................... 18
- Using International Currency and Number Formats ................................................................................................................................. 18
- Using International Currency Symbols .................................................................................................................................................. 22
- Using Custom and International Date and Time Formats ........................................................................................................................... 23
User Defined Styles..................................................................................................................................................................................................... 26
- Creating and Modifying Cell Styles ............................................................................................................................................................ 26
- Custom Color Formats ................................................................................................................................................................................ 28
- Custom Themes .................................................................................................................................................................................................... 29
+Body and +Heading Fonts ........................................................................................................................................................................ 33
Lesson Summary ................................................................................................................................................................................................... 35
Review Questions .................................................................................................................................................................................................. 35

---

## Lesson 1: Advanced Formatting

Lesson Objectives............................................................................................................................................................................................ 1
Conditional Formatting..................................................................................................................................................................................... 2
- Basic Conditional Formatting .................................................................................................................................................................... 2
- Manage Conditional Formatting Rules .................................................................................................................................................... 5
- Custom Conditional Formatting Using a Formula ....................................................................................................................................... 8
Using Custom Cell Formats........................................................................................................................................................................... 11
- Using Custom Number Formats ................................................................................................................................................................. 12
- Using Custom Accounting Formats ........................................................................................................................................................ 15
- Using Custom Date and Time Formats .................................................................................................................................................. 17
Internationalization ...................................................................................................................................................................................................... 18
- Using International Currency and Number Formats ................................................................................................................................. 18
- Using International Currency Symbols .................................................................................................................................................. 22
- Using Custom and International Date and Time Formats ........................................................................................................................... 23
User Defined Styles..................................................................................................................................................................................................... 26
- Creating and Modifying Cell Styles ............................................................................................................................................................ 26
- Custom Color Formats ................................................................................................................................................................................ 28
- Custom Themes .................................................................................................................................................................................................... 29
+Body and +Heading Fonts ........................................................................................................................................................................ 33
Lesson Summary ................................................................................................................................................................................................... 35
Review Questions .................................................................................................................................................................................................. 35

---

## Lesson 2: Advanced Functions And Formulas

Lesson Objectives............................................................................................................................................................................................ 37
Working with Named Ranges .......................................................................................................................................................................... 38
- Creating Named Ranges ................................................................................................................................................................................ 38
- Naming Tables .................................................................................................................................................................................................... 38
- Modifying and Deleting Named Ranges .................................................................................................................................................. 41
What are Functions? ................................................................................................................................................................................................ 45
- Using the Correct Syntax for Functions .................................................................................................................................................... 46
- Inserting Functions ................................................................................................................................................................................................ 47
Using Lookup Functions ................................................................................................................................................................................... 50
- CHOOSE Function ................................................................................................................................................................................................ 50
- INDEX Function ................................................................................................................................................................................................ 52
- MATCH Function ................................................................................................................................................................................................ 54
- LOOKUP Function ................................................................................................................................................................................................ 56
- HLOOKUP and VLOOKUP Functions ........................................................................................................................................................... 57
# Lesson 3: Data Analysis Using Pivot Tables And Business Intelligence

Lesson Objectives........................................................................................................... 85
Creating and Managing Pivot Tables............................................................................... 86
   Creating a Pivot Table................................................................................................... 86
   Format Pivot Table Data............................................................................................... 90
   Customizing Pivot Tables............................................................................................... 92
Using Data Slicers with a Pivot Table............................................................................ 94
   Group Pivot Table Data............................................................................................... 97
   Calculated Fields and Items....................................................................................... 101
   Referencing Pivot Table Data..................................................................................... 106
Pivot Charts.................................................................................................................... 110
   Creating a Pivot Chart............................................................................................... 110
   Changing Pivot Chart Options.................................................................................. 113
   Drilling Down a Pivot Table or Pivot Chart............................................................... 114
   Pivot Chart Styles...................................................................................................... 116
Business Intelligence...................................................................................................... 117
   Activating Power Pivot............................................................................................. 118
   Connecting Power Pivot to a Data Source............................................................... 119
   Power Pivot Calculated Fields.................................................................................. 125
   Manage Table Relationships.................................................................................... 126
   Using Cube Functions............................................................................................... 130
Lesson Summary............................................................................................................ 140
Review Questions.......................................................................................................... 140

# Lesson 4: Workbook Management Features

Lesson Objectives........................................................................................................... 143
Linking External Workbooks......................................................................................... 144
   Referencing Other Worksheets in Formulas............................................................ 144
   Linking Other Workbooks......................................................................................... 144
   Modifying Workbook Links...................................................................................... 147
   Removing Workbook Links...................................................................................... 148
Consolidating Data......................................................................................................... 149
Workgroup Functions...................................................................................................... 152
   Creating a Shared Workbook................................................................................... 153
   Tracking Changes...................................................................................................... 155
   Showing the History of Changes.............................................................................. 157
   Removing Shared Use of Workbooks....................................................................... 159
Lesson 5: Advanced Charts, Functions And What-If Analysis

Lesson Objectives ................................................................................................................................................. 177
Advanced Chart Elements ........................................................................................................................................ 177
  Formatting a Simple Chart ................................................................................................................................. 177
  Add a Secondary Vertical Axis .......................................................................................................................... 179
  Custom Chart Templates .......................................................................................................................................... 182
  Chart Trendline ...................................................................................................................................................... 187
Using Advanced Functions and Features .................................................................................................................. 191
  Financial Functions .................................................................................................................................................. 191
  Nesting Functions .................................................................................................................................................. 193
  Conditional Logic Functions ................................................................................................................................. 198
  Conditional Summary Functions ............................................................................................................................ 199
What-If Analysis .......................................................................................................................................................... 202
  Manual What-If Analysis ........................................................................................................................................ 202
  Using the Goal Seek Tool ...................................................................................................................................... 203
  Working with Scenarios ...................................................................................................................................... 209
  Using Cell Watch .................................................................................................................................................. 213
Structured References ............................................................................................................................................. 214
Lesson Summary ....................................................................................................................................................... 218
Review Questions ....................................................................................................................................................... 218

Lesson 6: Data Filtering, Macros, And Forms

Lesson Objectives ....................................................................................................................................................... 221
Fill Series ........................................................................................................................................................................ 221
Advanced Filtering .................................................................................................................................................... 224
  Using Advanced Filters .......................................................................................................................................... 224
  Using Comparison Operators ................................................................................................................................. 229
Working with Templates ......................................................................................................................................... 231
  Creating a Template .............................................................................................................................................. 231
  Modifying Templates ............................................................................................................................................. 233
  Deleting Templates ............................................................................................................................................... 234
Accessing Hidden Ribbon Tabs .............................................................................................................................. 235
Macros ......................................................................................................................................................................... 237
  Creating a Macro .................................................................................................................................................... 237
  Copy Macros ........................................................................................................................................................... 243
# Table of Contents

## Preface

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding Form Controls</td>
<td>245</td>
</tr>
<tr>
<td>- Adding Command Buttons</td>
<td>247</td>
</tr>
<tr>
<td>- Spin Buttons and Scroll Bars</td>
<td>250</td>
</tr>
<tr>
<td>- Check Boxes and Option Buttons</td>
<td>252</td>
</tr>
<tr>
<td>- List Boxes and Combo Boxes</td>
<td>253</td>
</tr>
<tr>
<td>- Group Box</td>
<td>256</td>
</tr>
<tr>
<td>- Text Boxes</td>
<td>257</td>
</tr>
<tr>
<td>Changing Excel Formula Calculation Options</td>
<td>260</td>
</tr>
<tr>
<td>Lesson Summary</td>
<td>264</td>
</tr>
<tr>
<td>Review Questions</td>
<td>264</td>
</tr>
</tbody>
</table>

## Appendices

<table>
<thead>
<tr>
<th>Appendix</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appendix A: Courseware Mapping</td>
<td>A2</td>
</tr>
<tr>
<td>Appendix B: Glossary of Terms</td>
<td>A5</td>
</tr>
<tr>
<td>Appendix C: Index</td>
<td>A8</td>
</tr>
</tbody>
</table>
Course Description

Microsoft® Excel Expert teaches students how to use a variety of intermediate and advanced features to merge workbooks, perform data analysis, and audit formulas in spreadsheets. Students also use summary functions, create PivotTables and PivotCharts, and work with macros.

Students who complete this course will have reviewed all the exam objectives to prepare for: Microsoft Excel 2016 Expert Exam #77-728. Successful completion of the certification exam provides a competitive advantage by validating the knowledge and skill sets for individuals who may be seeking employment or further job opportunities in their careers.

Course Series

Microsoft Excel 2016 Expert Certification Guide is one of seven courses in CCI’s Microsoft Office Specialist 2016 series. Other courses available in the series include:

- Word 2016 Core
- Excel 2016 Core
- PowerPoint 2016
- Outlook 2016
- Access 2016
- Word 2016 Expert
- Excel 2016 Expert

Course Prerequisites

This course assumes that students have completed the Microsoft Excel 2016 Core course or have equivalent Excel knowledge and experience.

- enter text, numbers, dates, and times into a worksheet
- create new workbooks using a template
- format cells and worksheets
- select a range of cells in different ways
- apply formatting to cells, rows, columns, and worksheet tabs
- split and freeze panes
- use autofill
- use absolute and relative cell references
- modify page layout and print worksheets
- create formulas and apply functions
- create charts and insert graphical objects
- use sparkline charts
- create and modify tables
- sort and filter data
- find and replace data
- import and export data as text and csv data
- customize quick access toolbar
System Requirements

According to the Microsoft Office System User’s Guide, you must have the following in place prior to using the program:

**PC Version:**
- personal computer with a 1 gigahertz (GHz) 32-bit or 64-bit CPU processor or faster
- 2 gigabytes (GB) RAM
- 3 gigabytes (GB) hard disk drive to save the files used in this courseware
- graphics system supports DirectX10
- 1280x800 or higher resolution monitor
- Windows 10, Windows 8 or 8.1, Windows 7 SP1, Windows 10 Server, Windows Server 2012, Windows Server 2012 R2, Windows Server 2008 R2 operating systems; note that Excel 2016 32-bit version will run on 32-bit or 64-bit operating system but Excel 2016 64-bit version will only run on 64-bit operating system
- mouse or other pointing device compatible with Windows
- most current version of Microsoft Edge, Mozilla Firefox, Google Chrome, Apple Safari, Internet Explorer or the immediately previous version of Internet Explorer (if the current version of IE is 11 then IE 10 is acceptable)
- .NET 3.5, but some features may require .NET 4.0, 4.5, or 4.6 CLR

**Mac Version:**
- Mac OS X 10.10 or later

**Office 365:**
- most current version of Microsoft Edge, Mozilla Firefox, Google Chrome, Apple Safari, Internet Explorer or the immediately previous version of Internet Explorer (if the current version of IE is 11 then IE 10 is acceptable)

**Mobile devices:**
- Windows: Office Mobile applications require Windows 10
- iOS: Office for iPad and iPhone requires iOS 8.0 or later, Office for iPad Pro requires iOS 9.0 or higher
- Android: Office for Android requires KitKat 4.4 or later and an ARM-based or Intel x86 CPU

In the materials contained in this courseware, we assume that you have met these criteria, and that you have successfully installed both Windows and Excel on your computer.

Classroom Setup

The features and exercises shown in this courseware were developed using the standard installation of the Microsoft Office 2016 Desktop applications on a system with Windows 10. If your computers have another version of Windows installed, you will need to adjust accordingly to accommodate for the differences in dialog boxes when saving or opening files.

It is likely your teacher set up the classroom computers based on the system requirements to run the software for this course. Most software configurations on your computer are identical to those on your teacher's computer. However, your teacher may use additional software to demonstrate network interaction or related technologies.
Teacher Resources are available and are produced specifically to help and assist an instructor in preparing to deliver the course using the CCI materials. Contact your coordinator or administrator, or call your CCI Account Manager for information on how to access these resources.

# Course Design

This course book was developed for teacher-led training and will assist you during class. Together with comprehensive instructional text and objectives checklists, this course book provides easy-to-follow hands-on lab exercises and a glossary of course-specific terms.

This course book is organized in the following manner:

<table>
<thead>
<tr>
<th>Microsoft Excel 2016</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table of Contents</td>
</tr>
<tr>
<td>Lessons</td>
</tr>
<tr>
<td>Lesson Objectives</td>
</tr>
<tr>
<td>Narrative Text</td>
</tr>
<tr>
<td>✓ Graphics</td>
</tr>
<tr>
<td>✓ Tips, Tricks and Tech Notes</td>
</tr>
<tr>
<td>Exercises</td>
</tr>
<tr>
<td>✓ Graphics</td>
</tr>
<tr>
<td>✓ Tips, Tricks and Tech Notes</td>
</tr>
<tr>
<td>Lesson Summary</td>
</tr>
<tr>
<td>Lesson Review</td>
</tr>
<tr>
<td>Appendices</td>
</tr>
<tr>
<td>Courseware Mapping</td>
</tr>
<tr>
<td>Glossary of Terms</td>
</tr>
<tr>
<td>Index</td>
</tr>
</tbody>
</table>

When you return to your home or office, you will find this course book to be a valuable resource for reviewing exercises and applying the skills you have learned. Each lesson concludes with questions that review the material. Lesson review questions are provided as a study resource only and in no way guarantee a passing score on a certification exam. Appendices in the back of this course book provide additional information.

# Course Objectives

This course book teaches the skills you will need to successfully complete the Excel 2016 Expert exams. These skill sets are introduced using a fictional company named Tolano Adventures, a travel service which offers tours to the public that are friendly to the environment.

You will use Excel to create and edit professional-looking spreadsheets for a variety of purposes and situations. As you build your skills, you will then explore advanced features of Excel as well as different ways to share the information with internal and external customers.
After completing this course, you will be able to:

- Manage workbooks
- Manage workbook review
- Apply custom data formats and validation
- Apply advanced conditional formatting and filtering
- Create and modify custom workbook elements
- Prepare a workbook for internationalization
- Apply functions in formulas
- Look up data by using functions
- Apply advanced date and time functions
- Perform data analysis and business intelligence
- Troubleshoot formulas
- Define named ranges and objects
- Create advanced charts
- Create and manage pivot tables
- Create and manage pivot charts

Conventions and Graphics

The following conventions are used in CCI learning materials.

**File and Folder Names** – Names of folders and files are indicated in italic font style.

**Database Fields** – Names of database fields are indicated in purple italic font style.

**Exercise Text** – Content to be entered by the student during an exercise appears in Consolas font.

**Procedures** – Procedures and commands you are instructed to activate are indicated in bold font style.

**Objective 1.1.1, 1.1.2** – This indicates the numbered objective from the Microsoft Office Specialist exam being covered in this topic. Refer to the Appendix for a complete listing of exam objectives.

**Technical Notes** point out exceptions or special circumstances that you may find when working with a particular procedure, or may indicate there is another method to complete the task.

**Learn Exercise**

Learn Exercise headings signal the start of step-by-step, hands-on exercises or other activities.
Microsoft Excel 2016
Expert Certification Guide

Lesson 1: Advanced Formatting

Lesson Objectives

The objectives of this lesson are to use some of the advanced formatting features in Excel. Upon completion of this lesson, you should be able to:

- use basic conditional formatting
- manage conditional formatting rules
- create custom conditional formatting rules using formulas
- customize formats for numbers, accounting, date and time data types
- customize numeric and date/time data to display in international formats
- use international currency symbols
- create and modify cell styles
- use custom color formats
- create and modify custom themes
- use +Body and +Heading fonts
Conditional Formatting

Basic Conditional Formatting

Objective 2.2.1

You can use conditional formatting to change the appearance of a cell (within certain limitations), depending on that cell’s value. The cell format will change automatically when the cell value changes, triggering a different conditional formatting rule. This saves time for you and eliminates errors in having to make the format changes manually.

The Excel 2016 Core courseware covered the topic of using the Ribbon to create conditional formats. The Ribbon method is easy to use and enables you to create the most frequently used conditional formats. Behind the scenes, the Ribbon method creates conditional formatting rules. You can also create these rules directly by using the New Formatting Rule dialog box. Click New Rule or More Rules in one of the Conditional Formatting drop-down menus to open the New Formatting Rule dialog box.

The New Formatting Rule dialog box has the following rule types available:

Format all cells based on their values

The main application of this rule is to display indicators that show how the values in a range of cells relate to each other. For example, you may want cells with the highest values to show in red (hot), while the cells with the lowest values show in blue (cold). Excel will choose gradient colors between the red and blue for all other cells with the data values in between the two extremes.

You can choose one of four main types of indicators: a 2-color scale, a 3-color scale, a data bar, or an icon set. Further, you can choose from several different types of icons for the icon set.
Format only cells that contain

The most commonly used rule, offering a wide variety of operators to select the cells to highlight, such as between, greater than, and equal to. All cells that meet that rule will be highlighted with the same formatting.

Format only top or bottom ranked values

Apply a specific format to the cells with the highest or lowest values or percentile in a range of cells. For example, you can use this rule to identify the 10% of students with the highest ranking scores in a course.
Lesson 1

Advanced Formatting

**Format only values that are above or below average**

Apply a specific format to cells that are above or below the average of a range of cells. Excel allows you to choose from the mean average or various degrees of standard deviation from the mean average.

**Format only unique or duplicate values**

Identify all cells within a range with duplicate or unique values.

**Use a formula to determine which cells to format**

Enter a formula that evaluates to TRUE or FALSE to enable the conditional formatting for the cells within the range. This formula may reference another cell in the same worksheet, but not another worksheet or workbook.
A cell may have both a manual format as well as a conditional format applied to it. As long as a cell is not affected by a conditional format, the cell will use the manual format.

Formatting options include only the font styles (regular, bold, italics, or bold and italics), font colors, borders, and background fill patterns. You may not choose different font names or font sizes in a conditional format.

Manage Conditional Formatting Rules

Objective 2.2.3

All conditional formatting rules for a worksheet are displayed in the Rules Manager window. To get to the Rules Manager window, click Manage Rules in one of the drop-down menus. You can use the Rules Manager to create new rules, modify existing ones, and delete rules that are no longer needed.

You may apply multiple conditional formats to a range of cells at the same time. For example, one rule may be to display a certain color if the value is less than 3,000; another rule to display a different color if the value is between 3,000 and 10,000; and a third rule if the value is greater than 10,000. In this situation, the rules do not conflict with each other and one of them will be in effect at any given time.

Suppose instead that one rule is where the value is less than 10,000 and another rule is where the value is greater than 3,000. In this case, the two rules overlap. Generally, the rule listed higher than the other in the Rules Manager will override the other. This is known as rule precedence. However, both will take effect if they do not conflict; for example, where one rule is to display an icon set and the other is to display a background fill color.

In the example at the right, the top two rules conflict with each other as both are setting background fill formats. Because the rule at the top takes precedence, all cells with a value greater than 3,000 have an orange background. The remaining cells have a green background because they meet the second condition of < 10,000.

The third rule applies to all cells because an icon set format does not conflict with the background fill.

The rules in the Rules Manager window apply in reverse sequence to when they were added; that is, the latest rule added is always placed at the top of the list, and takes precedence over any rules below it. The sequence of these rules can be changed; simply select a rule and click Move Up or Move Down.
Lesson 1

Learn to apply conditional formats to cells

This exercise is a quick refresher of basic conditional cell formatting.

1. Open *New York Temperatures* from the student data files folder and save it as *New York Temperatures Basic Formatting - Student*.

This worksheet shows the average monthly temperature for New York City from 2000 to 2015. You will create a conditional format using the Ribbon to set the fill color to blue for any cell that contains a temperature value of less than 32 degrees Fahrenheit (when water turns to ice).

2. Select the cell range B2:M17.

3. On the Home tab, in the Styles group, click *Conditional Formatting*, then click *Highlight Cells Rules, Less Than*.

   The Less Than dialog box is displayed with default values entered for you.

4. In the Less Than dialog box, enter: 32 in the left entry box, then click the drop-down button in the right list box and click *Custom Format*.

   Because the Custom Format option was selected, the Format Cells dialog box is now displayed.

5. In the Format Cells dialog box, click the Fill tab, then click the blue standard color (bottom line, third from the right) and click OK.

   ![Format Cells dialog box](image)

6. In the Less Than dialog box, click OK.

   Create another conditional cell format – this time using the New Formatting Rule dialog box - to set the fill color to red for any cell that contains a temperature value of greater than 75 degrees Fahrenheit.

7. On the Home tab, in the Styles group, click *Conditional Formatting*, then click *New Rule*.

8. In the New Formatting Rule dialog box, click *Format only cells that contain* in the Select a Rule Type list.
In the Edit the Rule Description section, click the drop-down button in the second list box and click **greater than**. In the right-most text box, enter: 75.

Click the **Format** button.

In the Format Cells dialog box, click the **red** standard color (bottom row, second from the left), and click **OK**.

In the New Formatting Rule dialog box, click **OK** to complete the creation of the conditional formatting rule.

Assume that the blue color is too dark. You can change an existing rule at any time.

On the Home tab, in the Styles group, click **Conditional Formatting**, then click **Manage Rules**.

Click the bottom rule (Cell Value < 32), then click **Edit Rule**.

You can change the formatting criteria rule in this window.

In the Edit Formatting Rule dialog box, click **Format**.

In the Format Cells dialog box, click the **light blue** standard color (bottom row, fourth from the right), then click **OK**.

In the Edit Formatting Rule dialog box, click **OK**. In the Conditional Formatting Rules Manager dialog box, click **OK**.

Click in a blank cell of the worksheet.
The screen should now look similar to the following example:

You can also format a cell manually. However, it will be overridden by the conditional format.

19 Click cell B6, then click the Fill Color drop-down button in the Ribbon. In the Theme Colors section of the drop-down menu, click the Gold, Accent 4, Lighter 40% color.

Now test the conditional formatting rules in some of the cells.

20 Click cell F5, and enter: 31.

21 Click cell C5, and enter: 75.1.

22 Click cell B6, and enter: 40.

23 Click the Undo button in the Quick Access Toolbar once to undo the change to cell B6.

Cell B6 is now back to the light blue background color, and the manually set yellow background is no longer visible. You can remove the conditional formatting from a selected range of cells or from the entire worksheet.

24 On the Home tab, in the Styles group, click Conditional Formatting, then click Clear Rules, Clear Rules from Entire Sheet.

Notice that the manual formatting in cell B6 from step 19 is now taking effect because the conditional formatting has been removed.

25 With cell B6 still selected, click the Fill Color drop-down button in the Ribbon, then click No Fill in the drop-down menu.

26 Save the workbook.

Custom Conditional Formatting Using a Formula

Objective 2.2.2

If the predefined conditional formatting rules cannot provide what you are looking for, you can also create a customized one using a formula.

In the example below, the formula =A$1=A$8$19 is used for a new conditional format on the cell range A1:M14.
There are two important rules to remember about this formula:

- The formula must result in a TRUE or FALSE value.
- If the formula contains any cell references, the formula must be entered as if it was being entered into the upper left corner cell of the selected range. In the example above, the upper left corner cell for this range of cells receiving the conditional formatting is cell A1. Therefore the cell formula \(=A$1=B$19\) is evaluated for that cell. However, if the cell range selected for the conditional format is B2:M14, the equivalent formula must be \(=B$2=B$19\).

Notice that if the formula contains cell references, these references may be relative, absolute or mixed. For all other cells in the cell range in which the conditional format rules apply, Excel will automatically adjust the relative and mixed cell references. Absolute cell references and the absolute part of mixed cell references will not change from cell to cell. Using the above example again, in cell C1 the formula will adjust to \(=C$1=B$19\), but for cell C2 the formula will also be \(=C$1=B$19\). For both cells C1 and C2, the formula evaluates to TRUE and therefore the conditional format will activate for these cells.

Learn to customize conditional formatting using a formula

This exercise demonstrates how to use a formula to apply conditional formatting.


Using the same New York City temperatures, create a conditional format to highlight an entire column based on the month value you enter into a cell.

2. Enter the following values into the worksheet:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>B19</td>
<td>Feb</td>
</tr>
<tr>
<td>C19</td>
<td>2001</td>
</tr>
</tbody>
</table>

Excel automatically formatted cell C19 using the same settings as the cells above containing numbers. Clear this formatting so that it shows as a year value without the decimal digits.

3. Select cell C19 again, then on the Home tab, in the Editing group, click Clear, and click Clear Formats.
4 Select the cell range **A1:M17**.

5 On the Home tab, in the Styles group, click **Conditional Formatting**, then click **New Rule**.

6 In the New Formatting Rule dialog box, click **Use a formula to determine which cells to format** in the Select a Rule Type list.

7 In the Format values where this formula is true text box, type: 

   \[
   =A1=$B$19
   \]

8 Click the **Format** button.

9 In the Format Cells dialog box, under the Fill tab, click the **green** standard color (bottom row, fifth from the right), and click **OK**.

10 In the New Formatting Rule dialog box, click **OK** to complete creating the conditional formatting rule.

   In the worksheet, only cell C1 is highlighted in green, because it is the only cell in which the formula entered in step 7 evaluates to the value of True (for this cell the formula is adjusted to 

   \[
   =C1=$B$19
   \]

   The conditional format can be modified so that the entire column is highlighted in green.

11 Click **Conditional Formatting** in the Ribbon, then click **Manage Rules**.

12 With the sole rule already selected, click **Edit Rule**.

13 In the Format values where this formula is true box, change the formula to: 

   \[
   =A$1=$B$19
   \]

   and click **OK**.

14 In the Conditional Formatting Rules Manager dialog box, click **OK**.

   The entire column is now highlighted: every cell (not just C1) in the cell range C1:C14 will now have the formula in the conditional format adjusted to 

   \[
   =C1=$B$19
   \]

   Add another custom conditional format to highlight the entire row for the year value entered into cell C19.

15 Ensure that the range **A1:M17** is still selected, then click **Conditional Formatting**, then click **New Rule**.

16 In the New Formatting Rule dialog box, click **Use a formula to determine which cells to format** in the Select a Rule Type list.

17 In the Format values where this formula is true box, type: 

   \[
   =$A1=$C$19
   \]

18 Click the **Format** button, then click the **orange** standard color (bottom row, third from the left), and click **OK**.

19 In the New Formatting Rule dialog box, click **OK** to complete creating the conditional formatting rule.

20 Click in any blank cell outside of the range A1:M17 to view the results of the conditional formatting.
The screen should now look similar to the following example:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
<th>L</th>
<th>M</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Year</td>
<td>Jan</td>
<td>Feb</td>
<td>Mar</td>
<td>Apr</td>
<td>May</td>
<td>Jun</td>
<td>Jul</td>
<td>Aug</td>
<td>Sep</td>
<td>Oct</td>
<td>Nov</td>
<td>Dec</td>
</tr>
<tr>
<td>2</td>
<td>2000</td>
<td>21.3</td>
<td>37.4</td>
<td>47.2</td>
<td>51.0</td>
<td>62.5</td>
<td>71.2</td>
<td>72.3</td>
<td>72.7</td>
<td>66.0</td>
<td>57.0</td>
<td>45.3</td>
<td>31.1</td>
</tr>
<tr>
<td>3</td>
<td>2001</td>
<td>33.6</td>
<td>39.6</td>
<td>39.6</td>
<td>54.2</td>
<td>63.8</td>
<td>72.9</td>
<td>73.2</td>
<td>78.7</td>
<td>67.7</td>
<td>58.5</td>
<td>52.7</td>
<td>44.1</td>
</tr>
<tr>
<td>4</td>
<td>2002</td>
<td>39.9</td>
<td>43.0</td>
<td>44.1</td>
<td>56.1</td>
<td>60.7</td>
<td>71.4</td>
<td>78.9</td>
<td>77.7</td>
<td>70.2</td>
<td>55.2</td>
<td>46.0</td>
<td>36.0</td>
</tr>
<tr>
<td>5</td>
<td>2003</td>
<td>27.5</td>
<td>30.1</td>
<td>48.1</td>
<td>49.8</td>
<td>58.7</td>
<td>68.3</td>
<td>75.8</td>
<td>76.7</td>
<td>67.9</td>
<td>65.1</td>
<td>50.0</td>
<td>37.6</td>
</tr>
<tr>
<td>6</td>
<td>2004</td>
<td>24.7</td>
<td>31.0</td>
<td>43.5</td>
<td>53.6</td>
<td>65.2</td>
<td>71.2</td>
<td>74.5</td>
<td>74.2</td>
<td>69.3</td>
<td>56.0</td>
<td>48.2</td>
<td>38.4</td>
</tr>
<tr>
<td>7</td>
<td>2005</td>
<td>81.3</td>
<td>88.5</td>
<td>89.4</td>
<td>55.1</td>
<td>58.9</td>
<td>74.0</td>
<td>77.5</td>
<td>78.7</td>
<td>78.5</td>
<td>77.9</td>
<td>49.6</td>
<td>35.3</td>
</tr>
<tr>
<td>8</td>
<td>2006</td>
<td>40.9</td>
<td>35.7</td>
<td>43.1</td>
<td>55.7</td>
<td>63.1</td>
<td>71.0</td>
<td>77.9</td>
<td>75.8</td>
<td>66.6</td>
<td>56.2</td>
<td>51.9</td>
<td>43.6</td>
</tr>
<tr>
<td>9</td>
<td>2007</td>
<td>37.5</td>
<td>32.8</td>
<td>42.2</td>
<td>50.3</td>
<td>65.2</td>
<td>71.4</td>
<td>75.0</td>
<td>74.0</td>
<td>70.3</td>
<td>63.0</td>
<td>45.4</td>
<td>37.0</td>
</tr>
<tr>
<td>10</td>
<td>2008</td>
<td>36.5</td>
<td>35.6</td>
<td>42.6</td>
<td>54.9</td>
<td>60.1</td>
<td>74.0</td>
<td>76.4</td>
<td>73.8</td>
<td>68.8</td>
<td>55.1</td>
<td>45.8</td>
<td>38.1</td>
</tr>
<tr>
<td>11</td>
<td>2009</td>
<td>27.9</td>
<td>35.7</td>
<td>42.4</td>
<td>54.5</td>
<td>62.5</td>
<td>67.5</td>
<td>72.7</td>
<td>75.7</td>
<td>66.3</td>
<td>55.0</td>
<td>51.2</td>
<td>35.9</td>
</tr>
<tr>
<td>12</td>
<td>2010</td>
<td>32.5</td>
<td>33.1</td>
<td>48.2</td>
<td>57.9</td>
<td>63.3</td>
<td>74.7</td>
<td>81.3</td>
<td>77.4</td>
<td>71.1</td>
<td>58.1</td>
<td>47.9</td>
<td>32.8</td>
</tr>
<tr>
<td>13</td>
<td>2011</td>
<td>29.7</td>
<td>36.6</td>
<td>42.3</td>
<td>54.3</td>
<td>64.5</td>
<td>72.3</td>
<td>80.2</td>
<td>75.3</td>
<td>70.9</td>
<td>57.1</td>
<td>55.9</td>
<td>43.3</td>
</tr>
<tr>
<td>14</td>
<td>2012</td>
<td>37.3</td>
<td>40.9</td>
<td>50.9</td>
<td>54.8</td>
<td>65.1</td>
<td>71.0</td>
<td>78.8</td>
<td>76.7</td>
<td>68.8</td>
<td>58.0</td>
<td>43.9</td>
<td>41.5</td>
</tr>
<tr>
<td>15</td>
<td>2013</td>
<td>35.1</td>
<td>33.9</td>
<td>40.1</td>
<td>53.0</td>
<td>62.8</td>
<td>72.7</td>
<td>79.8</td>
<td>74.6</td>
<td>67.9</td>
<td>60.2</td>
<td>45.3</td>
<td>38.6</td>
</tr>
<tr>
<td>16</td>
<td>2014</td>
<td>28.7</td>
<td>31.7</td>
<td>87.7</td>
<td>52.8</td>
<td>64.0</td>
<td>72.5</td>
<td>76.1</td>
<td>74.5</td>
<td>69.7</td>
<td>59.6</td>
<td>45.3</td>
<td>40.5</td>
</tr>
<tr>
<td>17</td>
<td>2015</td>
<td>29.9</td>
<td>24.9</td>
<td>38.1</td>
<td>54.3</td>
<td>68.5</td>
<td>71.2</td>
<td>78.8</td>
<td>79.0</td>
<td>74.4</td>
<td>58.0</td>
<td>52.8</td>
<td>50.8</td>
</tr>
</tbody>
</table>

Change the values in the cells containing the month and year values.

21 Click cell B19, and enter: Sep.

22 Click cell C19, and enter: 2013.

With these changes, every cell in column J is green, except cell J15. Every cell in row 15 is orange, including cell J15.

23 Click Conditional Formatting in the Ribbon, then click Manage Rules.

24 In the Show formatting rules for list box, click the arrow and select This Worksheet.

25 With the top-most rule already selected, click the Move Down button, then click OK.

By switching the sequence of the conditional formatting rules, the one that highlights in green now takes precedence. The entire column is now green including cell J15.

26 Save and close the workbook.

**Using Custom Cell Formats**

Formatting cells is a crucial activity because spreadsheets often contain large volumes of numeric information. Users can absorb the information much more quickly when the spreadsheet is visually readable by using a variety of fonts, colors, and sizes. The relevance and accuracy of the contents is an absolute necessity for spreadsheets, but poor presentation discourages users from paying attention.

Excel provides a good variety of standard display formats for numbers, dates, times, and text characters. The most commonly used options are easily accessible from the Ribbon.

In some cases, you may need to use special formats that are not one of these frequently-used cell formatting categories. For example, you may need special formatting for data such as dates, part numbers, phone numbers, and currencies (as you would in many European and Asian countries).
Using Custom Number Formats

Objective 2.1.1

The Format Cells dialog box includes several predefined custom formats in the Custom category.

![Format Cells dialog box](image)

You can also create your own custom number format, using the following specification:

- positive number format
- negative number format
- zero format
- text format

Notice that this format has four sections separated by semicolons. A custom format does not require all four sections; it can have as few as one section. If you specify only the first section, Excel will use this same format for all numbers (positive, negative, and zero). If you specify only the first two sections, Excel will use the positive number format for zero values as well as positive values and the format in the second section for negative numbers.

You can specify each numeric format by using a sequence of symbols to indicate the position and type of each of the numeric digits to be displayed. Some symbols that can be used in a custom format are:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Display a digit, but do not display anything for leading and trailing zeros.</td>
</tr>
<tr>
<td>0</td>
<td>Display a digit, even if it is a leading or trailing zero.</td>
</tr>
<tr>
<td>?</td>
<td>Display a digit and replace trailing zeros with a blank space so that multiple cells with this format are aligned by the decimal point.</td>
</tr>
<tr>
<td>, (comma)</td>
<td>Separate a number into thousands, and scales a number by a multiple of one thousand. In some countries, the period (.) is used as the thousands separator.</td>
</tr>
<tr>
<td>. (period)</td>
<td>Normally used as a decimal point. In some countries, the comma (,) is used as the decimal point.</td>
</tr>
</tbody>
</table>
Advanced Formatting

Lesson 1

1. Open Destination Profiles Numeric and save as Destination Profiles Numeric - Student.

2. Select cells B7:E8.

Select one of the existing number formats for these rows of data.

### Examples

<table>
<thead>
<tr>
<th>Value</th>
<th>Format</th>
<th>Displayed Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>98765.4</td>
<td>#.###</td>
<td>98765.4</td>
</tr>
<tr>
<td>98765.4</td>
<td>0.000</td>
<td>98765.400</td>
</tr>
<tr>
<td>98765.4</td>
<td>.???</td>
<td>98765.4</td>
</tr>
<tr>
<td>98765.4</td>
<td>[Blue]#,##0.00;<a href="#,##0.00">Red</a></td>
<td>98,765.40</td>
</tr>
<tr>
<td>-98765.4</td>
<td>[Blue]#,##0.00;<a href="#,##0.00">Red</a></td>
<td>(98,765.40)</td>
</tr>
<tr>
<td>36000</td>
<td>#,##0</td>
<td>36,000</td>
</tr>
<tr>
<td>3600000</td>
<td>#,..</td>
<td>36</td>
</tr>
<tr>
<td>360000000</td>
<td>#,###</td>
<td>36,000</td>
</tr>
<tr>
<td>36</td>
<td>0000</td>
<td>0036</td>
</tr>
<tr>
<td>123456.78</td>
<td>&quot;Cdn&quot; $#,##0.00</td>
<td>Cdn $123,456.78</td>
</tr>
<tr>
<td>123456789</td>
<td>&quot;Part #&quot; 000-00-0000</td>
<td>Part # 123-45-6789</td>
</tr>
<tr>
<td>456.78</td>
<td>0.00 &quot;cm&quot;</td>
<td>456.78 cm</td>
</tr>
<tr>
<td>456.78</td>
<td>*$0.00</td>
<td>$$$$$456.78 ($ repeats as necessary to fill the space at left)</td>
</tr>
</tbody>
</table>

The fourth section (text format) of the custom formatting specification applies only if the cell contains a text string instead of a number. You can also display text strings inside cells containing numeric values.

You can delete custom cell formats that you no longer need or have created by mistake. However, you cannot delete any of the built-in cell formats.

### Learn to create and use custom number formats

This exercise demonstrates how to create and use custom number formats.

1. Open Destination Profiles Numeric and save as Destination Profiles Numeric - Student.

2. Select cells B7:E8.

Select one of the existing number formats for these rows of data.
On the Home tab, in the Number group, click the **Number Format** dialog box launcher. If necessary, select the **Number** tab.

In the Category section, click **Number**.

Reduce the Decimal places value to 0, click **Use 1000 Separator (,)** to turn it on, and click **OK**.

For another row of numbers, select a custom format, which happens to be the same as the one above.

Select cells **B13:E13**, then click the **Number Format** dialog box launcher in the Number group.

In the Category section, click **Custom**, and in the Type section, click **##0** (fourth from the top).

Notice how the preview of the data changes in the Sample section of the dialog box as you enter each character of the custom format.

Click **OK**.

Select a different custom format for another row of data.

Select cells **B15:E15**, then click the **Number Format** dialog box launcher in the Number group.

In the Category section, click **Custom**, and in the Type section, click **##0,##0** (seventh from the top), and click **OK**.

You can also create your own custom format by modifying an existing one.

With cells B15:E15 still highlighted, click the **Number Format** dialog box launcher in the Number group.

Click the **Custom** category, and change the formatting instructions in the Type text box to:

[Blue]##0;[Red]-##0. Click **OK**, then click in a blank area of the worksheet to deselect these cells.

Notice that the positive values are blue and the negative values are red. You can select from a number of different colors to highlight positive and/or negative numbers.

Select cell **D15** and click the **Number Format** dialog box launcher in the Number group.

Notice that the new format created earlier has been added at the bottom of the list of custom formats. Now add the text “m” or “ft” to the numbers in row 15. Because these cell formats have both a positive and negative section, you must add the text to both.

In the Type text box, change the format code to: [Blue]##0 "ft"; [Red]-##0 "ft" and click **OK**.

Select cells **B15:C15**, and click the **Number Format** dialog box launcher in the Number group.

Click the **Type** text box, change the format code to: [Blue]##0 "m"; [Red]-##0 "m" and click **OK**.

Select cell **E15**, click the **Number Format** dialog box launcher in the Number group, and select the [Blue]##0 "m"; [Red]-##0 "m" custom format code at the bottom of the list.
18 Change several other cells containing numeric values to the following custom formats:

<table>
<thead>
<tr>
<th>Cell Range</th>
<th>Custom Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>B7:C7</td>
<td>#,##0 &quot;sq km&quot;</td>
</tr>
<tr>
<td>D7</td>
<td>#,##0 &quot;sq mi&quot;</td>
</tr>
<tr>
<td>E7</td>
<td>#,##0 &quot;sq km&quot;</td>
</tr>
<tr>
<td>B13:C13</td>
<td>#,##0 &quot;m&quot;</td>
</tr>
<tr>
<td>D13</td>
<td>#,##0 &quot;ft&quot;</td>
</tr>
<tr>
<td>E13</td>
<td>#,##0 &quot;m&quot;</td>
</tr>
</tbody>
</table>

The worksheet should appear similar to the following:

<table>
<thead>
<tr>
<th></th>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Tolano Adventures</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>Destination Profiles</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>Region:</td>
<td>Nepal</td>
<td>Mexico</td>
<td>California</td>
<td>British Columbia</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>Capital:</td>
<td>Kathmandu</td>
<td>Mexico City</td>
<td>Sacramento</td>
<td>Victoria</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>Primary Language:</td>
<td>Nepali</td>
<td>Spanish</td>
<td>English</td>
<td>English</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td>Population:</td>
<td>147,181 sq km</td>
<td>1,972,550 sq km</td>
<td>158,996 sq mi</td>
<td>944,755 sq km</td>
</tr>
<tr>
<td>9</td>
<td></td>
<td>Gross Domestic Product (GDP):</td>
<td>1,992,100,000</td>
<td>1,327,12</td>
<td>2,003,512</td>
<td>2,177,945</td>
</tr>
<tr>
<td>10</td>
<td></td>
<td>Currency:</td>
<td>Nepalese rupee</td>
<td>Mexican Peso</td>
<td>US Dollar</td>
<td>Canadian Dollar</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td>Exchange Rate (to US$)</td>
<td>0.01007</td>
<td>0.07541</td>
<td>1</td>
<td>0.839957</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>Highest Point:</td>
<td>Mount Everest</td>
<td>Pico de Ortebka</td>
<td>Mount Whitney</td>
<td>Mount Fairweather</td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td>8,848 m</td>
<td>5,700 m</td>
<td>14,505 ft</td>
<td>4,663 m</td>
</tr>
<tr>
<td>14</td>
<td></td>
<td>Lowest Point:</td>
<td>Musashimura</td>
<td>Laguna Salada</td>
<td>Death Valley</td>
<td>Pacific Ocean</td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td>59 m</td>
<td>-10 m</td>
<td>-282 ft</td>
<td>0 m</td>
</tr>
</tbody>
</table>

19 Save and close the workbook.

**Using Custom Accounting Formats**

**Objective 2.1.1**

The Accounting format is intended for use with numbers that represent money or currencies. The Symbol list in the Format Cells dialog box allows you to select from the many different currency symbols used around the world.

You can create custom accounting formats by combining the currency symbol with the custom number formatting described previously.
Learn to create and use custom accounting formats

This exercise demonstrates how to create and use custom accounting formats.

1. Open Destination Profiles Accounting and save as Destination Profiles Accounting - Student.

Use the Accounting format for one row of data.


3. In the Category section, select Accounting.

4. Click the drop-down for Symbol and then click $ English (United States).

5. In the Category section, select Custom.

   The formatting code is much more complex because a specific currency symbol was selected in step 4.

6. Click OK.

   Notice that the numbers in this row are indented to the left by one space. This space is reserved for the right bracket; if the number is less than zero, brackets are displayed on both the left and right side. Because these number are all greater than zero, a blank space appears on the right side.

   One of the differences between the Accounting and Currency formats is that the currency symbol in the Accounting format is at the far left of the cell, whereas it is immediately to the left of the number when the Currency format is used.

Create a custom Accounting format using the negative sign instead of brackets to display numbers that are less than zero. Also extend the number to display five digits to the right of the decimal point instead of two.

7. With cells B11:E11 still highlighted, click the Number Format dialog box launcher in the Number group.

8. Click Custom, delete the contents of the Type text box, and type: $0.00000;-$0.00000. Click OK.

Create another custom Accounting format for the GDP numbers. Because these numbers are very large, you can format them as billions of dollars by not showing the nine right-most digits and displaying the word “billions”. Since these numbers cannot be negative, you can simply enter the positive number format.


10. In the Custom category, change the custom format to: $#,##0,,, "billion" and click OK.

11. Save and close the workbook.
## Using Custom Date and Time Formats

### Objective 2.1.1

There are actually many more ways to format date and time values than you might expect. Excel provides the flexibility to accommodate almost all circumstances.

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>d</code>, <code>dd</code>, <code>ddd</code>, <code>dddd</code></td>
<td>Display the day of the month. The &quot;d&quot; version displays the days as 1 to 31; &quot;dd&quot; displays 01 to 31 (always two digits); &quot;ddd&quot; displays “Sun” to “Sat”; and “dddd” displays “Sunday” to “Saturday.”</td>
</tr>
<tr>
<td><code>m</code>, <code>mm</code>, <code>mmm</code>, <code>mmmm</code>, <code>mmmmm</code></td>
<td>Display the month of the year. The “m” displays 1 to 12; “mm” displays 01 to 12; “mmm” displays “Jan” to “Dec”; “mmmm” displays “January” to “December”; and “mmmmm” displays “J” to “D” (first letter of the month name).</td>
</tr>
<tr>
<td><code>yy</code>, <code>yyyy</code></td>
<td>Display the year value. The “yy” displays 00 to 99; “yyyy” displays the full combined century and year value.</td>
</tr>
<tr>
<td><code>h</code>, <code>hh</code></td>
<td>Display the hour value. The “h” displays 0 to 23; “hh” displays 00 to 23.</td>
</tr>
<tr>
<td><code>m</code>, <code>mm</code></td>
<td>Display the minutes value within the context of a time value. The “m” displays 0 to 59; “mm” displays 00 to 59.</td>
</tr>
<tr>
<td><code>s</code>, <code>ss</code></td>
<td>Display the seconds value. The “s” displays 0 to 59; “ss” displays 00 to 59.</td>
</tr>
<tr>
<td><code>AM/PM</code>, <code>am/pm</code>, <code>a/p</code></td>
<td>Display the time using the 12-hour clock format (hour value is 0 to 11). The “AM/PM” displays “AM” or “PM” in upper case; “am/pm” displays them in lower case; “a/p” displays only the first character of “am” and “pm.” If this symbol is absent, the time is displayed using the 24-hour clock format (hour value is 0 to 23).</td>
</tr>
</tbody>
</table>

### Learn to create and use custom date formats

This exercise demonstrates how to create and use custom date formats.

1. Open *Age Calculator* and save as *Age Calculator - Student*. 
2.  Enter your date of birth into cell B1.


4.  Select the **Number** tab. In the Category section, select **Custom**.

5.  Click in the Type text box. Move to the year section at the far right side of the text box and type: `yy` to expand the year format to four digits. Click **OK**.

6.  With cells B1:B2 still selected, on the Home tab, in the Number group, click the **Number Format** dialog box launcher.

7.  Delete the current contents of the Type text box and then type (do this slowly, and observe what is displayed in the Sample text box as you enter each character): `dddd dd-mmmm-yyyy` and click **OK**.

8.  Save and close the workbook.

---

**Internationalization**

Some types of data are displayed differently depending on which country is being represented. Examples include currency (or money), dates, and measurements such as temperature and weight. Some of this country-dependent data can be identified using ordinary text such as kg for kilograms or °C for Celsius. Excel has special capabilities to handle the unique formatting requirements for currency and date values.

**Using International Currency and Number Formats**

**Objective 2.4.1**

Most European countries in the EEC use the `€` symbol to identify the Euro as their recognized currency. Australia, Canada, USA, Mexico, and several other countries use the `$` symbol to identify the dollar or peso as their currency.

The currency format is set for all software on your computer through the Regional Settings of the Control Panel. Windows then determines the correct currency symbol to use with the selected region of the world. In addition, you can choose from a long list of currency symbols for other countries for your spreadsheet. The Symbol list in the Currency category of the Format Cells dialog box provides this list. Excel also ensures that the symbol position is correct when displaying the currency values.

Most English speaking countries use the period (`.`) as the decimal point for numbers, and the comma (`,`) to separate groups of thousands. Most European countries – for example, France and Italy – use the comma as the decimal point and the period or space as the thousands separator.

<table>
<thead>
<tr>
<th>Country</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>United States</td>
<td>1,234,567.89</td>
</tr>
<tr>
<td>Canada</td>
<td>1,234,567.89</td>
</tr>
<tr>
<td>United Kingdom</td>
<td>1,234,567.89</td>
</tr>
<tr>
<td>France</td>
<td>1 234 567,89</td>
</tr>
<tr>
<td>Germany</td>
<td>1.234,567,89 or 1 234 567,89</td>
</tr>
</tbody>
</table>
With the Control Panel Regional Settings configured to any country, Excel will use the correct currency format for that country.

You can also override the default currency format settings by using the Symbol option list in the Format Cells dialog box.

Learn to select different regional currency formats

This exercise demonstrates how to select different regional currency formats.

1. Open Consolidated Income Numeric and save as Consolidated Income Numeric - Student.
Display the numbers in column D using the English pound symbol.

2. Select cells D5:D13. On the Home tab, in the Number group, click the Number Format dialog box launcher.

3. If necessary, select the Number tab. In the Category section, select Currency.

4. Click the drop-down for Symbol and then click £ English (United Kingdom).

5. In the Negative numbers list box, select the option at the bottom (displays both negative sign and red font), then click OK.
Now add the currency symbols for the other countries. Note that, for this exercise, the Total values in column B are not correct because they do not factor the currency exchange rates into account.

6 Repeat steps 2 to 5 for cells C5:C13, using the $ English (South Africa) currency option (about one-half down the long list of currencies).

7 Repeat steps 2 to 5 for cells H5:H13, using the ¥ Japanese currency option.

The numbers in columns E, F, and G all use the same $ currency symbol, even though they are for different countries. To help differentiate these columns, you can customize the currency symbol as US$, C$, and A$.

8 Select cells E5:E13. On the Home tab, in the Number group, click the Number Format dialog box launcher.

9 In the Custom category, change the custom format in the Type field to:

"US"$#,##0.00;[Red]-"US"$#,##0.00 and click OK.

10 Launch the Format Cells dialog box for cells F5:F13 and use the following custom format:

"A"$#,##0.00;[Red]-"A"$#,##0.00.

11 Scroll down the list box to display the custom formats at the bottom of the list.

Notice that each of the other currency formats (U.K. pound, South African rand, and Japanese yen) also show up on this list as custom formats.

12 Click OK to close the Format Cells dialog box.

13 Repeat steps 8 to 9 for cells G5:G13, using the custom format "C"$#,##0.00;[Red]-"C"$#,##0.00.

14 Select cells B5:B13. On the Home tab, in the Number group, click the Number Format drop-down button and click Currency.

Your sheet should now look like the following:

Now change the Regional Settings in the Windows Control Panel, and observe the effect on the worksheet.

15 Display the Windows Control Panel; click the Start button, scroll down and open the Windows System folder, then click Control Panel.

16 In the Control Panel, click Clock, Language, and Region, then click Change date, time, or number formats under Region.

17 Click the Format drop-down button and select French (France).
18 Click **Additional settings**, then click the **Currency** tab.

The **Customize Format** dialog box shows the country-specific formatting for the many types of data that can appear in various MS Office products.
19 Click **OK** to close the Customize Format dialog box. Click **OK** to close the Region dialog box.

20 Minimize the Clock, Language, and Region (Windows Control Panel) window to the Taskbar, and select the Consolidated Income Numeric workbook as the active window.

Notice that the numbers in column B now show the currency values using the Euro symbol.

![Tolano Adventures Consolidated Income Statement](image)

Change the regional setting back to the correct country.

21 Re-display the Clock, Language, and Region window from the Windows Taskbar, and click **Change date, time, or number formats**.

22 Click the **Format** drop-down button and select the correct region and language for your location; for example, **English (United States)**. Click **OK** to close the Region dialog box.

23 Close the Clock, Language, and Region window.

24 Save and close the workbook.

**Using International Currency Symbols**

**Objective 2.4.2**

You can also manually insert the symbol for many of the most common international currencies as an individual text character. You may be able to find these symbols on the Insert tab, in the Text group, under Symbol. The currency symbols are listed under the Latin-1 Supplement or Currency Symbols subset.
Learn to insert a currency symbol as a text character

This exercise demonstrates how to insert a currency symbol as a text character.

1. Open Consolidated Income Currency Symbols and save as Consolidated Income Currency Symbols - Student.
2. Select cell A15 and type: British Pound (with a blank space at the end), but do not press ENTER yet.
4. If necessary, click the Font drop-down button and select (normal text).
5. Click the subset drop-down button and select Latin-1 Supplement.
6. If necessary, scroll up or down to find the £ symbol, then click the £ (Pound Sign) symbol and click Insert.

   **Note:** When you click the Insert button, you will be tempted to click it again because it may appear as if nothing had been inserted. This is caused by the Symbol dialog box staying open and blocking your view of the cell. After clicking the Insert button, the Symbol dialog box will display the Close button. If it still shows the Cancel button, then you have not yet clicked the Insert button.

7. Close the Symbol dialog box.
8. Press ENTER to finish the cell.
9. Select cell A16 and type: Japanese Yen (with a blank space at the end, but do not press ENTER yet.
10. Repeat steps 3 to 8 to insert the Japanese Yen ¥ (Yen Sign) symbol.
11. Save and close the workbook.

Using Custom and International Date and Time Formats

**Objective 2.4.1**

Similar to the currency formats, you can also select from a number of different date formats. To override the current Regional Settings date format, you can change the Locale (location) setting in the Format Cells dialog box for a range of cells.

Furthermore, you can customize a date value to any format of your choosing.
Learn to change the formatting of date and time values

This exercise demonstrates how to change the formatting of date and time values.

1. Open *Date and Time Demo* and save as *Date and Time Demo - Student*.

   **Note:** The dates and times shown on your computer will be current according on your computer’s clock and will differ from those shown in your coursebook. Date and time formatting will also reflect the Regional settings of your computer.

Format column B to customized date and time formats.

2. Select cell B2, then on the Home tab, in the Number group, click the Number Format dialog box launcher.

3. If necessary, select the Number tab. In the Category section, select Custom.

4. Delete the current contents of the Type text box and then type (do this slowly, and observe what is displayed in the Sample text box as you enter each character): *dddd dd-mmmm-yyyy* and click OK.

5. Select cell B3, then on the Home tab, in the Number group, click the Number Format dialog box launcher.

6. Select the Custom category, and replace the contents of the Type text box with: *hh:mm:ss* and click OK.

Change the formatting of the date in cell C2 to Canadian, which is DD/MM/YYYY. This is the same date format used by most countries around the world, such as European countries and Australia.

7. Select cell C2, and click the Number Format dialog box launcher in the Number group.

8. Click the Locale (location) drop-down button, select English (Canada), and click OK.
Change the formatting of the time in cell C3 to Canadian, which is H:MM:SS AM/PM.

9. Select cell **C3**, and click the **Number Format** dialog box launcher in the Number group.

10. Click the **Locale (location)** drop-down button, select **French (France)**, and click **OK**.

Change the formatting of the date in cell D2 to France. For this cell, the name of the month will be displayed.

11. Select cell **D2**, and launch the Format Cells dialog box.

12. With the **Date** category selected, change the **Locale (location)** to **French (France)**.

13. In the **Type** list box, select the **14-mars-12** entry (fifth from the top), and click **OK**.

Change the formatting of the time in cell D3 to French.


15. With the **Time** category selected, change the **Locale (location)** to **French (France)**.

16. In the **Type** list box, select the **13:30:55** entry (third from the top), and click **OK**.

Change the regional settings for the computer, and observe the effect on column A.

17. Display the Windows Control Panel.

18. In the Control Panel, click **Clock, Language, and Region**, then click **Change date, time, or number formats** under Region.

19. Click the **Format** drop-down button, select **German (Germany)**, and click **OK**.

![](image)

Notice that the date format in cell A2 has changed with the region. The time format in cell A3 may or may not change, depending on how time is normally formatted at your location. The other cells in columns B to D did not change with the region change, except for the language.

20. Re-display the Clock, Language, and Region dialog box from the Windows Task bar, and click **Change date, time, or number formats**.

21. Click the **Format** drop-down button and select the correct region and language for your location; for example, **English (United States)**. Click **OK** to close the Region dialog box.

22. Close the Clock, Language, and Region window.

23. Save and close the workbook.
User Defined Styles
Creating and Modifying Cell Styles

Objective 2.3.2

Cell styles are not only easy to apply, but you can also modify them and create new ones.

The Style dialog box allows you to create or modify a cell style that will force a specific set of formats onto the selected cells. The cell style can consist of any or all of the following formatting: number, alignment, font, border, fill, and protection. For example, if you use a cell style that specifies all of the above formatting except for alignment, then the affected cells will keep their existing cell alignment. If the cells contain numeric data that is centered, then the contents of those cells will remain centered when the cell style is applied.

Note the following restrictions when using cell styles:

- Styles are defined individually for each workbook. The only way to copy any custom user-defined styles from one workbook to another is to copy the original workbook, delete any data not needed, and re-enter the data.
- If you change a style, Excel applies the changes to all cells using that style in every worksheet in that workbook.
- To see the style currently applied to a cell, you must select it and then click Cell Styles in the Ribbon. The name of the applied style will be highlighted with a border. If the cell has no style applied, the Normal style will be highlighted. Each cell must be checked individually to view the cell style assigned to it.
- Styles are based on the currently selected theme. If you change the theme or the formatting of the theme, the style also changes.

You can create new styles using one of the following three methods:

- use the formatting in a cell or cell range as an example, or
- display the Format Cells dialog box to specify the formatting, or
- merge the styles from another workbook into the current workbook.

Learn to work with cell styles

This exercise demonstrates how to select and modify an existing cell style, and create a new cell style.

1. Open Travel Insurance Premiums Styles and save as Travel Insurance Premiums Styles - Student.
2. Apply existing styles to the data.
3. Select the cell range B1:K1, then on the Home tab, in the Styles group, click the Cell Styles drop-down arrow, and then click Heading 1.
4. Repeat step 2 for cell A2.
5. Select the cell range B2:K2, then on the Home tab, in the Styles group, click Cell Styles, and then click Heading 4.
5 Repeat step 4 for the cell range A3:A11.

6 Select the cell ranges B3:K3, then hold down the CTRL key while selecting B5:K5, B7:K7, B9:K9, B11:K11. Release the CTRL key.

7 On the Home tab, in the Styles group, click Cell Styles, and then click 60% - Accent5.

8 Use the CTRL key to select the cell ranges B4:K4, B6:K6, B8:K8, B10:K10, then release the CTRL key.

9 On the Home tab, in the Styles group, click Cell Styles, and then click 20% - Accent5.

Modify one of the styles and see how that affects the worksheet.

10 Select cell B2, then on the Home tab, in the Styles group click Cell Styles. Right-click Heading 4 and click Modify.

11 In the Style dialog box, click Format.

12 In the Format Cells dialog box, click the Font tab, and select 16 as the Size, and click OK.

13 In the Style dialog box, click OK to save the change.

Notice that this format change applied to every cell that is selected with the Heading 4 format. Now create new cell style.

14 On the Home tab, in the Styles group click Cell Styles, then click New Cell Style.

The Style dialog box is displayed. Notice that by default, all of the format options are turned on, and the new style is using the formatting of the active cell (where your cursor is).

15 Delete the default style name and replace it with: New Title.

16 Click the Number, Alignment, Border, Fill, and Protection check boxes to turn them off, then click Format.

Note: By turning off these formatting options, you are specifying only a font format for this cell style. When you apply this new cell style to any cell, it will keep its existing number format, alignment, border, fill, and protection formatting.

17 If necessary, click the Font tab.

18 Select the following font options:

- **Font:** Times New Roman
- **Font style:** Bold Italic
- **Size:** 12
- **Color:** Black, Text 1

19 Click OK in the Format Cells and then the Style dialog boxes to save this new style.
20 Select the cell range B2:K2, then on the Home tab, in the Styles group, click **Cell Styles**, and then click **New Title** in the Custom section.

21 Repeat step 20 for the cell range A3:A11.

22 Save and close the workbook.

**Custom Color Formats**

**Objective 2.3.1**

The Fill Color and Font Color buttons in the Ribbon display a color palette which includes a No Fill option. You can choose from two sets of colors on the color palette: the bottom row of colors comprises the Standard Colors, while the Theme Colors section offers a wider range of tones based on the current selected document theme.

You can also click More Colors to access an even wider range of colors and tones up to the full color spectrum.

You can also select the desired color by manually changing the Red, Green, and Blue index numbers in the lower section of the Custom tab.

To select a custom fill or font color, select the cell or range of cells and then use one of the following methods:

- on the Home tab, in the Font group, click the arrow for Fill Color or Font Color, and then click **More Colors**, or
• right-click the selection and, in the Mini toolbar, click the arrow for Fill Color or Font Color, and then click More Colors.
• If you simply click the Fill Color or Font Color button in the Ribbon, Excel applies the currently selected color to the selected range of cells.

Learn to work with fill colors

This exercise demonstrates how to change the fill color for cells using a standard and a custom color.

1. Open Travel Insurance Premiums Colors and save as Travel Insurance Premiums Colors - Student.
2. Select the cell range B3:K3, then on the Home tab, in the Font group, click the Fill Color drop-down button. In the Standard Colors section, click the orange color.
3. Select the cell range B5:K5, then on the Home tab, in the Font group, click the Fill Color drop-down button, then click More Colors.
4. Click the Standard tab (if necessary), then click another color pixel of your choice, then click OK.
5. Select the cell range B7:K7, then on the Home tab, in the Font group, click the Fill Color drop-down button, then click More Colors. Click the Custom tab, if necessary.
6. Click or drag the cross-hair to desired color, then drag the slide pointer down or up on the color depth bar to the right.

Note: You can expand this dialog box to full screen by double-clicking on the title bar. This will make the custom color palette easier to see. You can shrink the dialog box back to its normal size by double-clicking on the title bar again.

As you drag the cross-hair around and/or slide pointer up and down, the New half of the color preview section displays the new color selection.

7. Click OK.

8. Save and close the workbook.

Custom Themes

Objective 2.3.3

Theme colors consist of four sets of text and background colors, six accent colors and two hyperlink colors. You can select any color for any of these settings, but you need to consider how they will appear when combined together.
When you modify the theme colors, the Sample pane of the Create New Theme Colors window shows your proposed changes. The left sample shows the Dark 2 background and Light 1 text combination, and the right sample shows the Light 2 background and Dark 1 text combination.

After you have made changes, save the theme colors with a name of your choice. You must also save the overall theme using a theme name of your choice.

---

**Learn to create a custom theme**

This exercise demonstrates how to create a theme of your own.

1. Open *Travel Insurance Premiums Themes* and save as *Travel Insurance Premium Themes - Student*.

Here is a quick refresher on how themes work and what happens when you select a different one.

2. On the Page Layout tab, in the Themes group, click **Themes** to display the drop-down menu options for this button.

3. Position the cursor over the different theme options (but don’t click any of them) and observe how each of these themes affect how the data appears on the worksheet.

As different themes are selected, the character fonts and colors used in the worksheet change.
4 Scroll down the options list and click the **Parcel** theme.

You can create a new custom theme using the current theme as the starting point.

5 On the Page Layout tab, in the Themes group, click **Colors** and then click **Customize Colors** at the bottom of the list.

6 Click the arrow for **Accent 1**.

7 Click **More Colors** at the bottom of the color palette window.

8 In the Colors dialog box, click the **Standard** tab and select a bright green color of your choosing.

   If the Standard tab does not contain the specific color shade that you want, you can select it from the Custom tab.

9 Click **OK**.

   In the Sample section of the Create New Theme Colors dialog box, the left-most bar in the left and right sample bar charts are now displayed using the green color you selected.

10 In the **Name** field, replace the default name with: **New Colors**.

11 Click **Save**.

   The color of the bottom borders for cells formatted with the Heading 1 cell style have now changed to your selected color. You can select your own color for other components of the theme as well.

12 On the Page Layout tab, in the Themes group, click **Colors**. Right-click **New Colors** at the top of the drop-down list, then click **Edit** to make additional changes to the selected theme color combination.

13 Click **Accent 5**, then click the **Dark Gray, Background 2, Lighter 40%** (fourth row, third from left) color.

14 Click **Save**.

   The background color used in some of the data rows has now changed to your selected color. Now change the font color used in some of the cells.

15 On the Page Layout tab, in the Themes group, click **Colors**. Right-click **New Colors** at the top of the drop-down list, then click **Edit** to change the selected theme color combination.

16 Click **Text/Background – Dark 1**, then click the **Dark Gray, Background 2, Darker 25%** color.

17 Click **Save**.

18 On the Page Layout tab, in the Themes group, click **Fonts**, then click **Customize Fonts** at the bottom of the drop-down list.

19 Click the arrow under **Body font**, scroll down to click **Times New Roman**, and save as **New Font**.

20 Click **Save**.
### Lesson 1

#### Advanced Formatting

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>Age (Years)</td>
<td>0-25</td>
<td>26-39</td>
<td>30-44</td>
<td>45-59</td>
<td>60-64</td>
<td>65-69</td>
<td>70-74</td>
<td>75-79</td>
<td>80-84</td>
<td>85+</td>
</tr>
<tr>
<td>1</td>
<td>Travel Days</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>1-17</td>
<td>$2.54</td>
<td>$2.75</td>
<td>$3.02</td>
<td>$3.39</td>
<td>$4.16</td>
<td>$4.16</td>
<td>$5.34</td>
<td>$10.27</td>
<td>$20.59</td>
</tr>
<tr>
<td>3</td>
<td>18-30</td>
<td>$2.56</td>
<td>$2.78</td>
<td>$3.11</td>
<td>$3.47</td>
<td>$4.22</td>
<td>$4.51</td>
<td>$5.41</td>
<td>$6.74</td>
<td>$11.06</td>
</tr>
<tr>
<td>4</td>
<td>31-60</td>
<td>$2.60</td>
<td>$2.81</td>
<td>$3.14</td>
<td>$3.55</td>
<td>$4.37</td>
<td>$5.03</td>
<td>$7.97</td>
<td>$14.45</td>
<td>$23.78</td>
</tr>
<tr>
<td>5</td>
<td>61-90</td>
<td>$2.62</td>
<td>$2.84</td>
<td>$3.18</td>
<td>$3.60</td>
<td>$4.46</td>
<td>$5.16</td>
<td>$7.96</td>
<td>$16.03</td>
<td>$24.39</td>
</tr>
<tr>
<td>6</td>
<td>91-120</td>
<td>$2.66</td>
<td>$2.88</td>
<td>$3.23</td>
<td>$3.76</td>
<td>$4.61</td>
<td>$5.31</td>
<td>$8.09</td>
<td>$18.72</td>
<td>$35.32</td>
</tr>
<tr>
<td>7</td>
<td>121-150</td>
<td>$2.70</td>
<td>$2.92</td>
<td>$3.28</td>
<td>$3.83</td>
<td>$4.70</td>
<td>$5.41</td>
<td>$8.26</td>
<td>$21.38</td>
<td>$39.26</td>
</tr>
<tr>
<td>8</td>
<td>151-192</td>
<td>$2.76</td>
<td>$3.00</td>
<td>$3.36</td>
<td>$4.05</td>
<td>$4.96</td>
<td>$5.70</td>
<td>$8.49</td>
<td>$23.78</td>
<td>$42.39</td>
</tr>
<tr>
<td>9</td>
<td>213-365</td>
<td>$2.87</td>
<td>$3.15</td>
<td>$3.53</td>
<td>$4.38</td>
<td>$5.25</td>
<td>$6.09</td>
<td>$9.01</td>
<td>$26.25</td>
<td>$49.26</td>
</tr>
</tbody>
</table>

21. On the Page Layout tab, in the Themes group, click **Themes** and then click **Save Current Theme**.

22. In the Save Current Theme dialog box, replace the File name with: **New Theme**.

23. Click **Save**.

You have now saved the new theme to this workbook. The new theme and set of theme colors are now available to all workbooks used on this computer. You can also copy them and make them available to other users.

24. On the Page Layout tab, in the Themes group, click **Themes** to display the drop-down list of all available themes.

25. Right-click **New Theme** and click **Delete**.

A message box appears with the question: “Delete this theme?”

26. Click **Yes**.

27. On the Page Layout tab, in the Themes group, click **Colors** to display the list of available colors.

28. Right-click **New colors** and click **Delete**. Click **Yes** when the message box is displayed.

29. On the Page Layout tab, in the Themes group, click **Fonts**. Right-click **New Font** and click **Delete**. Click **Yes** when the message box is displayed.

Notice that the workbook still uses the new customized color theme—until another theme is selected in the future—even though the theme has been deleted.

30. Save and close the workbook.
**+Body and +Heading Fonts**

**Objective 2.4.3**

In the Microsoft Office Suite, the +Body and +Heading fonts are the ones that automatically adjust themselves whenever a different theme is selected. In Excel, the Font list in the Home tab and the mini toolbar identifies these two fonts in the Theme Fonts section with the font name and (Body) or (Heading).

However, if you insert a graphic text box or WordArt, the Font dialog box shows these morph-able fonts as +Body and +Heading.

If you choose any other font name, the font and size will remain unchanged if you select a different theme for your workbook. This applies to any text in the workbook, whether in a cell or in a graphic object.

---

**Learn to experiment with the + Body font and a static font**

This exercise demonstrates how to experiment with the +Body font and a static font.

1. Open *Travel Insurance Premiums Body Heading Fonts* and save as *Travel Insurance Premiums Body Heading Fonts - Student.*
Add a graphic text box to see how these objects are affected by this feature.

2 On the Insert tab, in the Text group, click **Text Box**.

3 Click in any blank area of the worksheet, and type: **Not valid for more than 365 days.**

4 Click and drag this text box to cell **H12**.

   Select a static font for one of the new worksheet cell values.

5 Select cell **K2**, then on the Home tab, in the Font group, click the **Font** drop-down button and select a script-like font such as **Freestyle Script**. Be sure to memorize the name of the font that you selected – you will need it for a later step.

6 Select cell **A2**, then on the Home tab, in the Font group, click the **Font** drop-down button, and view the list of fonts available.

   You will leave cell A2 with the default (Body) font.

   Now select different themes and observe the effect on the worksheet.

7 Click anywhere outside the drop-down menu to close it.

8 Select the cell range **B2:J2**, then on the Home tab, in the Font group, click the **Font** drop-down button and select **Calibri Light (Headings)**.

9 On the Page Layout tab, in the Themes group, click **Themes** to display the list of themes available.

10 Point the cursor at some of the different themes to see how the font and size of all cells except K2 (which was set to a script-like font in a previous step).

   Notice that all cells and the graphic text reformatted with the rest of the worksheet, except for cell K2.

11 Click the **Badge** theme to apply it.

12 Select cell **B2**, then then on the Home tab, in the Font group, click the **Font** drop-down button, and view the list of fonts available.

   The Font drop-down list shows that the Badge theme has changed the default Body and Headings font for this workbook.

   Now choose a static font for the graphic text box.

13 Select all of the text inside the text box in cell **H12**, then right-click and click **Font**.

14 Click the **Latin text font** drop-down button to display the list of fonts available.
15 Search for and click the same font that you had selected in step 5, and click OK to close the dialog box. Try different themes again.

16 Repeat steps 9 and 10. Notice that the font and size of the text box now remains unchanged as different themes are previewed on the worksheet.

17 Click away from the drop-down menu to close it, then save and close the workbook.

**Lesson Summary**

You should now be able to:

- use basic conditional formatting
- customize numeric and date/time data to display in international formats
- manage conditional formatting rules
- use international currency symbols
- create custom conditional formatting rules using formulas
- create and modify cell styles
- create and modify custom themes
- use custom color formats
- customize formats for numbers, accounting, date and time data types
- use +Body and +Heading fonts

**Review Questions**

1. Which of the following is not a valid conditional format?
   a. Display a dark gray background color if the cell contains a text string with the text string “con” in it.
   b. Display cell text in a different font if the cell value is greater than 10,000.
   c. Display a color that could range from dark green to dark red, with lighter shades between these two extremes, depending on the numeric value in the cell.
   d. Display an icon set that resembles a pie, with a solid black circle representing the largest values in the range to a solid white circle for the smallest value, with varying portions of black and white for values in between.

2. Suppose you create two conditional format rules on a range of cells:
   Rule 1: Display an orange background color if the cell has a value > 7.5.
   Rule 2: Display a green background color if the cell has a value >= 7.4.
   What background color will display if every value had a minimum value of 8?
   a. Orange.
   b. Green.
   c. It depends which rule is listed above the other in the Rules Manager dialog box.
   d. Brown – both colors are applied and combined.
3. Which of the following are valid formulas to use in a conditional formatting rule (select all that apply):
   a. =C2
   b. =F5 > TODAY()
   c. =A16<>SUM(A1:A15)
   d. =ISNUMBER(A1)
   e. All of the formulas are valid.
   f. None of the formulas are valid.

4. Which of the following date formats is not valid?
   a. mm-d-yyyy
   b. dd-mmm-yy
   c. mm-yyyy
   d. ddd mmm-d-yyyy
   e. mm-d-yyy
   f. d-m-yy

5. The only way to change the currency format for numbers in your worksheet is to select the correct currency symbol and country in the Format Cells dialog box.
   a. True
   b. False

6. When a cell style is applied to various cells in four different worksheets, any changes to the style will apply immediately to all of these cells.
   a. True
   b. False

7. Theme colors in Excel consists of which of the following:
   a. Four sets of text and background colors, six accent colors and two hyperlink colors
   b. Two sets of conditional formats, 4 sets of background colors, and 3 sets of charts
   c. Two sets of background colors and four sets of hyperlink colors
   d. Ten sets of column widths, six sets of fonts, and two sets of hyperlink colors.

8. How can you apply a fill color (other than one of the colors that displays in the Fill Color drop-down menu) to a cell?
   a. Click the Fill Color button, click More Colors, then click a color displayed on the Standard tab.
   b. Click the Fill Color button, click More Colors, then click anywhere in the color spectrum displayed on the Custom tab.
   c. Click the Fill Color button, click More Colors, then manually change the Red, Green, and Blue index numbers on the Custom tab.
   d. Any of these methods will allow you to apply a fill color (other than one of the colors that displays in the Fill Color drop-down menu) to a cell.

9. When you manually insert an international currency symbol using the Symbol dialog box, which of the following subset options would you likely select?
   a. The Latin-1 Supplement subset.
   b. The Basic Latin subset.
   c. The IPA Extensions subset.
   d. The Wingdings subset.

10. What is special about the +Body and +Heading fonts?
    a. They automatically increase in point size each time to select them.
    b. They are designed for use in HTML representations of your workbook.
    c. They automatically adjust themselves when a new theme is applied.
    d. They automatically configure themselves to be one point larger in size than text in surrounding cells.
Lesson 2: Advanced Functions and Formulas

Lesson Objectives

In this lesson, you will learn how to use range names, use some of the more advanced functions in Excel, check for errors in your formulas, and use the data validation feature to improve the quality of the data in your workbooks. Upon completion of this lesson, you should be able to:

- create, modify, and delete range names
- name tables
- describe what a function is
- use the correct syntax for functions
- insert a function
- use the lookup functions CHOOSE, INDEX, MATCH, LOOKUP, HLOOKUP, and VLOOKUP
- use date and time functions
- use the Error Checking Tool to mark possible incorrect formulas
- trace formula errors
- use the evaluate formula feature to debug a formula
- check the worksheet manually for formula errors
- use data validation
Working with Named Ranges

Creating Named Ranges

Objectives 3.6.1, 3.6.2

When developing worksheets, you will find that they quickly become very large and it becomes difficult to keep track of all the cells. One useful feature to help you cope with a vast amount of data is the ability to create a meaningful name for a cell or range of cells. For example, it is much easier to understand the formula =Total_Revenues–Total_Expenses than a cryptic formula such as =C7–C18. With meaningful names, it becomes easier for users to understand the purpose of the formula and the nature of the data contained within the referenced cells.

To define a range with a name, select the range and then use one of the following methods:

- on the Formulas tab, in the Defined Names group, click Define Name, or
- click in the Name Box and type the name, or
- right-click the selected range and then click Define Name, or
- on the Formulas tab, in the Defined Names group, click Name Manager, click New, type a name and press ENTER.

Once you define a name for a cell or a range of cells, you can use that name when creating formulas. Excel also provides tools to convert formulas by replacing the cell references with their new range names.

You can also quickly jump to a named range by using Go To or by selecting the named range from the Name Box list to the left of the formula bar.

In addition to making spreadsheets easier to read by using meaningful names, range names can help reduce errors. For example, the formula =C7–C18 can easily be entered incorrectly. However, if you incorrectly enter any range name in a formula such as =Total_Revenues–Total_Expenses, Excel will not be able to match a mistyped range name to any cell or range in the workbook and will display an error message.

Range names also reduce errors if you change the cells included in the range. For example, suppose you change the cell range for the range name Expenses from C10:C18 to C10:C19. By changing the cell range once, then every formula in the workbook that uses the Expenses range name will be automatically updated. If you did not use a range name, then you must ensure that the cell range C10:C18 is changed everywhere it is used in the workbook. You will likely miss one or more of them.

Range names can be from 1 to 255 characters in length. They may contain alphabetic or numeric characters (alphanumeric), underscores (_), backslashes (\), periods (.) and question marks (?). You cannot use spaces in range names. The first character must be alphanumeric, an underscore, or a backslash.

Learn to use range names

This exercise demonstrates how to create range names and set up formulas using those range names.

1. Open the Income Statement Create Range worksheet and save it as Income Statement Create Range – Student.
3 On the Formulas tab, in the Defined Names group, click **Define Name**.

The New Name dialog box displays with the cell range entered.

4 In the Name field, type: **Revenues** and click **OK**.

From now on, whenever you select these two cells, the range name **Revenues** displays in the Name Box, which appears to the left of the formula bar.

![Image showing Revenues range](image_url)

5 Select each of the cells in the cell range **C5:C6** and observe what displays in the Name Box.

6 Select the cell range **C5:C6** and observe what displays in the Name Box.

This demonstrates that the range name appears only when the entire range is selected.

You can also create a range name by entering it directly into the Name Box on the formula bar.

7 Select cells **C10:C17**.

8 Click in the Name Box in the formula bar, type: **Expenses** and press **ENTER**.

Now enter summary formulas using one of the range names.

9 Select cell **C7**.

**Note:** Range names are not case sensitive – you can enter any mixture of upper and lower case characters.

10 Type: =**SUM(Revenues)** and press **ENTER**.

Notice that as you type the first one or two characters of the range name, a quick tip box appears, showing you this name and other functions with similar names. You can use the mouse to double-click the range name in the quick tip box to select it and continue with entering the rest of the formula.

![Quick tip box](image_url)

11 Select cell **C18**, type: =**SUM(Expenses** to enter the first part of the formula.

12 Double-click on the **Expenses** name in the quick tip box to select it, continue with typing: **)** and press **ENTER**.

As another reminder, Excel permits you to omit entering the last parenthesis for this function. However, Excel does not permit this for every function, and it is poor practice.

13 Select cells **B7:C7**.
Lesson 2

14 On the Formulas tab, in the Defined Names group, click **Create from Selection**.

![Create from Selection dialog box](image)

15 Verify that the **Left column** check box is the only one turned on and click **OK**.

16 Select cell **C7**.

Note that the range name in the Name Box is **Total_Revenues**.

**Hint:** Excel does not permit blank spaces in range names. You can use the underscore character as one alternative between the words in a multi-word range name.

Next you will create a range name for the **Total Expenses** cell, but this time, using the Name Manager.

17 Select cell **C18**.

18 On the Formulas tab, in the Defined Names group, click **Name Manager**.

The Name Manager dialog box now displays.

19 In the Name Manager dialog box, click **New** to create a new range name.

20 Verify that the **Name** is **Total_Expenses** and that the **Refers to** field contains the formula `=Sheet1!$C$18`, then click **OK**.

If the Name Manager dialog box is blocking access to the worksheet behind it, you can minimize it temporarily by clicking the **Collapse** button to the right of the **Refers to** field. You can then select a range of cells from the worksheet.

The Name Manager dialog box now has this new range name added, similar to the following example:

![Name Manager dialog box](image)

21 Click **Close** to close the Name Manager dialog box.

Enter the formula to calculate the Net Income, using the range names.

22 Select cell **C20**, and type: `=`

23 On the Formulas tab, in the Defined Names group, click **Use in Formula**.
24 Click **Total_Revenues**, then press – (minus) to indicate that you are going to perform a subtraction operation.

25 On the Formulas tab, in the Defined Names group, click **Use in Formula**. Click **Total_Expenses** and press ENTER.

26 Save and close the workbook.

**Naming Tables**

**Objective 3.6.3**

Whenever a table is created, Excel assigns the default name *Table1* (or the next available incremental number if tables were previously created in the workbook). You can then rename the table to something more meaningful to you, and you can use the table name in a formula, just as you can use a named cell range. For example, the formula `=SUM(Call_Volume)` will calculate the sum total for all numeric values in the table named *Call_Volume*.

Because tables can contain a lot of data, you also have the ability to reference individual columns within the table by adding the column title within square brackets. For example: `=SUM(Call_Volume[Sales Inquiries])`
Lesson 2

Advanced Functions and Formulas

This type of cell reference is known as a **structured reference**.

It is highly recommended that your formulas reference individual columns in tables in order to avoid unintended results, especially if the tables contain columns with date, time, or text data. If a formula references the entire table, the date and time data will be treated as numeric data and will be included in the formula calculations.

### Learn to name a table

This exercise demonstrates how to name a table and use it in formula calculations.

1. Open the *Monthly Call Volume Table* workbook and save it as *Monthly Call Volume Table – Student*.
2. Click any cell in the range A4:E15.
3. On the Insert tab, in the Tables group, click **Table**.
4. Confirm that **My table has headers** is turned on and then click **OK**.
   
The data is now converted into a table.

Change the table name to something that is more meaningful to you.

5. Under Table Tools, on the Design tab, in the Properties group, click in the text box under Table Name type: **Call_Volume** and press ENTER.

Turn on the automatic Total row and display the sum total values for each column.

6. Under Table Tools, on the Design tab, in the Table Style Options group, click **Total Row** to turn it on.
7. Select cell B16, click the drop-down arrow that appears next to it, and click **Sum**.
8. Specify the Sum function for cells C16 and D16.

Now calculate the sum total of all numbers in the table.
9 Select cell B19, and enter the formula: =SUM(Call_Volume).

You can also reference specific columns (but not rows) in a table by name.

10 Select cell B20, and type: =SUM(Call_Volume[ ] to enter the first part of the formula.

A drop-down list then appears showing the column names in the table.

11 Double-click the Sales Inquiries name in the quick tip box to select it, continue with typing: ] and press ENTER.

The entire formula should be =SUM(Call_Volume[Sales Inquiries]).

12 Repeat the previous step for each of the following:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>B21</td>
<td>=SUM(Call_Volume[Service Inquiries])</td>
</tr>
<tr>
<td>B22</td>
<td>=SUM(Call_Volume[General Inquiries])</td>
</tr>
<tr>
<td>B23</td>
<td>=SUM(Call_Volume[Complaints])</td>
</tr>
</tbody>
</table>

13 Select the cell range B20:B23 and then look at the status bar.

At this point, you can see each of these formulas you have just entered in steps 10 to 12 show results that match the Total values displayed at the bottom of the table. In step 13, when you select this same cell range (B20:B23), the status bar shows three statistics for this selected range: average, count, and sum total. However, this sum total of 112,904 does not match the sum total displayed in cell B19.

This difference is caused by a sum total calculation of the Month column.

14 Select cell B24, and enter: =SUM(Call_Volume[Month]).

15 Select the cell range B20:B24.

The sum total shown in the status bar for this selected range now matches the calculated sum total in cell B19.

16 Save and close the workbook.
Modifying and Deleting Named Ranges

Objective 3.6.4

You can use the Name Manager to modify and delete range names or change the cell range references.

Be cautious when deleting named ranges. When you delete a named range, any formula that refers to this range name no longer displays the correct value. Deleting a range name may also cause a domino effect with other formulas that indirectly refer to a formula that refers to the (now deleted) range name.

Learn to use the Name Manager

This exercise demonstrates how to use the Name Manager to update and delete range names.


A common situation is adding more rows to a named range. As long as you add the rows inside the range, Excel automatically includes the new data as part of the range. If you add the new data outside of the range, you will need to expand the range to include the new row(s).

2. Click the header for row 18 to highlight the entire row. Right-click the row and click Insert.

3. Select cell B18, type: Travel and press TAB.

4. In cell C18 type: 1400 and press ENTER.

Note that none of the figures in the report changed because the new entry sits outside of the named range Expenses. When you first created the range name, you could have included additional blank cells for future growth. Then, as you add new entries to the list, Excel automatically recalculates the total expenses formula.

5. On the Formulas tab, in the Defined Names group, click Name Manager.

6. In the Name Manager dialog box, click the Expenses row to select it.

7. In the Refers to text field, change the range to =Sheet1!$C$10:$C$18 as the range.

8. Click Update (the checkmark) to the left of the field to update the changes, and click Close.

The worksheet should now show the correct calculations for each of the functions:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Tolane Adventures</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Income Statement</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Revenues:</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Sales</td>
<td>77,500.00</td>
</tr>
<tr>
<td>5</td>
<td>Other Revenues</td>
<td>555.00</td>
</tr>
<tr>
<td>6</td>
<td>Total Revenues</td>
<td>78,055.00</td>
</tr>
<tr>
<td>7</td>
<td>Expenses:</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Rent</td>
<td>60,000.00</td>
</tr>
<tr>
<td>9</td>
<td>Telephone</td>
<td>1,800.00</td>
</tr>
<tr>
<td>10</td>
<td>Internet</td>
<td>1,500.00</td>
</tr>
<tr>
<td>11</td>
<td>Photocopyer</td>
<td>560.00</td>
</tr>
<tr>
<td>12</td>
<td>Supplies</td>
<td>5,000.00</td>
</tr>
<tr>
<td>13</td>
<td>Courier</td>
<td>780.00</td>
</tr>
<tr>
<td>14</td>
<td>Advertising</td>
<td>3,000.00</td>
</tr>
<tr>
<td>15</td>
<td>Utilities</td>
<td>3,900.00</td>
</tr>
<tr>
<td>16</td>
<td>Travel</td>
<td>1,400.00</td>
</tr>
<tr>
<td>17</td>
<td>Total Expenses</td>
<td>76,540.00</td>
</tr>
<tr>
<td>18</td>
<td>Net Income</td>
<td>1,715.00</td>
</tr>
</tbody>
</table>
Try deleting a named range and see how it affects the worksheet.

9 On the Formulas tab, in the Defined Names group, click Name Manager.

10 Click the Revenues row and then click Delete.

Excel displays a message box asking you to confirm the deletion of this range name.

11 Click OK for the confirmation message box and then click Close to close the Name Manager dialog box.

When you remove a named range, Excel displays an error indicator regarding any formulas that depend on that name. Note that the change has affected the formula in cell C21 as well, even though it does not use the range name Revenues directly.

12 In the Quick Access Toolbar, click Undo.

13 Save and close the workbook.

What are Functions?

The power of a spreadsheet program comes from the ability to perform calculations based on entered values. For simple calculations such as ‘A – B =’, the use of common mathematical operators works well. For more complex calculations, such as computing a monthly loan payment amount, Excel offers a tool called a function. Excel has a large selection of built-in functions to help you perform calculations in a spreadsheet.

Built-in functions are grouped into the following categories:

<table>
<thead>
<tr>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compatibility</td>
<td>Statistical functions available in Excel 2007 and earlier versions have since been replaced with newer versions. Functions in this category are still available for workbooks that still require them. All the compatibility functions can also be found in the Statistical category.</td>
</tr>
<tr>
<td>Cube</td>
<td>Work with the Microsoft SQL Server Analysis Services tool to perform data mining.</td>
</tr>
<tr>
<td>Database</td>
<td>Extract and manipulate data within an Excel database.</td>
</tr>
<tr>
<td>Date &amp; Time</td>
<td>Perform calculations on dates and times.</td>
</tr>
</tbody>
</table>
Lesson 2
Advanced Functions and Formulas

<table>
<thead>
<tr>
<th>Engineering</th>
<th>Perform calculations that are typically used in engineering applications. These functions must be loaded as part of the Analysis Toolpak add-in.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Financial</td>
<td>Perform financial calculations, such as those typically used with loans, annuities, and cash flows.</td>
</tr>
<tr>
<td>Information</td>
<td>Display information about the cells in the worksheet.</td>
</tr>
<tr>
<td>Logical</td>
<td>Control the actions taken by Excel based on evaluations of data in the spreadsheet.</td>
</tr>
<tr>
<td>Lookup &amp; Reference</td>
<td>Locate information within tables or on the Internet.</td>
</tr>
<tr>
<td>Math &amp; Trig</td>
<td>Perform mathematical and trigonometric calculations, such as logarithms, cosine, and rounding.</td>
</tr>
<tr>
<td>Statistical</td>
<td>Perform statistical evaluations, such as average, mean, and standard deviation.</td>
</tr>
<tr>
<td>Text</td>
<td>Manipulate text strings and convert numbers and text.</td>
</tr>
<tr>
<td>Web</td>
<td>Exchange data with other systems located on the Internet or in the local network using web functionality.</td>
</tr>
</tbody>
</table>

For complete details on the available functions, refer to the Microsoft Excel Help feature or get online help from the Microsoft website.

Using the Correct Syntax for Functions

When using functions in Excel, you must follow a standard syntax. The basic components of a function consist of the “=” (equal sign) symbol, a function name, and its arguments. The purpose of each of these parts is as follows:

<table>
<thead>
<tr>
<th>The “=” Symbol</th>
<th>Identifies the start of a formula or function. Only one = symbol is required for each cell.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function Name</td>
<td>Identifies the particular function to be used.</td>
</tr>
<tr>
<td>(Arguments)</td>
<td>Identifies any variable portions of the argument or required parts of the formula.</td>
</tr>
</tbody>
</table>

You put these three components together in the following order:

=FUNCTION(Arguments)

The argument portion of a function is enclosed in parentheses and can include one or more values or references. Commas separate multiple arguments in a function. Some functions do not require any arguments; these functions do, however, still require parentheses.

If you do not include the “=” symbol, Excel treats the function as a text label. If the function name is invalid, Excel will display #NAME? in the cell. If you do not include the proper number of arguments, Excel displays a message box and suggests using the Insert Function feature to complete building the function.

A function can also be used as part of a larger formula. For example:

=SUM(A1:A5) + SUM(B1:B7)) / SUM(C1:C3)

In this example, the SUM function is used three times in the same formula. Note the use of parentheses to ensure that the calculations are performed in the sequence that you had intended.
Excel follows the standard mathematical precedence of operators:

1. Parentheses: ()
2. Exponents and roots
3. Multiplication and division
4. Addition and subtraction

You can also nest functions together; that is, you can embed one function within another function. An example of a nested function is shown here:

   =ROUND(SUM(C1:C5),-2)

You can accomplish the same result by putting the intermediate results into separate cells. That is, you could put the SUM function in cell C6 so the results are displayed there. You could then use =ROUND(C6,-2) to calculate your final result in a different cell.

You are permitted to nest up to 64 layers of functions, which is more than sufficient for any worksheet. Prior to Excel 2007, you could nest up to only seven layers.

Inserting Functions

Excel has a very large number of functions available; memorizing the syntax of every function is an impossible task. To make it easier to use functions, Excel has a special tool called Insert Function.

To access the Insert Function dialog box, use one of the following methods:

- click Insert Function ( ) to the left of the Formula bar; or
- type "=" (to indicate to Excel that you are entering a formula) and then type the first few characters of the function that you want to enter. Excel displays a drop-down list of all functions that begin with these characters; or
- on the Home tab, in the Editing group, click the arrow beside AutoSum, then click More Functions; or
- on the Formulas tab, in the Function Library group, click Insert Function.

The Insert Function dialog box displays all functions grouped by most recently used or by categories previously discussed. If you do not know the name of the function you want to use, but you do know what you want to accomplish, you can type a brief description of what you want to do and the Insert Function feature will recommend a function for you.

After you select a function, Excel displays the Function Arguments dialog box to help you enter all the required function arguments. Helpful features of this dialog box include:

- Each argument is listed and the required arguments are highlighted in bold. If the function you’re using allows a variable number of arguments, the dialog box displays additional argument boxes as necessary.
- When the cursor is in one of the argument text boxes, the relevant help information displays in the lower part of the dialog box.
• If you select or enter data values or cell references into the argument boxes, Excel previews the data to the right of that argument box. In the following example screen, the data values being considered are \{45;24;57;49;36\}.

• If enough arguments have been entered, Excel also displays the results in the lower part of the dialog box. In this example screen, the calculated sum for the selected cell range is 211.

Many of the arguments in a function permit you to select a cell or range of cells containing the values to be used. For example, consider the following three functions:

\[
\begin{align*}
&=\text{SUM}(45,24,57,49,36) \\
&=\text{SUM}(C1,C2,C3,C4,C5) \\
&=\text{SUM}(C1:C5)
\end{align*}
\]

Assuming that cell C1 contains the value 45, C2 contains 24, and so on, all three of these functions will result in the displayed value of 211.

You can type a value or cell range into the appropriate boxes within the Function Arguments dialog box, or you can select a cell or cell range directly in the worksheet. In some situations, such as if you are using a device with a very small screen, the Function Arguments dialog box may block your view of the cell range. If you click the Collapse button ( ) located to the right of the argument text box, the Function Arguments dialog box shrinks temporarily, as shown here:

Once you have selected your cell range, press ENTER or click the Restore ( ) button located at the right side of this text box. The Function Arguments dialog box restores to its full size.

### Learn to use the Insert Function feature

This exercise demonstrates how to use the Insert Function feature.

1. Create a new blank workbook and save it as Functions - Student.
2. Enter the following values into the worksheet:

![Worksheet Image]

Enter a function to total the values in column C and place the answer in cell B1.


4. Click **Insert Function** to the left of the Formula bar.

5. If necessary, in the **Or select a category** box, click the drop-down button and click **Math & Trig** (or **Most Recently Used**).

   As the SUM function is by far the most commonly used, it is usually in the **Most Recently Used** list. If it's not, you can find it in the **Math & Trig** category.

6. In the **Select a function** list, scroll down and click **SUM**, and then click **OK**.

   For this exercise, you will use the Collapse and Restore buttons to enter argument values into the Function Arguments dialog box. Alternatively, you can enter the cell range values directly into the argument text boxes or select the cell range without collapsing the dialog box.

7. With the cursor in the **Number1** box, click **Collapse** to temporarily shrink the Function Arguments dialog box and then drag the box to an empty part of the worksheet so that it does not obstruct the cell range to be selected.

8. Select cells C1 to C5 in the worksheet and click **Restore** to return to the Function Arguments dialog box.

9. Click **OK** to complete the function.

10. Select cell B2 and then click **Insert Function**.

11. In the Search for a function box, type: **standard deviation** and click **Go**.

   Excel displays a list of functions that involve the use of standard deviation. As you select each of these functions, you will see a short description below the text box describing how the selected function works. The STDEV function appears to be the one you are interested in. If you need further help with that function, you can click the hyperlink at the bottom left corner of the dialog box.

12. Click the **STDEV.S** function and then click **OK** to display the Function Arguments dialog box.

13. If necessary, drag the Function Arguments dialog box out of the way so that it is not blocking the cell range C1 to C5.

14. With the cursor in the **Number1** box, select the cell range C1 to C5 and click **OK**.
Your completed worksheet should appear similar to:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sum</td>
<td>2</td>
<td>11</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>Standard Deviation</td>
<td>12.67675</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>57</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>49</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>36</td>
<td></td>
</tr>
</tbody>
</table>

15 Save and close the workbook.

Using Lookup Functions

Objective 3.2

Lookup functions are used to find information in lists or arrays based on a known value. This capability is very useful in situations such as locating product information in a table containing product IDs, with the description and price next to each ID. You can scan down the list until you find the Product ID, then look at the adjacent columns to find the description and price for that product. That is the basic principle of the lookup functions: to look for a value in a table and select the corresponding values in adjacent cells.

Some of the most common lookup functions are described here.

CHOOSE Function

The CHOOSE function is the simplest form of lookup. Select from a one-dimensional list of values (called a vector) by using an index number. The first argument is the index number, which selects which of the remaining arguments in the list to use. The vector list does not require the cells to be in any sequence or structure. Suppose you have the following formula:

=CHOOSE(A1,C1,C3,D1,D4)

If cell A1 contained the value 3, then this cell will display the value that is entered into cell D1, which is the third argument in the list after the index number.

Learn to use the CHOOSE function

This exercise is designed to demonstrate the use of the CHOOSE function.

1 Open the Tour Price List workbook and save it as Tour Price List – Student. Ensure the CHOOSE worksheet tab is active.
This worksheet is the tour price list for one of Tolano’s travel suppliers. Each specific tour has a unique identification number, departure date, and price per person. In this worksheet you will create a simple lookup to display information about the tour.

2 In cell F4, enter: 1.

3 Enter the following formulas:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>F5</td>
<td>=CHOOSE(F4,A3,A4,A5,A6,A7,A8,A9,A10,A11,A12)</td>
</tr>
<tr>
<td>F6</td>
<td>=CHOOSE(F4,B3,B4,B5,B6,B7,B8,B9,B10,B11,B12)</td>
</tr>
<tr>
<td>F7</td>
<td>=CHOOSE(F4,C3,C4,C5,C6,C7,C8,C9,C10,C11,C12)</td>
</tr>
</tbody>
</table>

Unfortunately the CHOOSE function does not allow you to enter a cell range. It also does not bring the formatting over with the data.

4 Select cell B3, and on the Home tab, in the Clipboard group, click Format Painter. Click cell F6 to copy the formatting to this cell.

5 Use the Format Painter again to copy the formatting from cell C3 to cell F7.

Once the CHOOSE functions have been set up, you can easily display the data for any tour by entering the row number.

6 Select cell F4, and enter different numbers of your choice between 1 and 10, then enter other numbers not between 1 and 10 and see how the values in cells F5 to F7 change to match which row you selected.

The completed worksheet should appear similar to the following:

7 Save the workbook.
INDEX Function

Objective 3.2.4

The INDEX function is similar to the CHOOSE function, but will select a value from a two-dimensional table or range of cells, using both a row number and column number as indices. Unlike the CHOOSE function, this function has two different versions: array and reference. The most commonly-used version is the reference version:

```
=INDEX(reference, row num, [column num], [area num])
```

Where:

| reference | Refers to one or more ranges of cells. |
| row num   | Identifies the row in the range to find the value. |
| column num| Optional: Identifies the column in the range to find the value. If not specified, the entire row of data is used. |
| area num  | Optional: Identifies which reference range to use. If not specified, area 1 is used. |

Following are examples of the INDEX function using the reference version:

<table>
<thead>
<tr>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>=INDEX(A2:D4,2,3)</td>
<td>liter</td>
</tr>
<tr>
<td>=INDEX(A2:D4,1,2)</td>
<td>millimeter</td>
</tr>
</tbody>
</table>

You can also specify more than one range of cells in this version.

<table>
<thead>
<tr>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>=INDEX((A2:D2,A3:D3,A4:D4),1,3,2)</td>
<td>liter</td>
</tr>
<tr>
<td>=INDEX((A2:D2,A3:D3,A4:D4),1,2,1)</td>
<td>millimeter</td>
</tr>
</tbody>
</table>

In this form of the reference version, the first example specifies area 2 (A3:D3) be used for the index. In the second example, area 1 (A2:D2) is to be used.

The second version of the INDEX function is the array version, which uses an array constant instead of a range of cell references:

```
=INDEX(array, row num, [column num])
```

Where:

| array | Identifies a range of cells, or an array constant. An array constant is a set of values listed within a set of curly braces. |
| row num | Identifies the row in the range to find the value. |
| column num | Optional: Identifies the column in the range to find the value. |
Note that if the array is a range of cells, then the INDEX function will behave exactly like the reference version.

Following are examples of the array version using array constants:

<table>
<thead>
<tr>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>=INDEX({10,20,30;40,50,60},2,3)</td>
<td>60</td>
</tr>
<tr>
<td>=INDEX({10,20,30;40,50,60},1,2)</td>
<td>20</td>
</tr>
</tbody>
</table>

In this example demonstrating the array version, each set of numbers separated by the semicolon represents a separate row within the array. Therefore, the first example specifies to find a value in the second row of the array (consisting of the numbers 40, 50, and 60) and within that row, to select the value in the third column. The second example specifies to find a value in the first row of the array, and to select the value in the second column.

### Learn to use the INDEX function

This exercise is designed to demonstrate the use of the INDEX function.

1. In the Tour Price List – Student workbook, click the INDEX worksheet tab, select cell F4, and enter: =INDEX($A$3:$C$12,$F$4,2).
2. In cell F5, enter: =INDEX($A$3:$C$12,$F$4,2).

**Note:** Remember you can use the F4 key to convert a cell reference to an absolute reference. For example, when you press the F4 key after typing A3 in the formula above, Excel will automatically change it to $A$3.

By using absolute references, you can copy this formula to other cells while pointing at the same lookup range of cells. Even though using absolute references makes this formula more complex, the ability to copy makes the process easier than with the CHOOSE function.

3. Copy the formula in cell F5, and paste it into cell F6.
4. Select cell F6 again, press the F2 key to modify the cell contents, and change the last argument in the formula from 2 to 3. The formula in this cell should now be: =INDEX($A$3:$C$12,$F$4,3).
5. Use the Format Painter to copy the formatting from cell B3 to cell F5, and from C3 to cell F6.
6. Select cell F4, and enter different numbers of your choice between 1 and 10, then enter other numbers not between 1 and 10 and see how the values in cells F5 to F7 change to match which row you selected.

The row number cell can be custom-formatted to serve a second purpose.

7. Select cell F4, and on the Home tab, in the Number group, click the **Number Format** dialog box launcher button.
8. Click the **Number** tab if necessary, then click **Custom** as the Category.
9. Delete the current contents in the Type text box, and replace it with: “LP-”000 and click OK.
You can now use the row # cell to show the tour # value. As a reminder you should add some instructions that only the numeric value should be entered.

10 Select cell E4, type: Tour #: and then select cell G4 and type: (enter number only).

The completed worksheet should appear similar to the following:

11 Save the workbook again.

**MATCH Function**

**Objective 3.2.3**

The MATCH function is similar to the CHOOSE and INDEX functions in that it will look for a value in a list or range of cells. However, it is very different because it returns the position of the value in the list, instead of the actual value itself.

The MATCH function works by searching through the lookup array for the lookup value. When it is found, its position in the lookup array is reported back.

The format of this function is as follows:

`=MATCH(lookup value, lookup array, [match type])`

Where:

<table>
<thead>
<tr>
<th>lookup value</th>
<th>Identifies the value to be found in the lookup array.</th>
</tr>
</thead>
<tbody>
<tr>
<td>lookup array</td>
<td>Identifies the list of values or range of cells to be searched. This range must be a single row or column.</td>
</tr>
<tr>
<td>match type</td>
<td>Optional: 1 is less than, 0 is exact match, -1 is greater than. If 1 or -1 is specified, then the values in the lookup array must be sorted in ascending order.</td>
</tr>
</tbody>
</table>
Following are examples of the MATCH function:

<table>
<thead>
<tr>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>=MATCH(A6,D2:D4,0)</td>
<td>3</td>
</tr>
<tr>
<td>=MATCH(A6,B2:B4,0)</td>
<td>2</td>
</tr>
</tbody>
</table>

In this example, the MATCH function looks up the value in cell A6 (kilogram) and finds it in cell. Cell D4 is in the third position (column) in the cell range D2:D4, so the MATCH function returns the value 3.

**Learn to use the MATCH function**

This exercise is designed to demonstrate the use of the MATCH function.

1. In the Tour Price List – Student workbook, click the MATCH worksheet tab, select cell F4, and enter: LP-001.
2. In cell F5, enter: =MATCH(F4,A3:A12,0).
3. Select cell F4, and enter different tour numbers - including invalid ones - and see how the row number value in cell F5 changes to match the tour number you selected.

   At first, it appears that the MATCH function does not provide anything useful, until you extend it with the INDEX function.

4. In cell F6, enter: =INDEX($B$3:$C$12,$F$5,1).

   With the tour # cell being used as the lookup value, you need only include the date and price column in the lookup range. However, you can also include the tour # column in the lookup range if you prefer.

5. Copy the formula in cell F6, and paste it into cell F7.
6. Select cell F7 again, press the F2 key to modify the cell contents, and change the last argument in the formula from 1 to 2. The formula in this cell should now be: =INDEX($B$3:$C$12,$F$5,2).
7. Use the Format Painter to copy the formatting from cell B3 to cell F6, and from C3 to cell F7.
8. Select cell F4, and enter different tour numbers again.
The completed worksheet should appear similar to the following:

```
<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Tour Price List</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Tour #</td>
<td>Date</td>
<td>Price</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>LP-001</td>
<td>12-Mar</td>
<td>$3,295</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>LP-002</td>
<td>2-Apr</td>
<td>$2,348</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>LP-003</td>
<td>21-May</td>
<td>$2,957</td>
<td>Tour #: LP-005</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>LP-004</td>
<td>11-Jun</td>
<td>$2,681</td>
<td></td>
<td>Row:</td>
<td>5</td>
</tr>
<tr>
<td>7</td>
<td>LP-005</td>
<td>9-Jul</td>
<td>$2,681</td>
<td>Date:</td>
<td>9-Jul</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>LP-006</td>
<td>30-Jul</td>
<td>$2,463</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>LP-007</td>
<td>15-Aug</td>
<td>$2,463</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>LP-008</td>
<td>28-Aug</td>
<td>$2,515</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>LP-009</td>
<td>17-Sep</td>
<td>$2,839</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>LP-010</td>
<td>15-Oct</td>
<td>$2,499</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

9. Save and close this workbook.

**LOOKUP Function**

Like the INDEX function, the LOOKUP function has two different versions: a vector version and an array version.

Also like the INDEX function, LOOKUP will allow you to use a two-dimensional range of cells containing many rows and columns of data. However, the vector version requires that you use only one or, at-most, two vectors within that range, and the rest are ignored. A vector is simply a single row or column of cells.

Like the MATCH function, the LOOKUP function will search through a range of cells (the lookup vector) for the lookup value. Unlike the MATCH function, LOOKUP is limited to one vector (a row or a column). When the lookup value is found, its position in the lookup vector (for example third cell down from the top) is noted. The function will then find the value in the same position (third cell down from the top) in the result vector and display that value. If a result vector is not used, the result will be pulled from the lookup vector. If the lookup value is not found in the lookup vector, then the largest value in the lookup vector that is less than the lookup value is used.

The format of the vector version is:

```
=LOOKUP(lookup value, lookup vector, [result vector])
```

Where:

<table>
<thead>
<tr>
<th>Identifier</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>lookup value</td>
<td>Identifies the value to be found in the lookup vector.</td>
</tr>
<tr>
<td>lookup vector</td>
<td>Identifies the range of cells to be searched. This range must be a single row or column.</td>
</tr>
<tr>
<td>result vector</td>
<td>Optional: Identifies a range of cells where the result will be obtained.</td>
</tr>
</tbody>
</table>

In order for the vector version to work correctly, the following conditions must be met:

- The values in the range of cells designated as the lookup vector must be sorted in ascending order.
- The result vector must have the same shape (row or column) and number of cells as the lookup vector.
Example worksheet:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Factor</td>
<td>Length</td>
<td>Volume</td>
<td>Weight</td>
</tr>
<tr>
<td>2</td>
<td>-3</td>
<td>millimeter</td>
<td>milliliter</td>
<td>milligram</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>meter</td>
<td>liter</td>
<td>gram</td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>kilometer</td>
<td>cubic meter</td>
<td>kilogram</td>
</tr>
</tbody>
</table>

Following are examples of the LOOKUP function using the vector version:

<table>
<thead>
<tr>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>=LOOKUP(1,A2:A4,C2:C4)</td>
<td>liter</td>
</tr>
<tr>
<td>=LOOKUP(-3,A2:A4,B2:B4)</td>
<td>millimeter</td>
</tr>
<tr>
<td>=LOOKUP(2,A2:A4,D2:D4)</td>
<td>gram</td>
</tr>
</tbody>
</table>

The array version is similar to the vector version, except that it is simpler to use because only one cell range is specified. In the array version, the lookup vector is always assumed to be in the first row or column of the cell range, and the result vector is always assumed to be in the last row or column.

The format of the array version is:

=LOOKUP(lookup value, range array)

Where:

<table>
<thead>
<tr>
<th>lookup value</th>
<th>Identifies the value to be found in the range array.</th>
</tr>
</thead>
<tbody>
<tr>
<td>range array</td>
<td>Identifies the range of cells containing the values to be searched and the data to be returned.</td>
</tr>
</tbody>
</table>

In order for the array version to work correctly, the following conditions must be met:

- The values in the range array **must** be sorted in ascending order.
- Be sure to select the correct shape for the range array. If the range array has more columns than rows (short and wide), then the top row of the range is always assumed to be the lookup vector and the bottom row is always assumed to be the result vector. If the range array has the same (square) or fewer columns than rows (tall and thin), then left-most column is assumed to be the lookup vector and the right-most column is assumed to be the result vector.

Using the example worksheet shown previously, examples of the LOOKUP function using the array version are listed here:

<table>
<thead>
<tr>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>=LOOKUP(1,A2:C4)</td>
<td>liter</td>
</tr>
<tr>
<td>=LOOKUP(-3,A2:B4)</td>
<td>millimeter</td>
</tr>
<tr>
<td>=LOOKUP(1,A2:D4)</td>
<td>3</td>
</tr>
</tbody>
</table>

**Note:** Microsoft suggests that you use HLOOKUP or VLOOKUP instead of the array version of LOOKUP.

### HLOOKUP and VLOOKUP Functions

**Objectives 3.2.1, 3.2.2**

The HLOOKUP and VLOOKUP functions are similar to the LOOKUP function; you use them to search for a lookup value in the first row or column of a two-dimensional array, and return the value in the same position in the result vector. The HLOOKUP function is specifically designed to use the top row as the lookup vector, and the VLOOKUP function always uses the left-most column as the lookup vector.
The format for the vertical lookup function is:

\[ =\text{VLOOKUP}(\text{lookup value}, \text{table array}, \text{column index number}, \text{range lookup}) \]

Similarly, the format for the horizontal lookup function is:

\[ =\text{HLOOKUP}(\text{lookup value}, \text{table array}, \text{row index number}, \text{range lookup}) \]

<table>
<thead>
<tr>
<th>lookup value</th>
<th>The value to be found in the table array.</th>
</tr>
</thead>
<tbody>
<tr>
<td>table array</td>
<td>A range of cells containing the values to be searched and the data to be returned.</td>
</tr>
<tr>
<td>column index number</td>
<td>The column number in the array containing the value to be returned; columns are numbered sequentially from the left-most column.</td>
</tr>
<tr>
<td>row index number</td>
<td>The row number in the array containing the value to be returned; rows are numbered sequentially from the top row of the table.</td>
</tr>
<tr>
<td>range lookup</td>
<td>You can enter “0” or “false” if you wish the function to find an exact match in a sorted or unsorted list; enter “true” or omit argument if you want the function to find an approximate match in a sorted list.</td>
</tr>
</tbody>
</table>

Even though the range lookup parameter is optional, it has an important switch setting that deserves a closer look. Consider an example of a scoring sheet for a school examination paper:

<table>
<thead>
<tr>
<th>Mark Achieved on Exam</th>
<th>Grade Assigned</th>
</tr>
</thead>
<tbody>
<tr>
<td>0%</td>
<td>F</td>
</tr>
<tr>
<td>50%</td>
<td>D</td>
</tr>
<tr>
<td>60%</td>
<td>C</td>
</tr>
<tr>
<td>70%</td>
<td>B</td>
</tr>
<tr>
<td>85%</td>
<td>A</td>
</tr>
</tbody>
</table>

All students will have a result ranging from 0% to 100%. The VLOOKUP formula would be used here because the data is aligned vertically. By using a range lookup value of TRUE, you tell Excel to search the table for the highest mark value that does not exceed the lookup value. For example, a student achieving a mark of 65% will get a grade value of C because 60% is the highest table value found that does not exceed the lookup value.

If a range lookup value of FALSE is used, the VLOOKUP formula will not find the correct grade for most students. This is because the mark achieved must exactly match one of the values in the table in order to be found. Therefore, a range lookup value of FALSE is not the right choice to use here.

If the scoring sheet is structured horizontally, the HLOOKUP formula should be used instead, as follows:

<table>
<thead>
<tr>
<th>Mark Achieved on Exam</th>
<th>0%</th>
<th>50%</th>
<th>60%</th>
<th>70%</th>
<th>85%</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grade Assigned</td>
<td>F</td>
<td>D</td>
<td>C</td>
<td>B</td>
<td>A</td>
</tr>
</tbody>
</table>

The same range lookup value of TRUE can be used to find the correct grade to assign, even though the student’s mark can be any value between 0% and 100%. And the range lookup value of FALSE is also inappropriate for this HLOOKUP formula because most students will not have a mark that matches the table values exactly.
Learn to use the VLOOKUP and LOOKUP functions

This exercise is designed to demonstrate the use of the VLOOKUP and LOOKUP functions in an invoice worksheet.

1. Open the Pricing Sheet workbook, save it as Pricing Sheet – Student, and then ensure the VLOOKUP worksheet tab is active.

This worksheet shows a partial tour pricing list on the top and a sample invoice below it. The requirement is to enter a product number in column B of the invoice and have the description and cost appear on the invoice automatically. In this case, Excel will look up the product number in an inventory and retrieve the corresponding description and cost.

Notice that the tour numbers are sorted in ascending order. This is required for the lookup function to work properly.

In a real-world example, the inventory list would be on a different worksheet or, more often, in a different workbook. This exercise has been simplified for instructional purposes.

2. In cell E12, enter: =A12*D12.

3. Copy this formula to range E13:E14.

4. Select cell E15, then on the Home tab, in the Editing group, click AutoSum, verify the formula is: =SUM(E12:E14) and press ENTER.

5. In cell C12, type: =VLOOKUP(B12,$B$5:$D$8,2,TRUE) and press ENTER.

   The characters #N/A appear in cell C12.

6. Copy this formula to the range C13:C14.

7. In cell D12, type: =VLOOKUP(B12,$B$5:$D$8,3,TRUE) and press ENTER.

Notice the #N/A filling the cells; this is displayed by the lookup functions when there is no lookup value. The IF function could be used to clean up its appearance, but this exercise focuses on the lookup function.

9 Enter the following quantities and part numbers:

<table>
<thead>
<tr>
<th>Row</th>
<th>Qty</th>
<th>Tour#</th>
</tr>
</thead>
<tbody>
<tr>
<td>12</td>
<td>3</td>
<td>A0289</td>
</tr>
<tr>
<td>13</td>
<td>4</td>
<td>B3454</td>
</tr>
<tr>
<td>14</td>
<td>2</td>
<td>A4350</td>
</tr>
</tbody>
</table>

The worksheet should now appear similar to the following:

The last item entered had the wrong tour number. As a result, the wrong description and cost were displayed. For this kind of worksheet, you should use the FALSE value for the range lookup option so that Excel will identify incorrect tour numbers immediately.

10 Select cell C12, press F2, and change the TRUE to FALSE in the VLOOKUP formula.

11 Repeat the previous step for cell D12.

12 Copy the formulas in cell C12:D12 to cells C13:D14.

The Description (C14) and Cost (D14) for row 14 now show #N/A because this tour number was not found in the lookup list.

13 Select cell B14 and enter the correct tour # value: A4353.
Switch to a similar copy of this worksheet, but using the vector form of the LOOKUP function.

14 Click the LOOKUP VECTOR worksheet tab to select it.

15 Enter the following formulas into this worksheet:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>C12</td>
<td>=LOOKUP(B12,$B$5:$B$8,$C$5:$C$8)</td>
</tr>
<tr>
<td>D12</td>
<td>=LOOKUP(B12,$B$5:$B$8,$D$5:$D$8)</td>
</tr>
</tbody>
</table>

16 Copy the formulas in cells C12:D12 to cells C13:D14.

Now try the array form of the LOOKUP function.

17 Click the LOOKUP ARRAY worksheet tab to select it.

18 Enter the following formulas into this worksheet:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>C12</td>
<td>=LOOKUP(B12,$B$5:$C$8)</td>
</tr>
<tr>
<td>D12</td>
<td>=LOOKUP(B12,$B$5:$D$8)</td>
</tr>
</tbody>
</table>

19 Copy the formulas in cell C12:D12 to cells C13:D14.

20 Select cell D12 in each of the three worksheets and compare the formulas.

In the VLOOKUP worksheet, the components of the VLOOKUP formula are as follows:

- **B12**: Cell B12 contains the text string A0289 to be used as the lookup value.
- **$B$5:$D$8**: The left-most column of this data range – column B – is used to compare against the lookup value.
- **3**: The column index number of 3 indicates the data in column D to be retrieved. With a lookup value of A0289, the first row is used and the value 1,400.00 is retrieved.
- **FALSE**: This indicates that the lookup value must exactly match the values listed in the left-most column.
In the LOOKUP VECTOR worksheet, the components of the LOOKUP formula are as follows:

- **B12**: Cell B12 contains the text string A0289 to be used as the lookup value.
- **$B$5:$B$8**: This column is used to compare against the lookup value.
- **$D$5:$D$8**: This column contains the list of values to be retrieved. With a lookup value of A0289, the first row is used and the value 1,400.00 is retrieved.

In the LOOKUP ARRAY worksheet, the components of the LOOKUP formula are as follows:

- **B12**: Cell B12 contains the text string A0289 to be used as the lookup value.
- **$B$5:$D$8**: The left-most column of this data range – column B – is used to compare against the lookup value. The right-most column contains the list of values to be retrieved. With a lookup value of A0289, the first row is used and the value 1,400.00 is retrieved. Any other columns between the left-most and right-most are ignored.
Save and close this workbook.

Date and Time Functions

Objectives 3.3.1, 3.3.2

Excel’s date and time functions help you create worksheets that perform calculations based on dates and times. It is possible to use dates to calculate things such as age or length of service or the number of days between two dates. The use of time functions enables calculations based on time, with Excel converting seconds to minutes and minutes to hours.

To perform these calculations, Excel stores the date and time values as serial numbers with the integer part representing the number of days since January 1, 1900 and the fractional part as a portion of a 24-hour period. A *serialized date value* is simply a number that Excel uses to represent a specific point in time (which consists of the month, day, year, and time components), which could be the current date and time or a manually entered date and time. Special functions are provided to determine the date and time serial numbers, and to extract the month, day, year, hours, minutes, and second values from serial numbers.

Some of the most useful date and time functions include:

**NOW**
Return the serial number of the current date and time. This date and time value is continuously updated. The format of this function is **NOW()**.
The function does not take any arguments because it simply gets the current date and time from your local computer.

**TODAY**
Return the serial number of today’s date with the time portion set to 0. This date value is continuously updated. The format of this function is **TODAY()**.
Like the NOW function, it does not take any arguments.

**DATE**
Calculate the serial number for a specified date. The format of this function is **DATE(year, month, day)**.
Each of the year, month, and day values must be individual whole numbers, and must be valid for that component. For example, month must be between 1 and 12, and day must be valid for the specified month.
**DATEVALUE**

Like the DATE function, this function calculates the serial number for a specified date. The format of this function is **DATEVALUE(date in text form)**. Unlike DATE, DATEVALUE uses a text description of the date (e.g. March 15, 2016) as the argument.

**DAY**

Display the day value for the specified date serial number. This function is useful for separating out just the day value for a date. The format of this function is **DAY(date value)**.

**MONTH**

Display the numeric month value for the date serial number. This function is useful for separating out just the month value for a date. The format of this function is **MONTH(date value)**.

**YEAR**

Display the year value for the specified year serial number. This function is useful for separating out just the year value for a date. The format of this function is **YEAR(date value)**.

**DAYS**

Calculates the number of days between two dates as a whole number. The format of this function is **DAYS(end date, start date)**.

**WEEKDAY**

Display a numeric weekday value for the date serial number. For example, a date that falls on a Sunday will return a 1 (first day of the week), and a date on a Saturday will return a 7. You can also choose from different numbering patterns such as Monday is the first day of the week and therefore returns as a 1. The format of this function is **WEEKDAY(date value, return type)**.

**WORKDAY**

Calculates the nearest working day in the future or the past. This function is useful in business situations, such as developing project plans where weekends can’t be included in date calculations. The format of this function is **WORKDAY(start date, # of days, holiday date range)**.

**TIME**

Calculate the serial number for a specified time entered as three arguments: the hour, minutes, and number of seconds. The format of this function is **TIME(hour, minute, seconds)**.

**HOUR**

Display the hour value for the specified time serial number. This function is useful for separating out just the hour value for a date/time value. The format of this function is **HOUR(date/time value)**.

**MINUTE**

Display the minute value for the specified time serial number. This function is useful for separating out just the minute value for a date/time value. The format of this function is **MINUTE(date/time value)**.

**SECOND**

Display the second value for the time serial number. This function is useful for separating out just the seconds value for a date/time value. The format of this function is **SECOND(date/time value)**.

**Note**: A different way to obtain the current date is by pressing **CTRL+;** (semicolon), and the current time by pressing **CTRL+SHIFT+;** (semicolon). However, these date and time values are not continuously updated; they are inserted into the worksheet as fixed points in time.
Learn to use date and time functions

This exercise demonstrates the use of date and time functions.

1. Open the Departure Date Calculator workbook, and save as Departure Date Calculator - Student.
2. Select cell B3 and enter a date in the future of your choice.

Use a function to obtain the current date and time. It automatically updates itself over time.

3. Select cell B4 and enter: =NOW().

4. Select cell C5 and type the first part of the formula (do not press ENTER yet): =WEEKDAY(B3,

The WEEKDAY function returns a single number that identifies which of the week that a date falls on. It has a second argument that allows you to choose which numbering pattern to use, with Sunday being 1 as the default if the second argument is not specified.

5. Finish the rest of the formula by entering: 1)

Now use the INDEX function to translate the day of week number to its description.

6. Select cell B5 and enter: =INDEX(D4:E10,C5,2)

Perform a calculation using dates. These calculations look just like ones using numeric values.

7. Select cell B7 and enter: =B3-B4

You can also calculate the difference in days between the two dates using a built-in function. However, it calculates in whole days.

8. Select cell C7 and enter: =DAYS(B3,B4)

Extract the components of today’s date and time value into individual numbers.

9. Enter the following functions:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>B9</td>
<td>=MONTH(B4)</td>
</tr>
<tr>
<td>B10</td>
<td>=DAY(B4)</td>
</tr>
<tr>
<td>B11</td>
<td>=YEAR(B4)</td>
</tr>
<tr>
<td>B12</td>
<td>=HOUR(B4)</td>
</tr>
<tr>
<td>B13</td>
<td>=MINUTE(B4)</td>
</tr>
<tr>
<td>B14</td>
<td>=SECOND(B4)</td>
</tr>
</tbody>
</table>
Recalculate the current date and time.

10 Press the F9 key to recalculate the current date and time. Wait at least five seconds and press it again and note the changes in cells \( B13 \) and \( B14 \) as the current time changes.

Create a serialized date value using the month, day, and year numbers that you have just separated out.

11 Select cell \( B16 \) and enter: \( =\text{DATE}(B11,B9,B10) \)

Create a serialized date value using a date entered as a text string. To ensure that Excel is not confused which number is the month and day value, you will enter the date using the ISO format.

12 Select cell \( B17 \) and enter: \( =\text{DATEVALUE}("\text{yyyy-mm-dd}"") \) where \( \text{yyyy-mm-dd} \) is the date you entered in cell \( B3 \) at the beginning of the exercise.

The result is a number, which is the serialized date value. You can change the format to a date.

13 Select cell \( B17 \) again, then on the Home tab in the Number group, click the Number Format drop-down button and click Short Date.

Use the DAYS function again to calculate the same value as step 8 above, but this time on two date values that do not have any time components.

14 Select cell \( B18 \) and enter: \( =\text{DAYS}(B17,B16) \)

The WORKDAY function is useful in business situations when performing date calculations, but weekends and holidays must be excluded.

15 Examine cell \( B5 \). If it is a Saturday or Sunday, change the travel departure date in cells \( B3 \) and \( B17 \) so that cell \( B5 \) is displaying a weekday.

16 Select cell \( B20 \) and enter the number of days currently displayed in cell \( B18 \). Do not enter a formula that references cell \( B18 \).

17 Select cell \( B21 \) and enter: \( =\text{WORKDAY}(B16,B20,B22:B23) \)

18 Select cell \( B17 \), then on the Home tab, in the Clipboard group, click the Format Painter button once, then click cell \( B21 \) to copy the formatting for that cell.

At this point, cell \( B21 \) shows a date that is much later than the travel departure date showing in cell \( B17 \) (and \( B3 \)). This is caused by the \# of days value in cell \( B20 \), which should count only the number of working days difference from today to the departure date. Cell \( B18 \) shows the total \# of days, including weekends.

**Note:** If your weekend days are not Saturdays and Sundays, use the WORKDAY.INTL function to specify other days of the week as weekends.

19 Change the number in cell \( B20 \) so that the date in cell \( B21 \) is the same as the date showing in cell \( B17 \). You can estimate this number by multiplying the number in cell \( B18 \) by 0.714 (5 working days divided by 7 days in a week).

The WORKDAY function only skips over weekends by default. You can also have it skip over holiday dates.

20 Enter a date into cell \( B22 \). This date should be a date between today and the travel departure date displayed in cell \( B17 \) and \( B3 \). It also must be a weekday between Monday and Friday.
21 Enter another weekday date into cell B23.

By specifying two holiday dates (you can include as many holidays as needed in the cell range), the WORKDAY function will automatically adjust its calculations.

The worksheet should now appear similar to the following:

```
<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
<td>D</td>
<td>E</td>
</tr>
<tr>
<td>1</td>
<td>Tolan Adventures</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Travel departure date:</td>
<td>12-Oct-20</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Today's date:</td>
<td>20-Feb-17</td>
<td>1 Sunday</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Departure day of week:</td>
<td>Monday</td>
<td>2</td>
<td>2 Monday</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td>3 Tuesday</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td># of days until travel:</td>
<td>1329.664995</td>
<td>1330</td>
<td>4 Wednesday</td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td>5 Thursday</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Current month:</td>
<td>2</td>
<td>6 Friday</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Current day:</td>
<td>20</td>
<td>7 Saturday</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Current year:</td>
<td>2017</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Current hour:</td>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Current minutes:</td>
<td>26</td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Current seconds:</td>
<td>24</td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Current date:</td>
<td>2/20/2017</td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Departure date:</td>
<td>10/12/2020</td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td># of days difference</td>
<td>1330</td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td># of days</td>
<td>949.62</td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Nearest working day</td>
<td>10/12/2020</td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Holiday day 1</td>
<td>15-Feb-17</td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>Holiday day 2</td>
<td>22-Feb-17</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

Even though some of the cells only show two digits of the year value, Excel uses four digits internally to ensure the date calculations are correct.

22 Save and close the workbook.

### Checking for Formula Errors

Users automatically assume that spreadsheets are correct and base decisions on the information provided. Spreadsheet usage is pervasive in business and personal applications, ranging in size from major corporate investments to individual life insurance policies and everything in between. Accordingly, the impact from errors in spreadsheets can range from minor inconveniences to major implications on the livelihoods of thousands of employees. The simple checking of formulas should be performed on any worksheet before it is printed or saved.

### Using the Error Checking Tool

**Objective 3.5.3**

Excel includes an error checking feature that greatly reduces the time spent auditing formulas for accuracy. If background error checking is enabled, Excel displays a dark green triangle in the upper left corner of a cell to indicate that it contains an inappropriate formula. Possible errors that Excel will highlight include:

- formulas that are inconsistent with others in the same row or column.
- formulas that refer to a range but omit a cell that is within or adjacent to the range.
Lesson 2

Advanced Functions and Formulas

- formulas that evaluate to an error.
- numbers stored as text.

When you select a cell with a green triangle, a box with an exclamation mark (the Trace Error icon) appears beside it. Click the button to display a drop-down menu that describes the problem and offers to fix it.

Alternatively, on the Formulas tab, in the Formula Auditing group, click Error Checking.

Learn to use the Error Checking tool

This exercise demonstrates how to use Excel’s Error Checking tool to find errors in formulas.

1. Open the Rocky Mountains Tour Error Checking workbook and save it as Rocky Mountains Tour Error Checking – Student.

Tolano Adventures is using this spreadsheet to compare the revenues to the expenses for a planned tour. The numbers appear to indicate that a healthy profit will be made.

However, this worksheet has formulas with errors in them. Wherever Excel believes that a formula is incorrect, it displays an Error Indicator (green triangle at the upper left corner) in the cell. By default, this background error checking is turned on. You can verify this by looking in the Options dialog box.

2. Click File and then click Options. In the Excel Options dialog box, click the Formulas category.

3. Ensure that the Enable background error checking check box is turned on.
Notice that you can also change the color of the Error Indicator triangle or toggle various error checking rules on or off.

4 Click the **Reset Ignored Errors** button and then click **OK** to close the dialog box.

An error indicator (the small green triangle) is now visible in the upper left corner of cell D21, indicating that it contains a possible formula error.

5 Select cell **D21** and click the **Trace Error** icon to the left of this cell.

At the top row of the Trace Error menu, Excel describes the problem it has identified: the formula in this cell does not include adjacent cells containing data that you may have wanted to include. At this point, you should check the contents of the formula bar to determine whether to change this formula.

6 Look at the Formula Bar for this cell.

The formula in this cell is **=SUM(D13:D19)**. However, cells D12 to D20 contain expense numbers.

7 In the Trace Error menu, click **Update Formula to Include Cells**.

If you select Ignore Error, the green triangle disappears and the error is not identified in future error checks (unless you click Reset Ignored Errors in the Excel Options window).

8 Click **Undo** in the Quick Access Toolbar to revert the formula back to its previous value.

Instead of checking each cell one by one, use the Error Checking tool to automatically select the next one.

9 Select cell **A1** or any cell at the top of the worksheet.

This step demonstrates how Excel behaves when you use the error checking tool. In fact, it doesn’t matter where the cell pointer is when you carry out the next step.

10 On the Formulas tab, in the Formula Auditing group, click **Error Checking**.

The cursor jumps to the first cell that Excel finds with a potential error in it.

Excel has found the formula error again in cell D21.

11 Click **Update Formula to Include Cells**.
When Excel can no longer find any problems with formulas, it displays the following:

12 Click OK.

Your worksheet should now look like the following:

This updated worksheet shows that the profit has been substantially reduced, but there is still a small profit being made. The worksheet actually has more formula errors, but the Error Checking Tool has found as many errors as it could.

13 Save and close the workbook.

**Tracing Formula Errors**

**Objective 3.5.1**

Another method of finding formula errors is to use tracing tools. These tools (which can be found in the Formula Auditing group on the Formulas tab of the Ribbon) draw arrows to help you trace cells that are precedents or dependents of the current cell. By following the lines and dots in the arrows, you can determine which cells are referenced in formulas.

When you select a cell and trace its precedents, Excel draws lines from other cells leading to the current active cell. Excel also draws box outlines around these cells. This is a visual way of examining a worksheet to see which cells are being referenced by formulas. In a complex worksheet with many formulas, this is a very useful tool to ensure they are all correct.
When you select a cell and trace its dependents, Excel draws lines to any cells that use the data in the current active cell, directly and indirectly. Dependent cells contain formulas that reference the current active cell.

You can extend the tracing of precedent or dependent cells by selecting Trace Precedents or Trace Dependents again in the Ribbon.

Learn to use auditing tools

In this exercise, you will use the auditing tools on the Rocky Mountains Tour workbook to see if there are any other formula errors.

1. Open the Rocky Mountains Tour Tracing Errors workbook and save as Rocky Mountain Tour Tracing Errors – Student.

Start by selecting the most important cell in the entire workbook—the one that calculates the profit of Revenues less Expenses.

2. Select cell D23 and then, on the Formulas tab, in the Formula Auditing group, click Trace Precedents.

Notice the thin line and the dots drawn from cell D9 to D23. The dots in cells D9 and D21 indicate that these cells are referenced in the formula in cell D23. These appear to be correct.

3. With cell D23 still selected, click Trace Precedents again.

As the Trace Precedents tool drills down through the next layer of detail, Excel draws boxes above cells D9 and D21. The boxes indicate that these cell ranges are referenced in the formulas in the two cells. These also appear to be correct.

4. Click Trace Precedents one more time.

Another set of lines and dots are drawn as the Trace Precedents tool drills down through another layer of detail. These indicate the cells referenced in the formulas entered into the cell range D6:D8.
Looking at the last set of lines and dots drawn, you should see that they do not appear correct. The Fare value in cell B6 is used to calculate the total in cells D6 to D8, but the fares in cells B7 and B8 are not used at all.

5  Select cell D7.

By selecting cell D7, you can see that the formula is incorrect.

6  Change the formula in cell D7 to: \( \text{B7} \times \text{C7} \).

7  Select cell D8 and change the formula to: \( \text{B8} \times \text{C8} \).

8  Select cell D23 and click Trace Precedents again.

The lines and dots now appear in the correct cells. It also now appears that this tour will incur a loss instead of a profit.
When you have completed auditing the worksheet, you can remove the arrows.

9. On the Formulas tab, in the Formula Auditing group, click **Remove Arrows**.

Instead of finding the precedent cells, you can find cells containing formulas that depend on the value in a selected cell, either directly or indirectly. This is the reverse method: tracing dependent cells.

10. Select cell B6 and, on the Formulas tab, in the Formula Auditing group, click **Trace Dependents**.

11. Click **Trace Dependents** two more times.

The worksheet now appears similar to the following:

![Worksheet screenshot]

12. Save and close the workbook.

**Evaluate Formulas**

**Objective 3.5.4**

Excel formulas do an excellent job of performing calculations that are sometimes very complex. Even when a formula looks simple, you may be puzzled when the result is different than what you expected. You can use the Evaluate Formula feature to force Excel to slow down and perform each of the internal calculations in a formula one step at a time. As it performs each step, you can see the intermediate results, which will help you understand where the data is coming from.
The Evaluate Formula dialog box shows the formula that is in the selected cell in the Evaluation text box. An underline appears under the cell reference (or expression) that is about to be evaluated. You can then choose one of three buttons:

- **Evaluate**: If the underline appears under a cell reference, press this button to obtain the value from that cell and display it in the formula. If the underline is under an arithmetical expression, press this button to perform the arithmetic and display the result.
- **Step In**: If an underlined cell reference contains an intermediate formula, you can click this button to display and evaluate that formula in a separate box.
- **Step Out**: If you have stepped into a cell to evaluate its formula, press this button to return to the original formula in the upper box.

You may find the Evaluate Formula feature difficult to use. It is time-consuming to track every step inside the formula as it performs each calculation or evaluates each cell reference. You will most likely have to repeat the evaluation several times before identifying the errant calculation. As a result, you may want to use the Evaluate Formula feature only as a last resort (that is, if you are unable to debug it any other way).

### Learn to use the Evaluate Formula feature

This exercise demonstrates how to use the Evaluate Formula feature.

1. Open the *Travel Miles* workbook and save as *Travel Miles – Student*.
2. Select cell C4.

This worksheet combines the contents of two cells, C1 and C2, to form a sentence, as shown in cell C4. The intention is to enter different points values in cell C1 for different customer transactions and display a friendly message from cell C4 on a document, such as an email or statement for the customer.

This formula looks very intimidating, as it contains three levels of nested functions in some parts. The purpose of this function is to replace the “XX” in the template wording in cell C2 with the number from cell C1.

Notice that the displayed text in the cell is incorrect because an extra “X” displays before the value 300. You will need to find out what to fix in the formula to remove that “X”.

3. On the Formulas tab, in the Formula Auditing group, click **Evaluate Formula**.
The Evaluate Formula dialog box first shows the full formula. The underline under the first cell reference indicates that it will be the first to be evaluated. The Evaluate button will show the result of that cell reference as it is translated.

4 Click **Evaluate**.

![Evaluate Formula dialog box](image)

The Evaluation box now shows a current value of “Travel miles points earned – XX” where C2 used to be. The underline is now under the next cell reference, which is a reference to cell C2 again. The Evaluation box helps you by translating the formula piece by piece as it executes each calculation and cell reference. Pressing the Evaluate button forces Excel to perform one calculation at a time.

5 Click **Evaluate** again.

The underline is now under FIND(“XX”, “Travel miles points earned – XX”). If you recall your text functions, you will know that this finds the position of the characters “XX” in the text string and returns the number representing that position.

6 Click **Evaluate** again.

**Note:** If you lose track of what the original formula looks like, look up at the Formula Bar.

The underline is now under MID(“Travel miles points earned – XX”,1,30). The FIND(“XX”,C2) function has been completed and returned the value 30. So the MID function now shows the 30, replacing the FIND function that appeared in that position.

7 Click **Evaluate** again.
The result of the MID function is “Travel miles points earned – X”. You have now found the location of the error because the extra “X” appears here. The MID function needs to extract one less character at the far right end. By looking in the Formula Bar, you will notice that it is the FIND function that calculates the number of characters to extract. The correction is to subtract 1 from that number.

8 Click Close.

9 If necessary, select cell C4 again. Change the formula to:

```
=CONCATENATE(MID(C2,1,FIND("XX",C2)-1),TEXT(C1,"#,##0"))
```

Notice the “-1” is added at the right of the FIND function.

The worksheet should now appear similar to the following:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Points</td>
<td>Travel miles points earned – XX</td>
<td></td>
</tr>
<tr>
<td>Old text</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New text</td>
<td>Travel miles points earned - XX</td>
<td></td>
</tr>
</tbody>
</table>

The text displayed in cell C4 is now correct.

In evaluating this formula, you only used the Evaluate button. There are also the Step In and Step Out buttons.

10 Select cell C4 again and, on Formulas tab, in the Formula Auditing group, click Evaluate Formula.

11 Click Step In.

When you used the Evaluate button earlier, the C2 was simply replaced with the cell value in the Evaluation box. The Step In button shows you the contents of the cell in C2 in a separate box before completing that replacement.

12 Click Step Out.

13 Click Evaluate seven more times to perform this function.

The Evaluation window now shows the completed result of the entire formula, and the Evaluate button has changed to a Restart button.
14 Click Restart.

When you press the Restart button, the evaluation starts over again.

15 Click Close.

16 Select cell C2 and change the text to: Travel miles points you earned today – XX

17 Select cell C1 and enter: 1500.

The displayed text in cell C4 automatically adjusts itself to the new template wording and points value, because of the flexibility of the function used in that cell.

18 Save and close the workbook.

**Manually Checking and Displaying Formulas**

While the Error Checking tool is very helpful, you should never skip the step of manually checking your formulas to ensure they reference the correct cells. For example, if all the formulas in a row refer to values in the same incorrect row, Excel will not detect an error. Also, Excel ignores inconsistencies if formulas reference other formulas rather than values. Therefore, you should still manually check formulas for accuracy.

Manually checking a worksheet means selecting every cell in the worksheet to determine if it contains the right value or formula. If a cell contains a formula that references other cells, you should look and verify that the correct cells are being referenced. Excel displays cell range references visually by highlighting them with a colored border when you press F2 to help you verify that these formulas are correct.

A useful feature to help you review all of the formulas in a worksheet at the same time is the **Show Formulas** option. This feature forces every cell to display its underlying formula instead of the calculated value.
Learn to check worksheets for formula errors

This exercise demonstrates how to check worksheets to ensure there are no formula errors.

1. Open the *Rocky Mountains Tour Manual Checking* workbook and save as *Rocky Mountains Tour Manual Checking - Student*.

Select cells containing SUM formulas to verify that they are correct.

2. Select cell **C9** and then press the F2 key to switch to edit mode for this cell.

   While in edit mode, you can see the formula in this cell, and the referenced range of cells is highlighted on the worksheet. This formula appears to be correct.

3. Press the ESC key to exit from edit mode.

4. Repeat steps 2 and 3 for cells **D9** and **D21**.

   The formula in cell D9 appears to be correct. However, cell D21 does appear to be suspicious. Repeating these steps for each cell is tedious work.

Repeating these steps for each cell is tedious work. Activate the Show Formulas feature to speed things up.

5. On the Formulas tab, in the Formula Auditing group, click **Show Formulas**.

6. If necessary, adjust the size of the Excel workbook window so that you can see the cell range **A1:D23**.

   With the worksheet now in Show Formula mode, you can easily see which cells to check. First, select the cells containing SUM formulas to verify that they are correct.

7. Select cell **C9**, **D9**, and then **D21**.

   As you select each of these cells, note the range of cells that are highlighted and ask yourself if the selection appears to be correct.

The worksheet should appear as follows:
With cell D21 still selected, correct the formula by dragging the upper right (or upper left) handle around the blue highlighted cell range up by one row. Then drag the bottom left (or bottom right) handle down by one row.

The formula in cell D21 should now be =SUM(D12:D20).

Now check the multiplication formulas.

Click each of cells D6, D7 and D8. Correct any of the formulas in these cells, as necessary.

Then check the last remaining formula on this worksheet.

Click cell D23, and correct the formula in it, if necessary.

On the Formulas tab, in the Formula Auditing group, click Show Formulas again to turn the formula display off.

Save and close the workbook.

Data Validation

Objective 2.1.3

Electronic spreadsheets first appeared as very crude blank sheets. You could enter any type of value in any cell and the spreadsheet would attempt to cope with it. For example, even if it seemed as if there should be a numeric value in a cell, Excel would accept a text string if you entered it. If that cell were subsequently used in a calculation, Excel treated that cell as if it contained the value 0 (zero). This flexibility (or, described another way, this willingness of the spreadsheet to accept anything anywhere without many complaints) made spreadsheets very popular with novice computer users.

However, this flexibility often resulted in undesirable side effects when wrong values were entered into certain cells. For example, the upper case letter “O” can be mistakenly entered instead of the number “0” and the lower case “l” can be mistaken for the number “1” in some character fonts.

Excel can prevent these types of errors with the Data Validation feature which displays a helpful message when the user selects a particular cell or displays an error message if an incorrect value is entered.

You can choose various data types as validation checks:

<table>
<thead>
<tr>
<th>Any value</th>
<th>Deactivate any data validation. This is the default setting for all cells. However, you can also use it to display an input message without validating any data entry.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole number</td>
<td>Allow only numeric values without any decimal digits.</td>
</tr>
<tr>
<td>Decimal</td>
<td>Allow any numeric value.</td>
</tr>
<tr>
<td>List</td>
<td>Allow selections from a defined list of values in a cell range. This is also known as a pick list. By using this type of list, you can ensure the cell will contain only one of these values.</td>
</tr>
<tr>
<td><strong>Date</strong></td>
<td>Allow only date values. The lowest date value is January 1, 1900.</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Time</strong></td>
<td>Allow only valid time values.</td>
</tr>
<tr>
<td><strong>Text length</strong></td>
<td>Allow only the specified number of text characters. This validation does not permit any numbers, dates, or time values to be entered.</td>
</tr>
<tr>
<td><strong>Custom</strong></td>
<td>Enter a formula to validate the data being entered into the cell. The result of the formula must be a true or false value.</td>
</tr>
</tbody>
</table>

## Learn to use the Data Validation feature

This exercise demonstrates how to use the Data Validation feature.

1. Open the *Feedback Form* workbook and save as *Feedback Form – Student*.
2. Select cell B10. On the Data tab, in the Data Tools group, click Data Validation. If you clicked the drop-down button below the Data Validation button, click Data Validation.
3. Enter or select the following options for the Settings tab and click OK:

<table>
<thead>
<tr>
<th>Criteria</th>
<th>Select</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow</td>
<td>Whole number</td>
</tr>
<tr>
<td>Data</td>
<td>between</td>
</tr>
<tr>
<td>Minimum</td>
<td>1</td>
</tr>
<tr>
<td>Maximum</td>
<td>5</td>
</tr>
</tbody>
</table>

![Data Validation dialog box](image)

Now try entering an invalid rating value and observe the results.

4. Select cell B10. Type: 0 and press ENTER.
   Excel displays the default error message.

![Error message](image)

5. Click Cancel.

You can customize this error message to help users understand what values are valid or invalid.
6 Select cell B6. On the Data tab, in the Data Tools group, click Data Validation.

7 Enter or select the following options for the Settings tab, but do not click OK yet:

<table>
<thead>
<tr>
<th>Criteria</th>
<th>Select</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow</td>
<td>Date</td>
</tr>
<tr>
<td>Data</td>
<td>less than</td>
</tr>
<tr>
<td>End date</td>
<td>=TODAY()</td>
</tr>
</tbody>
</table>

8 Click the Error Alert tab, enter the following settings, and click OK:

<table>
<thead>
<tr>
<th>Criteria</th>
<th>Enter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Style</td>
<td>Stop</td>
</tr>
<tr>
<td>Title</td>
<td>Incorrect date</td>
</tr>
<tr>
<td>Error message</td>
<td>Your travel date must be before today.</td>
</tr>
</tbody>
</table>

9 Select cell B6 and enter a future date.

Your customized error message is now displayed.

10 Click Cancel.
You can also display a helpful message when a cell is selected.

11 Select cell B13. On the Data tab, in the Data Tools group, click Data Validation.

12 Click the Settings tab and enter or select the following, but do not click OK yet:

<table>
<thead>
<tr>
<th>Criteria</th>
<th>Select</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow</td>
<td>Text length</td>
</tr>
<tr>
<td>Data</td>
<td>less than</td>
</tr>
<tr>
<td>Maximum</td>
<td>150</td>
</tr>
</tbody>
</table>

13 Click the Input Message tab, enter the following settings, and click OK:

<table>
<thead>
<tr>
<th>Criteria</th>
<th>Enter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Your comments</td>
</tr>
<tr>
<td>Input message</td>
<td>Your comments will be entered into a grand prize drawing!</td>
</tr>
</tbody>
</table>

Your customized input message is now displayed.

14 Click another cell and then click cell B13 again to see the input message display again.

15 Test the worksheet by entering values of your own choosing into the various cells.

16 Save and close the workbook.
Lesson Summary

You should now be able to:

- create, modify, and delete range names
- name tables
- describe what a function is
- use the correct syntax for functions
- insert a function
- use the lookup functions CHOOSE, INDEX, MATCH, LOOKUP, HLOOKUP, and VLOOKUP
- use date and time functions
- use the Error Checking Tool to mark possible incorrect formulas
- trace formula errors
- use the evaluate formula feature to debug a formula
- check the worksheet manually for formula errors
- use data validation

Review Questions

1. Why might you want to name cell ranges in your worksheets?
   a. To help identify the purpose of the range of cells
   b. To prevent errors when referring to these cells formulas
   c. To make the spreadsheet easier to read and understand by using meaningful names
   d. All of these are valid reasons for naming cell ranges.

2. What restrictions are NOT in place regarding range names?
   a. Range names are limited to no more than 255 characters in length.
   b. The names may contain alphabetic or numeric characters, as well as underscores, backslashes, periods, or question marks.
   c. Blank spaces are not permitted
   d. The first character of the name cannot be alphanumeric, an underscore, or a backslash.

3. Which formula will calculate the average salary (using the values in the Current Salary column) of all employees listed in the table named Salaries?
   a. =AVERAGE(Current Salary)
   b. =AVERAGE(Salaries)
   c. =AVERAGE(Salaries.Current Salary)
   d. =AVERAGE(Salaries[Current Salary])

4. You can use the Name Manager to:
   a. Create a new range name
   b. Modify a range name or change the cell range references
   c. Delete a range name
   d. You can use the Name Manager to do all these things.

5. Which of the following functions returns the position of a value in a list, instead of the actual value itself?
   a. INDEX
   b. MATCH
   c. VLOOKUP
   d. HLOOKUP
Lesson 2

6. Which of the following shows the correct syntax for the INDEX function?
   a. \( =\text{INDEX}(A2,D4,2,3) \)  
   b. \( =\text{INDEX}(A2-D4,2,3) \)
   c. \( =\text{INDEX}(A2:D4,2,3) \)
   d. \( =\text{INDEX}(A2:D4),2,3) \)

7. Which VLOOKUP switch setting will find an exact match for a lookup value?
   a. 0 or FALSE  
   b. TRUE  
   c. EXACT  
   d. 1

8. Which of the following will look up a value in the third row of the cell range E12:I14?
   a. \( =\text{VLOOKUP}(L4,E12:I14,2,0) \)
   b. \( =\text{HLOOKUP}(L4,E12:I14,3) \)
   c. \( =\text{HLOOKUP}(L4,E12:L14,2,0) \)
   d. \( =\text{VLOOKUP}(L4,E12:L14,3,0) \)

9. Which function listed below will show the current date and time?
   a. \( =\text{TODAY} \)
   b. \( =\text{TODAY}() \)
   c. \( =\text{NOW()} \)
   d. \( =\text{NOW}(\text{Time}) \)

10. Which function listed below will show the day of the week for the date stored in cell A2, assuming that Monday is the first day of the week?
    a. \( =\text{DAY}(A2) \)
    b. \( =\text{DAY}(A2,1) \)
    c. \( =\text{WEEKDAY}(A2,2) \)
    d. \( =\text{WEEKDAY}(A2,0) \)

11. When the Error Checking tool detects a possible error in a worksheet cell, it:
    a. automatically corrects the error.
    b. displays a dark green triangle in the upper left corner of the cell
    c. opens the debug window
    d. opens the Evaluate Formula dialog box

12. Where can you find tools to trace precedents and dependents of the current cell in a worksheet?
    a. On the Formulas tab, in the Formula Auditing group
    b. On the Data tab, in the Data Tools group
    c. On the Insert tab, in the Tracing Tools group
    d. On the Review tab, in the Review Formulas group

13. Which feature can you use to “step” your way through a formula, one calculation at a time?
    a. The Error Checking feature
    b. The Trace Precedents feature
    c. The Show Formula feature
    d. The Evaluate Formula feature

14. Which of the following is NOT possible using the data validation feature:
    a. Restricting input to whole numbers only.
    b. Restricting input to a maximum of 50 characters.
    c. Restricting input to one of 10 values in a list.
    d. It is possible to impose all the restrictions listed here using the data validation feature.
Lesson 3: Data Analysis Using Pivot Tables and Business Intelligence

Lesson Objectives

In this lesson, you will learn how to use pivot tables and pivot charts. You will also learn how to use Power Pivot to extend the pivot tables and charts into large corporate databases. Upon completion of this lesson, you should be able to:

- create, format, and customize pivot tables
- use data slicers
- group pivot table data
- create calculated fields and items for pivot tables
- reference pivot table data using GETPIVOTDATA
- create a pivot chart
- change pivot chart options
- drill down a pivot table or pivot chart
- change pivot chart styles
- activate Power Pivot, and connect it to a data source
- create Power Pivot calculated fields
- manage Power Pivot table relationships
- use cube functions
Creating and Managing Pivot Tables

The pivot table is one of the most powerful features in Excel. A pivot table lets you summarize or cross-tabulate large amounts of data by selecting fields for rows and columns and performing a summary function on the intersections of the row and column fields.

Pivot tables are frequently used to analyze large volumes of data, which are usually found in corporate databases. When performing this kind of analysis, you almost always find values that repeat in many data records or rows. The repeating values can be paired in various combinations to reveal underlying trends.

Creating a Pivot Table

Objective 4.2.1

The PivotTable Fields task pane controls the structure of the pivot table. You use this task pane to decide which columns of data from your source data table (correctly referred to as fields) to use as the columns, rows, values, or filters for the pivot table.

<table>
<thead>
<tr>
<th>Filters</th>
<th>Select (or filter) rows of data from the source data that appear in the pivot table.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columns</td>
<td>Display fields in this area as columns across the top of the pivot table.</td>
</tr>
<tr>
<td>Rows</td>
<td>Display fields in this area as rows down the left side of the pivot table.</td>
</tr>
<tr>
<td>Values</td>
<td>Summarize fields in this area in the main body of the pivot table. The default summary function is SUM, although it can be changed to other functions, such as AVERAGE, MIN, or MAX.</td>
</tr>
</tbody>
</table>

Excel allows you to put more than one column from the source data into each area in the PivotTable Fields task pane.
Learn to create a pivot table

This exercise demonstrates how to create a pivot table.

1. With the Sales Pivot Table workbook open, take a moment to review the contents of the worksheet.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Date</td>
<td>Customer No.</td>
<td>Sale Type</td>
<td>Amount Paid</td>
</tr>
<tr>
<td>2</td>
<td>2-Jan-16</td>
<td>351</td>
<td>Flight+Cruise</td>
<td>6,423.00</td>
</tr>
<tr>
<td>3</td>
<td>2-Jan-16</td>
<td>354</td>
<td>Car rental</td>
<td>56.00</td>
</tr>
<tr>
<td>4</td>
<td>2-Jan-16</td>
<td>340</td>
<td>Hotel+Car rental</td>
<td>1,722.00</td>
</tr>
<tr>
<td>5</td>
<td>2-Jan-16</td>
<td>354</td>
<td>Flight+Hotel</td>
<td>505.00</td>
</tr>
<tr>
<td>6</td>
<td>3-Jan-16</td>
<td>300</td>
<td>Hotel</td>
<td>616.00</td>
</tr>
<tr>
<td>7</td>
<td>3-Jan-16</td>
<td>382</td>
<td>Car rental</td>
<td>188.00</td>
</tr>
<tr>
<td>8</td>
<td>3-Jan-16</td>
<td>325</td>
<td>Car rental</td>
<td>345.00</td>
</tr>
<tr>
<td>9</td>
<td>3-Jan-16</td>
<td>371</td>
<td>Flight+Hotel</td>
<td>1,437.00</td>
</tr>
<tr>
<td>10</td>
<td>3-Jan-16</td>
<td>399</td>
<td>Hotel</td>
<td>339.00</td>
</tr>
<tr>
<td>11</td>
<td>3-Jan-16</td>
<td>385</td>
<td>Flight+Cruise</td>
<td>4,254.00</td>
</tr>
<tr>
<td>12</td>
<td>3-Jan-16</td>
<td>305</td>
<td>Rock climbing</td>
<td>99.00</td>
</tr>
<tr>
<td>13</td>
<td>4-Jan-16</td>
<td>366</td>
<td>Cruise</td>
<td>3,503.00</td>
</tr>
<tr>
<td>14</td>
<td>4-Jan-16</td>
<td>359</td>
<td>Car rental</td>
<td>272.00</td>
</tr>
<tr>
<td>15</td>
<td>4-Jan-16</td>
<td>380</td>
<td>Flight+Cruise</td>
<td>4,316.00</td>
</tr>
<tr>
<td>16</td>
<td>4-Jan-16</td>
<td>387</td>
<td>Hotel</td>
<td>735.00</td>
</tr>
<tr>
<td>17</td>
<td>5-Jan-16</td>
<td>388</td>
<td>Hotel+Car rental</td>
<td>1,906.00</td>
</tr>
<tr>
<td>18</td>
<td>5-Jan-16</td>
<td>398</td>
<td>Flight+Car rental</td>
<td>1,301.00</td>
</tr>
<tr>
<td>19</td>
<td>5-Jan-16</td>
<td>323</td>
<td>Car rental</td>
<td>183.00</td>
</tr>
<tr>
<td>20</td>
<td>5-Jan-16</td>
<td>397</td>
<td>Flight</td>
<td>1,479.00</td>
</tr>
</tbody>
</table>

There is a lot of data – over 2,000 rows. It will be difficult to examine the data in its current conditions and identify patterns or trends. Note that the same data values are repeated down each column, but in different combinations and with different amount paid values. This kind of data is ideal for pivot tables.

The Date, Customer No., Sale type, and Payment type columns contain data values that appear multiple times and are excellent candidates for row or column labels.

2. Select a cell within the cell range A1:E2009. On the Insert tab, in the Tables group, click PivotTable.

You use the Create PivotTable dialog box to select the source of the data and to specify whether to put the PivotTable on the current worksheet or a new one. You can create pivot tables from data in a single range, multiple ranges, external data sources, or even other pivot tables.
If you select an external data source, Excel starts Microsoft Query to create a query that will retrieve the data for the pivot table.

3 Click **OK**.

The skeleton pivot table is now ready. Notice that Excel has created it in a new worksheet; you can put the pivot table into the same worksheet but you need to ensure that as the pivot table changes shape, it does not overwrite other cells containing data.

You can now create a summary that will display the total amount purchased using the different forms of payment.

4 Click the checkboxes for the **Amount Paid** and **Payment Type** fields in the PivotTable Fields task pane to turn them on and indicate that they are to be used in the pivot table. Excel does not know exactly where you will want to place these fields, so for now it takes a guess.

By default, Excel places columns containing text data into the Rows area and those containing numeric data into the Values area. Also by default, it applies the SUM function to the columns in the Values area.

Add another column containing text data to the pivot table.

5 Click the checkbox for the **Sale Type** field to turn it on.

With the addition of the Sale Type column, the pivot table is now much bigger. However, you will notice that the same sale type (for example, bike tour, car rental) labels are repeated under each of the payment types (for example, Air Miles, Amex, Cash).
This table would make more sense if the payment type labels and values were pulled across the columns.

6 In the PivotTable Fields task pane, drag the Payment Type field from the Rows area to the Columns area.

Now remove some of the field values from the PivotTable.

7 Click the Column Labels AutoFilter button in the PivotTable.

8 Click the Air Miles and Cash check boxes to turn them off, and click OK.
These two columns no longer appear in the pivot table. Notice that the grand total amounts appearing in the far right have also been adjusted to include only the columns appearing on the screen. To re-display all of the columns, use the Select All check box.

9 Click the **Column Labels** AutoFilter button in the PivotTable.

10 Click the **(Select All)** check box to turn it on, and click **OK**.

You can also clear all columns at one time.

11 Click the **Column Labels** AutoFilter button in the PivotTable.

12 Click the **(Select All)** check box to turn it off, then click the **Amex**, **Mastercard** and **Visa** check boxes to turn them on, and click **OK**.

The PivotTable Fields task pane automatically turns itself on and off when you select a cell inside or outside the pivot table.

13 Click any cell outside the pivot table to hide the PivotTable Fields task pane.

14 Click any cell inside the pivot table to re-display the PivotTable Fields task pane.

**Note:** The PivotTable Fields task pane can also be turned on or off using the Ribbon. Under PivotTable Tools, on the Analyze tab, in the Show group, click Field List to toggle it on or off.

**Format Pivot Table Data**

**Objective 4.2.7**

Almost all pivot table values are numeric, and occasionally they will include date values. Therefore, the Format Cells dialog box is primarily used to format numeric and date data. You cannot apply shading, borders, or change cell alignment using this dialog box.
To ensure that the formatting remains applied even as the pivot table changes, you should apply the formatting directly on the field (as opposed to applying it to the values that display in the pivot table). To apply formatting to the field, right-click the field and select Value Field Settings in the shortcut menu. Click the Number Format button to open the Format Cells dialog box.

Learn to format the data in a pivot table

This exercise demonstrates how to format the data in a pivot table.

1. Open the *Sales Pivot Table Formatting* workbook and save it as *Sales Pivot Table Formatting – Student*.
2. In the PivotTable Fields task pane, click the drop-down button on the far right of Sum of Amount Paid in the Values area and click **Value Field Settings**.

3. Click **Number Format** to open the Format cells dialog box.
4. In the Format Cells dialog box, select **Number** in the Category list.
5. Reduce the Decimal places to **0** and click **Use 1000 Separator (,)** to turn it on. Click **OK**.
6. Click **OK** to close the Value Field Settings dialog box.
The worksheet should now look reflect the formatting changes, as shown in the following image.

![Pivot Table Example](image_url)

7. Save and close the workbook.

### Customizing PivotTables

**Objective 4.2.2**

According to the *Merriam-Webster Dictionary*, a *pivot* is “a shaft or pin on which something turns” or “a person, thing, or factor having a major or central role, function, or effect.” An Excel pivot table is both because it allows you to rotate and filter data in different ways so that you can gain a better understanding of it.

For example, you can change the fields that are displayed in the pivot table simply by clicking or clearing their checkboxes in the PivotTable Fields task pane, or you can drag a field from the Rows area to the Columns area (or vice versa) in the task pane to change your view of the data.

Pivot tables completely change the way you analyze data—almost to the point of making it fun! You can change the way data is filtered, grouped, and/or summed together in a matter of seconds, even though the volume of data may be very large.

#### Learn to manipulate a pivot table

This exercise demonstrates how to manipulate a pivot table in various ways by moving fields around, as well as how to apply the PivotTable AutoFilter and change the summation function.

1. Open the *Sales Pivot Table Customizing* workbook and save it as *Sales Pivot Table Customizing – Student*. Ensure the cursor is on a cell within the Pivot Table on Sheet2.

2. In the PivotTable, click the **Column Labels** AutoFilter button, and click **Clear Filter From “Payment Type”**.

Flip the positions of the row and column labels and data.

3. In the PivotTable Fields task pane, click and drag the Payment Type field from the Columns area to the **Rows** area.

4. Drag the **Sale Type** field from the Rows area to the **Columns** area.

Add the Date and Customer No. fields to the PivotTable, and select the data for one customer.
5 In the PivotTable Fields task pane, click the checkboxes for the **Date** and **Customer No.** fields to turn them on.

6 Drag the **Date** and the **Customer No.** fields to the Filters area.

When you activated these two fields in the pivot table, Excel made a guess at how you wanted them added: the Customer No. field contains numeric data so it was put into the Values area, and the Date field was put into the Rows area. Because the Date field contains date data, Excel also created a new Month field and added it to the Rows area as well. Remove both of these fields.

7 Click the down arrow button to the right of the Months item in the Rows area and click **Remove Field**.

8 If the Sum of Customer No. field appears in the Values area, click the down arrow button to the right of the Sum of Customer No. item in the Values area and click **Remove Field**.

**Hint:** You could have avoided having to remove these fields if you had dragged them directly into the **Filters** area at step 2, instead of simply activating them.

9 In the PivotTable, click the drop-down button at the far right of the Customer No. field, select customer **300**, and click **OK**.

The PivotTable then shows only the data for customer 300:

10 In the pivot table, click the drop-down button at the far right of the Customer No. field, select **(All)**, and click **OK**.

Restore to all customers and then select the data for one date of the year. This will show you your total business volume for that one day.
11 Click the drop-down button at the far right of the Date field, and then scroll down, select 1-Apr, and click OK.

Now find out how all of your customers are paying for their travel. To answer this question, you need to count the number of times each payment type was used over the course of the year.

12 In the pivot table, click the drop-down button at the far right of the Date field, select (All), and click OK.

13 In the PivotTable Fields task pane, drag the Sale Type field from the Columns area to the Filters area.

14 In the PivotTable Fields task pane, click the Sum of Amount Paid drop-down in the Values area and click Value Field Settings.

15 Select Count in the Summarize value field by area and click OK.

The completed PivotTable now looks similar to the following:

![PivotTable Example](image)

This exercise has demonstrated a very small sample of what you can do with pivot tables. Try different combinations of your own; you will be impressed by Excel's power to help you accomplish large and complex tasks quickly and with relatively little effort.

16 Save and close the workbook.

Using Data Slicers with a PivotTable

**Objective 4.2.3**

Filters are an integral part of pivot tables. However, it is not always apparent what the active filter criteria are. You can use data slicers (or simply, “slicers”) on pivot tables to help you easily determine which filter conditions are currently active.
In this pivot table, four slicers are active. For the Sale Type slicer, four values are selected, and for the Payment Type slicer, three values are selected. The filter for the Customer No. slicer is not active because the Clear Filter icon in the upper-right corner of this slicer is grayed out. The Date timeline slicer filters out all data that does not have a date within the range of Jan 2016 to Sep 2016. If you also have a pivot chart, these slicer selections will apply to the chart as well.

Slicers also allow you to change your filter options very quickly: you simply click the desired buttons in the slicers to turn them on or off.

**Learn to activate slicers for a pivot table**

This exercise demonstrates how to activate slicers for a pivot table and use them to apply filters.

1. Open the *Sales Pivot Table Slicers* workbook and save as *Sales Pivot Table Slicers – Student*.

2. Select any cell inside the pivot table to activate the PivotTable Tools tabs in the Ribbon.

3. In the PivotTable Fields task pane, Drag the *Payment Type* field from the Rows area to the *Columns* area.

4. Drag the *Sale Type* field from the Filters area to the *Rows* area.

5. Click the *Count of Amount Paid* drop-down in the Values area, and click *Value Field Settings*.

6. Select *Sum* in the Summarize value field by area and click *OK*.

Insert the slicers for this pivot table.

7. Under PivotTable Tools, on the Analyze tab, in the Filter group, click *Insert Slicer*.

8. Click the checkboxes for *Date*, *Customer No.*, *Sale Type*, and *Payment Type* to turn these on, and click *OK*.
9 Move the slicers to an empty area to the right of the pivot table.

10 Click individual buttons of your choice in any of the slicers, and observe the effects on the PivotTable.

11 Hold the CTRL key to select (or deselect) more than one button in a slicer.

12 Click the Clear Filter button in the upper-right corner of any slicer to select all the values in that slicer.

You can also insert a special type of slicer for date fields that allows you to select a range of dates.

13 Under PivotTable Tools, on the Analyze tab, in the Filter group, click Insert Timeline.
14 Click the checkbox for Date to turn it on and click OK.

15 Move the Date timeline slicer to the blank area below the pivot table. Widen the Date timeline slicer to take all of the empty space available from column A to column H by dragging the handles on the left and right edges of the slicer.

16 Drag the timeline bar inside the Date timeline slicer so that it extends from Jan 2016 to the end of Sep 2016.

You can also change the zoom level for the timeline.

17 Click the down arrow button next to the time level indicator near the upper-right corner of the Date timeline slicer, then click QUARTERS.

The timeline slicer now shows the selector range in quarters of the year.

When you no longer need a slicer, you can remove it.

18 Click the Date timeline slicer and press DELETE.

19 Save and close the workbook.

Group Pivot Table Data

Objective 4.2.4

A large pivot table with many rows or columns (or both) can be simplified by using the grouping feature. Date values are good candidates for grouping; they can be automatically grouped by month, quarter, or year.
The following pivot table shows rows of date values grouped by month, quarter, and year.

You can also manually create groups by selecting the rows or columns to include in each group.

**Learn to group data in a pivot table**

This exercise demonstrates how to group data in a pivot table.

1. With the *Sales Pivot Table Grouping* workbook and save *Sales Pivot Table Grouping – Student*.
2. Select a cell within the cell range A1:E2009. On the Insert tab, in the Tables group, click *PivotTable* and click *OK* to create this pivot table in a new worksheet.
3. Click the *Date, Amount Paid* and *Payment Type* checkboxes
4. In the PivotTable Fields task pane, drag the *Payment Type* field from the Rows area to the Columns area.

You will notice that the date rows are already grouped by month.
Use the auto grouping feature in the pivot table to group the data by month and year. With date values, Excel will automatically offer various date-related grouping options.

1. The Months option is already selected for you. Add the Years selection as well.
2. Right-click any date value in the pivot table, and click **Group**.
3. Click the **Years** option, then click **OK**.
   - The date rows are now grouped by both year and month. You can expand and collapse the groups to see the rows at different levels of detail.
4. Click the **Collapse** (>>) button for the month of Jan and Feb.
5. Click the **Expand** (<<) button for the month of Feb.
6. Right-click any date in column A, click **Expand/Collapse**, then click **Collapse Entire Field**.
   - The grouping can be removed at any time.
7. Right-click any date value in the pivot table, and click **Ungroup**.
   - The data can then be grouped again at other levels.
8. Right-click any date value in the pivot table, and click **Group**. With the Months option selected, click the **Quarters** and **Years** options so that all three are selected. Click **OK**.
Notice that the lowest level of data is now at the month level, even though the Task Pane shows Date in the Rows area. Also notice two new items in the Rows area: years and quarters.

The summary totals were only applied to the highest level of groups. You can also manually activate summary totals at the quarter and year level.

12 Right-click any of the four Qtr row labels (cells A6, A10, A14, or A18), then click Field Settings

13 In the Field Settings dialog box, click Automatic in the Subtotals section and click OK.

14 Repeat steps 12 and 13 on the 2016 row label (cell A5).

You can also manually create your own groups by choosing the rows or columns to group together.

14 Select the Sheet2 tab.

15 Hold down the CTRL key, then click each of the following row labels:

- Bike tour
- Car rental
- Cruise
- Flight
- Hotel
- Nature tour
- Rock climbing

16 Release the CTRL key, then right-click any of the selected row values, and click Group.

17 Select the Flight+Car rental label, hold down the CTRL key, then click each of the following row labels:

- Flight+Cruise
- Flight+Hotel
- Hotel+Car rental

18 Release the CTRL key, then right-click any of the selected row values, and click Group.
19 Select cell A7 (containing the label Group1), select the text **Group1** in the Formula Bar and enter: **Single Booking** to replace it.

20 Select cell A15 (containing the label Group2), select the text **Group2** in the Formula Bar and enter: **Multiple Booking** to replace it.

The screen should look similar to the following example:

![Example of pivot table with calculated fields](image)

21 Save and close the workbook.

## Calculated Fields and Items

**Objective 4.2.6**

You can use formulas to create calculated fields for your pivot table. These calculated fields are very useful for creating new data that is meaningful, such as percent failure rate or sales rep commissions. However, there are several limitations to these fields:

- You cannot refer to worksheet cells outside of the pivot table by address or by name. For example, =J3 will not be accepted as a valid formula because it refers to a cell in the worksheet.
- You cannot use functions that use cell references outside of the pivot table. For example, =SUM(M3:M10) will not be accepted as a valid formula.
- Pivot table labels used in formulas must use single quotes if the labels contain a blank space. For example, =’Amount Paid’ * 0.05
- You cannot refer to the pivot table totals or subtotals.
- Calculated fields are not available in an Online Analytical Processing or OLAP-based pivot table.

Because of these limitations, calculated fields are usually simple formulas that use math operators such as add (+), subtract (-), multiply (*), and divide (/). You can also use any function that allows reference to pivot table labels, such as =SUM(Item1,Item2,Item3) or =IF(Amount>20,Amount*0.05,0).
Calculated items are similar to calculated fields in pivot tables, but are used for distinctly different purposes. One way of describing the differences is illustrated by the following example pivot table:

In the above example, the Sum of Commissions column is a calculated field based on each row (credit card type). This pivot table also has two calculated items added: Regular Card and Premium Card. Each of these new rows are calculated as a formula based on the rows 5 to 10. Therefore, a calculated field appears as a new column, but a calculated item shows as a new row, or vice versa.

This example also demonstrates that a calculated field appears as a separate column from the original data, and therefore does not affect the original data. A calculated item appears as another row, together with the original data rows. A calculated item can be described as a virtual item (row or column). Because it now behaves like one of the original data items, its value is added to summary totals, can be filtered in or out, and can be included in a group. In the previous example, the two calculated items are grouped separately from the original data to help users distinguish between the two.

Keep in mind that you must remove any groups from all pivot tables originated from the same data before you can create calculated items. After you have created the calculated items, you can group the data again.

**Learn to create a calculated field and items in a pivot table**

This exercise demonstrates how to create a calculated field and calculated items in a pivot table.

1. Open the *Sales Pivot Table Calculated Fields* workbook and save as *Sales Pivot Table Calculated Fields - Student*. If necessary, select the Sheet1 tab.

2. Select a cell within the cell range A1:E2009. On the Insert tab, in the Tables group, click PivotTable and click OK to create this pivot table in a new worksheet.

3. Click the Amount Paid and Payment Type checkboxes.

Use the auto grouping feature in the pivot table to group the data by month and year. With date values, Excel will automatically offer various date-related grouping options.

4. Under PivotTable Tools, on the Analyze tab, in the Calculations group, click Fields, Items, & Sets then click Calculated Field.

5. With the default name in the Name text box highlighted, type: Commissions.
6 In the Fields list box, click **Amount Paid** and click **Insert Field**.

![Insert Calculated Field dialog box](image)

7 With the cursor now in the Formula text box, type: \* 0.12 and click **OK**.

The pivot table should now appear similar to the following:

![Pivot table example](image)

8 Select **Sheet1** and insert a new pivot table that includes the **Amount Paid** and **Payment Type** fields.

9 Select any cell in the range **A4:A9**.

10 Under PivotTable Tools, on the Analyze tab, in the Calculations group, click **Fields, Items, & Sets** then click **Calculated Item**.

A warning message displays:

![Warning message](image)

**Note:** You will also notice that the PivotTable Fields task pane has additional fields that were not present originally, such as Quarters and Sale Type2.

11 Click **OK** to close the message.

12 Click the **Sheet2** worksheet tab.

13 Right-click the group label in cell **A15**, then click **Ungroup**.

14 Right-click the group label in cell **A7**, then click **Ungroup**.

15 Click the **Sheet3** worksheet tab. Right-click the group label in cell **A5**, then click **Ungroup**.
16 Select the Sheet5 worksheet tab, then under PivotTable Tools, on the Analyze tab, in the Calculations group, click Fields, Items, & Sets then click Calculated Item.

17 In the Name text box, type: Regular Card and press TAB.

18 In the Fields list box, type: = 0.025 * ( 

19 Click Air Miles in the Items list box and click Insert Item.

20 With the cursor in the Formula text box, type: +

21 Click Mastercard in the Items list box and click Insert Item.

22 With the cursor in the Formula text box, type: +

23 Click Visa in the Items list box and click Insert Item.

24 With the cursor in the Formula text box, type: ) and click OK.

25 On the Analyze tab, in the Calculations group, click Fields, Items, & Sets then click Calculated Item.

26 In the Name text box, type: Premium Card and press TAB.

27 In the Fields list box, type: = 0.03 * ( 

28 Click Amex in the Items list box and click Insert Item.

29 With the cursor in the Formula text box, type: +

30 Click Diner’s Card in the Items list box and click Insert Item.

31 With the cursor in the Formula text box, type: ) and click OK.
Click cell A4 (Air Miles), press the SHIFT key, and then click cell A9 (Visa). Release the SHIFT key.

Right-click any of the selected row values, and click Group.

Select the Regular Card label, hold down the CTRL key, then click the Premium Card label.

Release the CTRL key, then right-click any of the selected row values, and click Group.

Select cell A4 (containing the label Group1) and enter: Sales to replace it.

Select cell A11 (containing the label Group2) and enter: Credit Card Fees to replace it.

The screen should look similar to the following example:

In the Row Labels field (click the Row Labels drop-down arrow), ensure Payment Type is selected.

You can see each of the original credit card types and the two calculated items appearing in the filter list at the bottom.
Click **Cancel** then click the **Sheet4** worksheet tab.

Notice that this pivot table created earlier with a calculated field now also has the calculated items. All rows are also grouped in this pivot table, but the group names have not changed from their default.

Save and close the workbook.

**Referencing Pivot Table Data**

**Objective 4.2.5**

In general, you can use a cell reference in a formula to copy a value from another cell into the current active cell. You can also create a formula that references a cell inside a pivot table (but not the other way around). However, this is not advisable because one of the primary capabilities of a pivot table is its ability to easily flip data around. Because the data values can move around, a static cell reference can become outdated very quickly. To avoid directly referencing a cell inside a pivot table, you should use the GETPIVOTDATA function to retrieve a specific cell value using the column and row field names, instead of the Excel column and row header addresses.

In the following example, both cells B17 and B18 are referencing the same value. Cell B17 has a very simple formula =B5. Cell B18 uses the much more complex GETPIVOTDATA function to get the same value. But if the pivot table is modified in any way, cell B17 will likely show a different value, whereas B18 will continue to show the same value as long as it still appears in the pivot table.
The general format for this function is:

\[ =\text{GETPIVOTDATA(}\text{data field, pivot table address, [field 1, item 1], [field 2, item 2], ...}) \]

Where:
- Data field – the name of value field to retrieve
- Pivot table address – address of any cell inside the pivot table (typically the upper left cell which never changes regardless of how many rows or columns are specified)
- Field / Item – used to specify which row or column to find the value you want

Note that the field/item argument pair are optional, but if either is specified, then both are required.

**Learn to use the GETPIVOTDATA function**

This exercise demonstrates how to use the GETPIVOTDATA function to reference a cell value in a pivot table.

1. Open the *Sales Pivot Table Referencing* workbook save as *Sales Pivot Table Referencing - Student*. If necessary, select the Sheet5 tab.
2. Select cell D6, and enter: =B5
3. Select any cell within the pivot table, then drag the **Sale Type** field to the **Columns** area in the task pane.

Excel displays an error message because it is trying to expand the pivot table to the right, but you have used one of the cells in that area by entering a formula.

4. Click **Cancel** to cancel the expansion of the pivot table.
5. Select cell D6 again, and drag its contents down to cell B17 (position the cursor over one of the four edges of the cell until the cursor changes to a four-headed arrow, then click and drag the box to the new location).
Use the GETPIVOTDATA function to retrieve the same data value from the pivot table.

6 Select cell **B18**, and enter: \=GETPIVOTDATA(“Amount Paid”,$A$3,”Payment Type”,”Air Miles”)

Notice that the pivot table has only one column of values at this time. In the GETPIVOTDATA function, you then only need one field/item pair to specify which row of Amount Paid (the first argument in the function) that you want. In this specific function, you want to pull from the Payment Type field, Air Miles item. Alternatively, you can choose the Amex item, Cash item, or any of the other items. Another alternative is to change to the Payment Type2 field, with the Regular Card or Premium Card item. Each of these selections will pull from the appropriate row in the pivot table.

For any of the field/item arguments, you can also reference a cell instead of putting the data value directly into the function.

7 Select cell **A18**, and enter: **Air Miles**

8 Select cell **B18**, and change the last argument to cell A18 so that the formula becomes: 
\=GETPIVOTDATA(“Amount Paid”,$A$3,”Payment Type”,A18)

9 Select cell **A18**, and enter: **Amex**

By referencing a cell, you can change to different values without having to modify the formula – this may be a better option if you make the workbook available for others to use. Change the row selection back to Air Miles, then make another modification to the pivot table.

10 Select cell **A18**, and enter: **Air Miles**

11 Select any cell within the pivot table, then drag the **Sale Type** field to the **Columns** area in the task pane.

Because the pivot table was modified, the simple cell reference formula at cell B17 is now pointing at an empty cell (B5). On the other hand, the GETPIVOTDATA function at cell B18 continues to retrieve the same cell value, which demonstrates that it is a more reliable way of pulling data from pivot tables while giving you the flexibility to make changes.

Now that the pivot table is two-dimensional with multiple columns and your GETPIVOT function only specifies one field (Payment Type), it returns the total value for the other field (Sale Type) that was not specified as an argument.
12 If necessary, scroll to the right in the worksheet to view the Grand Total value for the Air Miles item row (cell M6) to verify it is the same value as what is showing in cell B18. Scroll back to the left in the worksheet.

In this modified pivot table, the air miles row now shows the sales amount for each sale type, such as car rental, cruises, and flights. If you want a specific column within the Sale Type and not the Grand Total, then you must add that field to the GETPIVOTDATA function.

13 Select cell B18, and change the formula to:

=GETPIVOTDATA("Amount Paid",$A$3,"Payment Type",A18,"Sale Type","Cruise")

Like Payment Type, you can use any Sale Type field value as an Item, such as Bike Tour, Car rental, and so on. In this formula, you are selecting the Cruise item.

Let's make more changes to the pivot table by flipping the row fields to the column area, and vice versa.

14 Make a note of the value currently displayed by the GETPIVOTDATA function in cell B18.

15 Select the cell range A17:B18, and drag its contents up to cell A1.

16 Select any cell within the pivot table, drag the Sale Type field from the Columns area to the Rows area in the task pane. Then drag both the Payment Type and Payment Type2 fields from the Rows area to the Columns area.

17 Compare the value now displayed by the GETPIVOTDATA function in cell B2 to its previous value that you had noted in a previous step.

This demonstrates that even if the pivot table is further modified, the GETPIVOTDATA function will continue to retrieve the correct amount, provided this value is still displayed in the pivot table.

On the other hand, the formula in cell B2 continues to reference cell B5, which is now a text label.

18 Click the Sale Type check box in the pivot table task pane to turn it off.

If the referenced value is not displayed in the pivot table, the GETPIVOTDATA function will display an error because it is not able to retrieve it.

19 Click the Sale Type check box in the pivot table task pane to turn it back on.

20 Save and close the workbook.
Pivot Charts

Creating a PivotChart

Objective 4.3.1

The data displayed in a PivotTable can be put into a chart, which is referred to as a PivotChart. Despite its special name, it is really nothing more than a regular chart that is tied to a pivot table.

A pivot chart can be created from a pivot table or directly from the source data. If you create a pivot chart directly, Excel creates a pivot table in the same worksheet because each pivot chart must be linked directly to a pivot table.

Learn to create a pivot chart

This exercise demonstrates how to create three pivot charts; one from an existing pivot table, and two more from the source data.

1. Open the Sales Pivot Chart workbook and save as Sales Pivot Chart - Student. If necessary, select the Sheet1 tab.


3. On the Insert tab, in the Charts group, click PivotChart.
4 Verify that the correct cell range has been selected and that the pivot chart will be placed in a new worksheet, then click OK.

5 In the PivotChart Fields pane, click the Sale Type and Amount Paid check boxes to turn them on.

    Notice that Excel links a pivot chart to a pivot table; therefore as you define your pivot chart, the pivot table is created on the worksheet at the same time.

6 Click the Payment Type check box to turn it on, then drag the Payment Type field from the Axis (Categories) to the Legend (Series) area.

7 Drag the pivot chart to the blank area below the pivot table.

Now create another pivot chart, this time directly from a pivot table.

8 Click the Sheet2 tab to go to that worksheet.
If necessary, click any cell in the pivot table to activate the PivotTable Fields Task Pane.

Under PivotTable Tools, on the Analyze tab, in the Tools group, click **PivotChart**.

With the **Clustered Column** chart (far left in the Column category) selected, click **OK**.

Move the pivot chart to a new position below the pivot table.

This pivot chart is identical to the one in Sheet3 but was created using the PivotChart command in the PivotTable Tools Ribbon. If you make any changes to the pivot table, the pivot chart will automatically change as well.

Click the **Column Labels** AutoFilter button in the pivot table.

Click the **Air Miles** and **Cash** check boxes to turn them off and click **OK**.

You can also create a standalone pivot chart.

Select the **Sheet1** worksheet, then on the Insert tab, in the Charts group, click **PivotChart**.

In the Create PivotChart dialog box, click the **Add this data to the Data Model** check box to turn it on.

Verify the correct cell range has been selected and that the pivot chart will be placed in a new worksheet, then click **OK**.

In the PivotChart Fields pane, click the **Sale Type**, **Amount Paid**, and **Payment Type** check boxes to turn them on.

Drag the **Payment Type** field from the Axis (Categories) to the Legend (Series) area.

Notice that the pivot chart appears on its own without any pivot table being visible.

To apply filtering on any data, you can use slicers.

Drag the pivot chart to the upper left area of the worksheet.

Under PivotTable Tools, on the Analyze tab, in the Filter group, click **Insert Slicer**.

In the Insert Slicers dialog box, click the **Payment Type** check box to turn it on and click **OK**.

In the Payment Type slicer box, click the **Amex** button, press and hold the CTRL key and click the **Diner’s Card**, **MasterCard**, and **Visa** buttons to select them as well. Release the CTRL key.

You can modify the pivot chart by changing the options in the PivotChart Fields Task Pane.

In the PivotChart Fields pane, drag the **Sale Type** field to the Legend (Series) area.
In the PivotChart Fields pane, drag the **Sale Type** field back to the Axis (Categories) area.

**Hint:** You can also use the **Switch Row/Column** from the Data group in the Design tab of the PivotTable Tools Ribbon to change the pivot chart.

Save and close the workbook.

## Changing Pivot Chart Options

### Objective 4.3.2

The pivot chart design can be changed easily using options displayed in the Ribbon. The most commonly used chart elements can be switched on or off by using the Chart Elements button that is displayed to the right of the pivot chart:

- **Chart Elements**
  - Axes
  - Axis Titles
  - Chart Title
  - Data Labels
  - Data Table
  - Error Bars
  - Gridlines
  - Legend

### Learn to make formatting changes to a pivot chart

This exercise demonstrates how to make formatting changes to a pivot chart.

1. Open the *Sales Pivot Chart Options* workbook and save as *Sales Pivot Chart Options - Student*. Select the **Sheet3** tab.
2. Click in the pivot chart to select it, then widen it to the same width as the pivot table. Also make the chart taller by at least two rows.
3. Click the **Chart Elements** icon displayed to the right of the pivot chart.
4. Point the cursor at each of the following check boxes that are turned off, and observe the effect on the pivot chart: Data Labels, Data Table, and Error Bars.
5.Click the **Chart Title** check box to turn it on.

6.Click the **Axis Titles** check box to turn it on, then click the arrow button to the right. Click the **Primary Vertical** check box to turn it off.

7.Click twice in the **Axis Title** text box below the horizontal axis, delete the default text there and type: **Sales Type**.

8.Click twice in the **Chart Title** text box at the top of the chart, replace the default text with: **Sales by Type**.

Excel changes the PivotChart to reflect the change in the structure of the PivotTable.

Because a pivot chart is a chart (even though it is directly connected to a PivotTable), you can format it like any other chart.

9.Under the PivotChart Tools, click the **Format** tab, and examine the various Ribbon commands available to format the pivot chart.

10.Under the PivotChart Tools, click the **Analyze** tab, then in the PivotChart group, click in the Chart Name text box and change the name to: **Sales by Type**.

11.Click in any blank area of the chart background, then under the PivotChart Tools, on the Format tab, in the Shape Styles group, click the arrow for Shape Fill, then hover the cursor over different colors displayed. Observe the changes to the chart background colors.

12.Click in an empty area of the worksheet to close the Shape Fill drop-down list.

13.Save and close the workbook.

**Drilling Down a Pivot Table or Pivot Chart**

**Objective 4.3.4**

Pivot tables and pivot charts are very useful tools for sorting, grouping, and flipping data around in many different ways. This feature allows you to see trends, patterns, and anomalies (something that doesn’t look right) if you are looking at hundreds or thousands of rows of data.

However, the pivot tools always perform an aggregation of the values; for example, they will calculate a sum total, or an average, or find the maximum value. Quite often when you look at an aggregate value, you will want to see the detailed data rows behind that value. You can perform this drill-down very easily by using the **Show Details** command.
Learn to drill down a pivot table and a pivot chart

This exercise demonstrates how to drill down a pivot table and a pivot chart.

1. Open the Sales Pivot Chart Drilling workbook and save as Sales Pivot Chart Drilling - Student. Select the Sheet3 tab.

   Suppose you want to know what were the detailed transactions that added up to the total value that you see for cruises that were paid for using air miles.

2. Select the Sheet3 tab if necessary, then double-click cell B5.

   **Note:** You can also right-click the pivot table cell and click *Show Details* in the right-click menu.

   A new worksheet is created with the detailed transactions that comprise this value in the pivot table.

3. Double-click the right edge of the column A header to auto-fit the column width to the largest value.

   You can also create a new pivot table from this selected data.

4. Select the Sheet3 tab again, then double-click cell B14.

5. Double-click the right edges of columns A and C to auto-fit those columns.

6. With the pivot table still selected, on the Insert tab, in the Tables group, click *PivotTable*.

7. Verify the pivot table will be placed in a new worksheet, then click *OK*.

8. In the PivotTable Fields pane, click the *Sale Type*, *Amount Paid*, and *Payment Type* checkboxes to turn them on.

9. Drag the *Payment Type* field from the Rows area to the *Columns* area.

   This new pivot table includes only Air Miles as the payment type column since the detailed data only for this payment type was selected for drilling down.

You can delete the worksheet containing drill down data when you no longer have any need for it.

10. Right-click the Sheet7 worksheet tab and click *Delete*. When the message “Microsoft Excel will permanently delete this sheet. Do you want to continue?” is displayed, click *Delete* in the message box.

11. Delete the Sheet6 worksheet.

   You can drill down to the detailed data from a pivot chart as well.

12. Select the Sheet3 worksheet tab again, if necessary.
13 Position the cursor over the left-most bar in the Cruise series in the pivot chart. A pop-box will display indicating this bar is series “Air Miles”, point “Cruise”.

14 Click this bar, and then click it again so that handles will appear for this bar only, then right-click the bar and click **Show Detail**.

15 Double-click the right edge of the column A header to auto-fit the column width to the largest value.

16 Switch between this worksheet (should be Sheet8) and Sheet5 (that was created at step 2 above).

You can see that the detailed transaction list displayed on both worksheets are identical.

17 Save and close the workbook.

**Pivot Chart Styles**

**Objective 4.3.3**

Like the Chart Elements button, the Chart Styles button allows you to easily select from the list of available chart styles and colors:
The full set of chart styles, colors, and elements are accessible from the PivotChart Tools Design tab:

Learn to select different chart styles and colors for a pivot chart

This exercise demonstrates how to select different chart styles and colors for a pivot chart.

1. Open the *Sales Pivot Chart Styles* workbook and save *Sales Pivot Chart Styles - Student*. If necessary, select the *Sheet2* tab.
2. Click a blank area of the pivot chart to select it.
3. Click the *Chart Styles* icon displayed to the right of the pivot chart.
4. Point the cursor at some of the chart styles icons, and observe the live preview effect on the pivot chart.
5. Click the *Style 7* to select it.
6. Click the *Color* tab in the Chart Styles window.
7. Point the cursor over some of the color options, and observe the effect on the pivot chart.
8. Click the *Chart Styles* icon again to close the Chart Styles window.
   Examine some of the pivot chart design options in the Ribbon.
9. Under the PivotChart Tools, on the Design tab, in the Chart Styles group, click *Change Colors*.
10. Under the PivotChart Tools, on the Design tab, in the Chart Styles group, click the *More* button to view the various chart styles available.
11. Click in a blank area of the worksheet to close the Chart Styles gallery.
12. Save and close the workbook.

Business Intelligence

Objective 3.4.1, 3.4.4

In simple terms, Business Intelligence (formerly known as data warehouse) refers to using information technology to understand how well an organization is performing and to identify opportunities to improve profitability (or other key performance indicators). The accounting department had traditionally performed this function before computers came into mass use, but they were slow, too focused on accuracy, and could report only on results achieved in the past. As a result, large companies are not able to adapt to rapid changes in customer wants and needs, and often miss out on new opportunities. In small companies, the owners and major decision-makers usually work at or near the front line and can see changes and new opportunities as they occur. Thus, small companies have always been able to adapt more quickly than large companies. In a large company, the owners are shareholders who are not involved in management, and the decision-makers are far removed from the front line.
Using the capabilities of modern information technology, a large company can emulate the nimble activities of small companies. The normal day-to-day business activities generate a large volume of data. Computer systems can absorb this huge volume of data, perform filtering, and summarizing (or transforming), and present it in understandable formats to decision-makers, who can then make the necessary changes. The challenge is developing the complex process of obtaining and transforming the vast amount of data. One of these tools designed to meet this challenge is Power Pivot, which is built into Excel.

Power Pivot is simply an extension of a pivot table, but is specifically designed to meet the needs of users in a corporate environment in which large complex databases are used to store their data. On the surface, Power Pivot is used like a basic pivot table. Beneath that familiar exterior is a high-performance engine (called the \textit{xVelocity in-memory analytics engine}) that can process millions of rows of data in a few seconds.

Corporate data is typically very large (often involving billions of rows of data), and constantly changing as business progresses throughout the day. Online databases must therefore reside in centralized servers. Power Pivot provides a bridge that allows corporate users (running Excel on their PCs) to connect to, and pull data from, high-powered centralized database servers.

**Activating Power Pivot**

Power Pivot is an add-in product, and by default it is not activated. There is no cost for activating it, and it can be activated at any time without downloading or installing any additional packages.

To activate Power Pivot, click \textbf{File} in the Ribbon, then click \textbf{Options}. In the Excel Options window, click \textbf{Add-Ins}.
The Power Pivot Add-in is grouped as part of the COM Add-ins.

Once activation is complete, the PowerPivot tab will display in the Ribbon.

**Connecting Power Pivot to a Data Source**

**Objective 3.4.1**

A key requirement for performing data analysis is having direct access to data. One of the useful features in Power Pivot is its ability to connect to a wide variety of external data sources including other Excel workbooks, text files, and databases such as Microsoft Access, SQL Server, Oracle, DB2, and other commonly-used database technologies.

Use the Table Import Wizard to specify the location and name of the database file that you want to connect to. If the database is password protected, then you must also enter a user name and password.
After the connection is established with the data source, a *Power Pivot data model* will display. This data model looks just like a workbook, with separate worksheets showing the topmost set of rows from the data source to which they are connected. This data model is not a real workbook—it is simply a staging area for the pivot table to work from. You cannot enter data of your own, but you can add columns to create calculated fields using fields from the connected tables. These calculated fields will then appear in the pivot table field list like the other fields.

Once created, the Power Pivot workbook will remain attached to the main workbook. You can close the Power Pivot workbook independently of the main workbook, and it will continue working in the background. If you need to re-display it, you can click Manage in the PowerPivot tab of the Ribbon.

If you want to connect to a simple Microsoft Access database, you can also use the From Access command in the Ribbon. This command will set up a direct connection in the workbook without using Power Pivot.

You can then select which table(s) to connect.
Next you will be prompted to select the method of accessing the data in your worksheet: as a set of tables, as a pivot table, or as a pivot chart.

Although simpler to use, one disadvantage of this method is not having the ability to use Power Pivot to create calculated fields and perform other transformations to make it easier to use in Excel.

## Learn to connect to an external database

This exercise demonstrates how to activate Power Pivot in Excel if it is not already activated. You will also learn how to connect to an external database using Power Pivot.

1. Open the *Power Pivot Connection* workbook and save as *Power Pivot Connection - Student*.
2. Click **File**, then click **Options**.
3. In the Excel Options window, click **Add-Ins**.
4. Click the **Manage** drop-down list button, click **COM Add-ins** and click **Go**.
5. Click the **Microsoft Power Pivot for Excel** check box to turn it on and click **OK**.
   
   The Power Pivot tab now appears in the Ribbon.
6. On the Power Pivot tab, in the Data Model group, click **Manage**.
   
   A new Power Pivot for Excel window is displayed on top of the workbook.
7. On the Home tab, in the Get External Data group, click **From Database**, then click **From Access**.
Lesson 3
Data Analysis Using Pivot Tables and Business Intelligence

The Table Import Wizard window displays. The first step in this wizard is the Connect to a Microsoft Access Database, in which you need to select the location and name of the Access database file that you want to connect to. If the database is password protected, then you must also enter a user name and password. The first step in this wizard is Connect to a Microsoft Access Database.

8 Click Browse.

9 In the Open dialog box, navigate to the Documents\Jasperactive\ResourceFiles folder, select GardenShop and click Open.

You can verify whether you entered the correct file path and file name by using the Test Connection button.

10 Click Test Connection.

After a short wait, the message “Test connection succeeded” is displayed.

11 Click OK to close the message box, then click Next in the Table Import Wizard dialog box.

12 In the Choose How to Import the Data step, you can choose to connect directly to the database or to create a SQL query to extract the data from the database in the format that you need.

13 With the “Select from a list of tables and views to choose the data to import” option selected, click Next.

14 Click the checkbox for the OrderItems table to select it, then click Select Related Tables twice.

15 Click the checkbox for the OrderDetails view to select it. (The views are listed below the tables, and they display a different icon.)

A database view is created by running a SQL query that extracts data fields from one or more tables. Once the data is “imported” into Power Pivot, the view behaves exactly like any other table. Therefore, both real tables and views will be referred to as tables in this topic.

16 Ensure that you have the same items selected as shown below, then click Finish in the Table Import Wizard dialog box.
The Table Import Wizard displays the status.

17 Click Close to close the Table Import Wizard.

The Power Pivot for Excel workbook now displays each open table as a separate tab.
18  Click each of the tabs near the bottom of the Power Pivot for Excel window to view the data in each of these tables.

Return to the Excel worksheet to create your pivot table.

19  Minimize the Power Pivot for Excel window. In the Excel workbook, click **Enable Content** in the Security Warning bar.

20  Select the cell range A1:B8, then on the PowerPivot tab, in the Tables group, click **Add to Data Model**.

21  In the Create Table dialog box, click the **My table has headers** check box to turn it on, then click **OK**.

The Power Pivot for Excel window is then restored as the active window, and the data table you had selected in the worksheet is now added to the overall data model.

22  Double-click the **Table1** worksheet tab at the bottom of the Power Pivot for Excel window, and enter: **Regions** as the new name for this worksheet tab.

23  Close the Power Pivot for Excel window.
Power Pivot Calculated Fields

Objective 3.4.1

Power Pivot calculated fields act essentially the same as calculated fields in pivot tables: they are formulas that will transform values in existing fields and create new values for display and analysis.

When Power Pivot was first introduced, calculated fields were called measures. The two terms can be used interchangeably. These calculated fields use DAX (or Data Analysis Expression), which is the special language developed for the sole purpose of creating calculated fields.

All DAX expressions start with the “=” symbol, and use the same math operators (such as “*” for multiply and “/” for divide), just like standard Excel formulas. An example of a calculated field is:

\[ \text{= [Quantity]} \times \text{[UnitPrice]} \]

Notice that names of fields are enclosed in square brackets. You may also use the names of fields from a different table by using the RELATED function. However, that related field must be in a table that is on the “one” side of a one-to-many table relationship (for more information about table relationships see the next topic). For example, suppose the Quantity field is in the local table and the UnitPrice field is in a related lookup table called Products. The calculated field would then be:

\[ \text{= [Quantity]} \times \text{RELATED(Products[UnitPrice])} \]

Learn to apply transformation features

This exercise demonstrates how to apply transformation features on your tables, including hiding fields and creating calculated fields.

1. Open the Power Pivot Transforms workbook and save as Power Pivot Transforms – Student.
2. On the PowerPivot tab, in the Data Model group, click Manage to open the Power Pivot for Excel window. If necessary, click the Customers tab to display it.

Assume that you want to prevent confidential customer information - such as names and phone numbers – from being displayed in the worksheets. You can hide selected columns.

3. Right-click the header for the Phone column to select the entire column and to display the context menu. Click Hide from Client Tools in this menu. Click anywhere else to see the column greyed out.
4. Select both the FirstName and LastName columns, then right-click and click Hide from Client Tools.
Create a calculated field in another table.

5 Click the OrderDetails worksheet tab.

6 Click in any cell in the Add Column, and enter: = [ ]

A drop down list will appear displaying the fields in the OrderDetails table/view.

7 Double-click the [Quantity] field and continue entering the rest of the formula: *[UnitPrice] in the formula bar.

8 Double-click the header of this calculated field column and enter: ExtendedPrice

9 On the Home tab, in the Formatting group, click Format, then click Decimal Number.

Even though this new ExtendedPrice field is not a “real” field (that is, it does not show data from a field in a table, Excel will treat it as if it were a real field.

10 Close the Power Pivot for Excel window, then save and close the workbook.

Manage Table Relationships

Unlike spreadsheets, databases typically parse data among several tables. As a result, these tables must be joined together in order to extract the data that you need for your pivot table. Tables are generally set up with at least one relationship with another table. This relationship identifies how the two tables are joined together. The following screen shot of Power Pivot for Excel Diagram View illustrates how tables may be related and joined together in a database.
Related tables are connected by a join line. Each join line includes an arrow which indicates that a one-to-many relationship exists between the tables. The number “1” displays beside that table which is on the “one” side of the relationship. In the preceding diagram, we can see that the Products table is joined to the OrderItems table in a one-to-many relationship.

In a one-to-many relationship, each record in the table on the “one” side of the relationship may have several matching related records in the table on the “many” side. However, each record in the table on the “many” side will have one (and only one) matching record in the table on the “one” side.

When we consider the one-to-many relationship between the Products table and the OrderItems table, we understand that one product may appear as an order item (or line item) on many different orders, but each individual order item can be for only one product.

Relationships are managed in the Power Pivot workbook, where the workbook is connected to the data sources. The Manage Relationships button in the Design tab of the Ribbon displays details about the established relationships.

You can use this dialog box to create new relationships, modify existing ones, and delete those that you no longer need.
When you connect to the tables in an external database, Power Pivot will automatically import the relationships already created between them. However, if you connect to multiple data sources (such as two different external databases), then the relationships will not exist between the objects from the different sources. Also, if you connect to both tables and queries in the external database, Power Pivot will not create the relationships between the queries and the tables. You will need to create these relationships manually if you extract data from these sources into the same pivot table.

The easiest way to create a relationship manually is in diagram view. Click the appropriate field in the table on the “one” side of the relationship, and drag it onto the related field in the table on the “many” side of the relationship.

### Learn to create relationships between tables

This exercise demonstrates how to create relationships between tables.

1. Open the *Power Pivot Relationships* workbook and save *Power Pivot Relationships - Student*.
2. On the PowerPivot tab, in the Data Model group, click **Manage** to open the Power Pivot for Excel window.
3. On the Home tab, in the View group, click **Diagram View**.
   
The relationships between the various tables are displayed in graphical form.
4. Adjust the height of the tables in the diagram to show all fields in their respective tables. The vertical scroll bar should no longer be displayed in any table.
   
The Regions table from the worksheet is standing on its own. You can easily connect it to the Customers table.
5. Click the **State** field in the *Regions* table, press and hold the left mouse button, drag a line to the **State** field in the *Customers* table, then release the mouse button.
   
Remember, you must begin by clicking a field in the table on the “one” side, and then drag to the appropriate field in the table on the “many” side.
6. Reposition the tables so that your diagram view looks similar to the one on the following page:

**Note:** To reposition a table in diagram view, simply click the table to select it, position the mouse pointer in an empty area in the table, then press and hold the left mouse button as you drag the table to a new position. Release the mouse button when the table is in the desired location.
Generally there is no “right” way to place tables in the relationship diagram. It is, however, easier to “read” a relationship diagram if you arrange the tables so that the “1” side of a relationship displays at the top and the “many” side displays at the bottom. It is also easier to identify the relationships if you arrange the tables so that none of the lines cross each other.

7 On the Home tab, in the View group, click **Data View**.

8 On the Design tab, in the Relationships group, click **Manage Relationships**.

The Manage Relationships dialog box shows all the defined relationships, including the one you just created between the Customers table and the Regions table.

Notice that a relationship has not yet been created between the OrderDetails table and any other table. This will be accomplished in a later exercise.

9 Click **Close** to close the Manage Relationships dialog box.

10 Close the Power Pivot for Excel window, then save and close the workbook.
Using Cube Functions

Objective 3.4.4

Data mining is a process whereby large corporations and other organizations analyze massive amounts of data in search of ways to increase sales, reduce costs, and better serve customers. In the past, because of the sheer volume of data, large companies have not had an effective set of tools to find niches that smaller companies were able to fill.

Data warehouse technology has now developed the concept of online analytic processing (OLAP) databases that are dedicated to data mining. Data analysts use these databases to answer questions such as:

- How do sales in the northern region this year compare with sales for the past three years?
- How does the quantity of sales to customers over age 55 compare with sales to customers between 35 and 55?
- Who are our top 10 suppliers and how many times have they been late in their deliveries?

Due to the complex ways in which various data dimensions relate to each other, they are often described in terms of cubes. A cube is usually visualized as three-dimensional. OLAP databases typically have many more than three dimensions but the cube analogy is still useful for understanding how the data are organized; essentially, the cube analogy describes how individual data values (cube values) are found at the intersection of the various dimensions being applied.

One design difference in OLAP databases is that data are organized into dimensions and measures.

A measure is a quantifiable value of an object that you can count, summarize, and/or aggregate (group together). Examples include sales dollars, costs, labor hours, and sales calls.

A dimension is a variable or attribute by which you can summarize measures. For example, you can summarize sales dollars by date, sales location, and product. In most cases, you would group dimensions. For example, you might group individual dates by week, month, and year; you might group sales locations by region, country, and continent; people often group products into categories.

Excel can extract data from data cubes using the following cube functions.

**CUBEMEMBER**

CUBEMEMBER(connection,member_expression,[caption])

Return (retrieve) the member or row defined by the member_expression. This is often used to verify that this member or row exists in the cube.

**CUBEVALUE**

CUBEVALUE(connection,[member_expression1,]member_expression2,]…) Return the aggregated value from the cube, filtered by the various member_expression arguments.
### CUBESET

**CUBESET** (connection, set_expression, [caption], [sort_order], [sort_by])

Return the set defined by the set_expression parameter.

### CUBESETCOUNT

**CUBESETCOUNT** (set)

Return the number of items in a set.

### CUBERANKEDMEMBER

**CUBERANKEDMEMBER** (connection, set_expression, rank, [caption])

Return the Nth (as determined by the rank argument) value from a set. For example, you can use it to return the names of the first-, second-, and third-highest performing sales representatives.

### CUBEMEMBERPROPERTY

**CUBEMEMBERPROPERTY** (connection, member_expression, property)

Return the value of a member property from the OLAP cube. You can use this both to verify that the member exists in the cube and to return the value for this member.

### CUBEKPIMEMBER

**CUBEKPIMEMBER** (connection, kpi_name, kpi_property, [caption])

Return a KPI (key performance indicator) from the OLAP cube and display the KPI name in the cell. An example of a KPI is gross profit or number of sales calls made.

You can use these cube functions only with OLAP databases, which very large organizations often employ for analysis purposes. To use OLAP databases effectively, you must have prior training working with data cubes and data warehouses, and have access to the data dictionaries. Setting up and accessing data cubes is beyond the scope of this courseware.

#### Learn to use CUBE functions

This exercise demonstrates how to create a pivot table using the Power Pivot data model, convert the pivot table into a set of cube functions, and manually enter cube functions.

1. Open the *Power Pivot Cube Functions* workbook and save *Power Pivot Cube Functions - Student*.
2. On the Insert tab, in the Tables group, click **PivotTable**.
3. In the Create PivotTable dialog box, verify that the Use this workbook’s Data Model option button is selected, click the **New Worksheet** option button and click **OK**.

   When you scan through the list of tables in the PivotTable Fields task pane, you will see a table with the default *Table1* name. This is the small table in the Regions worksheet. You can rename it with a more meaningful name for the pivot table.

4. Select the **Regions** worksheet tab, and select the cell range **A1:B8**. Under Table Tools, on the Design tab, in the Properties group, click in the **Table Name** text box, and type: **Regions**. Select the **Sheet1** worksheet tab to return to that worksheet.

   Now display the sales data in the pivot table, broken out first by vendor and then by individual product from each vendor.

5. Scroll the list of tables in the PivotTable Fields task pane, open the **OrderDetails** table/view and drag the **ExtendedPrice** field to the **Values** area.
6 Scroll the list of tables in the PivotTable Fields task pane, open the **Vendors** table/view and drag the **VendorName** field to the **Rows** area.

Excel displays a warning message in the PivotTable Fields task pane, and you can see that the data is not appearing correctly in the pivot table. When you put data from dimensions from both the OrderDetails table/view and the Vendors table onto the pivot table, Excel detected that the two tables do not have a defined relationship.

In an earlier exercise, you had verified that relationships were properly created between tables. However, Excel is now pointing out that none was set up between the OrderDetails table/view with the other tables. You can let Excel try to take a guess how the tables can be related together by using the Auto-Detect option.

7 Click **Auto-Detect**.

Check to see how Excel has set up the relationship.

8 Click **Manage Relationships**.
In the Manage Relationships window, you can see that a relationship was set up between the OrderDetails and Products tables using the Description field. Although this appears to work for this data, using text fields as relationship keys is not recommended. Numeric fields are ideally suited as keys, and the ItemID field should have been used.

Note that you are setting up a relationship between the Products table and the OrderDetails table/view, even though you were adding the vendor name to the pivot table. This is because the relationship from the OrderDetails table/view to the Vendors table is indirect, using the Products table as a “middleman” to do the matching at the product item level.

9 In the Manage Relationships window, select the **OrderDetails (Description)** relationship (second one from the top), and click **Edit**.

10 In the Edit Relationship dialog box, enter the following settings, and click **OK**.

11 Click **Close** to close the Manage Relationships window.

12 Scroll up and open the **Products** table/view and drag the **Description** field to the **Rows** area, below the VendorName field.

Adding the product description to the pivot table did not generate any warning message because the relationship between the OrderDetails table/view and the Products table was already established at step 9. Now add the customer data and their regions to the pivot table.

13 Open the **Regions** table/view and drag the **Region** field to the **Columns** area.
Excel has flagged this as a missing relationship as well. This time you will manually create the relationship instead of letting Excel make a guess.

14 Click **CREATE**.

15 In the Create Relationship dialog box, enter the following settings, and click **OK**.

![Create Relationship dialog box](image)

16 Scroll up and open the **Customers** table/view and drag the **State** field to the **Columns** area, below the Region field. Then drag the **City** field to the **Columns** area, below the State field.

The columns across the top of the pivot table are now getting crowded with three levels of data aggregation. Move the Region field out so that you can use it for data filtering instead.

17 Drag the **Region** field from the Columns area to the Filters area.

18 Click the **Collapse** ( ) for each state field so that the pivot table appears as shown below.

![Pivot Table Example](image)

Let’s assume that the pivot table is showing all of the data at the right level of detail. You can now convert it into a set of cube functions.

19 Click a few of the cells in rows 4 and 6 in the pivot table. You will see that they contain a numeric or text value.
20. Under the PivotTable Tools, on the Analyze tab, in the Calculations group, click **OLAP Tools**, then click **Convert to Formulas**.

21. Click **Convert** to convert the pivot table to formulas with CUBE functions.

22. Click those same cell in rows 4 and 6 again. This time the cells containing headings now contain a CUBEMEMBER function and the data cells contain a CUBEVALUE function.

   This conversion feature will save you a lot of time in setting up the necessary cube functions from your external data connection. Each cube function has a long set of arguments. You can also manually change any of the arguments to display the data you need. For example, you can change a column to display the data for Arizona instead of Illinois.

23. Select cell **E4**, press the F2 key, and replace the `[IL]` in the rightmost argument with: `[AZ]`. The formula should now be: `=CUBEMEMBER("ThisWorkbookDataModel","[Customers].[State].&[AZ]")`

   Notice by changing the heading for this column to AZ, the entire column now shows the values for Arizona.

24. Click **Undo** in the Quick Access Toolbar to revert cell E4 back to IL (Illinois).

   Make some formatting changes to your worksheet.

25. Drag the contents of cell A3 to B3, and click **OK** to overwrite the contents of cell B3.

26. Select the cell range **B3:G3**, then on the Home tab, in the Alignment group, click **Merge & Center**.

27. Delete row **5**.

28. Insert a new blank row after the first vendor (row 7).

29. Insert another new blank row after each of the remaining vendors (rows 22, 28, 32, and 40).

   Although the pivot table has been replaced, you still have the ability filter the data using a selection list in a cell.

30. Click the down arrow next to the **All** value in cell **B1**.

31. Expand the **All** item, click **West**, then click **OK**.
For demonstration purposes, you will now manually enter a cube function, displaying the same value as cell C6, which shows the total sales for Fieldstone stepper garden path in the state of Arizona. To make it easier to see which cells that cube function references, you can use the Trace Precedent feature.

32 Select cell C6, then on the Formulas tab, in the Formula Auditing group, click Trace Precedents.

33 Select cell I3 and then type: =cubevalue(" 

At this point of the function, Excel knows you have to enter the name of the data connection. So it displays a list of all available data connections, of which there is only one at this time.

34 Double-click the ThisWorkbookDataModel cube name, then continue typing the rest of the formula. The full formula is: =cubevalue("ThisWorkbookDataModel",B1,B3,A6,G4)

Notice that cell I3 now shows the same value as cell G6. Furthermore, the CUBEVALUE formula arguments correspond to the cell values that are referenced by the precedent lines.

You can also extract out the measure and dimension names by using the CUBEMEMBER function.

35 Select cell I2 and enter: =CUBEMEMBER("ThisWorkbookDataModel","[Regions].[Region].[West]"

As you type the formula, Excel displays a list of the measures and dimensions from the cube that are available. You can choose one from this list by double-clicking it to reduce typing errors.

36 On the Formulas tab, in the Formula Auditing group, click Remove Arrows.

37 Select cell I2 and look in the CUBEMEMBER function in the formula bar.
The first argument is the connection identifier, which refers to ThisWorkbookDataModel in this exercise. This name can be found in the Connections dialog box.

38 On the Data tab, in the Connections group, click **Connections**.

![Connections dialog box](image)

39 Click **Close**.

You can find the second argument in the CUBEMEMBER function by looking in the Power Pivot data model.

40 On the PowerPivot tab, in the Data Model group, click **Manage**.

When you built the initial pivot table, you selected Region for the filter area.

41 In the Power Pivot for Excel window that is displayed, click the **Regions** worksheet tab.
With the filter value set to "West", you have to then specify the argument as "[Regions].[Region].[West]" or "[Regions].[Region].&[West]", Notice that the construction is [worksheet name].[field name].[row value].

42 Close the Power Pivot for Excel window.

43 Select cell I3 and look in the CUBEVALUE function in the formula bar.

The second argument points to the filter value selected for the pivot table (if one is present). The last three arguments are cell references to the pivot table value, row header, and column header values.

It is important to understand that those cells do not contain simple text values – they contain the results of CUBEMEMBER functions.

To illustrate this point, the follow screenshot shows the equivalent values for two of the arguments.

This demonstrates that the CUBEMEMBER and CUBEVALUE functions work together.

You must use CUBEMEMBER functions to obtain the appropriate row and column header values, plus the measures value. These three components (in addition to any filter values) form the three dimensions to find the value you are looking for from the database.

As demonstrated here, the CUBEVALUE function can embed some or all of the CUBEMEMBER values.

Now modify your cube function to reference this cell for filtering.

44 With cell I3 selected, modify the formula to: =CUBEVALUE("ThisWorkbookDataModel", I2, B3, A6, G4)

45 Click the AutoFilter icon in cell B1, select All, and click OK.

Notice that even though you have changed the region filter to All for the general table, your manually created cube function is still displaying only the total sales for the western region.
As demonstrated in this exercise, the cube functions are more complex than most other Excel functions, and the data in data cubes is structured in complex patterns as well. It appears that a pivot table is a more intuitive way of obtaining the information you need. But cube functions have a distinct advantage over pivot tables: they can be programmed into a workbook in advance where they will update themselves as the data cubes are continuously updated. This is the fundamental principle behind data warehouses: pushing or publishing key information on a real-time basis without the need for manual intervention from the data consumers.

In addition, you can make any number of changes to your Excel worksheet such as creating a BI Dashboard displaying key data values for decision makers to monitor critical parts of their organization with just a quick glance. If the worksheet is limited to a pivot table as it was at the beginning of this exercise, then the format is limited to the structure of a pivot table. By using cube functions, you can place and move any lookup value anywhere. You can also add pivot charts, pictures, and other formulas that will improve the readability and usefulness of the worksheet.
Lesson Summary

You should now be able to:

☑ create, format, and customize pivot tables
☑ use data slicers
☑ group pivot table data
☑ create calculated fields and items for pivot tables
☑ reference pivot table data using GETPIVOTDATA
☑ create a pivot chart
☑ change pivot chart options
☑ drill down a pivot table or pivot chart
☑ change pivot chart styles
☑ activate Power Pivot, and connect it to a data source
☑ create Power Pivot calculated fields
☑ manage Power Pivot table relationships
☑ use cube functions

Review Questions

1. In order to apply styles to a pivot chart, which tab in the PivotChart Tools contextual ribbon would you use?
   a. Analyze  c. Format
   b. Design  d. Style

2. You can create a pivot chart directly from the source data without creating a pivot table first.
   a. True.  b. False.

3. What is an easy way to add or remove chart elements in a pivot chart?
   a. Switch them on or off using the Chart Elements button.
   b. Click the buttons for the elements on the Analyze tab of the PivotChart Tools contextual ribbon.
   c. Select the desired elements from a gallery on the Format tab of the PivotChart Tools contextual ribbon.
   d. You must re-create the pivot chart in order to include the elements you want.

4. Which command will allow you to drill down a pivot chart?
   a. Drill Down.  c. Show Details.

5. Cube functions are used to:
   a. Perform three calculations using one or more ranges of cells at the same time to calculate multiple results.
   b. Extract data from data cubes.
   c. Automatically find the correct input value (that is, the one that will result in the number you are looking for).
   d. Perform summation calculations in Pivot tables.
6. A(n) __________________ looks just like a workbook, but it is not a real workbook. It is simply a staging area for the pivot table to work from.
   a. Power Pivot data model  
   b. CUBEMEMBER  
   c. pivot table  
   d. pivot chart

7. You cannot enter data into a Power Pivot data model, but you can add columns to create calculated fields using fields from the connected tables.
   a. True  
   b. False

8. Which tool do you use to specify which columns of data from your source data table to use as the columns, rows, values, or filters of a pivot table?
   a. The PivotTable Transform dialog box  
   b. The PivotTable Fields task pane  
   c. The PivotTable Elements button  
   d. The PivotTable Slicer dialog box

9. Which pivot table feature can you use to easily determine which filter conditions are currently active?
   a. FilterTrackers  
   b. Calculated items  
   c. Timelines  
   d. Slicers

10. You want to display the value in worksheet cell B5 in cell D29. Cell B5 is located inside a pivot table. What is the best way to reference the value in cell B5?
    a. Use an absolute cell address  
    b. Use a mixed cell address  
    c. Use the GETPIVOTDATA function  
    d. You cannot reference a cell that is located inside a pivot table.

11. The formula =SUM(B5:B10) can be used in a calculated field for a pivot table, even when the cell range B5:B10 is not inside the pivot table.
    a. True  
    b. False

12. Elsie created a pivot table from 5,000 records of source data that groups employees by the following departments: Engineering, Fulfillment, Support, Sales, and Marketing. For budgeting purposes, she wants to group these five departments into two groups – Group 1 (which includes Engineering and Support) and Group 2 (which includes Fulfillment, Sales, and Marketing); however, these groups do not appear in the source data. What can she do?
    a. Recreate the source data range, and arrange the data into the desired Group 1 and Group 2 groups.  
    b. Create the Group 1 and Group 2 groups manually.  
    c. Add a calculated item to each group, and then group by the item.
13. Dean applied numeric formatting via the Format Cells dialog box to the values displayed in his pivot table, but discovered that when he changes the pivot table, the formatting disappears. What can he do to remedy the situation?
   a. Apply the formatting to the pivot table fields, instead of to the displayed values.
   b. Apply the formatting using the buttons on the Analyze tab of the PivotTable Tools contextual ribbon.
   c. Apply the formatting using the Tools button in the PivotTable Fields task pane.
   d. There is no remedy or this situation; it is the nature of pivot tables.

14. Which tool would you for customizing a pivot table – for example, for switching the fields used for rows with the fields used for columns?
   a. The PivotTable Transform dialog box
   b. The PivotTable Fields task pane
   c. The PivotTable Elements button
   d. The PivotTable Slicer dialog box
Lesson Objectives

The objectives of this lesson are to demonstrate how to enable your workbook to work with other workbooks and with users other than just yourself. Upon completion of this lesson, you should be able to:

- insert, modify, and remove links to external workbooks
- consolidate data from multiple workbooks
- create a shared workbook
- track changes on shared workbooks
- show the history of changes to workbooks
- remove shared use of a workbook
- mark a book as “Final”
- use comments
- understand how to create secure passwords
- protect a worksheet, workbook structure, or the workbook file from unwanted changes
Linking External Workbooks

Referencing Other Worksheets in Formulas

Excel formulas can reference cells in other worksheets in the same workbook. The general format of this kind of reference is:

'<worksheet name>'!<cell reference>

The ! (exclamation) symbol – also known as the bang symbol – is used by Excel to indicate that this cell reference is found in a different worksheet. The single quotes are required if the worksheet name includes blank spaces in it.

Linking Other Workbooks

Objective 1.1.3

In addition to referencing any cell within the same workbook — whether in the same or different worksheet — formulas can also reference worksheets in a different workbook. These formulas are set up with a link to these other workbook files even if they are not open.

Using workbook links in your worksheet formulas creates a very powerful tool for consolidating information. Other users can input data into source workbooks independently, and when the dependent workbook is opened, the links will be automatically updated.

Links between worksheets have a source portion and a dependent portion. The worksheet in which you create the linking formula is called the dependent worksheet because it depends on the data from the other worksheet. The referenced worksheet is called the source; it supplies data to the dependent worksheet.

When the source worksheet is in a different workbook, moving the source workbook to another folder or changing its file name can cause linking errors. Having both the source and dependent workbooks open and using Save As to change the name or location of the source workbook will ensure that the links are properly updated.

You can also link worksheets by entering the full workbook location, and cell reference directly. This method enables you to link to source worksheets that are not open in the current session. However, you must ensure that you accurately enter the path, filename, worksheet, and cell reference correctly.

The correct form for the reference is: ='path\[workbook name.xlsx]Sheet name'!cell reference. For example, a reference to cell B4 on Sheet 1 of a workbook named Land Tour Group 1 would be as follows:

='C:\Users\Instructor\Documents\[Land Tour Group 1.xlsx]Sheet1'!B4

The link address is often long, and every character is required or else the link will not work.

Learn to use the linking feature

This exercise demonstrates the linking feature using cell references between a dependent workbook and four source workbooks. Note that this exercise assumes that you have a large computer monitor that will enable you to view all five workbooks next to each other at the same time. If you have a small monitor, you can position the Totals workbook on the left half and then manually bring up and resize the other workbooks on the right half of the monitor.

1. Open the Land Tour Group 1, Land Tour Group 2, Land Tour Group 3, Land Tour Group 4 and Land Tour Group Totals Create Links workbooks. Save these five workbook with “- Student” for each.
2 On the View tab, in the Window group, click Arrange All. In the Arrange Windows dialog box, select the Tiled option and click OK to make it easier to view and copy data from one workbook to another.

Insert the first workbook link into the dependent workbook. With all workbooks open, it is easy to do this using the mouse.

3 Select B5 of the Land Tour Group Totals Create Links workbook, and type: = to start your formula.

4 Click anywhere in the Land Tour Group 1 workbook and select B4. Press ENTER.

5 Select B5 of the Land Tour Group Totals Create Links workbook again and note the cell reference in the Name Box. Within this worksheet, the cell is named B5.

Now look at the cell reference in the Formula Bar. You will see that it contains the filename (and full drive and folder name, after the workbook has been saved the first time) reference of the source workbook, the worksheet name, and the cell address.

The technique used in step 4 and 5 above is the same cell reference selection using the mouse, whether the cell being referenced is in the same worksheet (e.g., =D2), a different worksheet in the same workbook (e.g., =Sheet2!D2), or as it is in this exercise, a worksheet in a different workbook. This is a very powerful feature — Excel will simply add more information into the cell reference to ensure the correct worksheet and workbook are selected.

The workbook link uses an absolute cell reference; you will need to modify it if you want to copy and paste the formula to other cells.

6 With cell B5 in the Land Tour Group Totals Create Links workbook still selected, note the cell reference in the Formula Bar.

The cell reference contains the filename (and full drive and folder name, after the workbook has been saved the first time) reference of the source workbook, the worksheet name, and the cell address.

Note that the workbook link uses an absolute cell reference; you will need to modify it if you want to copy and paste the formula to other cells.

7 With cell B5 in the Land Tour Group Totals Create Links workbook still selected, press F2 and change the cell reference from $B$4 to $B4$.

8 Copy the formula in cell B5 to the cell range B6:B12.

For the next formula, use the Paste Link technique.

9 Select the cell range B4:B11 in the Land Tour Group 2 workbook, then copy these cells.

10 Select C5 of the Land Tour Group Totals Create Links workbook, then on the Home tab, in the Clipboard group, click the drop-down arrow below Paste. In the Paste drop-down menu, click Paste Link (N) (This item can be found in the Other Paste Options section, second from left).

This technique inserts the correct links for all the cells selected in the source workbook.

For the next two columns, use a third technique.

11 Select D5 of the Land Tour Group Totals Create Links workbook, and type: =.

12 Select cell B4 in the Land Tour Group 3 workbook, and press ENTER.

13 Select cell D5 of the Total workbook again, press F2 and change the cell reference from $B$4 to $B4$. 


Lesson 4

Workbook Management Features

14 Copy this formula in cell D5 across to cell E5.

15 Select cell E5, press F2 and change the worksheet reference to: Land Tour Group 4.xlsx.

With the two workbook links now referencing two different workbooks, you can correctly copy and paste these formulas to the remaining cells.

16 Select the cell range D5:E5, and copy down to the cell range D6:E12.

The screen now appears similar to the following (note the formula for E12 in the Formula Bar):

Now observe the effect of changing a value in one of the source workbooks.

17 Select B4 in the Land Tour Group 1 workbook, and enter: 80.

The Total workbook is updated automatically through the workbook link. Now try a scenario in which a source workbook is changed while the dependent workbook is closed.

18 Save and close the Land Tour Group Totals Create Links and Land Tour Group 1 workbooks.

19 Close the Land Tour Group 3 and Land Tour Group 4 workbooks without saving any changes that may have been made to them.

20 Select B4 in the Land Tour Group 2 workbook, and enter: 50.

21 Save and close the Land Tour Group 2 workbook.

Open the dependent workbook. It will automatically update itself using the new data once you verify that it is safe to do so.

22 Open the Land Tour Group Totals Create Links workbook.

23 Click Update.

Notice that cell C5 is now updated to the new changed value from the Land Tour Group 2 workbook.
24   Click on various cells of your choice in the cell range B5:E11, and look at the contents of the Formula Bar. It now contains the full drive, folder path, and file name of the source workbook, followed by the worksheet name and cell reference.

25   Save and close all workbooks.

Modifying Workbook Links

Objective 1.1.3

When the location of a source workbook changes from one drive or folder to another, the dependent workbook link also has to be changed. If both the source and dependent workbooks are open at the same time, Excel will make the changes automatically. When Excel is unable to update the links on its own, you will have to change them manually.

To change the link references, you can change the address reference directly in the cell or use the Edit Links dialog box. To display this dialog box, on the Data tab, in the Connections group, click Edit Links.

The Edit Links dialog box includes several command buttons:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update Values</td>
<td>Update all cells that reference this external workbook by fetching the data from the workbook.</td>
</tr>
<tr>
<td>Change Source</td>
<td>Display the Change Source dialog box to enable you to find the drive, folder, and/or file name that has changed for this workbook.</td>
</tr>
<tr>
<td>Open Source</td>
<td>Open the selected source workbook as a new Excel window.</td>
</tr>
<tr>
<td>Break Link</td>
<td>Automatically converts all cells that reference this external workbook from a formula to the existing equivalent data values.</td>
</tr>
<tr>
<td>Check Status</td>
<td>Verify the integrity of all links to external source workbooks. The Status column will be updated.</td>
</tr>
</tbody>
</table>

Learn to update cell reference links

This exercise will demonstrate how to update the cell reference links when the name of a source workbook is changed.

Start by renaming one of the source workbooks.

1   Use the Windows Explorer to navigate to the student data files folder and change the name of the Land Tour Group 1 workbook to Land Tour Group 1a (add an “a” to the end of the workbook name), but do not open it.
A security warning message may be displayed.

2 With the Land Tour Group Totals Modify Links workbook open, click Enable Content if necessary.

Excel now updates all formulas in the workbook that reference other workbooks. Because one of those source workbooks can no longer be found, the following message is displayed.

3 Select Edit Links.

The Edit Links dialog box lists all external source workbooks and the status information for each of them. An error message appears next to the Store 1 workbook, indicating that this source workbook cannot be found.

4 With the Land Tour Group 1.xlsx file selected, click Change Source.

The Change Source dialog box, which is almost identical to the Open dialog box, now displays, enabling you to find the correct location of this source workbook.

5 If necessary, navigate to the Documents\jasperactive\MyProjects folder.

6 Click the Land Tour Group 1a workbook and click OK.

The link is now updated with the correct workbook name. Furthermore, all data referenced from all linked workbooks has been validated.

7 Close the Edit Links dialog box, then save and close the workbook.

Removing Workbook Links

Objective 1.1.3

Links between workbooks can easily be deleted by clearing the linked cell. However, if you want to keep the data while breaking the link, you can use the Paste Values feature to replace the links with their current equivalent data values.

You can also use the Break Link command in the Edit Links dialog box to accomplish this task.
Learn to remove workbook links

In this exercise, you will remove the links from the Total workbook to the source workbooks.

1. Open the Land Tour Group Totals Remove Links workbook and save as Land Tour Group Total Remove Links - Student.
   
   A security warning message may be displayed.

2. Click Enable Content.


4. Then on the Home tab, in the Clipboard group, click the arrow below Paste and click Values (Paste Values section, first option).

   Each of these linked workbook cell references has now been converted to numeric values in this workbook.

5. Press ESC and select some of the cells in B5 to E12.

   You can see that the cells in row 5 contain numeric values, but the rest of the rows still contain links. The alternative method is to use the Edit Links dialog box to break the links.

6. On the Data tab, in the Connections group, click Edit Links.

7. Click the first workbook link in the Edit Links dialog box, then hold down the SHIFT key while clicking on the last workbook link. Release the SHIFT key.

8. Click Break Link.

9. Read the contents of the message box and click Break Links.

   With all the external references removed, the Edit Links dialog box is now empty.

10. Click Close in the Edit Links dialog box.

11. Select some of the cells in B6:E12. You can see that the cells now contain numeric values. The links have been removed.

12. Save and close the workbook.

Consolidating Data

Objective 3.4.2

Consolidating data refers to the process of summarizing multiple ranges of data into a single range. You can consolidate data from different areas within a worksheet, from other worksheets in the same workbook, or from other workbooks.
You begin by selecting the range where you want the consolidated results to be placed. With the range selected, on the Data tab, in the Data Tools group, click Consolidate to open the Consolidate dialog box. With the cursor in the Reference text box, select the first cell or range of cells that you want to consolidate, then click Add to copy the cell range into the All references list. Once you have selected and added all the cell ranges you want to include in the consolidation, click OK to perform the summary function and display the results.

<table>
<thead>
<tr>
<th>Function</th>
<th>Specifies the type of function (for example, sum, count, average, max, min, etc.) to apply to the data being consolidated. For example, if Sum is selected (the default), then the consolidated data will be added together.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference</td>
<td>Specifies the cell range from the worksheet/workbook where the source data is located. When you click the Add button, the cell range selection is added to the All references list.</td>
</tr>
<tr>
<td>All references</td>
<td>Lists all the source cell ranges that have been selected. When you click OK, the data from all the source cell ranges will be consolidated using the selected function.</td>
</tr>
<tr>
<td>Use labels in</td>
<td>Designates whether any label row and/or column is to be used to consolidate the data.</td>
</tr>
<tr>
<td>Create links to source data</td>
<td>Will automatically update your consolidated data whenever the source data is changed.</td>
</tr>
</tbody>
</table>

When consolidating by position, the source ranges must be the same layout as the destination range. Excel will process cell for cell from the source ranges to the destination range using the selected function. The data in each of the source worksheets must therefore be in the same positions; for example, the data in cell A1 from each of the source worksheets will be consolidated and placed in cell A1 of the destination worksheet.

A more flexible method is to use labels to consolidate data. Excel will use the column and row labels to match the source ranges to the destination range; the order does not matter. When using labels to perform consolidation, the row and column labels must match exactly. The matching process is not case sensitive.

Even though consolidating data is relatively easy, there are some points you should consider when you are using the consolidation process:

- Only numeric values are consolidated; any text in the source areas will display as a blank cell.
- Each consolidation area must be separate from other consolidation areas. For example, there must be a set area for the Eastern region sales, another area for Western region sales, and so on.
- Excel uses the same numeric format in the consolidated area as it found in the first source area.
- Excel consolidates data values only; formulas are not carried into the consolidated worksheet.
Workbook Management Features

Lesson 4

- To link different worksheets while consolidating choose Create links to Source Data. Creating links will result in a summary table with the details linked and summation formulas to total each group.
- You can specify a maximum of 255 source areas.
- When referencing other workbooks, the workbooks do not need to be opened at the time of specification.
- You can use range names in the source and destination worksheets. This makes it easier to find specific information, especially if you do not know exactly where the cells are.

Learn to consolidate data by category

This exercise will demonstrate how to consolidate data by category from two workbooks into a new summary workbook.

1. Open the Group Tour 1 and Group Tour 2 workbooks. Open the Group Tour Total workbook and save as Group Tour Total - Student.
2. On the View tab, in the Window group, click Arrange All.
3. Click Tiled and then click OK.
   Before starting the consolidation process, you must select the range where you want the results to be placed.
5. On the Data tab, in the Data Tools group, click Consolidate.
   Select the cells containing the data to be consolidated. Be sure to include the row labels.
6. With the cursor in the Reference text box, select cells A1:B3 of the Group Tour 1 workbook.
   If the Consolidate dialog box is obstructing the cells that you need to select, you can either click and drag it out of the way or click the Collapse button at the right side of the Reference text box.
   Note: The referenced workbook does not need to be opened in advance, as is in this exercise, for you to reference it. If it is not open, use the Browse option to find the file. Alternatively, you can manually enter the cell reference; be sure to enter the name of the workbook in square brackets followed by the worksheet name all in single quotes. Follow this with a bang character (!) and then the cell range from the source worksheet.
7. In the Use labels in section of the Consolidate dialog box, click the Left column checkbox to turn it on.
8. Click Add to copy this cell range into the All references list.
Now select the cells from the second workbook.
9. With the cell range in the Reference text box still highlighted, select cells C4:D6 in the Group Tour 2 workbook and click Add in the Consolidate dialog box.
Now proceed with consolidating these cell ranges.
10. In the Consolidate dialog box, click the OK button.
Notice that even though the data cells in the Group Tour 2 workbook were in a different sequence than the Group Tour 1 workbook, the consolidate feature added the correct cells together. Excel knew to use the cell labels to the left of the numbers to figure out which numbers to add together.

**Note:** If the row labels do not appear in the consolidated worksheet, use the **Undo** feature and be sure to turn on the Left column check box.

11 Click each of the cells in **B4** to **B6** in the **Group Tour Total** workbook to view the values entered into these cells.

12 Save and close the **Group Tour Totals** workbook. Close the other workbooks without saving them.

## Workgroup Functions

Spreadsheets were originally designed to be used by only one person on one computer at a time. Spreadsheet programs were always very fast because they kept the data in the computer’s memory; any time a cell value was changed, all formulas that referenced that cell were updated immediately.

However, people quickly developed the need to share their spreadsheets with others. When computers were first networked together, spreadsheets became available to multiple users at the same time. However, there were still limitations because the spreadsheet could be accessed by only a single user at a time. That is, the first person to open a spreadsheet could update it; others who subsequently tried to open the same spreadsheet either had to wait for the first person to close the spreadsheet, or open a copy of the spreadsheet with read-only access so that no changes could be saved to the original spreadsheet until the first person had closed it.
Excel workbooks can now be shared with other people, using three general methods:

- You can post your workbook on a network folder for other users to access and update. Different users may be allowed to open and update the same workbook at the same time or not. These same users must also ensure that they do not make their own copies of the workbook because someone else may make changes in the meantime. The changes can then be compiled for your review.

- You can send or distribute copies of your workbook by email or intranet. Each person makes changes and comments to his/her copy and returns it to you. You can then merge the changes into the original workbook.

- You can use Microsoft SharePoint document management services (or an equivalent version-control system) to manage access to workbooks; this ensures that, if one person makes changes, s/he does not over-write changes that are being made by others at the same time. Microsoft SharePoint controls updates by allowing only one person to check out a workbook, make the necessary changes, and then check it back in to make it available to others. Changes are accepted only while the workbook is checked out, and only one user can check it out at any one time.

This courseware describes the first two methods.

### Creating a Shared Workbook

**Objective 1.2.1**

In order for you and others to update the same workbook at the same time, it must be set up as a shared workbook. If you don't activate this feature, Excel displays a message indicating that someone else has the file open and you can open a read-only version or be notified when the other person has closed the file.

Excel will allow up to 256 people to update the same workbook at the same time. However, you should limit the number of concurrent users to no more than 10 because Excel is not designed for use as a robust multi-user system.

You should be aware that you are not permitted to perform certain functions while sharing workbooks. These include but are not limited to:

- Inserting or deleting blocks of cells; however, you can insert or delete entire rows and columns.
- Deleting worksheets in the workbook.
- Inserting or changing charts, pictures, objects, or hyperlinks.
- Using any of the drawing tools.
- Grouping or outlining data.
- Inserting automatic subtotals or summarizing data.
- Setting up or changing data validation restrictions and messages.
- Changing or removing passwords (although passwords that were added before the workbook was set to be shared remain unchanged).

Behind the scenes, Excel does not really allow multiple users to update the same workbook at the same time. In reality, each user updates his/her own copy of the shared workbook. Excel then tries to resolve multiple changes to cells.

**Note:** You cannot share workbooks that contain tables.
To share a workbook, on the Review tab, in the Changes group, click **Share Workbook** to open the Share Workbook dialog box. On the Editing tab, select the Allow changes by more than one user at the same time... checkbox, then click **OK**.

Excel will display a message box appears with the question: “This action will now save the workbook. Do you want to continue?”. Click **OK**.

The title bar at the top of a shared workbook displays the “[Shared]” indicator.

---

**Learn to set up a workbook for sharing**

This exercise demonstrates how to set up a workbook for sharing.

1. **On the Review tab, in the Changes group, click **Share Workbook**.**

2. **Click Allow changes by more than one user at the same time... to turn it on. Click **OK**.**
   
   A message box appears with the question: “This action will now save the workbook. Do you want to continue?”

3. **Click **OK** to save the workbook and leave the workbook open.**

   The title bar at the top of the workbook now has the indicator **[Shared]** displayed:
4 Close the workbook.

Tracking Changes

Objective 1.2.5

When you put a workbook into a shared location, such as a shared network drive, there will be almost no restrictions on how many changes others make to the data and how often they make them. Excel’s shared workbook feature helps to alleviate these concerns because all changes to the workbook are recorded in a history log, which can be viewed at any time.

The Track Changes feature in Microsoft Excel is similar to the Track Changes feature in Microsoft Word: Excel records most (although not all) changes to the workbook with the name of the person who made them, and you can reverse a change if you want. In Excel, this feature differs in some ways.

These include:

- There are some changes that Excel does not track, such as:
  - Cell formatting changes (for example, changing colors and fonts).
  - Inserting or deleting comments.
  - Hiding or unhiding rows or columns.
  - Inserting or deleting worksheets.
- By default, Excel’s change-history log tracks changes for only 30 days; any changes older than 30 days (or whatever the tracking limit is set to) are automatically purged from the log and are no longer reversible. This limit can be increased to a maximum of 32,767 days.

To activate Track Changes, on the Review tab, in the Changes group, click Track Changes, and then click Highlight Changes to open the Highlight Changes dialog box.
Lesson 4
Workbook Management Features

When | Options include: Since I last saved, All, Not yet reviewed, or Since date.
---|---
Who | Options include: Everyone, Everyone but Me, and a list of users who have updated the shared worksheet.
Where | This allows you to select specific cell ranges for which Excel will display change comments.

The default combination is Since I last saved, Everyone, and all cells. These choices are important to ensure that the history accurately records the changes that you want to track. However, you may consider more restrictive choices in order to limit the size of the change history.

Note that when you activate the Track Changes feature for a workbook, Excel automatically turns workbook sharing on (if it has not already been activated).

Once the Track Changes feature is activated, you can view changes in one of two ways:
- Display the change comment by positioning the mouse pointer over a cell. This displays the most recent change, who made the change, and the date and time that it was made. The comment can display only one change; previous changes will not appear.
- Display the change history in a temporary worksheet.

The change comment is marked by the small triangle in the upper left corner of a cell. Each user is assigned a different colored triangle. You can control when these change comment markers appear or are reset.

Learn to change the settings for tracking change comments

This exercise demonstrates how to change the settings for tracking change comments.

1. Open the Bookings Activity Highlight Changes (shared) workbook and save as Booking Activity Highlight Changes (shared) - Student.
2. On the Review tab, in the Changes group, click Track Changes and then click Highlight Changes.
3. Click the drop-down arrow for When, click All, and click OK.
4. Move the mouse pointer over some of the cells to display the change comments there.
5 On the Review tab, in the Changes group, click **Track Changes**, and click **Highlight Changes**.

6 Click the arrow for **When**, click **Since I last saved**, and click **OK**.

   Excel displays a message box indicating that "No changes were found with the specified properties." You may need to click on the blinking Excel icon in the Windows Task Bar to see this message box.

7 Click **OK**.

   All of the changed comment markers should now disappear.

Now change one cell.

8 Select cell **C18**, enter: 564.

   Notice that cell C18 is now the only cell with a change comment marker.

9 Save the workbook.

   The change comment marker disappears again.

10 Close the workbook.

**Showing the History of Changes**

**Objective 1.2.5**

Instead of highlighting the cells that were changed, you can display a list of changes (or *history*) on a separate, temporary worksheet. This worksheet contains a little more information than the change comment, and may be easier to read, as it lists all changes made to the workbook.
Lesson 4

Workbook Management Features

Each column heading in this worksheet includes an AutoFilter button. When you click one of these buttons, Excel displays a list of unique values in that column. You can select any of those values to filter out any rows that do not contain that selected value.

Tracking of changes starts automatically with shared workbooks. By default, Excel retains only the most recent 30 days of changes. To change this setting at any time, on the Review tab, in the Changes group, click Share Workbook, and then click the Advanced tab. The maximum number of days that you can set your change history to is 32,767.

You can turn off the tracking of changes by clicking the Don’t keep change history option in the Share Workbook dialog box. This will allow you to continue sharing the workbook without tracking the changes.

Learn to display the change history

This exercise demonstrates how to display the change history.

1. Open the Bookings Activity Change History (shared) workbook and save as Bookings Activity Change History (shared) - Student.

   Display the list of all changes made to this workbook during the last 30 days starting from when sharing was turned on.

2. On the Review tab, in the Changes group, click Track Changes, and then click Highlight Changes.

3. Click the When checkbox to turn it off. If necessary, deselect the Who and Where checkboxes as well.

   Note: Another way of selecting all changes to be listed is to select the “All” option for the When list box.

4. Click List changes on a new sheet to turn it on. Click OK.

5. If necessary, widen the worksheet window to view as much of the history worksheet as possible.

   Use the AutoFilter buttons to select certain rows to display.

6. Click the down arrow for the Time heading. Click a time value of your choosing to turn it off and click OK.

7. Click the down arrow for Time again, and click (Select All) and click OK.

8. Change the filter values in other columns of your own choosing.

Now turn off the history worksheet.

9. On the Review tab, in the Changes group, click Track Changes, and then click Highlight Changes.

10. Click the drop-down arrow for When and click Since I last saved.

11. Click List all changes on a new sheet to turn it off.

12. Click OK. Click OK once more to remove the message box.

13. Save and close the workbook.
Removing Shared Use of Workbooks

You can convert shared workbooks back to single user access at any time by turning off the option to share the workbook in the Editing tab of the Share Workbook dialog box.

Learn to convert a shared workbook

This exercise demonstrates how to convert a shared workbook back to single user.

1. Open the Bookings Activity Remove Sharing workbook and save as Book Activity Remove Sharing - Student.
2. On the Review tab, in the Changes group, click Share Workbook. If necessary, click the Editing tab.
3. Click Allow changes by more than one user... to turn it off.
4. Click OK. Excel displays the following warning message:

   ![Warning message]

5. Click Yes.

   The [Shared] indicator is no longer displayed in the title bar.

6. Save and close the workbook.

Mark as Final

Objective 1.2.1

Once all changes have been made to a workbook, you can use the “Mark as Final” command to prevent others from making any more changes to it.

When you open a workbook, the Marked as Final message will be displayed in the Notification bar, and the [Read-Only] indicator will be displayed in the title bar.

![Marked as Final]

Note that even when a workbook is marked as final, users can still click the Edit Anyway button and make changes. If you want to ensure that no one else can change the workbook, you must enable protection by putting a password on the workbook. Once this is done, only users who have the correct password will be able to make changes to the workbook. Everyone else will have Read-Only privileges or no access at all. This topic is covered later in this lesson.
Learn to mark a workbook as final

This exercise demonstrates how mark a workbook as final.

1. Open the Bookings Activity Final workbook and save as Bookings Activity Final - Student.
2. Click the File tab, and ensure the Info window is displayed.
3. Click Protect Workbook, then click Mark as Final.
   The message “This workbook will be marked as final and then saved” is displayed.
4. Click OK.

![Image of alert message]

5. Click OK.
   Notice that the title bar for this workbook now displays the [Read-Only] indicator.
6. Close the workbook.

Using Comments

Comments are like “sticky” notes on a hard-copy document. You typically use them so that several users who are sharing a workbook can annotate the spreadsheet with their various comments. Excel automatically adds the current user’s name at the top of the comment text box. The final reviewer can then act on each comment and follow up with the originator, if necessary.

In non-shared workbook situations, you can use comments to remind yourself about things you need to do, or to record detailed information about formulas you have used, for future reference. Spreadsheets typically contain large volumes of numbers, titles, and formulas to produce the desired results. Comments often help by providing explanations. The traditional way of adding comments is to enter free-form text into cells on the worksheet. Although this method is simple and works well with smaller spreadsheets, it does not work well with large spreadsheets where empty cells may be far away and you have to draw lines from your comments to the cells to which you are referring. Embedded comments are a better solution because you can insert them directly into the cells they reference and display them only when you want to see them.

The command buttons used to create, modify, and delete comments are located on the Review tab in the Comments group:
The New Comment and Edit Comment buttons share the same position in the Review tab: if the active cell does not have a comment, the New Comment button is displayed. Otherwise the Edit Comment button is displayed.

To insert a comment into a worksheet, use one of the following methods:

- select the cell where the comment will be inserted, then on the Review tab, in the Comments group, click New Comment, or
- press SHIFT+F2, or
- right-click the cell where the comment will be inserted and then click Insert Comment.

To temporarily display the contents of an individual comment, position the cursor over a cell containing the (Comment Symbol). When you move the cursor away, only the Comment Symbol displays.

To force a comment to remain displayed, use one of the following methods:

- select the cell containing the comment, then on the Review tab, in the Comments group, click Show/Hide Comment, or
- right-click the cell containing the comment and click Show/Hide Comment.

To display the contents of all comments in a worksheet, on the Review tab, in the Comments group, click Show All Comments.

To delete a comment, use one of the following methods:

- select the cell containing the comment, then on the Review tab, in the Comments group, click Delete, or
- right-click the cell and then click Delete Comment, or
- select the cell containing the comment, then on the Home tab, in the Editing group, click Clear, and then click Clear Comments.

### Learn to work with comments

In this exercise, you will insert, view, and delete comments in a worksheet.

1. Open the Income Statement workbook and save as Income Statement - Student.
2. Select cell C6.
3. On the Review tab, in the Comments group, click New Comment.
4. In the comment box, type: Revenue came from sales of souvenir T-shirts.
5. Click anywhere on the worksheet away from the comment.
Excel displays a ▪ (Comment Symbol) in this cell to remind you that you have inserted a comment there. Otherwise, the comment would remain hidden until you placed the cursor over that cell.

6 With the current active cell elsewhere on the worksheet, point the cursor at cell **C6**.
   The comment box reappears and continues to display until you move the cursor elsewhere.

7 Select cell **C21** and, on the Review tab, in the Comments group, click **New Comment**.

8 In the comment box, type: *Net income needs to be improved!*

9 Click elsewhere on the worksheet.

   If necessary, you can display all comments on a worksheet at one time. You may want to do this if you are seeing the worksheet for the first time, or if others have added many comments since you last opened the workbook.

10 Select cell **C21** again and then, on the Review tab, in the Comments group, click **Show/Hide Comment**.
   Click elsewhere on the worksheet.
   The comment remains visible.

11 Select cell **C21** and then, on the Review tab, in the Comments group, click **Show/Hide Comment** again.
   You can also make all the comments in the worksheet display at the same time.

12 On the Review tab, in the Comments group, click **Show All Comments**.

   ![Comment Displayed in Excel]

13 On the Review tab, in the Comments group, click **Show All Comments** again to hide all comments.

14 On the Review tab, in the Comments group, click **Next** to move the cursor to a cell containing a comment.

15 Click the **Next** button again until Excel displays a message box that says it has reached the end of the worksheet.

16 Click **Cancel** to close the message box and click elsewhere on the worksheet.
You can delete a comment from a cell when you no longer need it.

17 Select cell C6. Then on the Review tab, in the Comments group, click Delete.

18 Save and close the workbook.

Protecting Your Workbook
Using Passwords

Eventually, you may find yourself developing spreadsheets that other people will use. Once other people use a workbook, you no longer have control over what is being changed—unless you protect the workbook.

Excel provides levels of protection that range from protecting individual cells up to full workbook files. By using the appropriate level of protection, you can permit access to selected areas of the workbook while hiding sensitive information and protecting your formulas.

When protection is enabled, Excel prompts the user to enter a password. If you are just protecting your worksheet or workbook from accidental changes, you can leave the password blank. Although this is equivalent to giving everyone the password, the intention here is simply to act as a friendly reminder; changes can be made if they are important. A password, however, protects against malicious data tampering or unauthorized viewing of sensitive data. Once a worksheet, workbook, or file is password-protected, you will be able to remove the protection only by using the password.

Consider the following points when using passwords:

- It’s advisable to keep a record of your passwords in a safe place because, if you forget the password, even Microsoft will not be able to help you remove the protection.
- Passwords are case sensitive. If you use a mix of upper and lower case, you must remember the exact pattern. Remember that the CAPS LOCK key inverts the case when you are typing and be sure to check the Caps Lock indicator when setting and using passwords.
- Be careful as you type. Passwords do not display on the screen. You will be asked to retype the password to ensure that you typed it correctly the first time. Watch your hand position on the keyboard!
- If someone hacks the password (by guessing or other methods), the security will be lost. The best protection against this is to choose a strong password. There are numerous rules and guidelines for selecting strong passwords that cannot be easily guessed by others. Your choice of a password comes down to how important the information in the worksheet is.

If you need a secure password (one that is more difficult to hack), here are some guidelines:

- The password must be at least six characters long. It is usually not necessary to exceed 10 characters.
- It must have at least one of each of these: lower case alphabetic character (a to z), upper case (A to Z), numeric digit (0 to 9), and other characters (for example, # ! % &). An example of a secure password is seC#r3T.

If you don’t need as much security but do need a password that will be easy to remember, follow these guidelines:

- Choose a word that will not be obvious to others. For example, if you have a worksheet that lists the salaries of everyone in the company, you might choose “grsPaY-17” instead of “salary.”
• Avoid associating the password with the job function. For instance, do not use “payroll” as a password for a payroll workbook.

• If the password is distributed to people whom you want to access the workbook, do not use any of your personal passwords. If you share a password you normally use for your own access to a secure network or system, you risk others gaining access to your own secure area.

• Avoid using names of people you know, or pets, as these are typically the first words hackers try.

Protecting the Worksheet

Objectives 1.2.1, 1.2.2

There are occasions when you may want to restrict others from making changes to designated cells or cell ranges. This is known as enabling worksheet protection. By default, worksheet protection is turned off and anyone can make any change to any cell.

In addition to preventing others from making unwanted changes to your worksheet, this feature can prevent you from making mistakes that could cause the loss of formulas or core information. When this is a consideration, you may want to enable protection that doesn’t include the use of a password.

By default, every cell in a worksheet is set to locked. Therefore, when you turn on worksheet protection, none of the cells will permit changes. To unlock individual cells or cell ranges, use one of the following methods:

• On the Home tab, in the Cells group, click Format and click Lock Cell to toggle it off. As shown in the screen below, Excel displays the Lock Cell icon with a border around it, indicating that it is currently turned on.

• On the Home tab, in the Cells group, click Format, click Format Cells to open the Format Cells dialog box, and click the Protection tab as shown in the following screen. Click the Locked check box to turn it off or on.

Once you have unlocked the selected cells, you can turn on worksheet protection. To do this, use one of the following methods:

• on the Home tab, in the Cells group, click Format, and click Protect Sheet; or
• on the Review tab, in the Changes group, click Protect Sheet; or
• on the File tab, click Info group, click Protect Workbook, and click Protect Current Sheet.
The Protect Sheet dialog box is then displayed:

![Protect Sheet dialog box](image)

In this dialog box, you can choose from several additional protection options:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select locked cells, select unlocked cells</strong></td>
<td>These options allow users to select the locked or unlocked cells. By default, these options are turned on when protecting a worksheet. Turning off Select locked cells may be useful because it will restrict users to moving around only among unlocked cells. If both the Select unlocked cells and Select locked cells options are turned off, users will not be able to select or enter data into any cell on the worksheet.</td>
</tr>
<tr>
<td><strong>Format cells, columns or rows</strong></td>
<td>These options allow users to change any of the cell formatting in the worksheet. However, even with these options turned off, users are permitted to use locked cells as a source for the format painter (but not as target cells).</td>
</tr>
<tr>
<td><strong>Insert or delete columns or rows</strong></td>
<td>Insert new rows or columns, or delete existing rows or columns.</td>
</tr>
<tr>
<td><strong>Insert hyperlinks</strong></td>
<td>Insert hyperlinks into cells.</td>
</tr>
<tr>
<td><strong>Sort</strong></td>
<td>Sort data into a different sequence.</td>
</tr>
<tr>
<td><strong>Use AutoFilter</strong></td>
<td>Apply AutoFilters.</td>
</tr>
<tr>
<td><strong>Use PivotTable reports</strong></td>
<td>Allow use of PivotTables.</td>
</tr>
<tr>
<td><strong>Edit objects</strong></td>
<td>Delete or modify pictures, clipart, and other graphic objects.</td>
</tr>
<tr>
<td><strong>Edit scenarios</strong></td>
<td>Use or modify scenarios.</td>
</tr>
</tbody>
</table>

Note that by selecting any of these options, you allow others to have the selected capabilities. When you choose the default settings, others are permitted only to enter or change data in unlocked cells, and are prevented from doing anything else such as inserting or deleting rows or columns, or formatting cells.

Note also that the password is optional; if you leave it blank, the worksheet is protected but anyone can unprotect it. As you enter a password, the ● character displays in the dialog box for every character in the password; this prevents anyone else from seeing what your password is. If you enter a password, Excel prompts you to enter it again to ensure that you have entered it correctly.

When worksheet protection is turned on, the Review tab in the Ribbon will display Unprotect Sheet to indicate that this worksheet is currently in protected mode.
The Info screen in the Backstage view will also identify which worksheet is in protected mode.

**Note:** Worksheet protection does not prevent anyone from deleting the entire worksheet or the workbook! It also does not prevent anyone from copying data to another worksheet or workbook.

### Learn to protect a worksheet

This exercise demonstrates how to protect a worksheet.

1. Open the *Loan Calculator Protect Worksheet* file and save as *Loan Calculate Protect Worksheet - Student*.

Select the cell range to allow users to enter data even though the rest of the worksheet is locked.


3. On the Home tab, in the Cells group, click Format, and click Format Cells.

4. Click the Protection tab, click the Locked checkbox to deselect it and turn the setting off, and click OK.

You have now unlocked a range of cells that users will be permitted to update once worksheet protection is turned on.

Alternatively, you could also click the Lock Cell option in the Format drop-down list in the Ribbon. However, you need to look closely at the lock icon to confirm what the current state is.

You may find it less confusing to use the Protection tab of the Format Cells dialog box. The Locked check box clearly displays the locked status of the selected cells.

You have now unlocked a range of cells that users will be permitted to update once worksheet protection is turned on. Now activate the worksheet protection.

5. On the Home tab, in the Cells group, click Format, and click Protect Sheet.
The Protect Sheet dialog box opens so you can select which worksheet operations or objects to protect.

6 Leave all the checkboxes at their default settings, then type: 123 in the Password to unprotect sheet text box. Click OK.

**Note:** Do not use this password for your real workbooks! See the “Using Passwords” topic about selecting passwords to fit your security needs.

The Confirm Password dialog box now appears; re-enter your password to ensure it is correct.

7 Type: 123 in the text box and click OK.

8 Move to cell C12 and try to enter a value.

When you press any key, the following message box is displayed:

9 Click OK to clear the error message.

10 On the Home tab, in the Cells group, click Insert or Delete to try to insert or delete a row or column.

Note that the Insert and Delete (and other) commands in the Ribbon are grayed out, preventing you from accessing them. However, you do have the ability to insert new worksheets and copy data to different worksheets.

11 Enter the following information into the cells that were unlocked earlier:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>B4</td>
<td>1000</td>
</tr>
<tr>
<td>B5</td>
<td>.06</td>
</tr>
<tr>
<td>B6</td>
<td>12</td>
</tr>
</tbody>
</table>

Now remove the password protection.

12 On the Home tab, in the Cells group, click Format, then click Unprotect Sheet.

The Unprotect Sheet dialog box is displayed.

13 Type: 123 in the Password text box and click OK.
Enter a value into a locked cell to verify that the worksheet is unprotected.

14 Move to cell **C12**, and enter: 10000.

Now enable worksheet protection without a password and disable all options.

15 On the Review tab, in the Changes group, click **Protect Sheet**.

16 Click the **Select locked cells** and **Select unlocked cells** checkboxes to turn them off and click **OK** without specifying a password.

This worksheet is now in read-only mode.

17 Try to select any cell in this worksheet.

You should not be able to click and select a cell.

18 On the Review tab, in the Changes group, click **Unprotect Sheet**.

You did not need to enter a password to unprotect the worksheet because you did not use one when you had protected it previously.

Once you have unlocked the worksheet, it remains unlocked until you protect it again.

19 Select cell **C12**, and delete the value in that cell.

20 Save and close the workbook.

**Allow Ranges for Editing**

**Objectives 1.2.1, 1.2.2**

Another way of allowing users to make changes to cells in an otherwise protected worksheet is to use the Allow Users to Edit Ranges option. The Locked option described in the previous section allows all users to make changes to unlocked cells.

The Allow Users to Edit Ranges option is different: it allows users to make changes to unlocked cells, but they need to know the password for that cell range. This feature enables you to allow only **some** users to update a particular cell range.

On the Review tab in the Changes group, click Allow Users to Edit Ranges to open the New Range dialog box.

Use the New Range dialog box to specify different passwords and permission levels for each range of cells.

<table>
<thead>
<tr>
<th>Title</th>
<th>Choose a text title for this group of cell ranges.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Refers to cells</td>
<td>Identify the ranges of cells that are unlocked in this group. You can specify more than one range of cells for the worksheet by using a comma between each range.</td>
</tr>
<tr>
<td>Range password</td>
<td>Use this password to unlock this group of cell ranges for editing.</td>
</tr>
<tr>
<td>Permissions</td>
<td>Identify the individual IDs or groups that will have open access to these cell ranges. This feature works best on computers connected to a domain-based (enterprise) network; managing security access privileges on individual computers is too time-consuming to be practical.</td>
</tr>
</tbody>
</table>
**Note:** You should not use the same password for the unlocked range as the password for locking the worksheet or workbook.

The example Permissions dialog box shown here allows Bob and Susan to make changes to the selected cell range without having to enter the password. All other users must enter the password to make changes.

---

**Learn to unlock a cell range**

This exercise demonstrates how to unlock a cell range using an alternate method.

1. Open the *Loan Calculator Allow Ranges* file and save as *Loan Calculator Allow Ranges – Student*.
2. Select the cell range to allow users to enter data even though the rest of the worksheet is locked.
4. On the Home tab, in the Cells group, click **Format**, and click **Lock Cell** to unlock the selected cells.
5. With cells B5:B6 still selected, on the Review tab, in the Changes group, click **Allow Users to Edit Ranges**.
   - The Allow Users to Edit Ranges dialog box is displayed.
6. Click **New** to open the New Range dialog box.
7. Select the text in the Title text box, then type: *Loan data*.
8. Click in the Range password text box, and enter: *456*.
9. Click **OK**.
   - In the Confirm Password message box, type: *456* and click **OK**.
   - The completed Allow Users to Edit Ranges dialog box is displayed.
10 In the Allow Users to Edit Ranges dialog box, click **Protect Sheet**.

11 In the Protect Sheet dialog box, scroll up if necessary, then click the **Select locked cells** and **Select unlocked cells** checkboxes to turn them back on.

12 Click in the Password to unprotect sheet text box, type: 123 and click **OK**.

13 In the Confirm Password message box, type: 123 and click **OK**.

   With the worksheet now protected, change the value in a cell that is simply unlocked.

14 Select cell **B4** and enter: 10,000.

Now change the value in a cell that is unlocked by a password (using the unlock technique from the previous section).

15 Select cell **B5** and press any key.

   Because this cell is one of the locked ranges, the Unlock Range dialog box is displayed. The key that you pressed to display this dialog box is ignored.

16 Enter: 456 and click **OK**.

17 Select cell **B5**, and enter 5.

Now enter a value into the other cell that is unlocked by this password. You do not have to enter the password again.

18 Select cell **B6** and enter: 36.
Workbook Management Features

Lesson 4

19. Save and close the workbook.

Protecting the Workbook Structure

Objective 1.2.4

Excel also provides protection for the workbook structure, which will prevent users from adding, deleting, moving, or renaming worksheets within the workbook.

In the Review tab, in the Changes group, click Protect Workbook to open the Protect Structure and Windows dialog box. Specify what you want to protect, specify a password if desired, then click OK.

Learn to enable workbook protection

In this exercise, you will enable workbook protection.

1. Open the Monthly Salary Protect Structure file and save as Monthly Salary Protect Structure – Student. Demonstrate that you can freely insert and delete worksheets in this workbook.

2. On the Home tab, in the Cells group, click the arrow button below Insert, then click Insert Sheet to add a new worksheet.

3. On the Home tab, in the Cells group, click the arrow button below Delete, then click Delete Sheet to delete this new worksheet. Click Delete.

Now activate the workbook protection feature.

4. On the Review tab, in the Changes group, click Protect Workbook.

Note: Even though the button in the Ribbon is named Protect Workbook, it will lock down only the structure of the workbook. Other users will still be permitted to freely open the workbook and make changes to any cell in any worksheet.

5. If necessary, click the Structure checkbox to turn it on.

6. Type 123 in the Password text box and then click OK.

7. Type 123 in the Reenter password to proceed text box and then click OK.

8. On the Home tab, in the Cells group, click the arrow button below Insert.

Note that the Insert Sheet option is grayed out.
9 On the Home tab, in the Cells group, click the arrow button below Delete.  
  Note that the Delete Sheet option is grayed out.

10 On the Home tab, in the Cells group, click the arrow button below Format. The Organize Sheets menu options are also grayed out.

11 Right-click the Sheet1 worksheet tab. After reviewing the different menu options that are grayed out, click any blank area of the worksheet to close the right-click menu.

**Password Protecting Workbook Files**

**Objective 1.2.6**

You can protect a workbook by preventing users from opening it, or by allowing them to view the contents without making any modifications. You can enable this type of access control with passwords.

If you forget your password, you will never be able to retrieve the data. No one—not even Microsoft—can get around this password protection. Be sure to store your password in a secure location (but not in an obvious place, such as taped to your computer).

To password-protect your workbook, open the Save As dialog box, click Tools, and then click General Options to open the General Options dialog box. Here, you can specify a password to open, and a password to modify.

You can enter two different passwords to control the level of access for your users:

- If you enter only a Password to open, all users must enter the password to see the contents of the workbook. Once the file is open, users can make changes to the workbook and save them.
- If you enter only a Password to modify, all users may open the workbook and see the contents without the password. However, if they make any changes to the workbook, they cannot save them to the same workbook, although they can save the workbook with a different name or to a different folder.
- If you enter both a Password to open and a Password to modify, users must enter both passwords to have full access to the workbook. If they only have the Password to open, they can only see the contents of the workbook; they will be unable to save changes. If they only have the Password to modify, then will not be able to do anything with the workbook because Excel requires the Password to open first.

Control these passwords carefully, as anyone who knows one of them will have that type of access to the workbook. If you change either password, you must give the new password to every person who needs to know.
For shared workbooks, you can also ensure that tracking remains enabled unless a password is entered to turn it off. On the Review tab, in the Changes group, click **Protect and Share Workbook** to display the following dialog box:

![Protect Shared Workbook dialog box](image)

---

### Learn to enable workbook protection using passwords

In this exercise, you will enable workbook protection using passwords.

1. Open the *Monthly Salary Workbook Password* workbook but do not save it yet.
2. Click **File** and then click **Save As**. In the Save As screen, click **More Options**.
3. In the Save As dialog box, click **Tools** in the lower right corner and then click **General Options** to open the General Options dialog box.

![General Options dialog box](image)

4. In the **Password to open** text box, type: 123.
5. In the **Password to modify** text box, type: 456.
6. Click **OK**.
   
   You must now confirm your passwords: first is the Password to open, then the Password to modify.

7. In the first **Confirm Password** dialog box enter: 123 and then click **OK**.
8. In the second **Confirm Password** dialog box enter: 456 and then click **OK**.
9. In the Save As dialog box, verify that the workbook is being saved to the student data files folder, click at the end of the file name to type: - Student, and then click **Save**.
10. Close the workbook.
Excel requires the passwords in order to grant access to you. You must enter the Password to open password in order to continue.

12 Type: 123 and click OK.

Excel wants to know if you want read-only access to the workbook or if you want to enter the Password to modify password.

13 In the second password dialog box, click Read Only.

14 In cell B5, enter: 4000.

15 In the Quick Access toolbar click Save.

Excel displays a message informing you that you cannot save changes to the current workbook.

16 Click OK. In the Save As screen, click the Back button to return to the worksheet.

17 Close the workbook without saving the changes.

18 Open the Documents\Jasperactive\MyProjects\Monthly Salary Workbook Password workbook again.

19 In the Password dialog box, type: 456 and click OK.

   The message “The password you supplied is not correct...” displays. If you need to modify this workbook, you will need to know both passwords.

20 Click OK.

21 Open the Monthly Salary Workbook Password – Student workbook once more.

22 In the Password dialog box, type: 123 and click OK.

23 In the second password dialog box, type: 456 and click OK.

24 In cell B5, enter: 4000.

25 Save and close the workbook.
26 Open the *Monthly Salary Workbook Password - Student* workbook and enter the two passwords, as appropriate. 

The change you made to cell B5 was successfully saved.

27 Close the workbook.

**Lesson Summary**

You should now be able to:

- insert, modify, and remove links to external workbooks
- consolidate data from multiple workbooks
- create a shared workbook
- track changes on shared workbooks
- show the history of changes to workbooks
- remove shared use of a workbook
- mark a book as “Final”
- use comments
- understand how to create secure passwords
- protect a worksheet, workbook structure, or the workbook file from unwanted changes

**Review Questions**

1. Which of the following is the correct workbook link to obtain the value in cell B12 in Sheet1 of the January Sales workbook?
   
   a. =’C:\Users\Me\January Sales’!B12
   
   b. =’C:\Users\Me\[Total Sales.xlsx]Sheet1’!B12
   
   c. =c:\Users\Me\[January Sales.xlsx]!B12
   
   d. =’C:\Users\Me\[January Sales.xlsx]Sheet1’!B12

2. Which of the following methods will protect worksheet cell C12 from unwanted changes?
   
   a. Enabling workbook protection
   
   b. Marking the workbook as final
   
   c. Enabling worksheet protection
   
   d. Any of these methods will protect cell C12 from unwanted changes.

3. Martin cannot add a new worksheet to the 2017 Sales workbook. Why not?
   
   a. Workbook protection is enabled
   
   b. The workbook has been marked as final
   
   c. Worksheet protection is enabled
   
   d. Martin is working on a domain-based network.

4. What is the maximum number of days for which Excel will maintain a change history log?
   
   a. 30 days
   
   b. 90 days
   
   c. 9,000 days
   
   d. 32,767 days
5. Which of the following methods can use you to enable worksheet protection?
   a. On the Home tab, in the Cells group, click Format, and click Protect Sheet
   b. On the Review tab, in the Changes group, click Protect Sheet
   c. On the File tab, click Info group, click Protect Workbook, and click Protect Current Sheet
   d. Any of these methods can be used to enable worksheet protection.

6. Where can you access the commands that will enable you to encrypt a workbook with a password?
   a. In the Save As dialog box
   b. On the Info tab in Backstage view
   c. On the Review tab in the Ribbon
   d. You can access the appropriate commands from any of the listed locations.

7. On which Ribbon tab can you access the command to consolidate data?
   a. On the Formulas tab
   b. On the Data tab
   c. On the Insert tab
   d. On the PowerPivot tab
Lesson Objectives

The objectives of this lesson are to use advanced features with charts and functions, perform What-If Analysis, and use structured references. Upon completion of this lesson, you should be able to:

- format a simple chart
- add a secondary vertical axis
- create and apply chart templates
- create and modify a chart trendline
- use financial functions
- nest functions inside other functions
- use AND, OR, and NOT functions
- use conditional summary functions
- perform What-If Analysis using the trial-and-error method
- use the Goal Seek tool
- use the Scenario Manager
- use the cell watch window
- use structured references

Advanced Chart Elements

Formatting a Simple Chart

The Excel charting feature is an extremely powerful tool that displays your data in a visual manner. The tabs of the Chart Tools contextual ribbon include a wide variety of options you can use to customize the appearance of your chart.
Because there are so many combinations to choose from, you may want to start with one of the selections under the Chart Layouts group in the Chart Tools/Design tab. Each of these options commonly uses a pre-selected mix of titles, legend, and other chart formatting settings.

### Learn to create and customize a simple chart

This exercise is a refresher on how to create a chart, move and resize it, and perform some common customizations.

1. Open the *Sales by Type and Year Simple Chart* file and save as *Sales by Type and Year Simple Chart - Student*.

2. Click any cell in the range A5:J14, then on the Insert tab, in the Charts group, click *Insert Column or Bar Chart*. Click *Clustered Column* in the 2-D Column section.

Move the chart so that it is below the data and make it bigger. Also add a chart title.

3. Click and drag the chart to a new location on the worksheet with the upper left corner in cell A17.

4. Click and drag the bottom right corner handle down to cell L40.

Switch the data so that the years are displayed on the horizontal X-axis.

5. Under Chart Tools, on the Design tab, in the Data group, click *Switch Row/Column*.

6. Select the *Chart Title* label, and change the label to: *Sales by Type and Year*.

The chart includes the Total row because it was directly below the rest of the data. It is skewing the chart by creating the very tall columns.

7. Under Chart Tools, on the Design tab, in the Data group, click *Select Data*.

8. In the Select Data Source dialog box, scroll down to the bottom of the Legend Entries (Series) list. Click anywhere on the Total line (except the check box on the left) and click *Remove*.

9. Click *OK* to close the dialog box.
Add a Secondary Vertical Axis

Objective 4.1.2

The Y-axis is always displayed on the left side of the chart. You can add an optional secondary Y-axis on the right side. The primary reason for having two axes is that the chart may display two types of data, each requiring its own scale. An example is a chart that shows data containing prices and sales volume. The sales volume may use the primary axis on the left with the scale reaching up to 1,000,000 units. The price data may use a secondary axis on the right with the scale reaching up to $10.00. If you displayed the price data using the primary axis, each data point will be very low compared to sales data, and therefore, not appear to be meaningful.

In many cases, you may want to configure the chart using two different chart types at the same time. This is known as a combo chart, in which some of the data series use one chart type (for example, a clustered column) while the rest of the data series use a different chart type (such as a line). You can select more than two chart types, but the chart will look too complex. You can also combine a combo chart with dual axes so that one chart type uses the primary axis, and the other chart type aligns to the secondary axis.

To change these chart type and secondary axis options, click **Change Chart Type** on the Design tab, in the Type group:
An alternative method of shifting a data series to the secondary axis is to right-click on one of the data points (or bars), and click **Format Data Series** in the shortcut menu. To switch to the other axis, select the Secondary Axis option from the Series Options in the Formatting Data Series pane. Note that you must select one of the data series – four resize handles will appear around each of the data bars in the series.
Learn to set up a secondary Y-axis

The Marketing Department manager for Tolano Adventures has been reviewing her sales data for the past several years, looking for a pattern. In this exercise, you will modify a chart as a combo chart and use a secondary Y-axis.

1. Open the Sales by Type and Year Secondary Axis file and save as Sales by Type and Year Secondary Axis - Student.

2. Click in a blank area of the chart to select it.

3. Under Chart Tools, on the Design tab, in the Data group, click Select Data.

4. In the Select Data Source dialog box, click Add.

5. In the Edit Series dialog box, click in the Series name text box, then click cell A16.

6. Delete the current contents of the Series values text box, select cells B16 to J16, then click OK.

7. In the Select Data Source dialog box, click OK to add this new row of data to the chart.

   This new data represents an expense, unlike the other data series which represent income. It would therefore make better sense to display it as a different chart type with its own separate Y-axis.

8. Under Chart Tools, on the Design tab, in the Type group, click Change Chart Type.

9. In the Change Chart Type dialog box, click the Combo chart type on the left.

   By changing to the combo chart type, Excel changes the second half of the data series to the line type.

10. Scroll down the Choose the chart type and axis for your data series list box, and ensure the Chart Type for every series is Clustered Column. The last one, Advertising and Promotions (the bottom one) should be Line.

11. Click the Secondary Axis check box for the Advertising and Promotions series, and click OK.
Notice that if you had left the new data row as another column bar, its significance would not have been obvious. By changing the data series to a line, you can now see a very distinct pattern – the Advertising and Promotions amount rises and falls in direct proportion to the sales of the various travel types.

12 Save and close the workbook.

Custom Chart Templates

Objective 4.1.3

Once you have created a chart with specific formatting in it, you may want to apply that same formatting to other charts, whether you have an existing chart or you are creating a new one. For example, you (or your organization) may want to apply the same color scheme or layout to all your charts in order to maintain a consistent look. This can be accomplished by saving an existing chart as a template.

To save a chart as a chart template, do the following:

1. Click in a blank area of the chart to select the chart. Any of the blank areas in the four corners of the chart would work best, to ensure the overall chart is selected.
2. Click **Save as Template**.
   The Save Chart Template dialog box will appear.
3. Enter a name for the chart template and click **Save**.
   Once created, the user-created chart templates appear in the Insert Chart dialog box in the Templates category.

When you create a chart template, you are saving the chart design, not the data. The design can then be applied to any series of data for which you create a new chart. For example, the following screen shows a new chart created from the selected data using the example user-defined chart template shown previously:
In this chart, the data comes from the current worksheet. The formatting of the data bars, plot area, and chart area are all encoded into the chart template and are easily applied to the new chart, saving you the time and effort of applying the formatting manually.

**Learn to save a chart as a template**

This exercise demonstrates how to save a chart as a template and how to use that template to create new charts.

1. Open the *Sales by Type and Year Create Template* file, and ensure the **Sheet1** worksheet is currently displayed.
2. Click a blank area of the chart to select it.
3. Under Chart Tools, on the Design tab, in the Chart Styles group, click **Style 5**.
4. Right-click a blank area of the chart and click **Format Chart Area** in the shortcut menu.
5. In the Format Chart Area pane, click the **Fill & Line** icon, then open the Fill options menu.
6. Click **Gradient fill**, select the **Light Green** color (Standard Colors, fifth from the left), and change the **Angle** to **45°**.
7. Close the Format Chart Area pane.
8. Right-click a blank area of the chart, and click **Save as Template**.
9. In the File name text box, type: *Sales and Advertising Combo* and click **Save**.
Notice that this chart template is saved to your private templates folder; that is, only you have access to this template from this location.

10 Close the Sales by Type and Year Create Template workbook and discard all changes.

Now open another workbook where you want to use this chart template.

11 Open the Advertising and Promotions Expense workbook.

12 Select any cell in the range A5:E12.

The only place where you can access your user-defined chart templates is from the Insert Chart dialog box.

13 On the Insert tab, in the Charts group, click the See All Charts dialog box launcher.

14 Click the All Charts tab, then click the Templates category at the left side of the Insert Charts dialog box.

15 Click the Sales and Advertising Combo icon in the My Templates section to select it, and click OK.

The chart is now displayed in the current worksheet, using the same formatting as the original chart.

16 Under Chart Tools, on the Design tab, in the Location group, click Move Chart.

17 Click New sheet and click OK.

Chart formatting that is not carried over in the chart template are the chart title (other than a default label), the data series selection, and the chart type for individual data series in a combo chart (such as the original chart used to create this template).

18 Select the chart title and replace the default text with: Advertising Expenses.

19 On the Design tab, in the Data group, click Switch Row/Column.

20 Click one of the bars in the Total data series (the tallest bars).

21 Under Chart Tools, on the Design tab, in the type group, click Change Chart Type.
In the Change Chart Type dialog box, scroll down to the bottom of the Choose the chart type and axis for your data series list box, change the Total data series to **Line**, and click the **Secondary Axis** check box. Click **OK**.

The completed chart should now look similar to the following example:

![Completed Chart Example](image)

Click the **Sheet1** tab again.

On the Insert tab, in the Charts group, click the **See All Charts** dialog box launcher.

Click the **All Charts** tab, and click the **Templates** category. Click the **Manage Templates** button.

An Explorer window now displays the folder where the template is located. From here you can copy or move it to another location, or delete it.

Close the Explorer window and click **Cancel** in the Insert Chart dialog box.

Save and close the workbook.
**Chart Trendline**

**Objective 4.1.1**

A common method of analyzing data is to create charts or graphs using the data in a worksheet. But charts will only display the data in a visual format; you must still interpret this visual information and try to find a pattern in it. Adding a trendline to a chart will not only help you analyze existing data, but also help you to predict future values.

A *trendline* is used to highlight a pattern or trend in the mass of data points that appear on a chart. Excel uses advanced mathematical techniques (such as regression analysis) to determine a best-fit line using the data available.

Before deciding to insert a trendline, you should:

- Include as many data points as possible in your chart. For example, creating a trendline using only two or three points will be very misleading. Trends are usually more accurate with 10 data points as a bare minimum; having at least 100 data points is preferred.
- Do not automatically accept the trendline as presented. The human brain can sometimes see a different pattern that the computer will not be able to identify.

Trendlines can easily be added to an existing chart when the chart is selected. Excel offers a choice of six types of trendlines based on different statistical calculation methods.
Lesson 5

Advanced Charts, Functions and What-If Analysis

Exponential
Create a trendline by using an exponential equation. This option is not available when your data includes negative or zero values.

Linear
Create a very simple trendline by using the linear equation \( y = mx + b \).

Logarithmic
Create a simple trendline by using the logarithmic equation \( y = \ln x + b \).

Polynomial
Create a trendline by using the polynomial equation. A maximum order number must also be specified.

Power
Create a trendline by using the power equation. This option is not available when your data includes negative or zero values.

Moving Average
Use a specific number of points (set by the Period option), average them, and use the average value as a point in the line.

A detailed description of these trendline types is beyond the scope of this courseware.

In addition to choosing the type of trendline, you can select an option to forecast (forward or backward) beyond the time period specified in your data. You can also change the color of the trendlines to make the chart more readable.

Learn to create and forecast a trendline in a chart

This exercise demonstrates how to create a trendline in a chart, and use it to create a forecast into the future.

1. Open the Sales by Type and Year Trendline workbook and save as Sales by Type and Year Trendline – Student.

2. Click a blank area of the chart to select it.

Add a trendlines on one of the data series to your chart.

3. Under the Chart Tools, on the Design tab, in the Chart Layouts group, click Add Chart Element, point at Trendline and click Linear.

4. In the Add Trendline dialog box, click American Vacation Packages, and click OK.
This line shows a declining trend in the sales between the beginning and end of the period being analyzed. The line is calculated using a sophisticated mathematical formula. However, the most recent years indicate an increasing trend. Perhaps a different trendline may be better suited to this data.

5 Right-click on the trendline, and click **Format Trendline**.

6 In the Format Trendline pane, click **Moving Average**, then change the number of **Periods** to 4.

Your chart should now appear similar to the following:

The trendline depicts a four-year moving average. For example, the first data point in the trendline is the average of the past four years from 2008 to 2011. The second data point is the average from 2009 to 2012. This trendline indicates that the sales for American vacation packages has overcome its low point and is now on an increasing trend.

7 Click each of the other trendline options and observe how the trendline changes in the chart.

The trendline can also be used to create a forecast of future values, based on the direction and rate of change in the current data.
Lesson 5
Advanced Charts, Functions and What-If Analysis

8 Click the **Polynomial** trendline option.

9 Scroll down the Format Trendline pane, click in the **Forecast Forward** entry box, replace the current value with: 5 and press the TAB key.

The chart has now widened to add another 5 years to the X-axis. Because the data table does not have any numbers for those additional years, the data labels do not appear along that axis.

10 Increase the **Polynomial Order** value to 3.

Notice that the scale on the primary Y-axis has changed to accommodate the new trendline range, jumping up to 1,000,000 which indicates a very large projected sales increase over the next 5 years.

11 Click in a blank area of the chart to de-select the trendline.

Add another trendline using a different data series in the chart.

12 Under the Chart Tools, on the Design tab, in the Chart Layouts group, click **Add Chart Element**, hover over Trendline and click **Exponential**.

13 In the Add Trendline dialog box, click **Cruises**, and click **OK**.

14 Click the new blue trendline (cruises) to select it.

15 In the Format Trendline pane, ensure you are viewing the Trendline Options pane, then click the **Forecast Forward** text box, replace the default value to 5, and press the TAB key.

The chart now shows a green trendline indicating sales of American vacation packages will approach $1,000,000 by the year 2024, while the blue trendline indicates sales of cruises will drift down to about $180,000 in that same period.

Now assume that you are not satisfied with these forecasts, and that the two trendlines need adjustments.

16 With the blue trendline still selected, click **Polynomial**, and increase the Order to 3.

17 Click the green trendline (American vacation packages), and click **Exponential** in the Format Trendline pane.
The forecast has now switched drastically: the green trendline indicates sales of American vacation packages will drift down to about $320,000 by the year 2024, while the blue trendline indicates sales of cruises will explode up to about $440,000.

This exercise demonstrates that the statistical analysis tools in Excel are powerful, but must be used correctly by knowledgeable analysts. Otherwise people will make incorrect decisions, which could lead to disastrous results.

18 Save and close the workbook.

Using Advanced Functions and Features

Financial Functions

Objective 3.4.5

Excel includes a rich variety of financial functions. These financial calculations have some very complex mathematics underneath, so they are useful in many applications. They are particularly useful when using worksheets that require calculations of loan payments, annuities, and related calculations. Some of the more commonly-used financial functions include:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PMT</td>
<td>Calculate the payment required for a given principal, interest rate, and number of time periods.</td>
</tr>
<tr>
<td>NPV</td>
<td>Calculate the Net Present Value of a stream of cash flows.</td>
</tr>
<tr>
<td>PV</td>
<td>Calculate the Present Value of an ordinary annuity or series of payments.</td>
</tr>
<tr>
<td>FV</td>
<td>Calculate the Future Value of an ordinary annuity or series of payments.</td>
</tr>
</tbody>
</table>

As an example, the PMT function requires that you specify the principal (amount borrowed), the interest rate, and the term (repayment period). The function also includes two optional arguments: ending balance (termination/buy out) and type (when payments will be made; enter “0” or leave this blank for the end of the month or enter “1” for the beginning of the month). The format is:

=PMT(interest,term,principal,ending balance,type)

When you enter the values for interest and term, ensure that you express them in the same time units. For example, if you want to find the monthly loan payment, you must ensure that both interest and term are expressed in months. If you are given an annual interest rate, you must divide that value by 12 to calculate the monthly interest rate. If the term is also expressed in years, then you must also multiply that value by 12 to calculate the total number of months (which is also the number of payments to be made).

For example, to calculate the monthly payment for a loan with an annual interest rate of 6% and a term life of five years, the arguments used in the PMT function are:

- interest rate = 6% / 12 = 0.5% per month
- term = 5 x 12 = 60 months

Note: The PMT function cannot be used to correctly calculate mortgage payments in some countries, such as Canada, where interest on residential mortgages is calculated semi-annually, not in advance. As a result, the monthly payment amount is lower because the interest is not compounded monthly. The PMT function does correctly calculate the mortgage payments in other countries where interest is compounded monthly, such as the United States.
In general, Excel calculates the Total per Term by using the number of monthly payments multiplied by the amount of the monthly payment. The Total Interest paid is based on the Total per Term minus the amount of the Loan.

### Learn to use the PMT function

This exercise demonstrates the use of the PMT function on a loan used to pay for vacation travel.

A loan analysis table enables you to see the amount of principal and interest that is paid on a loan monthly or yearly. Once completed, the spreadsheet can be used to quickly determine the payments required for any loan amount, interest rate, and term.

1. Open the *Monthly Payments* workbook and save as *Monthly Payments - Student*.
2. Use the following data for the loan payment calculation:

   - **Amount of Loan**: 5,000
   - **Interest Rate**: 0.06
   - **Term of Loan**: 12
   - **Ending Balance**: 0
   - **Payment Type**: 0
   - **Payment/Month**: \( \text{=PMT}(B2/12, B3, -B1, B4, B5) \)
   - **Total/Term**: \( B7*B3 \)
   - **Total Interest**: \( B8-B1 \)

   Note that the interest rate used here is for a full year, but the term is in months. The interest rate must be converted into a monthly rate. The loan will be fully paid off at the end of the term, so the ending balance will be zero.

   **Note:** Because the Ending Balance and Payment Type values are both zero, the last two arguments of the function could be omitted in this case.

3. In cell **B13**, enter: \( =B1 \) to represent the initial loan amount.
4. In cell **C13**, enter: \( =$B$7 \) as the monthly payment amount.
5. In cell **D13**, enter: \( =B13*$B$2/12 \) to calculate amount of interest paid for the month.

   This will show the amount of interest to be paid in the first month. You will be copying this formula, so you will have to make the entry in the Interest Rate cell into an absolute cell reference.

6. In cell **E13**, enter: \( =C13-D13 \) to calculate the amount of the loan paid for this month by subtracting the interest paid from the monthly payment.

7. In cell **F13**, type: \( =B13-E13 \) to calculate the remaining balance left to be paid by subtracting the amount paid towards the loan from the beginning balance of the loan for the current month.

Complete the table by following these steps.

8. In cell **B14**, type: \( =F13 \) to represent the Ending Balance of the first month.
9. Copy the range of cells C13:F13 to cells **C14:F14**.
10. Copy the range of cells B14:F14 to cells **B15:F24**.
The ending balance in cell F24 (after the last payment is made) is $0.00, showing that the loan has been completely paid off.

Now perform some financial calculations that are often used in investment analysis situations.

11 Select cell B26, and enter: \( =PV\left(\frac{B2}{12}, B3, -B7, B4, B5\right) \)

12 Select cell B27, and enter: \( =FV\left(\frac{B2}{12}, B3, -B7, 0, B5\right) \)

Because the IRR function requires the initial principal to be included in the range of cells as a negative number, the loan amount must be added at the top of the list of payments.

13 Select cell C12, and enter: -5000

14 Select cell B28, and enter: \( =IRR(C12:C24) \)

The worksheet should now appear similar to the following:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Amount of Loan</td>
<td>$5,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Annual Interest Rate</td>
<td>6.0%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Term (months) - NPER</td>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Ending Balance</td>
<td>$0.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Payment Type</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Payment/Month</td>
<td>$430.33</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Total Payments</td>
<td>$5,183.99</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Total Interest</td>
<td>$183.99</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Month #</td>
<td>Beginning Principal</td>
<td>Monthly Payment</td>
<td>Interest Paid</td>
<td>Principal Paid</td>
<td>Ending Balance</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td>-5,000.00</td>
<td>$430.33</td>
<td>$25.00</td>
<td>$405.33</td>
<td>$4,594.67</td>
</tr>
<tr>
<td>12</td>
<td>1</td>
<td>$5,000.00</td>
<td>$430.33</td>
<td>$25.00</td>
<td>$405.33</td>
<td>$4,594.67</td>
</tr>
<tr>
<td>13</td>
<td>2</td>
<td>$4,574.67</td>
<td>$430.33</td>
<td>$22.97</td>
<td>$407.36</td>
<td>$4,187.31</td>
</tr>
<tr>
<td>14</td>
<td>3</td>
<td>$4,148.11</td>
<td>$430.33</td>
<td>$20.94</td>
<td>$409.39</td>
<td>$3,777.91</td>
</tr>
<tr>
<td>15</td>
<td>4</td>
<td>$3,722.13</td>
<td>$430.33</td>
<td>$19.91</td>
<td>$411.44</td>
<td>$3,366.47</td>
</tr>
<tr>
<td>16</td>
<td>5</td>
<td>$3,356.47</td>
<td>$430.33</td>
<td>$18.88</td>
<td>$413.45</td>
<td>$2,952.97</td>
</tr>
<tr>
<td>17</td>
<td>6</td>
<td>$3,000.35</td>
<td>$430.33</td>
<td>$17.86</td>
<td>$415.49</td>
<td>$2,537.40</td>
</tr>
<tr>
<td>18</td>
<td>7</td>
<td>$2,642.07</td>
<td>$430.33</td>
<td>$16.84</td>
<td>$417.54</td>
<td>$2,121.76</td>
</tr>
<tr>
<td>19</td>
<td>8</td>
<td>$2,298.96</td>
<td>$430.33</td>
<td>$15.82</td>
<td>$419.69</td>
<td>$1,700.03</td>
</tr>
<tr>
<td>20</td>
<td>9</td>
<td>$1,956.07</td>
<td>$430.33</td>
<td>$14.81</td>
<td>$421.85</td>
<td>$1,278.14</td>
</tr>
<tr>
<td>21</td>
<td>10</td>
<td>$1,615.76</td>
<td>$430.33</td>
<td>$13.80</td>
<td>$423.51</td>
<td>$854.25</td>
</tr>
<tr>
<td>22</td>
<td>11</td>
<td>$1,278.14</td>
<td>$430.33</td>
<td>$12.80</td>
<td>$425.17</td>
<td>$428.19</td>
</tr>
<tr>
<td>23</td>
<td>12</td>
<td>$854.25</td>
<td>$430.33</td>
<td>$11.80</td>
<td>$426.53</td>
<td>$428.19</td>
</tr>
<tr>
<td>24</td>
<td>13</td>
<td>$428.19</td>
<td>$430.33</td>
<td>$10.80</td>
<td>$427.99</td>
<td>$428.19</td>
</tr>
<tr>
<td>25</td>
<td>14</td>
<td>$428.19</td>
<td>$430.33</td>
<td>$9.80</td>
<td>$428.39</td>
<td>$428.19</td>
</tr>
</tbody>
</table>

15 Save and close the workbook.

**Nesting Functions**

**Objective 3.1.2**

Excel functions are very flexible because they allow you to nest (or embed) one function inside another one. This is a very useful feature because Excel functions are designed to perform only one calculation. For example, the formula \( =MID(A1,6,10) \) will extract ten characters from the text string in cell A1, starting from character #6. If cell A1 contained the text string “Adam Smith”, then this formula will return the second word “Smith”. However, if the cell was changed to “Joe Zhukov”, the result will be “hukov”. The FIND function can be used to automatically adjust to different text:

\( =MID(A1,FIND(" ",A1)+1,10) \)
This FIND function will search the text string for the location of the blank space and return it to the MID function to indicate where to begin extracting characters. The “+1” is used to start at the next character to the right of that blank space in the text string.

You are not limited to nesting or embedding only one function inside another. You can nest up to 64 functions.

When you need to nest logical functions together, be sure to build them slowly, one function at a time. Nested functions are complex: the arguments, commas, and brackets must be in the right place to prevent them from being rejected by Excel, or from returning incorrect results.

Another function commonly used for nesting is IF. For example, a simple IF function will evaluate one logical test, and then return either one value or another value.

=IF(A1=10,"text A","text B")

This simple IF function will not permit you to choose from three different values. The logical test will return one of only two possible results: TRUE or FALSE. To work around this limitation, you can nest functions. An example of a nested IF function would look as follows:


In this example, the following values will be displayed when the conditions are met:

<table>
<thead>
<tr>
<th>If A1 contains</th>
<th>Then this will display</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>text A</td>
</tr>
<tr>
<td>20</td>
<td>text B</td>
</tr>
<tr>
<td>Any other value</td>
<td>text C</td>
</tr>
</tbody>
</table>

### Learn to nest a function

This exercise demonstrates how to nest a function inside another function.

1. Open the Nesting Functions workbook and save as Nesting Functions - Student. If necessary, click the FIND worksheet tab to display that worksheet.

   ![Worksheet Example](image)

   In this worksheet you will enter text formulas to extract the first names from column A and put them in column B, then extract the family names from column A and put them in column C. Enter the first set of formulas for row 4.

2. Enter the following formulas:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Formulas</th>
</tr>
</thead>
<tbody>
<tr>
<td>B4</td>
<td>=MID(A4,9,5)</td>
</tr>
<tr>
<td>C4</td>
<td>=LEFT(A4,6)</td>
</tr>
</tbody>
</table>

   ![Formulas Example](image)
Using these formulas, the first person’s name is correctly separated into the first and last name components. Copy these same formulas into the remaining rows to extract the first and last names for the remaining individuals.

3 Copy the formulas in cells B4:C4 down to the cell range B5:C12.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tolano Adventures</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Travel Directors</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gibson, Jamie</td>
<td>Jamie</td>
<td>Gibson</td>
</tr>
<tr>
<td>McSweeney, Andrew</td>
<td>An</td>
<td>McSweeney</td>
</tr>
<tr>
<td>Cowell, Madison</td>
<td>Madison</td>
<td>Cowell</td>
</tr>
<tr>
<td>Klassen, Nick</td>
<td>Nick</td>
<td>Klasse</td>
</tr>
<tr>
<td>Gorski, Curtis</td>
<td>Curtis</td>
<td>Gorski</td>
</tr>
<tr>
<td>Jang, Lawrence</td>
<td>Wrenc</td>
<td>Jang</td>
</tr>
<tr>
<td>Akira, Christie</td>
<td>Hrist</td>
<td>Akira</td>
</tr>
<tr>
<td>Yamoto, Kanda</td>
<td>Kanda</td>
<td>Yamoto</td>
</tr>
<tr>
<td>Belanger, Toby</td>
<td>Tob</td>
<td>Belanger</td>
</tr>
</tbody>
</table>

The results demonstrate that you will need to adjust the parameters of almost every formula to correctly extract the names. The formulas will need to be changed again if any of the names in column A is changed afterwards. However, there is a better way to perform this same task, by using nested functions.

By looking at the names in column A, you will see that a comma always separates the first name from the last name. Change the formulas in cells B4 and C4 to calculate the position of the comma in cell A4.

4 Select cell B4 and enter the formula: =FIND(",",A4)

5 Enter the same formula into cell C4 (but do not copy it from cell B4): =FIND(",",A4)

Both formulas yield the exact same results, as expected.

When you look at the name in cell A4, you can see the last name is to the left of the comma. You can then use the LEFT function to extract the last name from cell A4. The LEFT function requires two parameters: the original text string, and the number of characters to extract. The second parameter will be calculated for you by the FIND function, which you had just entered in step 5.

6 Select cell C4 again, and modify the formula to: =LEFT(A4,FIND(",",A4))

The results demonstrate that the FIND function returns the position of the comma, which follows immediately after the last name. To extract the last name without the comma, simply subtract one from the results of the FIND function.

7 Select cell C4 again, and modify the formula to: =LEFT(A4,FIND(",",A4) - 1)

Use the same technique to extract the first name, which is located to the right of the comma, using the MID function. The MID function requires three parameters: the original text string, the starting position, and the number of characters. The starting position can be calculated again using the FIND function.

Because the first name is to the right of the comma, then the number of characters to extract is simply the number of characters to the right of the comma. This can be calculated by nesting yet another function to calculate the total length of the text string and subtract the length of the last name.
However, the MID function is very forgiving; if you use a number that is greater than the number of characters available, it will still only return what is there and will not add blank spaces at the end. You can therefore use any number of your choice, but it must be big enough to extract enough characters. For this exercise, you will use a length of 20 characters, which you can adjust if necessary.

8 Select cell \textbf{B4}, and modify the formula to: \texttt{=MID(A4,FIND(","A4),20)}

Like the last name, the FIND function includes the comma in its calculation. Add 2 to the result to skip over the comma and the blank space after it.

9 Select cell \textbf{B4} again, and modify the formula to: \texttt{=MID(A4,FIND(","A4)+2,20)}

10 Copy the formulas in cells B4:C4 down to the cell range B5:C12.

The formula is designed to be flexible to handle any name changes, as long as the comma is in the correct position.

11 Select cell \textbf{A4} and enter: \texttt{Nye, Jim}

\begin{table}[h]
\centering
\begin{tabular}{ccc}
\hline
\textbf{A} & \textbf{B} & \textbf{C} \\
\hline
1 & Tolano Adventures & \hline
2 & Travel Directors & \hline
3 & \hline
4 & Nye, Jim & Jim & Nye \\
5 & McSweeney, Andrew & Andrew & McSweeney \\
6 & Cowell, Madison & Madison & Cowell \\
7 & Klassen, Nick & Nick & Klassen \\
8 & Gorski, Curtis & Curtis & Gorski \\
9 & Jang, Lawrence & Lawrence & Jang \\
10 & Akira, Christie & Christie & Akira \\
11 & Yamoto, Kanda & Kanda & Yamoto \\
12 & Belanger, Toby & Toby & Belanger \\
\hline
\end{tabular}
\end{table}

\textbf{Note:} The Excel Flash Fill feature will also perform this same task for you without requiring the use of any formulas. After you enter the first and last name into cells B4 and C4, Excel will detect the pattern and offer to fill in the rest of columns B and C for you.

The IF function is also frequently nested within other IF functions.

12 Click the \textbf{IF} worksheet tab.

This worksheet will be used to calculate the number of corporate rewards points to be given to frequent travelers:

\begin{table}[h]
\centering
\begin{tabular}{cc}
\hline
\textbf{Range} & \textbf{Number of Points} \\
\hline
Less than 5 & 1 \\
5 to 9 & 3 \\
10 to 19 & 6 \\
20 to 29 & 10 \\
30 and up & 20 \\
\hline
\end{tabular}
\end{table}

A good way of approaching this problem is to start with a very simple formula and then add to it in pieces.

13 Select cell \textbf{F5}, and enter: \texttt{=IF(D5<5,1,3)}

14 Copy this formula down to the cell range \textbf{F6:F29}.
You can see that every customer has either 1 or 3 points assigned to them. The very maximum that a customer can get is 3 points, even though most of them should be getting more. Modify this formula so that a second IF function is nested inside the first one. The full formula will be: 
=IF(D5<5,1,IF(D5<10,3,6)).

15 Select cell F5 again, press F2, delete the 3 and replace it with: IF(D5<10,3,6)

16 Copy this formula down to the cell range F6:F29.

Notice that the second IF function nested inside the other IF function uses the condition D5<10, even though the 3 points applies only to customers with 5 to 9 bookings. The condition should therefore be (D5>4) AND (D5<10). It turns out that the extra logic test (D5>4) is unnecessary because the nested function is performed only if the first IF condition (D5<5) results in a FALSE value.

The points value are now getting closer to what they should be. The customers with less than 10 bookings are correctly getting 1 or 3 points, but many of the remaining customers should be getting more than 6 points. The next version of the formula will be: =IF(D5<5,1,IF(D5<10,3,IF(D5<20,6,10)))

17 Select cell F5 again, press F2, delete the 6 and replace it with: IF(D5<20,6,10)

18 Copy this formula down to the cell range F6:F29.

One more nested formula needs to be added to create the final formula:
=IF(D5<5,1,IF(D5<10,3,IF(D5<20,6,IF(D5<30,10,20))))). As you can see, this formula can appear overwhelming when trying to enter it all at once.

19 Select cell F5 again, press F2, delete the final 10 and replace it with: IF(D5<30,10,20)

20 Copy this formula down to the cell range F6:F29.

21 Look at each of the points values in column F to verify that they are correctly calculated.

**Note:** The LOOKUP or VLOOKUP functions will also produce the same results.

22 Save and close the workbook.
Conditional Logic Functions

Objective 3.1.1

Most Excel functions simply perform their calculations and display the results in the cells in which they are located. Conditional logic functions are useful in situations where you want to perform one of two different calculations, depending which value is in one or more cells other than the ones in which the logical functions are located.

When you use the IF function, you are permitted to have only one logical test that results in a TRUE or FALSE value. If you need to perform two or more different logic tests, then you must either nest the requisite number of IF functions inside each other, or use an AND or OR function.

**AND**
The AND function allows multiple logical tests to be performed, and all of them are combined to return a single TRUE or FALSE value. The AND function returns a TRUE value only if all of the logical tests are TRUE. It returns a FALSE value if any of the logical tests result in a FALSE value.

\[
\text{AND(logical test 1, logical test 2, ...)}
\]

You can have up to 255 logical tests in an AND function.

**NOT**
This function returns the logical opposite value of a logical result. That is, a TRUE value is reversed to a FALSE, and a FALSE is reversed to a TRUE.

\[
\text{NOT(logical test)}
\]

You can enter only one logical value in this function.

**OR**
Like the AND function, the OR function evaluates multiple logical tests to return a single TRUE or FALSE value. Unlike the AND function, this function returns a TRUE value if any of the logical tests are TRUE. It returns a FALSE value only if all of the logical tests result in a FALSE value.

\[
\text{OR(logical 1, logical 2,...)}
\]

You can have up to 255 logical tests in an OR function.

---

Learn to use the **AND, NOT, and OR functions**

This exercise is designed to demonstrate the use of the AND, NOT, and OR functions.

1. Open the **AND OR Functions** workbook and save as **AND OR Functions - Student**.

Enter a formula to award the Gold designation if a customer had more than 25 bookings and spent more than $75,000 in travel this year.

2. Select cell F5, and enter: `=IF(AND(D5>25,E5>75000),"Gold","")`

3. Copy this formula down to the cell range F6:F29.

Using this formula, only two customers have qualified for the gold membership. So try a different formula to see how many customers would qualify for the Gold designation if a customer had more than 25 bookings or spent more than $75,000 in travel this year.

4. Select cell G5, and enter: `=IF(OR(D5>25,E5>75000),"Gold","")`

5. Copy this formula down to the cell range G6:G29.
Try a third alternative formula to label any customer who has spent $75,000 or less in travel this year with a Bronze designation. The formula can therefore be \( =\text{IF}(E5\leq 75000, \text{"Bronze"}, \text{""}) \). However, you can also reverse the logical test using the NOT function.

6. Select cell H5, and enter: \( =\text{IF}(\text{NOT}(E5>75000), \text{"Bronze"}, \text{""}) \)

7. Copy this formula down to the cell range H6:H29.

The completed worksheet should appear similar to the following:

8. Save and close the workbook.

Conditional Summary Functions

Objective 3.1.3

The conditional summary versions of the commonly used summary functions AVERAGE, COUNT, and SUM are very powerful extensions of the base functions. Although the function name has an IF in it, the selection capability works more like filtering: for the given range of cells, Excel first selects only the rows that meet the criteria and applies the summary function on those rows. The remaining rows are ignored.

**AVERAGEIF**

Calculate the average value of a range of cells in which the criterion value is met. The format of this function is as follows:

\[
\text{AVERAGEIF(criteria\_range, criterion\_value, average\_range)}
\]

The average range is optional. If it is not specified, the criteria range is assumed to be the average range.

**COUNTIF**

Count the number of cells that contain a non-blank value in a range of cells where the criterion value is met.

\[
\text{COUNTIF(criteria\_range, criterion\_value)}
\]
SUMIF
Calculate the sum total of all cells containing a numeric value in a range of cells where the criterion value is met.

SUMIF(criteria_range, criterion_value, sum_range)
The sum range is optional. If it is not specified, the criteria range is assumed to be the sum range.

An example of a conditional summary function is:

=SUMIF(D4:D207, "Visa", F4:F207)

In this function, the criteria range is D4 to D207, the sum range is F4 to F207, and the criterion value is "Visa"; therefore, Excel will examine each of the cells in the range D4 to D207. If the cell contains the value "Visa," the corresponding numeric value in the cell range F4 to F207 will be included in the sum total.

Note that the SUMIF is very different from the more common SUM function. With SUM, the numeric value in all cells in the sum range are added to the sum total. With SUMIF, the cells are added only if the criterion value is met.

These three conditional summary functions permit you to perform only one criteria test. If you need to perform more than one criteria test at the same time, then a different version is needed.

AVERAGEIFS
Calculate the average value of a range of cells in which the multiple criteria are met. The format of this function is as follows:

AVERAGEIFS(average_range, criteria_range 1, criteria 1, criteria_range 2, criteria 2...)
The average range is mandatory.

COUNTIFS
Count the number of cells that contains a non-blank value in a range of cells where the criteria are met.

COUNTIFS(range 1, criteria 1, range 2, criteria 2...)

SUMIFS
Calculate the sum total of all cells containing a numeric value in a range of cells where the criteria are met.

SUMIFS(sum_range, criteria_range 1, criteria 1, criteria_range 2, criteria 2...)
The sum range is mandatory.

An example of this kind of conditional summary function is:

=SUMIFS(F4:F207, D4:D207, "Visa", F4:F207, ">100")

In this function, the sum range is F4 to F207, the first criteria range is D4 to D207, and its corresponding criterion value is "Visa"; the second criteria range is F4 to F207 and its corresponding criterion test is >100. This means that a value in the cell range F4 to F207 is included in the sum total only if both criteria tests are evaluated as true. For example, the value in cell F4 is included if D4 contains the word "Visa" and F4 contains a value that is greater than 100. If D4 does not contain the word "Visa," or if F4 is less than or equal to 100, or both, then the value in F4 is not included.

Because these functions have multiple selection criteria, the sequence of the arguments is different from the single criterion versions of these functions. The different sequence is necessary to allow multiple selection criteria to be entered as arguments.
Learn to use conditional summary functions

This exercise demonstrates the use of conditional summary functions.

1. Open the Summary Functions workbook and save as Summary Functions - Student.

Enter the first set of conditional summary formulas that will calculate statistics for all customers who spent over $50,000. These formulas are straightforward because they only have one criterion: sales in column E is greater than $50,000.

2. Enter the following formulas into cells:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>I5</td>
<td>=COUNTIF(E5:E29, ”&gt;50000”)</td>
</tr>
<tr>
<td>I6</td>
<td>=SUMIF(E5:E29, ”&gt;50000”)</td>
</tr>
<tr>
<td>I7</td>
<td>=AVERAGEIF(E5:E29, ”&gt;50000”)</td>
</tr>
</tbody>
</table>

Notice that the SUMIF and AVERAGEIF conditional formulas used here perform their calculations on the same column in which the selection criteria are applied. In other words, these formulas select only those cells that meet the stated criteria and then perform the COUNT, SUM, and AVERAGE on only those cells. The significance of this will become clearer as you examine the next sets of conditional formulas.

Suppose these statistics are similar to the first set, but the criterion is that the customer is a Gold customer. However, a Gold customer may have spent less than $50,000 this year, such as customer #7 and #11. Other customers have spent more than $50,000, but are not Gold customers, such as customer #4 and #12.

3. Enter the following formulas into cells:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>I9</td>
<td>=COUNTIF(F5:F29, ”Gold”)</td>
</tr>
<tr>
<td>I10</td>
<td>=SUMIF(F5:F29, ”Gold”, E5:E29)</td>
</tr>
<tr>
<td>I11</td>
<td>=AVERAGEIF(F5:F29, ”Gold”, E5:E29)</td>
</tr>
</tbody>
</table>

These are the same conditional formulas as the first set, except that an additional argument has been added to the SUMIF and AVERAGEIF. In this variation, the criteria are applied to the cells in column F (”Gold”), but the SUM and AVERAGE are applied to the corresponding cells in column E, which is where the sales amounts are located. The average value can be verified by dividing the sum value into the count value. In contrast, the first set of conditional summary formulas calculated the statistics on the same column E on which you are applying the selection criteria.

These formulas are even more complex because they have two criteria: the sale must be with a Gold customer and the sales amount must be greater than $50,000. These functions are different than the ones used in the first and second set of formulas.

4. Enter the following conditional summary formulas into cells:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>I13</td>
<td>=COUNTIFS(F5:F29, ”Gold”, E5:E29, ”&gt;50000”)</td>
</tr>
<tr>
<td>I14</td>
<td>=SUMIFS(E5:E29, F5:F29, ”Gold”, E5:E29, ”&gt;50000”)</td>
</tr>
<tr>
<td>I15</td>
<td>=AVERAGEIFS(E5:E29, F5:F29, ”Gold”, E5:E29, ”&gt;50000”)</td>
</tr>
</tbody>
</table>

Notice that the sequence of the parameters for the sum and average formulas is different in the single-criterion and multiple-criteria versions.
Also notice that only five customers met the selection criteria. This is because not all Gold customers spent more than $50,000, and not all customers who spent more than $50,000 are Gold customers.

The worksheet should now appear as follows:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Tolano Adventures</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Corporate Gold Membership</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Customer Last Name</td>
<td>First Name</td>
<td>Bookings</td>
<td>Spending</td>
<td>Type</td>
<td>Sales Over $50,000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>Święciszynski</td>
<td>Pawel</td>
<td>32</td>
<td>$136,763.20</td>
<td>Gold</td>
<td>$100,000</td>
<td>7</td>
</tr>
<tr>
<td>6</td>
<td>2</td>
<td>Wylie</td>
<td>Jack</td>
<td>21</td>
<td>$76,552.98</td>
<td>Gold</td>
<td>$100,000</td>
<td>7</td>
</tr>
<tr>
<td>7</td>
<td>3</td>
<td>Lownachie</td>
<td>Sharin</td>
<td>1</td>
<td>$5,112.89</td>
<td></td>
<td>$50,000</td>
<td>7</td>
</tr>
<tr>
<td>8</td>
<td>4</td>
<td>Whitcomb</td>
<td>Ada</td>
<td>15</td>
<td>$74,896.85</td>
<td></td>
<td>$50,000</td>
<td>7</td>
</tr>
<tr>
<td>9</td>
<td>5</td>
<td>Fletcher</td>
<td>Paul</td>
<td>24</td>
<td>$49,000.48</td>
<td>Gold Member Sales</td>
<td></td>
<td>7</td>
</tr>
<tr>
<td>10</td>
<td>6</td>
<td>Strohmeyer</td>
<td>Allison</td>
<td>2</td>
<td>$4,744.26</td>
<td>Total Gold Member Sales</td>
<td>$536,481.29</td>
<td>5</td>
</tr>
<tr>
<td>11</td>
<td>7</td>
<td>Sijje</td>
<td>Dai</td>
<td>40</td>
<td>$42,977.20</td>
<td>Gold Member Sales</td>
<td>$76,483.04</td>
<td>5</td>
</tr>
<tr>
<td>12</td>
<td>8</td>
<td>Angelini</td>
<td>Sara</td>
<td>5</td>
<td>$26,559.05</td>
<td></td>
<td>$50,000</td>
<td>5</td>
</tr>
<tr>
<td>13</td>
<td>9</td>
<td>Ruegle</td>
<td>Patrick</td>
<td>4</td>
<td>$16,117.40</td>
<td>Gold Members Over $50,000</td>
<td>$91,403.01</td>
<td>5</td>
</tr>
<tr>
<td>14</td>
<td>11</td>
<td>Haasma</td>
<td>Ben</td>
<td>28</td>
<td>$16,699.04</td>
<td>Total Gold Members Over $60,000</td>
<td>$457,015.05</td>
<td>5</td>
</tr>
<tr>
<td>15</td>
<td>12</td>
<td>Frankel</td>
<td>Valerie</td>
<td>14</td>
<td>$63,088.62</td>
<td>Avg Gold Members Over $50,000</td>
<td>$91,403.01</td>
<td>5</td>
</tr>
<tr>
<td>16</td>
<td>13</td>
<td>Abdi</td>
<td>Zehar</td>
<td>17</td>
<td>$18,133.71</td>
<td></td>
<td>$50,000</td>
<td>5</td>
</tr>
<tr>
<td>17</td>
<td>14</td>
<td>Aubert</td>
<td>Rosemary</td>
<td>41</td>
<td>$91,750.62</td>
<td>Gold</td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>18</td>
<td>15</td>
<td>Pearson</td>
<td>Ryan</td>
<td>11</td>
<td>$35,829.94</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>19</td>
<td>16</td>
<td>Huso</td>
<td>Anthony</td>
<td>19</td>
<td>$25,205.66</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>20</td>
<td>17</td>
<td>Pai</td>
<td>Pal Kit</td>
<td>9</td>
<td>$46,949.67</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>21</td>
<td>18</td>
<td>Jablonski</td>
<td>Douglas</td>
<td>22</td>
<td>$76,687.82</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>22</td>
<td>19</td>
<td>Ramirez</td>
<td>Misa</td>
<td>4</td>
<td>$6,914.72</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>23</td>
<td>20</td>
<td>Robothan</td>
<td>Maya</td>
<td>8</td>
<td>$23,087.52</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>24</td>
<td>21</td>
<td>Karmazin</td>
<td>Panos</td>
<td>8</td>
<td>$33,186.48</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>25</td>
<td>22</td>
<td>Kylgaard</td>
<td>JD</td>
<td>21</td>
<td>$72,200.43</td>
<td>Gold</td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>26</td>
<td>23</td>
<td>Singh</td>
<td>Khushwant</td>
<td>24</td>
<td>$13,679.88</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>27</td>
<td>24</td>
<td>Unaweaver</td>
<td>Jeannie</td>
<td>12</td>
<td>$32,151.36</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>28</td>
<td>25</td>
<td>Popescu</td>
<td>Petra</td>
<td>24</td>
<td>$48,062.64</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td>29</td>
<td>26</td>
<td>D'Hermitz</td>
<td>Francois</td>
<td>12</td>
<td>$26,982.80</td>
<td></td>
<td></td>
<td>5</td>
</tr>
</tbody>
</table>

5  Save and close the workbook.

**What-If Analysis**

**Manual What-If Analysis**

One of the most common applications for spreadsheets is a *What-If Analysis*, which gives you the ability to pursue an almost endless series of trial-and-error scenarios using a variety of numbers and formulas. When spreadsheet programs were introduced, they almost instantly rendered the traditional manual method obsolete—even with the help of handheld calculators—because spreadsheets could recalculate a large number of formulas and display the results simultaneously. This capability saved a tremendous amount of manual work and virtually eliminated calculation errors.

**Learn to use a What-If Analysis**

This exercise will demonstrate the use of a What-If Analysis using the trial-and-error method to perform a simple break-even calculation.

Suppose your company, Tolano Adventures, is investigating the possibility of launching a new company that will provide whale-watching tours to its own customers as well as other travel agencies’ customers. An important task is researching the financial viability of this new venture.

1  Open the *Whale Watching What If* workbook and save as *Whale Watching What If - Student*. 
The cost of renting the boats is estimated to be about 25% of revenues, and fuel is another 35%. The remaining costs are fixed monthly expenses for salaries, a small office near the pier, and various boat-related expenses.

This worksheet does not use the traditional income-statement format that is used for financial reporting purposes. The format used here is designed for profitability or CVP (cost-volume-profit) analysis. The variable elements—including revenues and costs—are placed together in the upper part of the worksheet; the fixed elements are placed together in the lower part.

2 In the following cells, enter the specified formulas:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>B4</td>
<td>=B3*0.25</td>
</tr>
<tr>
<td>B5</td>
<td>=B3*0.35</td>
</tr>
<tr>
<td>B6</td>
<td>=B3-B4-B5</td>
</tr>
<tr>
<td>B14</td>
<td>=SUM(B8:B13)</td>
</tr>
<tr>
<td>B16</td>
<td>=B6-B14</td>
</tr>
</tbody>
</table>

With a monthly revenue of $15,000, this worksheet shows a loss of $2,250 a month.

3 Select cell B3 and enter: 20,000.

Excel has quickly calculated a new net income of -$250, which clearly shows that the company will not break even at this revenue level. The term break-even point means the point at which total revenues match total expenses, leaving a net income of $0. Any revenue level above that will result in a profit and any revenue level below that will result in a loss.

4 Repeat step 3 with other revenue values to try to achieve a net income of $0. Keep track of how many guesses you had to make.

You will have to make many guesses to achieve a break-even point. Each of your guesses will be too high or too low until you narrow your guesses down to the right number.

5 Once you have a net income as close as possible to $0, save and close the workbook.

Using the Goal Seek Tool

Objective 3.4.3

When you create a worksheet, you enter formulas into cells and the results of your calculations are displayed in those same cells. This works well when you know all of the components required to create the formulas. But what happens when you don’t know all the variables, yet you do know the answer you want? A very common business example is determining the break-even point for a new product. The trial-and-error method works, but it becomes tedious, especially considering that you have the ability to access the enormous computing power that modern computers offer. A much easier solution is to use the Goal Seek tool in Excel.

The Goal Seek tool automates the entire process of changing one variable while calculating a formula and trying to match the desired value. In a break-even situation, you can set the Goal Seek tool to make all necessary changes to the number of units produced to attain a zero profit. Using this tool, you can easily determine the impact of a 10% increase in labor cost on the number of units needed to break even.
The variables used to perform the Goal Seek are as follows:

<table>
<thead>
<tr>
<th>Set cell</th>
<th>Select the cell in which you want Excel to display the result of your goal-seeking. This cell must contain a formula that will calculate the result you want using values from other cells in the worksheet.</th>
</tr>
</thead>
<tbody>
<tr>
<td>To value</td>
<td>Enter the end result (value) that you want to achieve. It must be a numeric value—it cannot be a formula or reference a cell.</td>
</tr>
<tr>
<td>By changing cell</td>
<td>Select the cell in which you want Excel to display the variable result of your goal-seeking. This cell must not contain a formula. If you imagine that you had to perform the What-If Analysis without the Goal Seek feature, you would have to continuously change this cell value.</td>
</tr>
</tbody>
</table>

When using the Goal Seek tool, keep the following in mind:

- The Goal Seek feature is a tool; it is not a function. That is, it changes the value of the variable cell to achieve the desired goal. If you change any of the values or formulas involved with the results, you must run the Goal Seek tool again.
- The cell displaying the outcome must contain a formula that is dependent on the variable cell, either directly or indirectly.
- You can reverse any changes you make with the Goal Seek tool by using the Undo feature.

### Learn to use the Goal Seek feature

This exercise demonstrates how to use the Goal Seek feature to perform the What-If Analysis that you did manually earlier, and use the Goal Seek for more complex situations.

1. Open the *Whale Watching Goal Seek* workbook and save as *Whale Watching Goal Seek - Student*.
2. Select cell B16.
3. On the Data tab, in the Forecast group, click What-If Analysis, and click Goal Seek.
   - The Goal Seek dialog box appears with the Set cell text box referring to the answer cell.
4. Select the To value text box and set the value to: 0.
5. Select the By changing cell text box and type: B3 or use the mouse to select cell B3.
6. Click OK to initiate the Goal Seek analysis.

The Goal Seek tool displays the result on the Goal Seek Status dialog box. If Excel is able to find a solution, the Target value and Current value will be the same. The Goal Seek dialog box should appear as follows:

![Goal Seek Status Dialog Box](image)

Unlike the previous exercise, which involved a lot of guesswork, this feature quickly calculates the answer for you.

7. Click OK in the Goal Seek Status message box to accept the results of your goal-seeking.
Now run the What-If Analysis again to find how much revenue is needed if certain expenses are higher than expected and you want to achieve a net income of $5,000.

8. Change cell B8 to: 3,000 and B12 to: 700.

9. Repeat steps 2 to 6 to determine the revenue with a target net income of $5,000 per month.

The worksheet should look something like the following screenshot.

10. Click OK to close the Goal Seek Status message box.

Now use the Goal Seek tool with the PMT function.

11. Select the Loan worksheet.

12. Select cell B4 and enter: \(=\text{PMT}(B2/12, B3, -B1)\)

Let’s assume that you have an opportunity to purchase a boat suitable for running your business. You do not want to pay more than what you are currently spending on your boat rental, but you are willing to pay the loan off over a reasonable period of time that does not exceed 30 months. As the worksheet currently shows, you will need more than 24 months to pay off the loan.

13. With the cursor on B4, set the following Goal Seek values:

<table>
<thead>
<tr>
<th>Text Box</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set cell</td>
<td>B4</td>
</tr>
<tr>
<td>To value</td>
<td>8812.50</td>
</tr>
<tr>
<td>By changing cell</td>
<td>B3</td>
</tr>
</tbody>
</table>

14. Click OK to initiate the Goal Seek analysis.
Click OK to close the Goal Seek Status message box.

The Goal Seek tool is able to find the exact number of payment periods even though it may not be a whole number. Usually financial institutions will set the number of payment periods to a whole number, and adjust the payment amount as necessary. In this case, you are doing What-If Analysis so it makes sense to set your objective to locking the payment amount to a target and let Goal Seek calculate the number of payments. You can then make a decision on whether your plan is reasonable or not.

Close the workbook.

Open the Corporate Rebate Goal Seek workbook with the IF worksheet active and save as Corporate Rebate Goal Seek - Student.

In this new workbook, you are calculating the rebates that you will be giving your best customers as an incentive. The rebates will be scaled based on how much business they gave you during the past year.

Select each of the cells F1, F2, and F3 to view their contents.

In these 3 cells you have initially set your rebate rates at 1% for your lowest rank, twice that rate for the middle tier, and three times that rate for your best customers. You have decided that Bronze customers are those who generated less than $45,000, Silver customers generated up to $90,000, and Gold customers are those who spent $90,000 or more.

Select cell F6, and enter: =IF(E6<45000,$F$1,IF(E6<90000,$F$2,$F$3))

Select cell G6, and enter: =E6*F6

Copy the formulas in cells F6:G6 to the cell range F7:G30.
The total cost of the rebates is more than you had budgeted for, which is $15,000. You can use the Goal Seek tool to adjust the rebate levels to ensure you do not spend more than your budget. The complication is that Goal Seek can only specify one variable cell, and you have 3 different rebate values, as shown in the IF function in column F. In this worksheet, you avoided that limitation by setting the Silver and Gold rates as dependent on the Bronze rate. You will see that in the formulas used in cells F2 and F3.

22. Select cell G31, then on the Data tab, in the Forecast group, click What-If Analysis, and click Goal Seek.

23. Set the following Goal Seek values and click OK:

<table>
<thead>
<tr>
<th>Text Box</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set cell</td>
<td>G31</td>
</tr>
<tr>
<td>To value</td>
<td>15000</td>
</tr>
<tr>
<td>By changing cell</td>
<td>F1</td>
</tr>
</tbody>
</table>

24. Click OK to close the Goal Seek Status message box.

Goal Seek was able to perform the What-If Analysis for you even though one of the calculations involved a set of IF functions.

25. Select the ANDOR worksheet.

This worksheet has the same data as the IF worksheet, but you now want to use a different set of criteria for setting the Bronze, Silver, and Gold rates: customers who booked more than 25 trips and spent over $90,000 will be your Gold customers. Your Silver customers are the ones who booked more than 25 trips or spent more than $90,000. Everyone else will be your Bronze customers.
26 Select cell F6, and enter: =IF(AND(D6>25,E6>90000),$F$3,IF(OR(D6>25,E6>90000),$F$2,$F$1))

27 Select cell G6, and enter: =E6*F6

28 Copy the formulas in cells F6:G6 down to the cell range F7:G30.

29 Select cell G31, then on the Data tab, in the Forecast group, click What-If Analysis, and click Goal Seek.

30 Set the following Goal Seek values and click OK:

<table>
<thead>
<tr>
<th>Text Box</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set cell</td>
<td>G31</td>
</tr>
<tr>
<td>To value</td>
<td>15000</td>
</tr>
<tr>
<td>By changing cell</td>
<td>F1</td>
</tr>
</tbody>
</table>

31 Click OK to close the Goal Seek Status message box.

In this worksheet, you can give larger rebates to every one of your customers, and yet you can stay in your $15,000 budget. This appears to be a better deal for both you and your customers. On closer examination of this worksheet, however, you can see that fewer customers were able to qualify as Silver and Gold.

32 Save and close the workbook.
Working with Scenarios

Objective 3.4.3

The Goal Seek tool is excellent for performing What-If Analysis. However, it can display only one result at a time; as well, if you want to revert back to an earlier result set, you must re-enter the data to regenerate those same results. The Scenario Manager tool in Excel overcomes this limitation by allowing you to store each result set as a scenario. After creating several scenarios, you can compare them using the scenario summary.

When you create a scenario, you identify the cells to be changed. The Scenario Manager then lists the cells and values. To make the Scenario Manager easier to use, you should create range names for all the cells you expect to change. This allows Excel to display the cell names instead of just cell addresses.

Once you have created your scenarios, use the Scenario Manager to display and switch from one scenario to another or to add more scenarios as you continue your What-If Analysis. You can also modify existing scenarios or delete scenarios.

An important limitation of scenarios is that worksheet cells identified as Changing Cells become fixed for all scenarios. Once you have set up at least one scenario, you cannot add cells or remove them from this list.

You can compare the results of all scenarios at the same time by creating a scenario summary. The summary displays the input values and the results cells that you select from your worksheet, as shown in the following screen example.
Learn to create three scenarios for a worksheet

This exercise demonstrates how to create a simple worksheet with three scenarios.


Tolano Adventures uses this worksheet to decide the price of a charter flight package offering. The travel company purchases all of the seats on a charter airline and sells the seats to its customers. The costs are set by the charter airline, airports, catering company, and so on. However, Tolano has to use their best guess on what price to charge and how many seats will be sold at that price.

You will use the Scenario Manager to help decide which price will result in the highest profit for the company.

2. On the Data tab, in the Forecast group, click the arrow for What-If Analysis, and click Scenario Manager.

3. Click Add.

4. In the Scenario name text box, type: Standard pricing.

5. Click in the Changing cells text box and delete the cell reference that is currently there.

Select the three cells on the worksheet that will change for each of the scenarios.

6. Select cell A2 on the worksheet and then hold the CTRL key while selecting the cell range B4:B5.
Cell A2 is not essential for scenarios; it is simply a cell that displays a descriptive comment whenever a scenario is activated for a worksheet.

You may also want to enter your own information in the comment field. By putting in some details (such as assumptions and explanations), you could potentially save many hours when you are using and changing the scenarios at a later date.

**Note:** You can select a maximum of 32 worksheet cells per scenario.

7. Click **OK**. The Scenario Values dialog box displays.

8. Click **Add** to save this scenario. The Add Scenario dialog box displays again.

9. In the Scenario name text box, type: **Discount pricing** and click **OK**.

10. Change the values in the Scenario Values dialog box as follows:

    - $A$2 Discount Pricing
    - $B$4 140
    - $B$5 599

11. Click **Add** to save this scenario.

12. In the Scenario name text box, type: **Premium pricing** and click **OK**.

13. Change the values in the Scenario Values dialog box as follows:

    - $A$2 Premium Pricing
    - $B$4 75
    - $B$5 799

14. Click **OK** to save this scenario.

15. With the **Premium pricing** scenario selected, click **Show**.
16 Click **Show** for each of three scenarios on the worksheet and observe the changes to the worksheet.

17 Click **Close** to go back to the worksheet.

18 Select cell **B6** and, on the Formulas tab, in the Defined Names group, click **Define Name**.

![](image)

**Note:** If you create names for these cells, the Scenario Values dialog box displays these names instead of the cell reference. You may find these range names more meaningful than cell references.

19 Click **OK** to save this cell name.

20 Repeat steps 18 and 19 for cells **B13** (Total_Costs) and **B15** (Net_Profit).

21 On the Data tab, in the Forecast group, click the arrow for What-If Analysis, and click **Scenario Manager**.

22 In the Scenario Manager dialog box, click **Summary**.

**Note:** You can also choose the Scenario PivotTable from this dialog box. The PivotTable is useful when the worksheet is shared by multiple users; this allows you to select scenarios by user.

23 Verify that Scenario summary is selected.

24 Select cell **B6** on the worksheet and then hold the CTRL key while selecting cells **B13** and **B15**.

![](image)

The Result cells text box is used to select the cell(s) in the worksheet that display the results of the scenario. These cells are important because they contain formulas that show the results of each scenario. In this exercise, the important result cells are the Total Revenue, Total Expenses, and Net Income cells. You can include as many or as few result cells as you wish.

25 Click **OK**.

Note the cells that you had named earlier appear on this summary with those names, making the table more meaningful to you.

26 Save and close the workbook.
Using Cell Watch

Objective 3.5.2

In some situations, you may need to observe one or more cells while you are entering or changing data in a worksheet. The worksheet may be too large to display on your screen at one time. You could split the worksheet window or enter a formula into a cell to reference the other cell; however, these methods are strictly workarounds and have their own limitations.

A better solution to this is to set up a watch window to display the current value of these cells in a small pop-up window. Even if you move around the worksheet and workbook, this watch window conveniently displays the cells that you want to watch.

The watch window is especially useful in What-If Analysis involving large spreadsheets.

Learn to use the cell watch window

This exercise will demonstrate how to use the cell watch window.

1. Open the Personnel Bonus workbook and save as Personnel Bonus - Student.

   In this worksheet, each employee’s annual bonus is calculated using the bonus rate at the top of the worksheet. The bonus rate is limited to the amount of money available to pay – $200,000 for the purpose of this exercise. Column D calculates each employee’s bonus. The total bonus amount is at the bottom of the list, but you will need to adjust the bonus rate while watching the total bonus amount. You can accomplish this by setting up a cell watch window.

2. On the Formulas tab, in the Formula Auditing group, click Watch Window.

   A blank Watch Window now appears.

3. Make the Watch Window bigger by clicking and dragging the bottom right corner of the Watch Window.

4. Click Add Watch in the Watch Window.

5. With the text box selected in the selection box, scroll down in the worksheet and select cell D36.

   The Add Watch dialog box now shows this cell reference:

   ![Add Watch dialog box]

6. Click the Add button in the Add Watch dialog box.

   The Watch Window now has this cell reference.
Lesson 5
Advanced Charts, Functions and What-If Analysis

7 Scroll back to the top in the worksheet.

8 Move the Watch Window to an area of the worksheet where you can see it, but you can update cell B1 easily.

9 Change the bonus rate value in cell B1 until cell D36 is as close to $200,000 as possible (you can exceed that amount by no more than $499).

Once you have determined the right bonus rate, you can remove the Watch Window.

10 Select the D36 cell reference in the Watch Window.

11 Click Delete Watch in the Watch Window.

12 Close the Watch Window. Then save and close the workbook.

Structured References

Objective 1.1.4

A formula such as =SUM(G2:G29) is very commonly used in Excel workbooks. However, the formula is difficult to read by simply glancing at it. Many Excel users have to use techniques such as pressing the F2 key to visually see which cells are being referenced. On the other hand, a formula such as =SUM_Customers[Rebate]) is much easier to read and understand. At the same time, tables tend to change as new rows of data are added or deleted, or filters are applied to highlight important data. In other words, the cell range containing the data you want may change from G2:G29 to G2:G44 when new data is added. When that happens, you must change all formulas that use that cell range. A structured reference like Customers[Rebate] will automatically remedy that problem.

The use of structured references has opened a whole new set of opportunities to enable accessing data components inside tables. By using different identifiers, you can access different components of tables:

<table>
<thead>
<tr>
<th>tablename</th>
<th>Data for all columns, excluding the header and total row.</th>
</tr>
</thead>
<tbody>
<tr>
<td>tablename[#All]</td>
<td>Data for all columns, including the header and total row; for example, Customers[#All]</td>
</tr>
<tr>
<td>tablename[#Headers]</td>
<td>Header row for all columns; for example, Customers[#Headers] Note that this reference will display an error if the header row is turned off.</td>
</tr>
<tr>
<td>tablename[#Totals]</td>
<td>Total column for all columns; for example, Customers[#Totals] Note that this reference will display an error if the total row is turned off.</td>
</tr>
<tr>
<td>tablename[column name]</td>
<td>Data for a specific column, excluding the header and total row; for example, Customers[Rebate]</td>
</tr>
<tr>
<td>tablename[#All],[column name]</td>
<td>Data for a specific column, including the header and total row; for example, Customers[#All],[Rebate]</td>
</tr>
</tbody>
</table>
The SUBTOTAL function has also been extended with new function numbers that are designed specifically for structured references in tables. For example, the function number 9 is used to calculate the subtotal for a range of cells. To use the table version for any of the original SUBTOTAL function numbers, simply add 100. Therefore, function number 109 is used to calculate the sum with structured references for a table.

A specific feature of the SUBTOTAL function using the 100-series function numbers is that it will automatically adjust to any filters applied to the table. On the other hand, the regular functions such as SUM, AVERAGE and MIN will ignore any filter operations on the table.

Depending on your needs, you may want to use the SUBTOTAL or the regular functions such as SUM.

### Learn to use the structured reference feature

This exercise will demonstrate how to use the structured reference feature.

2. Select any cell in the range A4:F29, then on the Insert tab, in the Tables group, click Table.
3. In the Create Table dialog box, verify that the cell range is A4:G29 and the My table has headers check box is turned on, then click OK.
4. Under Table Tools, on the Design tab, in the Properties group, click in the Table Name text box to replace the name with: Customers.
5. Select cell G5, type: = to begin the formula.
6. Click cell E5, type: * to enter the multiplication symbol, then click cell F5.

Notice how the formula is being constructed using the column name.
Lesson 5  

Advanced Charts, Functions and What-If Analysis

7 Press ENTER to complete the formula.

The entire column is now autocompleted with the same formula.

8 Select all of column G, then on the Home tab, in the Number group, click the arrow for the Number Format list box and select Currency.

Activate the Total Row for this table.

9 Under Table Tools, on the Design tab, in the Table Style Options group, click Total Row to turn it on.

10 If cell G30 does not show the sum total value for the Rebate column, select cell G30, click the arrow button to the right, and click Sum.

11 Select cell F30, click the arrow button to the right, and click Average.

12 On the Home tab, in the Number group, click Increase Decimal twice to add two decimal digits to the average rate value in cell F30.

13 Select cell E30, click the arrow button to the right, and click Sum.

14 Select cell G30.

Notice the formula created by Excel for the Rebate column is =SUBTOTAL(109,[Rebate]). Also notice that when the formula is entered while inside the table, the table name does not need to be used.

Now display the total for the Rebate column in a worksheet cell outside of the table, using a similar SUBTOTAL function.

15 Select cell G32, and enter: =SUBTOTAL( 

A popup window displays, showing all of the available SUBTOTAL function numbers.

16 Scroll down the SUBTOTAL function list, click 109 – SUM and press TAB.

17 Continue typing the rest of the formula: ,Customers[ 

18 Click Rebate and press TAB, type: ]) and press ENTER.

Display the same sum total value, but using a different formula to fetch the sum total value directly.

19 Select cell G33, type: = to start a new formula, then click G30 and press ENTER to complete the formula.

This is a quick method of getting the cell reference from within a table. Cell G33 should now have the formula =Customers[[#Totals],[Rebate]]
20 Select cell G34, and enter: =SUM(Rebate)

21 Select cell range G32:G34, then on the Home tab, in the Number group, click the drop down arrow for the Number Format list box and select Currency, if necessary.

22 Make a note of the sum total value currently displayed at the bottom of the Rebate column. You should see that this same number is displayed in cells G32, G33, and G34.

23 Click the AutoFilter icon to the right of the Office column name in the table, click Select All to turn this off, then click New York and Toronto to turn these on, and click OK.

The completed worksheet should appear similar to the following:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Toronto</td>
<td>Wylie</td>
<td>Jayel</td>
<td>21</td>
<td>$76,552.98</td>
<td>2%</td>
</tr>
<tr>
<td>7</td>
<td>New York</td>
<td>Whitcomb</td>
<td>Isla</td>
<td>15</td>
<td>$74,696.85</td>
<td>2%</td>
</tr>
<tr>
<td>8</td>
<td>Toronto</td>
<td>Ruech</td>
<td>Patrick</td>
<td>4</td>
<td>$10,117.40</td>
<td>1%</td>
</tr>
<tr>
<td>9</td>
<td>Toronto</td>
<td>Frankel</td>
<td>Valerie</td>
<td>14</td>
<td>$63,088.62</td>
<td>2%</td>
</tr>
<tr>
<td>10</td>
<td>Toronto</td>
<td>Huso</td>
<td>Anthony</td>
<td>19</td>
<td>$29,205.66</td>
<td>1%</td>
</tr>
<tr>
<td>11</td>
<td>New York</td>
<td>Ramirez</td>
<td>Misa</td>
<td>4</td>
<td>$6,914.72</td>
<td>1%</td>
</tr>
<tr>
<td>12</td>
<td>New York</td>
<td>Robotham</td>
<td>Maya</td>
<td>8</td>
<td>$23,087.52</td>
<td>1%</td>
</tr>
<tr>
<td>13</td>
<td>New York</td>
<td>Karmazin</td>
<td>Panos</td>
<td>8</td>
<td>$33,186.48</td>
<td>1%</td>
</tr>
<tr>
<td>14</td>
<td>New York</td>
<td>Kjelgaard</td>
<td>JD</td>
<td>21</td>
<td>$75,260.43</td>
<td>2%</td>
</tr>
<tr>
<td>15</td>
<td>Toronto</td>
<td>Singh</td>
<td>Khushwant</td>
<td>4</td>
<td>$13,679.88</td>
<td>1%</td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>33</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>34</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Notice that the Total Row values for the table at row 30 have adjusted to what is now currently displayed. Also notice that the numbers in cells G32 and G33 continue to match the sum total for the Rebate column. However, the number in cell G34 still shows the sum total for the Rebate column for the original, unfiltered table. This demonstrates that you need to choose the correct function to use to summarize data from a table, depending on your requirements.

24 Under Table Tools, on the Design tab, in the Table Style Options group, click the Total Row to turn it off.

The formula referencing the total row in the table is now showing an error.

25 Click the Total Row check box in the Ribbon again to turn it back on.

26 Save and close the workbook.
Lesson Summary

You should now be able to:

☑ format a simple chart
☑ add a secondary vertical axis
☑ create and apply chart templates
☑ create and modify a chart trendline
☑ use financial functions
☑ nest functions inside other functions
☑ use AND, OR, and NOT functions
☑ use conditional summary functions
☑ perform What-If Analysis using the trial-and-error method
☑ use the Goal Seek tool
☑ use the Scenario Manager
☑ use the cell watch window
☑ use structured references

Review Questions

1. How many functions can you nest within other functions?
   a. 16 c. 64
   b. 32 d. 128

2. Which of the following statements regarding the AND function is true?
   a. The AND function returns a TRUE value only if all of the logical tests are TRUE.
   b. The AND function returns the logical opposite value of a logical result.
   c. The AND function returns a TRUE value if any of the logical tests are TRUE.
   d. You can have up to 5 logical tests in an AND function.

3. Which of the following conditional summary functions will perform more than one criteria test at the same time?
   a. SUMIF c. AVERAGEIFS
   b. COUNTIF d. All

4. Which of the following structured references will access data for a specific column in the current row?
   a. tablename[@[column name]] c. tablename[#All]
   b. tablename[column name] d. tablename

5. Which of the following statements about the PMT function is true?
   a. The function takes only one argument.
   b. If the interest rate is 6% per year and the term of the loan is 60 months, then you must divide the 6% by 12.
   c. You cannot use the function to determine the buyout left on a loan.
   d. The function will correctly calculate mortgage payments in all countries around the world.
6. What is a cell watch?
   a. The ability of one worksheet cell to monitor the value of another cell, and perform an action if it changes.
   b. An Excel feature that allows you to always see the current value of one or more worksheet cells in a small pop-up window no matter where you are in the workbook.
   c. A special type of worksheet cell that displays each step of a macro as it is executed.
   d. A special type of worksheet cell that displays the current time of day.

7. Why is the Goal Seek tool more efficient than using a manual what-if worksheet?
   a. The Goal Seek tool automatically creates three scenarios.
   b. The Goal Seek tool automatically applies formatting to the cells involved in the calculation.
   c. The Goal Seek tool automates the entire process of changing one variable while calculating a formula and trying to match the desired value.
   d. The Goal Seek tool automatically creates a chart to illustrate the possible input values.

8. What type of element can you add to a chart to help you predict future values?
   a. Data labels
   b. A legend
   c. Dual axe
   d. A trendline

9. What type of element can you add to a chart that will allow you to display two types of data, each requiring its own scale?
   a. Data labels
   b. A legend
   c. Dual axes
   d. A trendline

10. Why might you want to save a chart as a template?
    a. To share macros among your charts.
    b. To share your chart design with Microsoft.
    c. To quickly apply formatting from that chart to a new chart.
    d. To quickly create a new workbook.
Microsoft Excel 2016
Expert Certification Guide

Lesson 6: Data Filtering, Macros, and Forms

Lesson Objectives
The objectives of this lesson are to use various advanced Excel features that allow you to filter data, extend a data series by filling, and use form controls and macros. You will also learn how to create your own workbook templates and control formula iterative calculations. Upon completion of this lesson, you should be able to:

- use the Fill Series feature
- use advanced filter options and different comparison operators to search for data
- create, modify, and delete custom workbook templates
- access hidden Ribbon tabs
- create and use macros
- save and open workbooks containing macros
- copy macros from one workbook to another
- add form controls to a worksheet, including command buttons, spin buttons, scroll bars, check boxes, option buttons, combo boxes, list boxes, group boxes, and text boxes
- change excel formula calculation options

Fill Series

Objective 2.1.2
Excel provides you with the ability to copy values or formulas into worksheet cells. In some situations, you need to fill a range of cells with incremental values, starting with an initial value.
The AutoFill feature performs the same function, except that it takes a guess on what the incremental value is. For example, if you select two cells containing the values 1 and 3, the AutoFilled cells will have the values 5, 7, 9, and so on because Excel has determined the increment is 2. If you select only one cell containing the value 1, the AutoFilled cells will all contain the value 1. If you select a cell containing the value Monday, the AutoFilled cells will be filled with Tuesday, Wednesday, and so on.

The Fill Series feature allows you to have more direct control over how much to increment each subsequent cell using only one starting cell. The Fill Series dialog box appears as follows:

```
You must pay careful attention to selecting the combination of Type, Date unit, and Trend option buttons to obtain the desired results:

- **Linear**: In this option, Excel will add a cell value and the Step value together, and place the sum in the next blank cell in the selected range.
- **Growth**: In this option, Excel will multiply a cell value by the Step value, and place the product in the next blank cell in the selected range.
- **Date**: In this option, Excel will open the Date unit section in the dialog box for you to select. By default, the Day option is selected. Excel will then add a cell value with the Step value together, and place the sum in the next blank cell in the selected range.
- **AutoFill**: This option is the same as the Linear type, but Excel will automatically determine the correct Step value to calculate each value to be placed in the blank cells of the range. Note that this option works best with at least two starting values.

Excel will continue calculating values in blank cells until there are no more cells remaining in the selected range, or the Stop value is reached.

The Trend check box can be used as an alternative to entering a Step value of your own for the Linear and Growth option types. It will perform a regression analysis for a linear or exponential best-fit – for Linear or Growth, respectively – using the starting values that are in the selected range. The blank cells are then filled with the calculated step value. This option requires at least two cells in the selected range with starting values.

The Date option button will allow you to add the Step value to the day, weekday, month, or year component of the date value in the starting value. In the following example, the start value of 15-Jan-14 is copied into the cell range B2:E2. The Fill Series tool is then used with a step value of 2 to fill downwards to row 7 in each respective column using the Day, Month, Year, and Weekday options.
Data Filtering, Macros, and Forms

Lesson 6

Learn to use the Fill Series feature for numbers

This exercise demonstrates the use of the Fill Series feature for numbers.

1. Open the Fill Series workbook and save as Fill Series - Student.
2. Select cells B4 to B18.
3. On the Home tab, in the Editing group, click Fill, then click Series.
4. Click OK to accept the default options.

Now do a linear increment series with a step increase of 4.

5. Select cells C4 to C18, then on the Home tab, in the Editing group, click Fill, then click Series.
6. In the Step value field, replace the 1 with the value of 4, then click OK.

Now do a linear decrement series with a step value of -4.

7. Select cells D4 to D18, then on the Home tab, in the Editing group, click Fill, then click Series.
8. In the Step value field, replace the 1 with the value of -4, then click OK.

Now do a growth increment series with a step increase of 1.

9. Select cells E4 to E18, then on the Home tab, in the Editing group, click Fill, then click Series.
10. Select Growth in the Type section and click OK.

Now do a growth increment series with a step increase of 1.

11. Select cells F4 to F18, then on the Home tab, in the Editing group, click Fill, then click Series.
12. Select Growth in the Type section.
13. In the Step value field, replace the 1 with the value of 4, and click OK.
14. Increase the width of column F as necessary.

Now do the same growth increment series but specify a stop value of 100,000.

15. Select cells G4 to G18, then on the Home tab, in the Editing group, click Fill, then click Series.
16. Select Growth in the Type section.
17. In the Step value field, replace the 1 with the value of 4.
18  In the Stop value field, enter: 100000, and click OK.

Now do the same growth increment series with no stop value but with a step value of -4.

19  Select cells H4 to H18, then on the Home tab, in the Editing group, click Fill, then click Series.

20  Select Growth in the Type section.

21  In the Step value field, replace the 1 with the value of -4, and click the OK button.

22  Increase the width of column H as necessary.

The worksheet should appear similar to the following:

23  Save and close the workbook.

**Advanced Filtering**

Finding information in a database takes effort, especially if the database is large and unorganized. Sorting the database is one way of making it easier to find information; however, you still have to look through all the records in the database. Another way to locate information quickly is to use a filter to hide the records you are not interested in viewing. Filtering does not change the content of your database or the sequence of the records, only what you see of your database.

**Using Advanced Filters**

The AutoFilter feature provides a quick and easy way to apply simple filters to your database. In most situations, it can select the data that interests you.

However, when you need to specify more complex selection criteria, Excel provides an advanced filter feature. For example, Excel can use many combinations of selection criteria with virtually unlimited And and Or conditions. The advanced filter allows you to apply the filter directly to the data cells, which tells Excel to temporarily hide any rows that do not meet the criteria. Alternatively, you can put the filtered records into another area of the worksheet so that you can see the original data cells and the results of the filter at the same time.
An advanced filter consists of a List Range or database, Criteria Range, and an optional Copy To Range. Each of these ranges must be set up before you apply the advanced filter.

**Action** Choose between either filtering the data directly in the data range or extracting the results to a different location on the worksheet.

**List range** Identify the cell range for your data. You can apply advanced filters to any data range as long as every column has a label.

**Criteria range** Identify the cell range in your worksheet where the selection criteria are located.

**Copy to** Identify the range to which records will be copied; this only applies when you select Copy to another location.

**Unique records only** Select this option if you want the filter or copied records to hide duplicates.

The **Criteria range** consists of a range of cells with column labels matching the column labels at the top of the data range. You must ensure the column labels in the criteria range exactly match the data column labels, including any blank spaces at the beginning or end of the column labels. The best way to ensure they match is to use the Excel Copy tool on the column labels and paste them to the criteria range.

You enter the specific criteria in the rows below the column labels. The conditions in each row represent sets of “and” criteria or “or” conditions. It is important to understand the difference between “and” and “or.”

**And** If you enter two or more criteria in the same row, Excel selects a data row as long as all of the criteria are true. For example, in the screen that follows, a data row must have both a Sale Type of Flight and a Payment Type of Cash in order to be selected.

<table>
<thead>
<tr>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>Customer</td>
<td>Sale Type</td>
<td>Amount Paid</td>
<td>Payment Type</td>
</tr>
<tr>
<td></td>
<td>Flight</td>
<td></td>
<td></td>
<td>Cash</td>
</tr>
</tbody>
</table>

**Or** If you enter two or more criteria, but on different rows, Excel selects a data row if it meets any one of the criteria rows. For example, in the screen that follows, a data row must have a Payment Type of Visa or Mastercard in order to be selected.

<table>
<thead>
<tr>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>Customer</td>
<td>Sale Type</td>
<td>Amount Paid</td>
<td>Payment Type</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Visa</td>
<td></td>
<td>Mastercard</td>
</tr>
</tbody>
</table>

**And and Or** If you choose this combination, Excel selects a data row if it meets all the criteria in any one criteria row. For example, in the screen that follows, a data row must have a Sale Type of Hotel and a Payment Type of Visa, or a Sale Type of Flight and a Payment Type of Mastercard in order to be selected.

<table>
<thead>
<tr>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>Customer</td>
<td>Sale Type</td>
<td>Amount Paid</td>
<td>Payment Type</td>
</tr>
<tr>
<td></td>
<td>Hotel</td>
<td>Flight</td>
<td>Visa</td>
<td>Mastercard</td>
</tr>
</tbody>
</table>
Learn to use the advanced filter

This exercise demonstrates how to use the advanced filter.

1. Open the Sales Filtering workbook and save as Sales Filtering - Student.

Start with a very simple application of the advanced filter—use the filter to display only those sales where the payment type was cash. Excel applies the results to the data cells.

2. Enter the following:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>G1</td>
<td>Payment Type</td>
</tr>
<tr>
<td>G2</td>
<td>Cash</td>
</tr>
</tbody>
</table>


4. On the Data tab, in the Sort & Filter group, click Advanced to open the Advanced Filter dialog box.

5. Verify that cells A1:E2009 have been selected in the List range text box.

   The cells in the List range must include the column labels. Otherwise, the advanced filter feature will not work because the column label(s) of the cells selected in the Criteria range text box must match these labels.

6. Click the Criteria range text box and select the cell range G1:G2 in the worksheet.

   **Note:** If the Advanced Filter dialog box is obstructing your view of the criteria range, drag the window away from the cell range or use the Collapse and Restore buttons to select the cell range.

7. Click OK to apply the advanced filter.

   In these results, Excel displays all the sales data with a cash payment type. All other rows are hidden, as you can see by looking at the large gaps in the row numbers at the left side of the worksheet. Notice also that the row numbers display in blue, indicating that the list has a filter applied.
Now redisplay all records in the database.

8 On the Data tab, in the Sort & Filter group, click Clear.

The preceding task demonstrated how to enter just the one selection criteria that you need. Alternatively, you can copy all the column labels to your criteria range. Using this approach, many of the criteria cells will be empty. But with the full set of column labels, you can quickly change your filter criteria to anything that you need.

9 Copy the column labels in cells A1:E1 to the cell range G1:K1.

10 Change the column widths as follows:

<table>
<thead>
<tr>
<th>Column Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
</tr>
<tr>
<td>G</td>
</tr>
<tr>
<td>I</td>
</tr>
<tr>
<td>J</td>
</tr>
<tr>
<td>K</td>
</tr>
</tbody>
</table>

11 Delete the entry in cell G2.

12 If necessary, widen the workbook window so that you can see columns A to K.

Enter another set of filter criteria. This time, you want to display all sales that contain the word Flight and were paid by cash.

13 Enter the selection criteria into the following cells:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>I2</td>
<td>Flight</td>
</tr>
<tr>
<td>K2</td>
<td>Cash</td>
</tr>
</tbody>
</table>

14 Select any cell in the data range A1:E2009 and then, on the Data tab, in the Sort & Filter group, click Advanced to open the Advanced Filter dialog box.

15 Highlight the contents of the Criteria range text box, select the cell range G1:K2 in the worksheet, and click OK.
Again, Excel has applied the filter to the data range. With these filter criteria, both Flight and Cash were in the same row and therefore every sale had to meet both criteria to be displayed. Note that any sale type with the word “Flight” in it was selected, including “Flight+Car rental”, “Flight+Cruise”, and others.

As an alternative, you can also leave the original data range unchanged and put the filter results into an unused part of the worksheet. You should copy the column titles again as your output range.

16 On the Data tab, in the Sort & Filter group, click **Clear**.

17 Copy the column labels in cells A1:E1 to the cell range G7:K7.

18 Select any cell in the data range.

19 On the Data tab, in the Sort & Filter group, click **Advanced**.

20 Select the **Copy to another location** option.

21 Click in the Copy to text box and select the cell range G7:K7.

![Advanced Filter dialog box]

**Note:** Do not place the Copy to range above the data or criteria ranges on the worksheet. Doing so could result in the data accidentally overwriting these areas.

22 Verify that the Advanced Filter dialog box contains the same selections as the preceding screen example and click **OK**.
The worksheet should now look something like the following:

Save and close the workbook.

Using Comparison Operators

The advanced filter is a very powerful search engine because it provides a lot of flexibility in building filter criteria. In addition to entering a criterion to find exact matches, you can also use comparison operators to find data ranges. The following operators are commonly used for numeric data:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Operation</th>
<th>Example Criteria</th>
<th>Example Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
<td>=1,000</td>
<td>1,000</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
<td>&lt;&gt;1,000</td>
<td>250, 0,–100, 999</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>&lt;1,000</td>
<td>250, 0,–100, 999</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td>&lt;=1,000</td>
<td>250, 0,–100, 999, 1,000</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>&gt;1,000</td>
<td>1001, 3,500</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td>&gt;=1,000</td>
<td>1,000, 3,500</td>
</tr>
</tbody>
</table>

Note: Do not place blank spaces in or around comparison operators. In the example <=2000, there must not be spaces between the “<” and “=” or between the “=” and “2”.

You can also use comparison operators on text strings.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Operation</th>
<th>Example Criteria</th>
<th>Example Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>text</td>
<td>Begins with the text</td>
<td>Hotel</td>
<td>Hotel, Hotel and car</td>
</tr>
<tr>
<td>=“=text”</td>
<td>Exactly matches text</td>
<td>=“=Hotel”</td>
<td>Hotel</td>
</tr>
<tr>
<td>&lt;&gt;text</td>
<td>Not equal to text</td>
<td>&lt;&gt;Hotel</td>
<td>Flight, Car rental</td>
</tr>
<tr>
<td>&lt;</td>
<td>Alphabetically less than text</td>
<td>&lt;Hotel</td>
<td>Flight, Car rental</td>
</tr>
<tr>
<td><em>text</em></td>
<td>Wildcard characters</td>
<td><em>th</em></td>
<td>fifth, throw, heather</td>
</tr>
<tr>
<td>text1*text2</td>
<td>Wildcard characters</td>
<td>s*t</td>
<td>sit, seat, shout</td>
</tr>
<tr>
<td>text??text</td>
<td>Wildcard characters</td>
<td>s??t</td>
<td>seat, sift</td>
</tr>
</tbody>
</table>

23
The wildcard characters * (asterisk) and ? (question mark) are similar in that they allow any characters to be matched in their place. The difference is that * (asterisk) allows any number of characters, whereas ? (question mark) permits only one character to be matched. Using the preceding examples, the words “sit”, “seat”, and “shout” will satisfy the criterion “s*t” because all three begin with “s” and end with “t”. However, only the words “seat” and “sift” satisfy the criterion “s??t” because only one character can take the place of each of the two wildcard characters.

**Learn to use different comparison operators for advanced filtering**

This exercise demonstrates the use of different comparison operators for advanced filtering.

1. Open the *Sales Filter Operators* workbook and save *Sales Filter Operators - Student*.
2. Select cells **G2:K2** and press DELETE.
3. Create the criteria cells by entering:
   
<table>
<thead>
<tr>
<th>Cell</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>K2</td>
<td>Air Miles</td>
</tr>
<tr>
<td>J3</td>
<td>&gt;5,000</td>
</tr>
</tbody>
</table>

   **Note:** When entering these criteria values, be sure not to add blank spaces on the left or right of the text.

4. Select any cell in the data range and then, on the Data tab, in the Sort & Filter group, click **Advanced**.
5. In the Advanced Filter dialog box, select **Copy to another location**.
6. Select the contents of the Criteria range (so that all of it will be replaced by the new selection) and select **G1:K3** on the worksheet.
7. Verify the Copy to cell range is still **G7** and **K7** and click **OK**.

You can do a quick verification by comparing some the filter results on the right against the data range on the left of the worksheet.

Now try another criterion: you want to find all sales in which customer #300 purchased more than a hotel stay.
8 Delete the existing criteria in cells J2:K3, then create the new criteria cells by entering:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>H2</td>
<td>300</td>
</tr>
<tr>
<td>I2</td>
<td>&lt;&gt;Hotel</td>
</tr>
</tbody>
</table>

9 Run the advanced filter again. Select **Copy to another location** and ensure the **Criteria range** is set to **G1:K2**.

10 Save and close the workbook.

## Working with Templates

Most spreadsheets are relatively simple; they generally contain data, several formulas and functions, some cell formatting, and possibly a chart. Creating one of these when starting with a blank workbook will not take much time. However, in some cases, the spreadsheets can be much more elaborate; for example, they may include more complex formatting, formulas, charts, and possibly other Excel features. An organization may also have a specialized workbook format for employees to use when interacting with outside parties such as customers or suppliers. Complex workbooks take much longer to create from scratch.

Excel offers workbook templates that make it much easier to create complex workbooks. Instead of building one from scratch each time, you can create a new workbook with most or possibly all of the formatting, formulas, charts, and other elements already in place. All you need to do is to enter the new data in the appropriate cells, plus any additional refinements, as necessary.

Excel includes several pre-built sample templates for a variety of purposes—expense statements, invoices, budgets, and purchase orders, for example—which you can download from the Office.com Web site whenever you need them. You can also create your own user-defined workbook templates from scratch or customize an existing template and save it as a user-defined template.

## Creating a Template

### Objective 1.1.1

A workbook template is nothing more than a regular workbook that has been saved using a different filename extension. Instead of the .xlsx extension applied to regular workbooks, templates use the extension .xltx.

Once you create a user-defined template, Excel uses it only for the purpose of creating a new workbook. When you save this new workbook, Excel saves the changes only to the workbook (not to the template). You can re-use a template as many times as you want; it will create the same initial workbook each time.
Excel stores templates in two locations on the computer – in each user’s My Documents\Customer Office Templates folder (this is a Personal Templates area) and in the Workgroup Templates area. Templates that are stored in the Workgroup Templates area are accessible to all users on the system. Templates stored in each user’s My Documents\ Custom Office Templates folder are accessible only to the user who saved the template.

Learn to create and use a custom template workbook

In this exercise, you will create and use a custom template workbook.

1. Open the First Aid Schedule workbook.
2. On the File tab, click Save As. Click Browse.
3. Click the arrow for Save as type and then click Excel Template.
   
   The Save As dialog box automatically sets the Save in location to the Custom Office Templates folder. This is a standard folder that all Microsoft Office programs share.
4. Change the File name to: First Aid Schedule Template.
5. Click Save and then close the workbook to exit from Excel.

Now create a new workbook using this user-defined workbook template.

6. Click the File tab, click New, then click PERSONAL.
Click **First Aid Schedule Template** to create a new workbook.

Excel creates a new workbook using your new template workbook.

Fill in the range **B5:B10** with the data displayed in this screen example and copy this data to the range **C5:F10**.

Click **File** and then click **Save As**.

Change the file name to: **First Aid Schedule – week of Jan 16** and click **Save**.

Close the workbook.

**Modifying Templates**

**Objective 1.1.1**

You can update a user-defined workbook template at any time, as you would with a regular workbook. Simply open the file, make your changes, and save the file again. All user-defined templates are easily found in your Custom Office Templates folder. If you have not created any custom templates, that folder will not exist.

*Note:* If you are upgrading from Microsoft Office 2010 or earlier versions, your user-defined templates will be stored in a different folder: `C:\Users\<user ID>\AppData\Roaming\Microsoft\Templates`. The `<user ID>` is the ID you used to log into Windows. Be aware that this folder is hidden by default, and may not be displayed in File Explorer using its normal settings.

If you do have user-defined templates created with earlier versions of MS Office, you should move them to your Custom Office Templates folder (and create that folder if necessary) so that Excel can find them easily.
If you recently opened a template workbook, you can find it again quickly by clicking on the File tab, and then clicking Recent.

### Deleting Templates

Templates are just like workbooks—they are simply files. You can use File Explorer to find and delete any template file that is no longer needed.

## Learn to modify a user-defined workbook template

This exercise demonstrates how to modify a user-defined workbook template.

1. Start Excel, then click Open Other Workbooks. If Excel is already running, click File, then click Open.
2. Click File, then click Open. In the Open screen, click Browse.
3. If necessary, navigate to the Documents folder. Double-click the Custom Office Templates folder to open it.
4. Select the First Aid Schedule Template workbook and click Open.

For demonstration purposes, take a quick look in the Excel Options.

5. Click File, then click Options.
6. Click Save in the Excel Options window.

   The personal templates folder is identified in the Default personal templates location field.

7. Click Cancel.

Now make a change to the workbook template.

10. Select cell B5 to identify it as the active cell.

   After you have completed your changes to the template, you will save it again as a template file in the Templates folder.

11. Save and close the First Aid Schedule Template workbook template.

Now test the modified template.

12. Launch Excel and click the PERSONAL tab.
13. Click the First Aid Schedule Template template.

   A new workbook is created with this updated template.
14. Close the First Aid Schedule Template1 workbook without saving it.
Accessing Hidden Ribbon Tabs

Objective 1.1.6

Excel includes a rich variety of commands, tools, and features. There are so many that even the Ribbon does not display all of them. Many commands and tools are buried inside a dialog box that is displayed only when you click the dialog box Launcher from the Ribbon, or when you click a link in another dialog box.

By default, the Ribbon contains the commands and tools that most of users will need. Also by default, all tabs except one are displayed. If you are an advanced user, you may want to unhide the Developer tab so that you can access it. You can display hidden tabs by customizing the Ribbon.

You can use one of the following methods to customize the Ribbon:

- Click **File**, click **Options**, and then click **Customize Ribbon**, or
- right-click anywhere on the Ribbon, then click **Customize the Ribbon** to display the Excel Options customize Ribbon window.

Learn to reactivate a hidden Ribbon tab

This exercise demonstrates how to reactivate a hidden Ribbon tab.

1. Create a new blank workbook.
2. Click **File**, then click **Options**.
3. In the Excel Options dialog box, click **Customize Ribbon**.
**Lesson 6**

**Data Filtering, Macros, and Forms**

**Hint:** You can also right-click anywhere on the Ribbon, then click **Customize the Ribbon**.

4. In the Customize the Ribbon tree list on the right side of the screen, click the **Developer** check box to turn it on.

5. Click the **Power Pivot** check box to turn it off, then click **OK**.

6. Click the **Developer** tab to view it in the Ribbon.

Now redisplay the Customize the Ribbon screen.

7. Right-click anywhere on the Ribbon, then click **Customize the Ribbon**.

8. Move the Excel Options dialog box down so that you can view all the buttons on the Developer tab in the Ribbon.

9. In the Excel Options dialog box, click the **Open Tree (+)** button for Developer, and then click the **Open Tree** button for Controls.

![Developer Tab](image)

Notice that the various levels and commands shown here in the dialog box matches the commands and groups in the Developer tab in the Ribbon.

Despite the many commands and features accessible from the Ribbon, there are many more that are hidden elsewhere.

10. Click the **Choose commands** from drop-down arrow and click **Commands Not in the Ribbon**.

11. Scroll down this list of commands to view the many commands that are available.

12. Click any command in the list.

   Notice that the Add button is no longer grayed out, indicating that you can add this command to the Ribbon.

13. Click **Cancel**.

14. Close the workbook and discard any changes that may have been made.
Macros

The term macro typically refers to a set of actions that can be recorded and then executed with a single command. This capability is very useful when you are performing tasks that must be repeated on different cells in a workbook. You can create macros to perform almost any command that you can access from the Ribbon. Typically, you use macros to format cells, copy data from one cell range to another, or update charts and PivotTables.

The building blocks that perform the work inside a macro are components of a programming language called Visual Basic for Applications, or VBA. When macros were first introduced in Excel version 4.0, users quickly discovered how useful they were in automating and simplifying many tasks. Since that time, the Excel macro tool has evolved into VBA, a highly capable and flexible tool that is now common to all Microsoft Office applications. This capability allows independent software developers to develop systems to integrate these applications. This courseware covers only the basics of creating, using, and editing macros.

To make it simple to create macros, Excel provides a tool to record your actions and key strokes, storing the information in a macro for later execution. This is extremely useful if you do not have time to learn the VBA language.

You can execute a macro in many ways. You can create a shortcut key combination to run the macro, assign the macro to the Quick Access Toolbar, or to a command button, or set it up as an auto-execute macro (that is, a macro that runs automatically whenever the workbook is opened).

You can access all the basic macro features by clicking the drop-down arrow below Macros on the View tab in the Macros group.

Creating a Macro

Objectives 1.1.5, 2.3.4

The quickest way to create a macro in Excel is to use the Macro Recorder. Once turned on, the Macro Recorder will track your Ribbon selections and activities on the worksheets. It will continue recording until you turn it off. After the recording is stopped, Excel converts the macro into a VBA program.

The VBA program does not actually store your cursor movements. It only records the commands that you select. Many years ago, when you ran a macro in Excel 4.0, you could see the main menu options being highlighted, pulled down, and selected as if the mouse were being remotely controlled. In VBA language, only the actual commands are encoded into the macro and no cursor movements or command selections appear on the screen. Because of this change, you can select a very wide range of commands for your macro including cell formatting, selecting cells, inserting and deleting rows, columns, and worksheets, saving the workbook, and inserting charts.
The Record Macro dialog box includes several text boxes:

<table>
<thead>
<tr>
<th>Description</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Macro name</strong></td>
<td>Identifies the macro. The first character of the name must be an alphabetic character. The rest of the name can be any combination of letters, numbers, and the underscore character. You are not permitted to use any other character or blanks.</td>
</tr>
<tr>
<td><strong>Shortcut key</strong></td>
<td>Activates the macro in the worksheet by assigning a letter key as a shortcut. You can use only one uppercase or lowercase alphabetic character. It cannot be a number or a special character such as # or @. If you use one of Excel’s default shortcut keys (such as CTRL+P to print), the macro will override the default command while the worksheet containing your macro is open.</td>
</tr>
<tr>
<td><strong>Store macro in</strong></td>
<td>Selects where to store the macro. If the macro is stored in This Workbook, it will be available only within the current workbook. Storing the macro in the Personal Macro Workbook makes it available in any workbook that is opened on your computer.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Allows you to enter additional information about the macro.</td>
</tr>
</tbody>
</table>

The Macro dialog box allows you to manage your macros: it displays all macros that have been created in the workbook, and allows you to run, edit, or delete them from the workbook.

If you forget the shortcut key assigned to a macro or you want to assign a different one, click the Options button.
Choose a letter to assign as the shortcut key for your macro carefully. If Excel uses the same letter as a default keyboard shortcut for a command, your macro will take precedence whenever your workbook is open and active. For example, you can create a macro that deletes the contents of the selected cells, and assign lowercase “c” as the shortcut key. Imagine the surprise of someone who opens your workbook and tries to copy a range of cells by pressing CTRL+C only to find that instead of copying the data, Excel deletes it!

To avoid this problem, you should generally choose the CTRL+SHIFT combination (upper case alphabetic characters) instead. If you do select a shortcut key with only the CTRL key, avoid the following letters:

- b—Bold
- c—Copy
- f—Find
- h—Replace
- i—Italics
- n—New workbook
- o—Open workbook
- p—Print
- s—Save
- u—Underline
- v—Paste
- w—Close workbook
- x—Cut
- y—Redo/repeat
- z—Undo

Because of its powerful capabilities, the macro has attracted an inordinate amount of publicity over its exposure to computer viruses (that is, macro viruses). To protect users, Microsoft has redeveloped the architecture of the security components in the Office suite of applications. One of the changes is that the standard Excel workbook does not permit you to store any macros. Any workbook containing a macro must be stored as an Excel Macro-Enabled Workbook. If you do try to save a workbook containing a macro as a standard workbook, the following warning message is displayed.

You must choose to continue saving the workbook as a standard workbook without the macros, or click No and change the workbook type to a macro-enabled workbook.

**Note:** The macro protection feature in Excel only detects the presence of macros in a workbook. It cannot determine if a macro contains a virus. You must use antivirus software to detect and remove macro viruses.
Learn to create a basic macro

This exercise demonstrates how to create a basic macro and execute it using the shortcut key.

1. Open the *Balance Sheet Macro* workbook. Do not save this workbook yet.

2. Select cell B5 and then, on the View tab, in the Macros group, click the drop-down arrow below Macros, and click `Record Macro`.

3. In the Macro name text box, type: **Title** and press TAB to move to the Shortcut key text box,

4. Hold the SHIFT key and type: **A**, then release the SHIFT key and click `OK`.
   Notice that the shortcut key changes from just **Ctrl+** to **Ctrl+Shift+**.

**Hint:** If you enter a lower case alphabetic character (that is, a to z), you only need to use the CTRL key to activate the macro. If you enter an upper case letter (A to Z), you must use both the CTRL and SHIFT keys to activate the macro. The Shortcut key indicator will change if you enter an uppercase letter.

At the left end of the Excel Status Bar, the macro indicator is displayed. By pointing at it, you will see the current macro state.

Starting from this point on, any actions that you perform on the workbook will be recorded in the macro.

5. On the Home tab, in the Font group, click **Bold**. Then in the Alignment group, click **Center**.

6. On the View tab, in the Macros group, click the drop-down arrow below Macros and then click **Stop Recording**.

Now try out the macro.

7. Select cell A6 and then press **CTRL+SHIFT+A**.

8. Repeat step 1 for cells A13 and A18.

Create another macro to format a range of cells as numbers.

9. Click the on the Excel Status Bar to open the Record Macro dialog box again.

10. In the Macro name text box, type: **Numbers**, TAB to the Shortcut key text box, hold the SHIFT key and type: **N** and then click `OK`.

11. Select cells B7:B11 and then, on the Home tab, in the Number group, click the Number Format dialog box launcher.

12. In the Format Cells dialog box, select the Number category and reduce the Decimal places to **0**. Then click the Use 1000 Separator (,) check box to turn it on and click `OK`.

13. Click the on the Excel Status Bar to stop the macro recording.

Now perform the same formatting for a range of cells in column D. And for demonstration purposes, let’s undo the formatting for cells B7:B11 (the Undo does not affect the macro you had created).
14 Click **Undo**.

15 Select cells **D7:D11** and then press CTRL+SHIFT+N.

Notice that the formatting was performed again for the cell range **B7:B11**. This macro will only work on those cells because they were selected while the macro was being recorded. As a result, the macro will not apply formatting to other cells in the workbook.

You can fix this problem easily using one of two methods. Select all cells before recording a macro. This is usually the easier method; or use the Relative Reference option button while recording the macro.

16 Select cells **B7:B11** if necessary. Then on the Home tab, in the Editing group, click **Clear**, and click **Clear Formats**.

17 On the View tab, in the Macros group, click the drop-down arrow below Macros, and then click **View Macros**.

**Note:** You can also run a macro by clicking the **Run** button from this dialog box. If you do not assign a shortcut key or assign your macro to the Quick Access Toolbar, this will be the only way to run it.

18 Select the **Numbers** macro and click **Delete**.

Excel displays a message box with the warning “**Do you want to delete macro Numbers?**”

19 Click **Yes**.

Create the macro again and test it on the cell range in column D again.

20 With cells **B7:B11** still selected, click the on the Excel Status Bar to open the Record Macro dialog box.

21 In the Macro name text box, type: **Numbers** and then click **OK**.

22 On the Home tab, in the Number group, click the **Number Format** dialog box launcher.

23 In the Format Cells dialog box, select the **Number** category, reduce the Decimal places to 0. Click the **Use 1000 Separator (,)** check box to turn it on and click **OK**.

24 Click the on the Excel Status Bar to stop the macro recording.

Assume now that you had forgotten to specify the shortcut key for the macro. You can modify your macro without re-recording it.

25 On the View tab, in the Macros group, click the drop-down arrow below **Macros**, and then click **View Macros**.

26 With the **Numbers** macro selected, click **Options**.

27 In the Macro Options dialog box, type: **n** in the Shortcut key text box, then click **OK**.

28 Click **Cancel** to close the Macro dialog box.

Now test out your macro.

29 Select cells **D7:D11** and then press CTRL+N (you do not need the SHIFT key because you did not use it when defining your shortcut key for this macro.)
Save the workbook.

30 Click **File**, click **Save As**, and save as **Balance Sheet Macro - Student**.

31 Click **Save**.

Excel displays a warning message stating that your workbook contains a VB project and therefore can't be saved as a macro-free workbook. Change the workbook type to a macro-enabled workbook.

32 Click **No**.

33 In the Save As screen/dialog box, change the Save as type to **Excel Macro-Enabled Workbook**, and click **Save**.

34 Close the workbook.

35 Open the **Balance Sheet Macro - Student** workbook again.

A security warning is displayed to inform you that this workbook contains a macro. Since you know you created this workbook, you can assume that it is still safe to use.

36 Click **Enable Content** in the Security Warning bar.

37 Select cells **B14:B16** and then press CTRL+N.

38 Save and close the workbook.

If you open this workbook again on this computer, Excel will no longer display the security warning message. By clicking the **Enable Content** button, you have tagged the workbook as "safe". Other users will still see the security warning message if they open this workbook for the first time.
Copy Macros

Objective 1.1.2

As described above, workbook macros are created in each individual workbook. As a result, they are accessible only in the workbook where they are created. If you store your commonly-used macros in your Personal Macro Workbook, they will be accessible in all your workbooks. But to safeguard yourself against unwanted macro viruses, you may prefer to avoid using a Personal Macro Workbook and restrict your use of macros to individual workbooks.

To save yourself time and effort entering every macro from scratch into every workbook, you can simply copy them from one workbook to another using the Visual Basic Project Explorer.

Learn to copy a macro from a workbook

This exercise demonstrates how to copy a macro from one workbook to another workbook.

1  Open the Romance At Sea workbook. Note that it contains a macro and was therefore saved as a macro-enabled workbook.

2  This worksheet was saved as a macro-enabled workbook and requires you to click Enable Content to enable the macro in this workbook.

3  Select the cell range A5:D13.

4  On the View tab, in the Macros group, click Macros.

5  Select the macro listed in this dialog box, and click Run.

6  Click any blank cell away from this cell range to see the results of the macro.

Enable the Developer tab if it is not displayed so you can then display the Visual Basic window.

7  Open the Hawaiian Adventure workbook.

8  On the Developer tab, in the Code group, click Visual Basic.

9  If necessary, click View, then click Project Explorer to ensure this pane is displayed on the left side of the Microsoft VBA window:
If necessary, click the **Open Tree** (+) icon at the *VBAPr0ject (Romance At Sea.xlsm)* and **Modules** level to open them up.

Double-click on **Module1** under VBAProject (Romance At Sea.xlsm) to open this VB code window.

Click the **Module1** under *VBAPr0ject (Romance At Sea.xlsm)*, and drag it to the *VBAPr0ject (Hawaiian Adventure.xlsx)*.

Click the **Open Tree** (+) icon for the newly created **Modules** tree under *VBAPr0ject (Hawaiian Adventure.xlsx)*, and double-click **Module1** to view its contents.

An identical copy of the macro is now in the Hawaiian Adventure workbook.

In the Microsoft Visual Basic for Applications window, click **File**, then click **Close and Return to Microsoft Excel**.

Save the Hawaiian Adventure workbook as a macro-enabled workbook.

With the Hawaiian Adventure workbook as the active workbook, click **File**, click **Save As** and save as **Hawaiian Adventure - Student**.

In the Save As dialog box, click the Save as type drop-down button, select **Excel Macro-Enabled Workbook**, and click **Save**.
Test the macro in the Hawaiian Adventure workbook thoroughly by closing it, and then opening it again, as if it is being used by other users.

17 Close all worksheets without saving any changes.
18 Open the Hawaiian Adventure - Student workbook, and click Enable Content to enable the macro.

Run the macro to verify it works in this workbook.

19 Select the cell range A5:D22.
20 On the View tab, in the Macros group, click Macros. Click View Macros.
21 Select the macro listed in this dialog box, and click Run.
22 Click any blank cell away from this cell range to see the results of the macro.

The screen should look similar to the following example:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Toluca Adventures</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Hawaiian Adventure Cruise Itinerary</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Day</td>
<td>Port</td>
<td>Arrive</td>
</tr>
<tr>
<td>5</td>
<td>Day 1</td>
<td>San Diego, California</td>
<td>5:00 PM</td>
</tr>
<tr>
<td>6</td>
<td>Day 2</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Day 3</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Day 4</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Day 5</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Day 6</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Day 7</td>
<td>Lahaina, Hawaii</td>
<td>10:00 AM</td>
</tr>
<tr>
<td>12</td>
<td>Day 8</td>
<td>Honolulu, Hawaii</td>
<td>7:00 AM</td>
</tr>
<tr>
<td>13</td>
<td>Day 9</td>
<td>Nawiliwili, Kauai, Hawaii</td>
<td>8:00 AM</td>
</tr>
<tr>
<td>14</td>
<td>Day 10</td>
<td>Kona, Hawaii</td>
<td>8:00 AM</td>
</tr>
<tr>
<td>15</td>
<td>Day 11</td>
<td>Hilo, Hawaii</td>
<td>8:00 AM</td>
</tr>
<tr>
<td>16</td>
<td>Day 12</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Day 13</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>Day 14</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>Day 15</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Day 16</td>
<td>At sea</td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Day 17</td>
<td>Ensenada, Mexico</td>
<td>Noon</td>
</tr>
<tr>
<td>22</td>
<td>Day 18</td>
<td>San Diego, California</td>
<td>7:00 AM</td>
</tr>
</tbody>
</table>

23 Save and close the workbook.

Adding Form Controls

Objective 2.3.5

Printed forms are often associated with large government bureaucracies. In reality, well-designed forms help reduce data entry errors. For example, the date March 8, 2016 can be entered as 3/8/2016 or 8/3/2016. If you are buying train tickets in a foreign country, you need to be sure that you are entering the date correctly.

Excel allows you to create forms by adding controls that will help reduce the number of data entry errors. A control is an object that can display data, allow users to enter data, select from a limited range of options, or perform an action.
The Insert button in the Developer tab allows you to add a variety of controls, that are grouped into form controls and ActiveX controls. Form controls are objects that experienced Excel users are familiar with; they have been a mainstay for Excel form designers since 1993. ActiveX controls perform the same function as traditional form controls but are more powerful because you can add VBA code to perform additional tasks and you can modify their look and behavior.

Note that three of the form controls in this drop-down menu are grayed out but become available when creating a dialog box. These controls are inactive when building a form on a worksheet.

To add a control to the worksheet, click on the icon in the drop-down menu, and then click and drag the size and shape of the control on the worksheet. Some of the controls are created with a default label—such as button 01—which can be changed. You then use the Format Control dialog box to link a control to a worksheet cell or a macro.

The Format Control dialog box allows you to display the properties of a form control. The settings are grouped into various tabs, as follows:

<table>
<thead>
<tr>
<th>Font</th>
<th>Allows you to configure the font settings (for example, font, style, size, color) for the text. This tab does not appear for all controls.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alignment</td>
<td>Allows you to set the text alignment settings, such as horizontal and vertical placement, and orientation. This tab does not appear for all controls.</td>
</tr>
<tr>
<td>Size</td>
<td>Set the size, rotation, and scale of the control on the worksheet. You can also adjust the size of the control by using the mouse.</td>
</tr>
<tr>
<td>Protection</td>
<td>Allows you to unlock the control on a worksheet so users can access it after the worksheet is protected.</td>
</tr>
</tbody>
</table>

The shapes, illustrations and photos in this file are either created in Microsoft Office or downloaded from public domain sources. The text within the file is created in Microsoft Word and is subject to the standard copyright protection.
Properties
Contains two settings. Object positioning allows the control to float with the worksheet cell or ensure that it stays in place if the cell is resized. Print object determines whether a control will be included if the worksheet is printed.

Margins
Allows you to set margins for the text within the control. This tab does not appear for all controls.

Alt Text
Specify the text you want shown if you decide to publish the worksheet to the web. The web browser then displays this text while pictures are loading.

Control
Choose from various settings for each type of control, such as input range and link cell to a worksheet cell. This tab does not appear for all controls.

Adding Command Buttons
Objective 2.3.5

Command buttons are familiar, clickable objects. You can set a command button to execute a macro when a user clicks the button. Using a command button to launch a macro (like setting a shortcut key) is simply a way to make a macro convenient and easy to use. You can also enter a label to be displayed on the face of the command button to quickly describe its purpose to users.

Learn to add a command button to a worksheet

This exercise demonstrates how to add a command button to a worksheet.

1 Open the Travel Quote Form Command Button workbook and save as Travel Quote Form Command Button – Student. Change the file type to be Macro-Enabled Workbook (even though it does not have any defined macros as of yet).

This worksheet is intended to allow customers to request pricing and other travel information from Tolano Adventures. You start with a basic pre-formatted worksheet and then add various form controls to simplify and limit what customers can enter into the form.

The actual form is in the cell range A1:I19. Normally the data you see in columns K and L would be in different, hidden worksheets that customers cannot access. Once you complete the form, your staff will use the data in the cell range K2:L11 to process the request. They will use the rest of the data in the two columns as lookup values (this will be explained in subsequent exercises).
If the Developer tab is not displayed in the Ribbon, click File, Options, and then click the Customize Ribbon tab. Click the Developer check box in the right-side list to turn it on and then click OK.

Now create a macro to which you will later add a command button.

3. On the Developer tab, in the Code group, click Record Macro.

4. In the Record Macro dialog box, change the Macro name to SetToday, and click OK.

5. Select cell B4 and then, on the Home tab, in the Clipboard group, click Copy.

6. Select cell G6 and then, on the Home tab, in the Clipboard group, click Paste. Then press ESC to turn off the copy mode.

7. On the Developer tab, in the Code group, click Stop Recording.

8. Select cell G6 if necessary and press DELETE.

Finally, you can create the command button for the form.

9. On the Developer tab, in the Controls group, click Insert, and then click Button (Form Control) (1st row, left-most icon).

10. Click and drag a rectangular box that covers all of cell G7.

11. In the Assign Macro dialog box, select the SetToday macro. Click OK.
Note: If you created the command button before creating the macro, you can click the Cancel button now. You can then create your macro and assign it to the button later.

Put your own custom label on this button. Be sure to use a short text label that clearly explains the purpose of this button.

12 Right-click the new command button and click Edit Text.

13 Replace the current text with: Set Today and then click an empty cell elsewhere on the worksheet.

Test the button to ensure that it works.

14 Click the Set Today command button.

The worksheet should now look something like the following (except for the actual dates displayed):

The departure and return dates also show up in cells L8 and L9 now.

15 Save and close the workbook. Be sure that it is being saved as a macro-enabled workbook.
Spin Buttons and Scroll Bars

Objective 2.3.5

You can use spin buttons and scroll bars to increase or decrease numeric values in a cell with a mouse.

You use the Control tab in the Format Control dialog box to enter settings for these controls, which have almost identical characteristics. You can specify minimum and maximum values as well as the incremental change value. You must also link the control to a worksheet cell by entering the cell reference in the Cell link text box. When you click the spin button or scroll bar, the value in that linked cell will change.

The spin button icon is easy to understand: click the “up” part to increase the value in the linked cell or click the “down” part to decrease it.

A scroll bar also allows you to increase or decrease a value in a cell. With this type of control, you can specify a page change value in the Control tab, which allows users to increase or decrease the value faster than the increment and decrement value. Clicking in the gap between the elevator button and the increment or decrement button activates the page change. You can also increase or decrease by the same incremental change amount as you can by using a spin button.

Note that the increment and decrement buttons on the scroll bar and spin button are in reverse order, relative to each other.

Also note that both spin buttons and scroll bars limit you to a number range from 0 to 30,000; you cannot use negative numbers or numbers greater than 30,000.

Learn to add spin buttons and scroll bars

This exercise demonstrates how to add and use a spin button and a scroll bar to a worksheet.

1. Open the Travel Quote Form Spin Button workbook and save as Travel Quote Form Spin Button - Student. Click the Enable Content button to close the security warning bar.

2. On the Developer tab, in the Controls group, click Insert, and then click Spin Button (Form Control) (top row, 4th icon from the left).
3. Click and drag a small box at the left side of cell C7.

4. With the handles still appearing around the spin button, right-click the spin button and click **Format Control** from the menu.

5. Click the **Control** tab and change the following values in the dialog box:
   - Minimum value: 1
   - Maximum value: 100

6. Click in the Cell link text box, click in cell B7 to select it, and click **OK**.

7. Click an empty cell elsewhere on the worksheet to remove the handles around the spin button.

8. Click the up and down buttons in the spin button to get the highest and lowest numbers possible in cell B7.

   With the spin button now added, the number of travelers now appears in cell L4.

Now add a scroll bar for the travel-duration value.

9. Add a scroll bar (2nd row, 3rd icon) to the left side of the cell range H8:H11 and link it to cell G9. Set the minimum value to 1 and the maximum value to 365.

10. Click various parts of the scroll bar and observe how the value in cell G9 changes.

   While you are using the scroll bar, notice how the return date in cell H6 is changing because the formula in that cell is adding together the date in cell G6 with the number in cell G9.

The worksheet should now look something like the following:

11. Save and close the workbook.
Check Boxes and Option Buttons

Objective 2.3.5

Checkboxes and option buttons can also be linked to worksheet cells to display choices for selection by the user. Checkboxes return only a true or false value while option buttons return values of 0 or 1. Toggle buttons are available only as ActiveX controls and function like checkboxes by returning values of true or false. These controls are useful in situations where you are interested in binary values, such as yes or no, on or off. You can then use another worksheet cell containing an IF function to perform further calculations.

Checkboxes and option buttons work very well as standalone objects. When a user clicks one of them, the value returned is either true or false and clicking it again simply reverses that value.

Option buttons work well only when used inside a group box (described in more detail later). Unlike checkboxes and toggle buttons, once you turn an option button “on,” you cannot turn it “off.”

Learn to add check boxes and option buttons

This exercise demonstrates how to add and use check boxes and option buttons on a worksheet

1. Open the Travel Quote Form Check Box workbook and save as Travel Quote Form Check Box - Student. Click the Enable Content button to close the security warning bar.

2. On the Developer tab, in the Controls group, click Insert, and then click Option Button (Form Control) (top row, far right).

3. Click and drag a rectangular box from the top edge of cell A18 to the right edge of B18.

4. With the handles still visible, right-click the option button and click Edit Text.

5. Delete the default text, and type: Prefer non-stop flights.

6. Click an empty cell elsewhere on the worksheet to exit from the Edit Text mode.

7. Right-click the option button again and click Format Control.

8. Click the Control tab, click in the Cell link text box, then select cell L7, and click OK.

Note: If you reverse the sequence by entering the Cell link cell reference value before changing the text label in step 4 above, the Edit Text option will no longer appear in the right-click menu.

9. Click an empty cell elsewhere on the worksheet to remove the handles around the option button.

10. Click the option button to turn it on and observe the change in cells L7 and M7.

    Note that the formula in cell M7 (and other cells in column M) was previously set up specifically for this exercise. Excel does not create it for you automatically when you add an option button control.

11. Try to turn the option button off. You will notice that you cannot turn the option button off once it has been selected.

    The Group Box option will be demonstrated later in this lesson as a more common substitute for the standalone option button.

Now add a check box for a different question.
12 On the Developer tab, in the Controls group, click **Insert**, and then click **Check Box (Form Control)** (top row, 3rd icon).

13 Drag a rectangular box from the left edge of cell F11 to the middle of G11.

14 Right-click the check box and click **Edit Text**.

15 Delete the default text and type: **Travel dates are flexible.**

16 Click an empty cell elsewhere on the worksheet to exit from the Edit Text mode.

17 Right-click the check box again and click **Format Control**.

18 Click the **Control** tab, click in the Cell link text box, select cell L10, and click **OK**.

19 Click an empty cell elsewhere on the worksheet to remove the handles around the option button.

20 Click the check box to turn it on, and observe the change in cells L10 and M10.

21 Click the check box again to turn it off, and observe the change in cells L10 and M10, and then turn it back on again.

The worksheet should now look something like the following:

![Worksheet Example](image)

22 Save and close the workbook.

### List Boxes and Combo Boxes

**Objective 2.3.5**

You can use both list boxes and combo boxes to allow users to select from a list of choices. If you have more items than space available, Excel also displays a vertical scroll bar so that users can view more choices. For both controls, you use a range of cells elsewhere in your workbook to store the list of choices to display. When you create the controls, you reference this cell range as your input range. This design is very flexible and easy to use; if you need to change the choices available, you need only change the values in the cell range that you have referenced as your input range. If there are more or fewer choices, you just change the input range values in the Format Control dialog box. Also, for both controls, the linked cell receives a number indicating the position of the selected item in the list; for example, if the user selects the fifth item in the list, the control puts the number 5 into the linked cell.
A combo box displays the list of items only when the user clicks the drop-down arrow button.

After you select a value, Excel hides the list again. This is very useful when trying to conserve valuable space on a crowded form. Also, the combo box will allow the selection of only one item.

In the Format Object dialog box for the combo box (as seen here), you can set the number of items to display in the drop-down list—the default is 8.

Unlike the combo box, a list box allows the user to select more than one value from the list. However, you must set this option in advance in the Format Control dialog box. You should try to avoid allowing multiple selections because Excel will put a zero value into the linked cell, which removes your ability to detect what the user had selected.

For multiple selections, the Multi option allows the user to select or deselect an item in the list by clicking on it more than once; however, to the user must click each item individually. The Extend option allows the user to select multiple items using the click-and-drag technique.

The number of items displayed in the list box is determined by the size of the box.

### Learn to add a list box and a combo box

This exercise demonstrates how to add and use a list box and a combo box on the worksheet.

1. Open the *Travel Quote Form List Box* workbook and save as *Travel Quote Form List Box - Student*. Click the Enable Content button to close the security warning bar.

2. On the Developer tab, in the Controls group, click Insert and then click List Box (Form Control) (top row, 5th icon).

3. Click and drag a rectangular box around the outer edges of the cell range B9:D11.

4. Right-click the list box and click Format Control.

5. In the Control tab, click in the Input range text box, then select the cell range K14:K26.

6. Click in the Cell link text box, select cell L5, and click OK.

7. Click an empty cell elsewhere on the worksheet to remove the handles around the list box.

8. Scroll around inside the list box, select different destinations, and observe the results in cells L5 and M5. Click cell M5 and note the formula used to display the value.

Now add a combo box for another set of options.
9 On the Developer tab, in the Controls group, click **Insert**, and then click **Combo Box (Form Control)** (top row, 2nd icon).

10 Click and drag a rectangular box from the left edge of cell G13 to the right edge of **H13**.

11 Right-click the combo box and click **Format Control**.

12 In the Control tab, click the Input range text box, and select the cell range **K29:K35**.

13 Click in the Cell link text box, select cell **L11**, and click **OK**.

14 Click an empty cell elsewhere on the worksheet to remove the handles around the combo box.

15 Click the combo box drop-down button and select an option of your choice. Observe the change in cells **L11** and **M11**.

**Note:** You can also use a pick list as an alternative to a combo box or list box. Pick lists are explained in a later topic in this lesson.

The worksheet should now look similar to the following:

16 Click cells **M5** and **M11**.

Both cells contain an IF function nested with an INDEX function inside. These formulas are used to perform a lookup task using the same cell range as the list box and combo box that you have just added. For example, the list box uses the cell range K14:K26 as its input range of values to display. If you select the bottom-most destination in the list box, it will put the value 13 into cell L5. The INDEX function in cell M5 will search down the cell range K14:K26 and display the 13th value in that list: “Anywhere warm”, which is the same item selected in the list box.

17 Save and close the workbook.
Group Box

Objective 2.3.5

A group box is an alternative to using a combo box or list box to allow users to select an option from a group of choices.

In some ways, a group box is easier to use and more aesthetically pleasing than combo boxes and list boxes because all the options are visible. You can also choose to use either check boxes or option buttons inside the group box for the individual selections.

When used inside a group box, checkboxes and option buttons behave differently because they now work together as a group. When you click a checkbox that is outside a group box, the value is placed into a linked worksheet cell. Clicking that check box more than once flips the value, and clicking on other check boxes on the worksheet does not affect it. However, when you click a checkbox that is inside a group box, all other checkboxes in the same group box are turned off. Also, the entire group box has only one linked worksheet cell. In the example group box below, there are four option buttons. You can make only one choice for travel type, and that one choice is entered into one worksheet cell.

One disadvantage of using group boxes is lack of flexibility in making changes. For example, if you want to add a new travel type to the group box above, you have to redesign it by making it bigger and adding another option button. Another disadvantage is that group boxes often take a lot of space on the worksheet.

Learn to add a group box

This exercise demonstrates how to add and use a group box on the worksheet.

1. Open the Travel Quote Form Group Box workbook and save as Travel Quote Form Group Box - Student.
2. Click the Enable Content button to close the security warning bar.
3. On the Developer tab, in the Controls group, click Insert, and then click Group Box (Form Control) (second row, 1st icon).
4. Click and drag a rectangular box in the cell range A13:D17.
5. Right-click any of the edges of the group box and click Edit Text.
6. Delete the default label and replace it with: Travel Type.
7. Click an empty cell elsewhere on the worksheet to remove the handles around the group box.
8. On the Developer tab, in the Controls group, click Insert, and then click Option Button (Form Control) (top row, far right).
9. Click and drag a small rectangular box in the upper left area of the group box (cell A14).
10. Right-click the option button and click Edit Text.
11. Delete the default text and type: Flight.
11 Click an empty cell elsewhere on the worksheet to exit from the Edit Text mode.

12 Repeat steps 1 to 5 to add three more option buttons with the labels: **Hotel**, **Car rental**, and **Cruise**. Place these option buttons in any position inside the group box, but be sure to add them in this sequence (the reason for this will become obvious soon).

13 Right-click an option button and then click one of the edges. Click and drag the option button to where you want it to be. Repeat for other option buttons in the group box.

14 Resize the group box as necessary.

**Note:** The arrow keys on your keyboard (for example, the LEFT or RIGHT arrow direction keys) are an easy way to move the controls around.

15 Right-click one of the option button controls within the group box and click **Format Control**.

16 Click in the **Cell link** text box, select cell L6, and click **OK**.

17 Click an option button inside the group box and observe the change in cells L6 and M6.

18 Click the other three option buttons in the group box.

Notice that clicking on any option button will cause the previously selected option button to be deselected. Excel displays the value in cell L4 from the list in the cell range K38:K41.

The worksheet should now appear similar to the following:

19 Save and close the workbook.

**Text Boxes**

**Objective 2.3.5**

You can add text boxes to a worksheet only as ActiveX controls. It will usually be more practical to simply use a worksheet cell to enter data instead of using a text box.

However, because a text box is an ActiveX control, you can place it anywhere on the worksheet—it does not need to be tied to the rigid structure of rows and columns. Because it is an ActiveX control, you can also add characteristics such as setting the maximum number of characters and executing VBA code to hide the entry as a password.

Unlike with form controls, you enter custom settings for ActiveX controls in the Properties window.
Lesson 6

Data Filtering, Macros, and Forms

Learn to add a text box to a form

This exercise demonstrates how to add a text box to a form and convert the worksheet into a working form.

1. Open the Travel Quote Form Text Box workbook and save as Travel Quote Form Text Box – Student. Click the Enable Content button to close the security warning bar.

2. On the Developer tab, in the Controls group, click Insert, and then click Text Box (ActiveX Control) (3rd row, 5th icon from the left) in the ActiveX Controls section.

3. Click and drag a rectangular box encompassing the outer edges of cells B6 to D6.

4. Right-click the text box and click Properties.

Note: Alternatively, you can display the properties window by clicking Properties in the Controls group on the Developer tab.

5. In the Properties dialog box, click twice in the LinkedCell text field—once to select that field and the second time to put the cursor into the empty text field.

6. Type (do not select this cell on the worksheet with your mouse): L3 and press ENTER.

7. Close the Properties dialog box.

Test this text box by entering some data into it. Before you can use the field, you must turn off the design mode toggle switch.

8. On the Developer tab, in the Controls group, click Design Mode to toggle it off.

9. Click inside the text box and enter your own name.
Your name now appears in cell L3 as well.

The text box is a little too short. You can make it taller.

10 On the Developer tab, in the Controls group, click **Design Mode** to toggle it back on.

11 Click the text box to select it and drag the middle resizing handle on the top edge in an upwards direction. Release the handle when the text box is tall enough.

The form is now complete with all the controls that you need.

Because this form will be used by others, you should enable worksheet protection. You will need to unlock the controls and their linked cells first.

12 Hold CTRL and then click each of the following controls:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Control</th>
</tr>
</thead>
<tbody>
<tr>
<td>B6</td>
<td>text box</td>
</tr>
<tr>
<td>C7</td>
<td>spin button</td>
</tr>
<tr>
<td>B9</td>
<td>list box</td>
</tr>
<tr>
<td>A14</td>
<td>option button (any one of them) inside the group box</td>
</tr>
<tr>
<td>A18</td>
<td>option button (stand-alone)</td>
</tr>
<tr>
<td>G7</td>
<td>command button</td>
</tr>
<tr>
<td>H8</td>
<td>scroll bar</td>
</tr>
<tr>
<td>F11</td>
<td>check box</td>
</tr>
<tr>
<td>G13</td>
<td>combo box</td>
</tr>
</tbody>
</table>

13 Release CTRL and then right-click any of the selected controls again and click **Format Object**.

14 In the **Protection** tab, click the **Locked** check box to turn it off, and click **OK**. This change will be applied to all the controls selected in step 1.

15 Click an empty cell in the worksheet to de-select all controls.

16 Toggle the **Design Mode** off again so that you can use the text box.

Unlock the other input cells as well.

17 Select the cell range **L2:L11**. Hold CTRL, left-click on cells B7, G6, G9, and release CTRL.

18 Right-click any of the selected cells and click **Format Cells**.

19 In the Protection tab, click the **Locked** check box to turn it off. Click **OK**.

To make the worksheet look like a form, turn off the gridlines and row and column headings.

20 On the Page Layout tab, in the Sheet Options group, click **Gridlines View** and **Headings View** check boxes to turn both off.
On the Review tab, in the Changes group, click **Protect Sheet**. In the Protect Sheet dialog box, click the **Select locked cells** check box to turn it off, and then click **OK** to activate worksheet protection.

Click various cells and controls on this form and make changes of your choice.

The completed worksheet form should look similar to the following:

![Tolano Adventures Travel Quote Request](image)

Save and close the workbook.

**Changing Excel Formula Calculation Options**

**Objective 1.2.3**

Excel provides many options and settings that customize how it behaves in a specific workbook or in all workbooks.

The Formulas tab of the Excel Options dialog box has two settings that affect how formulas and calculations are performed:

- **Workbook Calculation**
  - When PCs were first introduced, spreadsheets required a large amount of processing power to complete all calculations. On spreadsheets with many formulas, calculation was often set to Manual. Otherwise, the user would have to wait several seconds after updating each cell. Because the abundant processing power of today’s computers makes the waiting time nearly impossible to notice, the default setting of Automatic is usually used.
Enable iterative calculation

Most Excel formulas require only one calculation to reach completion. Some types of calculations, such as circular references and formulas that result in a loop, require that formulas be recalculated several times. Some highly specialized applications – such as scientific applications – may require a very large number of recalcuations. For these formulas, you can specify the maximum number of iterations to prevent Excel from recalculating endlessly.

Learn to change calculation options

This exercise demonstrates the effect on workbook calculations when Excel calculation options are changed.

1. Create a new blank workbook.
2. Click File, then click Options. In the Excel Options window, click Formulas, click the Manual option button, and click OK to save this setting.

**Note:** You can also change this setting on the Formulas tab, in the Calculation group, click Calculation Options, and then click Manual.

3. Click in cell A1 and enter: 1.

Cell B1 now shows the value 11, which is correct.

5. Click in cell A1 and enter: 10

Cell B1 has not changed to 20, which is what you would expect if Excel were performing the calculations automatically. You will need to manually push Excel to recalculate the formula.

6. Press the F9 key. Cell B1 now shows the correct value.

**Note:** Alternatively, you could also force Excel to perform the calculation by clicking Calculate Now in the Calculation group on the Formulas tab.

Before closing the workbook, change the default back to automatic calculations.

7. On the Formulas tab, in the Calculation group, click Calculation Options, and click Automatic.

8. Close the workbook and discard the changes.

Now examine an interesting workbook that uses circular references to perform the necessary calculations.

9. Open the Sudoku Solver workbook and save it as Sudoku Solver – Student.
In normal circumstances, workbooks should not contain circular references. This workbook is designed to use circular references to solve Sudoku puzzles.

10 Click OK to close the message, and then and save the file again.

11 Select cell H26 (Game state). Click in that cell again to display the drop-down list, and select 1. Now press the F9 key to force Excel to make the next calculation.

Because of the presence of circular references — there are many on this worksheet — Excel automatically stops whenever it encounters one. An example of a circular reference is where cell A1 contains the formula \(=B1+10\) and cell B1 contains the formula \(=A1+10\). Because these two cells reference each other (in some cases, cells may indirectly reference each other through other cells), Excel could perform these calculations in a never-ending circle. Therefore, Excel is normally set to stop when it encounters a circular reference.
12 Press the F9 key, and continue pressing it several more times—as many as you have patience for.

Every time you press the F9 key, Excel performs the calculation and moves on to the next cell that requires recalculation. Excel displays a different blue line to show the circular reference between those two cells—and then it stops again.

Instead of continuing to hold down the F9 key, you can tell Excel to ignore its setting to stop on circular references and proceed with the calculations up to a limit that you specify.

13 Click the File tab and then click Options.

14 Click the Formulas tab in the Excel Options dialog box.

Enable the iterative calculation switch but reduce the maximum number of iterations down to 2 for this exercise so that you can see the partial results. (If you leave the number at the default of 100, the entire puzzle will be solved in about 12 iterations.)

15 Click the Enable iterative calculation check box to turn it on, reduce the Maximum Iterations to: 2, and click OK.

Excel has done the first two full iterations and the solution board is now partially complete.

16 Press the F9 key again several times until the solution board is completed. It should take five repeated presses of the F9 key.

The completed worksheet should now look something like the following, with the solved puzzle in the lower left side of the worksheet.

You can use this workbook to help you solve your own Sudoku puzzle, but more complex puzzles will require more iterations.

Now that this exercise is completed, you need to change the iteration options back to the default before moving on to a non-Sudoku solver workbook.
Lesson 6

17 Click File and then click Options. Click the Formulas tab in the Excel Options dialog box.

18 Click the Enable iterative calculation check box to turn it off, increase the Maximum Iterations to: 100, and click OK.

19 Click OK to close the circular reference warning message box.

20 Save and close the workbook.

Lesson Summary

You should now be able to:
☑️ use the Fill Series feature
☑️ use advanced filter options and different comparison operators to search for data
☑️ create, modify, and delete custom workbook templates
☑️ access hidden Ribbon tabs
☑️ create and use macros
☑️ save and open workbooks containing macros
☑️ copy macros from one workbook to another
☑️ add form controls to a worksheet, including command buttons, spin buttons, scroll bars, check boxes, option buttons, combo boxes, list boxes, group boxes, and text boxes
☑️ change excel formula calculation options

Review Questions

1. Which of the following is an advantage of using the Fill Series feature as opposed to the AutoFill feature?
   a. The Fill Series feature lets you apply formatting as you fill the range.
   b. The Fill Series feature gives you control over how much to increment each subsequent cell.
   c. The Fill Series feature automatically inserts Quick Analysis Data Bars.
   d. The Fill Series feature allows to select from up to 3 scenarios as you fill the range.

2. Which of the following elements can you configure in the Fill Series dialog box?
   a. Type  
   b. Data unit  
   c. Step value  
   d. All elements can be configured in the Fill Series dialog box.

3. Which of the following statements regarding workbook templates is true?
   a. A workbook template is a regular workbook that has been saved with the .xltx filename extension.
   b. A workbook template is a read-only file.
   c. A workbook template can be used only once; after that it must be re-created.
   d. All of these statements regarding workbook templates are true.

4. Angela cannot see the Developer tab in Excel. What can she do?
   a. Adjust the Excel security settings to make the Developer tab visible.
   b. Upgrade from Office Home Premium to Office Professional.
   c. Customize the Ribbon to show the Developer tab.
   d. Download and install the free Developer COM add-in.
5. Dean created several macros in his TaxPrep-2016 workbook. How can he use these macros in his TaxPrep-2017 workbook?
   a. He should export each macro to the VBA project named SharedMacros.
   b. He should copy his macros from the 2016-version of his workbook to the 2017-version of the workbook.
   c. He should save his 2016-version of the workbook over the 2017-version, and replace the 2016 data with 2017 data.
   d. He should re-create the 2016-version macros in his 2017-version workbook.

6. A macro is:
   a. available only after you have enabled it using the Excel Add-In tool.
   b. intimidating because of the complex code you must enter accurately.
   c. stored as a VBA program.
   d. All of these statements regarding macros are true.

7. A workbook containing a macro must be saved as a macro-enabled workbook.
   a. True   b. False

8. Spin buttons and scroll bars can be used with a data range of:
   a. 0 to 30,000. c. -100 to 100
   b. -10 to 0. d. There are no data range limits for spin buttons or scroll bars.

9. Which of the following statements accurately describes check boxes that are inside a group box on a form?
   a. Clicking one check box in the group has no effect on the other check boxes in the group.
   b. Each check box within the group is linked to its own worksheet cell.
   c. All the check boxes within the group are linked to one single worksheet cell.
   d. You may select zero, one, or all the check boxes within the group.

10. Where can you specify the maximum number of iterations Excel will perform for interactive calculations?
    a. In the Data Tools group on the Data tab.
    b. In the Calculation group on the Formulas tab.
    c. In the Controls group on the Developer tab.
    d. On the Formulas tab of the Excel Options dialog box.
## Appendix A: Courseware Mapping

Skills required for the Microsoft® Office Specialist Excel 2016 Expert Exam 77-728:

<table>
<thead>
<tr>
<th>Objective Domain</th>
<th>Lesson</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Manage Workbook Options and Settings</td>
</tr>
<tr>
<td>1.1</td>
<td>Manage workbooks</td>
</tr>
<tr>
<td>1.1.1</td>
<td>save a workbook as a template</td>
</tr>
<tr>
<td>1.1.2</td>
<td>copy macros between workbooks</td>
</tr>
<tr>
<td>1.1.3</td>
<td>reference data in another workbook</td>
</tr>
<tr>
<td>1.1.4</td>
<td>reference data by using structured references</td>
</tr>
<tr>
<td>1.1.5</td>
<td>enable macros in a workbook</td>
</tr>
<tr>
<td>1.1.6</td>
<td>display hidden ribbon tabs</td>
</tr>
<tr>
<td>1.2</td>
<td>Manage workbook review</td>
</tr>
<tr>
<td>1.2.1</td>
<td>restrict editing</td>
</tr>
<tr>
<td>1.2.2</td>
<td>protect a worksheet</td>
</tr>
<tr>
<td>1.2.3</td>
<td>configure formula calculation options</td>
</tr>
<tr>
<td>1.2.4</td>
<td>protect workbook structure</td>
</tr>
<tr>
<td>1.2.5</td>
<td>manage workbook versions</td>
</tr>
<tr>
<td>1.2.6</td>
<td>encrypt a workbook with a password</td>
</tr>
<tr>
<td>2</td>
<td>Apply Custom Data Formats and Layouts</td>
</tr>
<tr>
<td>2.1</td>
<td>Apply custom data formats and validation</td>
</tr>
<tr>
<td>2.1.1</td>
<td>create custom number formats</td>
</tr>
<tr>
<td>2.1.2</td>
<td>populate cells by using advanced Fill Series options</td>
</tr>
<tr>
<td>2.1.3</td>
<td>configure data validation</td>
</tr>
<tr>
<td>2.2</td>
<td>Apply advanced conditional formatting and filtering</td>
</tr>
<tr>
<td>2.2.1</td>
<td>create custom conditional formatting rules</td>
</tr>
<tr>
<td>2.2.2</td>
<td>create conditional formatting rules that use formulas</td>
</tr>
<tr>
<td>2.2.3</td>
<td>manage conditional formatting rules</td>
</tr>
</tbody>
</table>
## Objective Domain

<table>
<thead>
<tr>
<th>Lesson</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.3.1</td>
<td>create custom color formats</td>
</tr>
<tr>
<td>2.3.2</td>
<td>create and modify cell styles</td>
</tr>
<tr>
<td>2.3.3</td>
<td>create and modify custom themes</td>
</tr>
<tr>
<td>2.3.4</td>
<td>create and modify simple macros</td>
</tr>
<tr>
<td>2.3.5</td>
<td>insert and configure form controls</td>
</tr>
<tr>
<td>2.4.1</td>
<td>display data in multiple international formats</td>
</tr>
<tr>
<td>2.4.2</td>
<td>apply international currency formats</td>
</tr>
<tr>
<td>2.4.3</td>
<td>manage multiple options for +Body and +Heading fonts</td>
</tr>
</tbody>
</table>

## Create Advanced Formulas

<table>
<thead>
<tr>
<th>Lesson</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1.1</td>
<td>perform logical operations by using AND, OR, and NOT functions</td>
</tr>
<tr>
<td>3.1.2</td>
<td>perform logical operations by using nested functions</td>
</tr>
<tr>
<td>3.1.3</td>
<td>perform statistical operations by using SUMIFS, AVERAGEIFS, and COUNTIFS functions</td>
</tr>
<tr>
<td>3.2.1</td>
<td>look up data by using the VLOOKUP function</td>
</tr>
<tr>
<td>3.2.2</td>
<td>look up data by using the HLOOKUP function</td>
</tr>
<tr>
<td>3.2.3</td>
<td>look up data by using the MATCH function</td>
</tr>
<tr>
<td>3.2.4</td>
<td>look up data by using the INDEX function</td>
</tr>
<tr>
<td>3.3.1</td>
<td>reference the date and time by using the NOW and TODAY functions</td>
</tr>
<tr>
<td>3.3.2</td>
<td>serialize numbers by using date and time functions</td>
</tr>
<tr>
<td>3.4.1</td>
<td>import, transform, combine, display, and connect to data</td>
</tr>
<tr>
<td>3.4.2</td>
<td>consolidate data</td>
</tr>
<tr>
<td>3.4.3</td>
<td>perform what-if analysis by using Goal Seek and Scenario Manager</td>
</tr>
<tr>
<td>3.4.4</td>
<td>use cube functions to get data out of the Excel data model</td>
</tr>
<tr>
<td>3.4.5</td>
<td>calculate data by using financial functions</td>
</tr>
</tbody>
</table>
## Objective Domain

<table>
<thead>
<tr>
<th>Lesson</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>3.5</strong> Troubleshoot formulas</td>
<td></td>
</tr>
<tr>
<td>3.5.1</td>
<td>trace precedence and dependence</td>
</tr>
<tr>
<td>3.5.2</td>
<td>monitor cells and formulas by using the Watch Window</td>
</tr>
<tr>
<td>3.5.3</td>
<td>validate formulas by using error checking rules</td>
</tr>
<tr>
<td>3.5.4</td>
<td>evaluate formulas</td>
</tr>
<tr>
<td><strong>3.6</strong> Define named ranges and objects</td>
<td></td>
</tr>
<tr>
<td>3.6.1</td>
<td>name cells</td>
</tr>
<tr>
<td>3.6.2</td>
<td>name data ranges</td>
</tr>
<tr>
<td>3.6.3</td>
<td>name tables</td>
</tr>
<tr>
<td>3.6.4</td>
<td>manage named ranges and objects</td>
</tr>
<tr>
<td><strong>4</strong> Create Advanced Charts and Tables</td>
<td></td>
</tr>
<tr>
<td><strong>4.1</strong> Create advanced charts</td>
<td></td>
</tr>
<tr>
<td>4.1.1</td>
<td>add trendlines to charts</td>
</tr>
<tr>
<td>4.1.2</td>
<td>create dual-axis charts</td>
</tr>
<tr>
<td>4.1.3</td>
<td>save a chart as a template</td>
</tr>
<tr>
<td><strong>4.2</strong> Create and manage pivot tables</td>
<td></td>
</tr>
<tr>
<td>4.2.1</td>
<td>create PivotTables</td>
</tr>
<tr>
<td>4.2.2</td>
<td>modify field selections and options</td>
</tr>
<tr>
<td>4.2.3</td>
<td>create slicers</td>
</tr>
<tr>
<td>4.2.4</td>
<td>group PivotTable data</td>
</tr>
<tr>
<td>4.2.5</td>
<td>reference data in a PivotTable by using the GETPIVOTDATA function</td>
</tr>
<tr>
<td>4.2.6</td>
<td>add calculated fields</td>
</tr>
<tr>
<td>4.2.7</td>
<td>format data</td>
</tr>
<tr>
<td><strong>4.3</strong> Create and manage pivot charts</td>
<td></td>
</tr>
<tr>
<td>4.3.1</td>
<td>create PivotCharts</td>
</tr>
<tr>
<td>4.3.2</td>
<td>manipulate options in existing PivotCharts</td>
</tr>
<tr>
<td>4.3.3</td>
<td>apply styles to PivotCharts</td>
</tr>
<tr>
<td>4.3.4</td>
<td>drill down into PivotChart details</td>
</tr>
</tbody>
</table>
Appendix B: Glossary of Terms

Accessibility Checker tool – An Excel feature that inspects a workbook for data and objects that may have accessibility issues.

Active cell – The currently selected cell.

Alignment – The positioning of the contents of a cell; e.g. left, right, or centered.

AutoFill – A method of copying data and formulas or creating data series by dragging the lower right corner of a cell or range.

AutoFit – A feature that will automatically adjust the width of a column or the height of a row so that the cells are just wide or high enough to display the values in all of those cells.

AutoFilter – See Filter.

AutoFormat – A feature that enables you to apply many different formatting characteristics with a single command by choosing from a selection of format templates; see Cell Styles also.

AutoSum – A tool that will quickly insert a SUM function into the current cell, and determine the appropriate cell range to be used.

Backstage – Introduced in the Microsoft Office 2010 suite, replacing the Office button. The Office Backstage is a single view that allows you to manage the workbook, including printing, opening and saving in different formats, and changing the metadata.

Bold – Dark or highlighted text.

Borders – The feature that enables you to add lines or surrounding borders to the selected cells in the worksheet.

Built-in Functions – Pre-programmed formulas to do specific calculations. You can either type these functions in or use the Insert Function Wizard to assist.

Business Intelligence – Using information technology to understand how well an organization is performing and to identify opportunities to improve profitability.

Cell Styles – A feature that enables you to apply many different formatting characteristics to one or more cells with a single command by choosing from a selection of format templates; see AutoFormat also.

Center – To place text in the center of a cell.

Chart Wizard – The automatic feature that Excel provides to help you create a chart in a step-by-step process.

Chart – A pictorial representation of the data you enter in a worksheet.

Circular References – A type of error that occurs when one or more cells refer to each other directly or indirectly.

Clear – Removes information (and/or formatting and comments) from selected cells and leaves the cells blank.

Column – A vertical arrangement for text or numbers, separated from other columns by a grid line and denoted with alpha letters per column. Excel has a maximum of 256 columns, denoted from A to IV.

Comma Separated Values (CSV) file – Also known as Comma Delimited text file. One of the formats available to create from an Excel workbook. All data in this file is of variable length. Each cell value is followed by a comma, except for the last value in each row. See also Fixed width text file.

Comments – Similar to a post-it note where you can enter information for yourself or others to review.

Copy – An editing function used to duplicate selected cells.

Cut – The editing process of transferring selected cells to the Clipboard so that you can move them from one location and place them into another.

Data Table – A table that displays one or two input variables and the result of a calculation using the input variables.

Data Validation – A feature that helps you set up validation checks in the cells, e.g., numbers only, list of inventory items available, etc.

Database – Used for compiling and sorting (typically large) lists of data.

Digital certificate – A code sequence that can be applied to any document or macro. Excel is able to read and display these certificates so that the user can assure themselves that the document is safe to use. Digital certificates may be issued by a commercial certification authority or created by individuals.

Document Inspector – A tool to assist in removing any personal or hidden information you don’t want others to see when they open this file.

Error Checking – An auditing tool to assist in checking any errors that may exist in the formulas. Any errors are marked with a dark green triangle in the upper left corner of a cell.

Excel Services – A component of Microsoft SharePoint that is used to Excel data to others, whether they have Excel installed on their computer or not. It is used in business intelligence applications to help users analyze business data.

Extensible Markup Language – A set of rules developed by the World Wide Web Consortium to facilitate data to be transferred from one computer system to another over the Internet.

Filter – A feature that will suppress the display of data that do not meet the filter criteria.

Fixed width text file – The format of the data exported from a program such as Excel. All data in the same column have the same length, usually the defined width of the column. Cells that have less data than the defined width will have extra blank spaces added at the right side of the cell. See also Comma delimited text file.

Font – A specific typeface and point size.

Footer – Text that repeats at the bottom of every page and may include automatic page numbers.

Format – Instructions to Excel as to how it should display and number styles, fonts, colors, etc.
Formula Bar – A field on the screen that displays the formula in the active cell. It can also be used to make entries into the worksheet.

Formula – Used in a cell to calculate new result values to be displayed. Composed of values, cell references, arithmetic operators and special functions. These results may be used in other formulas located in other cells.

Function – A feature designed by Excel that enables you to perform quickly a calculation or formula using a specialized function.

Graphics – Illustrations that can be inserted into a worksheet such as pictures, clip art, charts, text boxes, shapes, etc.

Header – Text that repeats at the top of every page and may include automatic page numbers.

HTML – Acronym for Hyper Text Markup Language. It is the underlying language for the set of instructions used by web browsers to display information on a web page.

Hyperlink – A link to another document. It is usually stored in the form of a Uniform Resource Locator (URL), which is the unique address to find this document; e.g. on the Internet, the intranet, folder on local or network hard drive, location in current document or workbook.

Insert – An editing function that enables you to add text between other text, including entire columns or rows.

Insert Function – The feature that Excel provides to help you select the desired function to perform calculations.

Insert Worksheet Tab – The tab at the end of the worksheet tabs on the lower left corner of a workbook to assist in inserting/creating a new worksheet at the current location.

Justification – The formatting function that determines how Excel will align the data within a cell or cells.

Legend – A box on a chart that explains the meaning of each line in a line chart, or bar in a bar chart.

Linking – The process of referencing cells or worksheets in one file to another, so that changes made on one file will automatically change in the linked file.

Macro – A feature that “records” keystrokes for future use. Macros save time in operations where the same series of commands is repeated.

Margin – The white space or area from the edge of the paper to the text.

Metadata – Information that describes the file, such as date and time created and last modified, who created it, and the size of the file. Metadata is useful for sorting, organizing, and finding workbooks, especially when you have a large number of them.

Name Box – This box displays the cell address of the active cell. It is located on the left below the toolbar.

Named Range – A range of cells that has been assigned a name.

Office Open XML – A set of rules developed by Microsoft that defines how spreadsheet, chart, presentation, and word processing data is stored in files.

OneDrive – A file storage and sharing service that is part of the Windows Live range of online services. All Window Live users are given 7 GB of free personal storage. Formerly known as SkyDrive.

Page Break – The division between two pages.

Page Setup – The feature that determines how Excel will display and/or print the worksheet — e.g., margins, headers/footers, gridlines, etc.

Paste – The editing function of placing cut or copied data into a new location.

Pick List – A type of data validation that ensures only valid information is entered by allowing the user to select only from a predefined list of items.

Power Pivot – A tool that enables users to connect to large, complex corporate databases and create pivot tables.

Quick Access Toolbar – A toolbar that is displayed in the upper left part of the Excel window. It is customizable to give you ready access to commands that you want to use frequently without having to select a tab in the Ribbon.

Range of cells – A contiguous block of cells with one or more rows and one or more columns of cells.

Ribbon – The collection of commands grouped under different tabs across the top of the Excel screen. Each tab is aimed at a type of activity, such as page layout or inserting items into a worksheet. Some tabs are only shown when appropriate.

Secondary Vertical Axis – The secondary axis appears on the far right of a chart. In a chart with dual axes, you can tie some of the data series to the primary axis on the left, and the remaining series to the secondary axis on the right.

Series – Each set of data used in a graphical chart.

Shared Workbook – A feature in Excel which enables more than one user to update a workbook at the same time. If the same cell(s) are updated by different people, Excel will display the conflicts and allow one of the values to remain.

SharePoint – A Microsoft software product that allows multiple users (usually within an organization) to collaborate by sharing documents, files, and workbooks. This concept is that end products are better through team work.

SmartArt – A type of illustration with a variety of diagrams to show progress or flow of information.

Solver – A tool designed to reach a solution, by changing a number of variables.

Structured reference – A method of referencing cell ranges within a table.

Style – A combination of formatting features you can save and apply as a set.

Table Styles – A feature that enables you to apply many different formatting characteristics to a table with a single command by choosing from a selection of format templates; see AutoFormat also.

Template – A pre-designed workbook that may already contain data, formulas, and other objects, thereby saving you time and effort in entering these items.
Glossary of Terms

**Tracing Errors** – An audit tool that draws arrows to help you find or trace formula errors in cells that are precedents or dependents of the current cell.

**Tracking Changes** – A process that displays all changes made to the worksheet, including editing actions and formatting changes.

**Transpose** – Copies data from one range in a worksheet to another range, except that the data in rows are flipped over into column sequence and data in columns are flipped into row sequence. This tool is available both as a Paste Special option and as a TRANSPOSE function.

**Trendline** – A common method of analyzing data using charts or graphs based on the data in a worksheet.

**Watch Window** – A small pop-up window that displays the current value of selected worksheet cells. It is useful when working with large worksheets; the watch window displays these cell values regardless of what part of the worksheet you have currently displayed on the screen.

**What-if analysis** – The ability to pursue an almost endless cycle of trial-and-error use of base numbers in formulas and therefore be able to make important decisions quickly.

**Workbook properties** – A group of data that is used to help users sort, organize and find workbooks. This data is stored internally and can be displayed in Windows using the File Explorer.

**X-axis** – The horizontal edge of a chart, marking the scale used there.

**XML** – See Extensible Markup Language.

**Y-axis** – The vertical edge of a chart, marking the scale used there.
Appendix C: Index

A
ActiveX Controls, 246
Advanced Excel options, 260
Advanced filtering, 224
Analysis Tools
  Goal seek, 203
  Scenario manager, 209
  Watch cell, 213
  What-If, 202
AVERAGEIF, 199
AVERAGEIFs, 200

B
Business Intelligence, 117

C
Calculated fields, 101
Calculated Fields, 106
  Power Pivot, 125
Cell Watch, 213
Charts, 177
  Custom templates, 182
  Formatting, 177
  Secondary axis, 179
  Trendline, 187
Check boxes, 252
CHOOSE, 50
Combo boxes, 253
Command Buttons, 247
Comments, 160
Comparison operators, 229
Conditional Formatting, 2
  Creating a new rule, 2
  Customizing, 8
  Formulas, 8
  Managing Rules, 5
  Rule precedence, 5
Conditional Logic Functions, 198
Conditional Summary Functions, 199
Connecting Power Pivot, 119
Consolidating Data, 149
Controls
  ActiveX, 246
  Command buttons, 247
  Form, 246
Copy macros, 243
COUNTIF, 199
COUNTIFS, 200
Creating a template, 231
Creating new macro, 237
Cube Functions, 130
Custom Chart Templates, 182
Custom Formatting, 11
  Accounting, 15
  Custom color formats, 28
  Date and time formats, 17
  International currency formats, 18
  International formats, 18


D
Data Slicer, 94
Data Validation, 79
DATE, 63
Date and Time, 63
DATEVALUE function, 64
DAX, 125
DAY function, 64
DAYS function, 64
Deleting templates, 234
Dependent Worksheets, 144
Drilling Down, 114

E
Editing Protected Cells, 168
Error Checking Tool, 67
Error indicator, 68
Evaluate Formulas, 73

F
Fields, 86
Fill series, 221
Filling Data
  Series, 222
Filtering
  Advanced filters, 224
  Comparison operators, 229
Financial Functions, 191
Form controls
  Check boxes, 252
  Combo boxes, 253
  Group box, 256
  List boxes, 233
  Option buttons, 252
  Scroll bars, 250
  Spin buttons, 250
  Text boxes, 257
Form Controls, 245
Formatting
  Charts, 177
  Custom, 11
  Pivot table data, 90
Formula errors, 67
  Error checking tool, 67
Formulas
  Display, 77
  Evaluate formulas, 73
  Linking external workbooks, 144
  Manual checking, 77
  Modifying workbook links, 147
  Referencing other worksheets, 144
  Removing workbook links, 148
  Tracing formula errors, 70
Functions
  DATE, 63
  DATEVALUE, 64
  DAY, 64
  DAYS, 64
  FV, 191
  HOUR, 64
  MINUTE, 64
  MONTH, 64
  NOW, 63
  NPV, 191
  PMT, 191
  PV, 191
  SECOND, 64
  TIME, 64
  TODAY, 63
  WEEKDAY, 64
  WORKDAY, 64
  YEAR, 64
Functions, 45
  CHOOSE, 50
  Correct Syntax, 46
  Date and time, 63
  HLOOKUP, 57
  INDEX, 52
  Inserting, 47
  Lookup, 50
  LOOKUP, 56
  MATCH, 54
  Nesting, 47
  VLOOKUP, 57
Functions
  Workgroup, 152
Functions
  Financial, 191
Functions
  Nesting, 193
Functions
  Conditional logic functions, 198
Functions
  AND, 198
Functions
  NOT, 198
Functions
  OR, 198
Functions
  Conditional summary functions, 199
Functions
  AVERAGEIF, 199
Functions
  COUNTIF, 199
Functions
  SUMIF, 200
Functions
  AVERAGEIFs, 200
Functions
  COUNTIFS, 200
Index

Functions
SUMIFS, 200
FV, 191

G
GETPIVOTDATA, 106
Goal seek, 203
Group box, 256
Group Pivot Table Data, 97

H
Hidden ribbon tabs, 235
HLOOKUP, 57
HOUR function, 64

I
INDEX, 52
Inserting
Functions, 47
International
Currency formats, 18
Currency symbols, 22
Date and time formats, 23

L
Linking External Workbooks
Creating links, 144
Modifying links, 147
Removing links, 148
List boxes, 253
LOOKUP Function, 56
Lookup Functions, 50
CHOOSE, 50
INDEX, 52
MATCH, 54
Vector, 50

M
Macros, 237
Creating, 237
Mark as Final, 159
MATCH, 54
MINUTE function, 64
Modifying templates, 233
MONTH function, 64

N
Name Manager, 40, 44
Named Ranges
Name Manager, 40
Named Ranges, 38
Creating, 38
Named Ranges
Modifying, 44
Named Ranges
Deleting, 44
Naming
Ranges, 38
Tables, 41
Naming Tables, 41
Nesting functions, 47
Nesting Functions, 193
NOW, 63
NPV, 191

O
OLAP, 130
Option buttons, 252

P
Passwords, 163
Files, 172
Workbook, 171
Pivot Charts
Changing pivot chart options, 113
Creating, 110
Drilling down, 114
Styles, 116
Pivot Tables, 86
Calculated fields, 101, 106
Creating, 86
Customizing, 92
Data slicer, 94
Drilling down, 114
Fields, 86
Formatting, 90
Group data, 97
Pivot charts, 110
PivotTables
Scenario PivotTable, 212
PMT, 191
Power Pivot
Activating, 118
Calculated fields, 125
Connecting to data source, 119
Manage table relationships, 126
Power Pivot data model, 120
Power Pivot Table Relationships, 126
Protecting a workbook
Passwords, 163
Protecting a Workbook, 163
Allow ranges for editing, 168
Protecting the structure, 171
Using passwords, 172
Worksheet protection, 164
PV, 191

R
Ranges
Deleting, 44
Modifying, 44
Referencing other worksheets, 144
Removing Shared Workbooks, 159
Removing Workbook Links, 148
Rule Precedence, 5

S
Scenario Manager, 209
Scenarios, 209
Scroll bars, 250
SECOND function, 64
Secondary Axis, 179
Serialized date value, 63
Shared Workbooks
Creating, 153
SharePoint, 153
Sharing Workbooks, 153
Showing change history, 157
Tracking changes, 155
Showing History of Changes, 157
Source worksheets, 144
Spin buttons, 250
Structured Reference, 42
Structured References, 214
Styles, 26
Custom color formats, 28
Pivot charts, 116
SUMIF, 200
SUMIFS, 200

T
Tables
Naming, 41
Structured reference, 42
Templates
Creating a template, 231
Deleting templates, 234
Modifying, 233
Text boxes, 257
Themes, 29
TIME function, 64
TODAY, 63
Toggle buttons, 252
Trace dependent cells, 71
Trace precedent cells, 71
Tracing Formula Errors, 70
Tracking Changes, 155
Trendline, 187

U
User Defined Styles, 26

V
Vector, 50
VLOOKUP, 57

W
WEEKDAY function, 64
What-If Analysis, 202
Workbook Structure, 171
workbooks
Sharing, 153
Workbooks
Linking, 144
Mark as final, 159
Modifying links, 147
Passwords, 163
Protecting, 163
Protecting with passwords, 172
Removing links, 148
Removing shared use, 159
WORKDAY function, 64
Workgroup, 152
Appendix C

Workgroup Functions
  Mark as final, 159
  Removing shared use of workbooks, 159
  Sharing workbooks, 153
  Showing change history, 157
  Tracking workbook changes, 155

Worksheets
  Dependent, 144
  Protection, 164
  Referencing, 144
  Source, 144

Y
  Year function, 64